13:00:24 <fdegir> #startmeeting Cross Community CI
13:00:24 <collabot`> Meeting started Wed Apr 25 13:00:24 2018 UTC. The chair is fdegir. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:24 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:24 <collabot`> The meeting name has been set to 'cross_community_ci'
13:00:29 <fdegir> #topic Rollcall
13:00:35 <fdegir> who else is around?
13:00:38 <ttallgren> #info Tapio
13:00:49 <fdegir> hello ttallgren
13:00:52 <fdegir> good to see you :)
13:00:53 <electrocucaracha> #info Victor Morales
13:01:03 <ttallgren> Hello hello
13:01:20 <hw_wutianwei_> #info Tianwei Wu
13:01:30 <fdegir> lets start
13:01:38 <fdegir> the agenda looks kind of full but mostly status updates
13:02:02 <fdegir> #topic OpenCI Updates: Event Driven/Federated CI/CD
13:02:29 <fdegir> #info We are working on bringing the prototype up based on what is proposed on the docs shared last week
13:02:42 <fdegir> #link https://docs.google.com/document/d/1WyjD6Wz4p7jVnEtRfwhsKltrtHxDiJZGaj5Nn0U-psE/edit#
13:03:03 <fdegir> #info yolanda_ is also helping out with it by writing a utility to publish events to activemq message broker
13:03:41 <fdegir> #info I hope to have it up and running before OpenDev which we can hopefully have a demo to OPNFV before that
13:04:28 <fdegir> ping me if you have any questions/comments about this
13:04:39 <mbuil> #info Manuel Buil
13:04:51 <fdegir> #topic OpenCI Updates: Zuul Prototype
13:05:19 <fdegir> #info Zuul is up and running on my VM and I'll move it to OPNFV machine during the rest of the week
13:05:25 <hwoarang> #info Markos Chandras
13:05:42 <mbuil> fdegir: OPNFV machine?
13:05:44 <fdegir> #info A sample change is
13:05:46 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/56399/
13:06:01 <fdegir> mbuil: we got a machine from OPNFV to using during the prototype
13:06:11 <fdegir> mbuil: it will run in parallel to jenkins
13:06:57 <fdegir> that was all about openci
13:07:06 <fdegir> now the xci topics if there it no question
13:07:14 <mbuil> question
13:07:20 <fdegir> yes
13:07:30 <mbuil> fdegir: did you already agree on a MQ protocol/utility then?
13:07:39 <fdegir> mbuil: no
13:07:57 <fdegir> mbuil: before doing that, I think we need to demostrate what we are trying to solve
13:08:15 <mbuil> yolanda_'s work is just for the prototype then
13:08:16 <fdegir> mbuil: so we have chosen few tools for the prototype and created 3 event types
13:08:19 <fdegir> mbuil: yes
13:08:31 <mbuil> got ya
13:08:33 <hwoarang> i have a question
13:08:37 <fdegir> yes
13:08:38 <hwoarang> what is this zuul for
13:08:46 <epalper> #info Periyasamy Palanisamy
13:08:50 <fdegir> it is a Jenkins assassin
13:08:53 <hwoarang> is this sometihng that's going to replace jenkins in opnfv?
13:09:00 <hwoarang> or just something for xci + openci thing
13:09:09 <fdegir> we can hopefully replace jenkins with zuul
13:09:16 <fdegir> but there is some way to go
13:09:23 <hwoarang> ok
13:09:31 <fdegir> we asked for 2 features; 1 of them is fully implemented and the other is halfway there
13:09:35 <fdegir> multiple gerrit support
13:09:40 <fdegir> static node support
13:09:58 <fdegir> we need to try these out and provide feedback and contributions hopefully
13:10:27 <hwoarang> ok
13:10:30 <fdegir> if we get zuul one day, we can gate/promote things properly
13:10:37 <fdegir> not like what we are doing today; post-merge...
13:11:04 <fdegir> moving to the next topic
13:11:08 <fdegir> #topic Baremetal Status
13:11:22 <fdegir> #info mbuil started looking into introducing baremetal for XCI
13:11:27 <fdegir> mbuil: anything you'd like to add?
13:11:37 <hwoarang> mbuil: which pod are you using?
13:11:44 <hwoarang> i presume you use an entire pod right?
13:11:46 <mbuil> lfpod4
13:11:50 <hwoarang> ok
13:12:00 <fdegir> hwoarang: we have another pod if you need one?
13:12:15 <ttallgren> mbuil: You can also use the Nokia pod. It is for long-term testing
13:12:23 <hwoarang> i am not sure if can dedicate 100% to my hope was to jump in an help mbuil if he needs help
13:12:25 <fdegir> ttallgren: we will come to that topic
13:12:30 <ttallgren> Ok
13:12:31 <hwoarang> but i need to get access to these pods first
13:12:37 <mbuil> I am right now thinking about how to do the contributions in a way which is swallable by all reviewers
13:12:58 <fdegir> mbuil: I think the easiest way is to adapt virtual deployments to pdf/idf
13:13:08 <hwoarang> yes
13:13:11 <fdegir> mbuil: before dealing with baremetal
13:13:12 <hwoarang> i agree.
13:13:16 <mbuil> My first thinking, and this is what I am doing right now, is creating a spec so that everyone is on the same page before the code starts to flow in
13:13:42 <mbuil> fdegir: ok, good idea
13:13:45 <fdegir> #action fdegir to request access for hwoarang for lf-pod4 & ericsson-pod2
13:14:03 <mbuil> then we should start with the inventory thing
13:14:08 * hwoarang back in a bit
13:14:23 <fdegir> mbuil: i think it is best you do what you intend to do - create a spec somewhere
13:14:24 <mbuil> ttallgren: thanks :)
13:14:42 <fdegir> mbuil: and we comment there first to make the steps simpler
13:14:44 <mbuil> fdegir: yes, and there we can discuss what could be done first, etc
13:15:02 <mbuil> fdegir: I hope I can have version 1 today
13:15:03 <fdegir> #action mbuil to share his spec regarding pdf/idf introduction and baremetal support
13:15:09 <fdegir> mbuil: that would be great
13:15:23 <fdegir> mbuil: anything else?
13:15:29 <fdegir> on this topic i mean
13:15:47 <mbuil> no. Great that hwoarang wants to help me :)
13:16:09 <fdegir> thanks mbuil
13:16:20 <fdegir> #topic Promotion criterias/test scope for CI Loops used by XCI
13:16:41 <fdegir> #info The changes talking about the terminology, CI loops and criterias are up for review
13:16:50 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/q/status:open+project:releng-xci+branch:master+topic:set-promotion-criterias
13:17:05 <fdegir> #info It didn't get much love from scenario owners so I'll ping them again
13:17:19 <fdegir> it would be good if everyone can look into them and provide feedback
13:17:38 <fdegir> especially to https://gerrit.opnfv.org/gerrit/#/c/56135/
13:18:01 <fdegir> hw_wutianwei_: can you think about k8s scenarios please?
13:18:24 <fdegir> hw_wutianwei_: we know we only have healtcheck (smoke) and smoke (conformance)
13:18:37 <fdegir> hw_wutianwei_: so it would be good if you can comment about these there for others to see
13:18:43 <hw_wutianwei_> fdegir: ok,
13:18:56 <fdegir> epalper: we need your input for odl and bgpvpn scenarios
13:19:14 <fdegir> epalper: anything else you think
13:19:46 <epalper> fdegir: ok, will review and provide the feedback
13:19:58 <fdegir> again, if you have any questions or feedback, just provide them on the changes directly
13:20:14 <fdegir> #topic Tagging repos/Pinning scenarios
13:20:30 <fdegir> #info sdnvpn repo has been tagged with 6.0.0 project internal tag and the scenario is pinned in xci
13:20:37 <fdegir> mbuil: any luck with sfc repo?
13:21:32 <mbuil> fdegir: no. Helpdesk has been invoked
13:21:47 <fdegir> #info sfc repo is waiting to be tagged so we can pin the scenario
13:21:54 <fdegir> mbuil: ok
13:22:24 <fdegir> #info Tagging/pinning generic scenarios requires us to move them to their own repo since tagging and pinning can't be done while they're in same repo
13:23:16 <fdegir> #info So the folder releng-xci/xci/scenarios will be moved to its own repo releng-xci-scenarios as is and the history will be preserved
13:23:36 <fdegir> #action fdegir to submit a ticket to helpdesk for the move
13:23:50 <fdegir> #action fdegir hwoarang to look at possible impacts of this move
13:24:09 <fdegir> a short background why tagging/pinning
13:24:29 <fdegir> we want to be able to ensure we can lock things down when we come closer to the release
13:24:44 <fdegir> we already do this for upstream projects such as openstack and so on but not for the scenarios
13:24:56 <fdegir> this fills that gap, ensuring full reproducibility
13:25:11 <fdegir> any comments/concerns?
13:26:03 <fdegir> ok, the next topic is what ttallgren brought up earlier
13:26:09 <fdegir> #topic Long Duration Testing Support
13:26:25 <fdegir> #info We will not be able to support LDT near term
13:26:42 * hwoarang back
13:26:52 <fdegir> ttallgren: as I responded to Alec's mail, it is better you get something else on that POD so testing community don't have to wait even further
13:27:19 <ttallgren> Sorry?
13:27:38 <ttallgren> You mean we should allocate the pod to something else?
13:27:42 <fdegir> ttallgren: no
13:27:56 <fdegir> ttallgren: the pod should still be used for ldt but xci will not be able to support ldt near term
13:28:21 <ttallgren> So it could be used for something else short term?
13:28:27 <fdegir> ttallgren: no
13:28:32 <ttallgren> :-)
13:28:48 <fdegir> ttallgren: it needs to be installed as soon as possible with something so test community can start using it for ldt
13:28:51 <fdegir> :)
13:28:59 <fdegir> ttallgren: haven't you seen my mail?
13:29:15 <fdegir> ttallgren: subject is LDT pod and bare metal install for Plugfest?
13:29:15 <ttallgren> Probably in my inbox
13:29:32 <fdegir> ttallgren: ok - I told Gabriel the same as well
13:29:47 <ttallgren> Last night?
13:29:49 <fdegir> yes
13:29:56 <fdegir> 21:47
13:29:58 <fdegir> my time
13:30:16 <ttallgren> Ok, I see.
13:30:31 <fdegir> I would have liked things to be different but can't do much about that apart from continuing the path we set no matter what and we catch up later
13:30:49 <ttallgren> Makes sense. It has nothing usable on it so it could be used for bare metal installations
13:31:09 <fdegir> ttallgren: Alec put some of his requirements there so it is in your plate now
13:31:32 <fdegir> moving to next topic then
13:31:45 <fdegir> #topic Scenario Status Check
13:32:06 <fdegir> hw_wutianwei_: mbuil: epalper: hwoarang: any updates?
13:32:18 <hw_wutianwei_> one question
13:32:29 <hw_wutianwei_> fdegir: do we have a plan to deploy onap in XCI?
13:32:38 <hwoarang> not much, i was doing OSA stuff the past few days/weeks
13:32:46 <fdegir> hw_wutianwei_: we do
13:33:03 <fdegir> hwoarang: are all k8s scenarios now supported on openSUSE?
13:33:12 <hwoarang> of course
13:33:21 <fdegir> hwoarang: then you have an update :)
13:33:29 <fdegir> #info All k8s scenarios are now supported on openSUSE
13:33:38 <hwoarang> ah i thought we talked about it last week
13:33:43 <hw_wutianwei_> fdegir: it is in progress?
13:34:08 <fdegir> hwoarang: and all 3 distros are supported it seems - which is even better
13:34:19 <fdegir> hw_wutianwei_: nope - we need someone to take the lead
13:34:24 <fdegir> hw_wutianwei_: would you like to do that?
13:34:36 <ttallgren> k8 seems to fail on CentOS
13:34:39 <epalper> just a heads up. we do have edge cloud project coming up from opnfv. it might need some onap scenarios to be supported by XCI
13:34:43 <hw_wutianwei_> maybe I can try
13:34:46 <mbuil> fdegir: not much from my side either. Finding small things in the ODL-XCI integration to use the tip of master
13:35:05 <fdegir> hw_wutianwei_: epalper: we should start talking about this then
13:35:17 <hw_wutianwei_> we want onap on openstack or onap on kubernetes?
13:35:20 <fdegir> hw_wutianwei_: epalper: I'll start an etherpad to see how we can do that and who we can reach out to
13:35:38 <hw_wutianwei_> fdegir: Ok
13:35:39 <fdegir> hw_wutianwei_: openstack might be a bit tricky since they might be on pretty old version of openstack
13:35:48 <epalper> I'm getting involved in edge project. will let you know once we have some concrete items to pick up
13:36:02 <epalper> specifically for xci
13:36:07 <fdegir> hw_wutianwei_: but cncf cross cloud ci already deploys onap so we can look at what they are doing
13:36:15 <fdegir> epalper: that would be good
13:36:21 <electrocucaracha> epalper: are you talking about akraino project?
13:36:42 <fdegir> epalper: you can also ask them to see if they would be interested in having onap on k8s since this would probably be the one to start with
13:37:05 <epalper> electrocucaracha: no, about this one https://wiki.opnfv.org/display/PROJ/Edge+cloud
13:37:07 <fdegir> hw_wutianwei_: so, should we just make up a scenario right now like k8-nosdn-onap or something?
13:37:26 <electrocucaracha> fdegir: the major thing about the way to deploy ONAP in k8s is that they are consuming the images from the official site, I meant there is no way to tag the images
13:37:50 <fdegir> electrocucaracha: I see you are interested in this
13:38:06 <fdegir> #action hw_wutianwei_ electrocucaracha epalper to start talking about onap scenario in xci on k8s
13:38:12 <electrocucaracha> fdegir: well, I have been doing that for some time
13:38:18 <fdegir> hw_wutianwei_: ^^
13:38:18 <ttallgren> How many servers do you need for onap on k8s?
13:38:26 <hw_wutianwei_> fdegir: electrocucaracha ok
13:38:55 <electrocucaracha> ttallgren: you can do it in aio
13:39:04 <ttallgren> On a single server?
13:39:09 <electrocucaracha> yes
13:39:11 <ttallgren> Ok
13:39:19 <fdegir> electrocucaracha: i suppose it is possible to do virtual as well?
13:39:29 <fdegir> electrocucaracha: so we might start with a mini flavor
13:39:45 <fdegir> 1 master 1 worker
13:39:48 <electrocucaracha> fdegir: a huge VM, I don't remember the last changes but more than 64gb
13:39:57 <fdegir> electrocucaracha: we have that
13:40:05 <fdegir> thanks to jmorgan1
13:40:11 <electrocucaracha> hahaha
13:40:45 <hw_wutianwei_> electrocucaracha: thanks
13:40:53 <fdegir> you three have the action now and I very much look forward to it
13:40:58 <electrocucaracha> basically the OOM Beijing release uses helm to deploy it
13:41:09 <fdegir> that's what I want
13:41:33 <fdegir> this is part of the tsc goal cross community collab and me and frankbrockners were talking about exactly this
13:41:43 <fdegir> oom, helm, etc. etc.
13:41:55 <epalper> fdegir: i think edge project looks for heterogeneous cloud (openstack and k8s) using onap multi cloud
13:42:05 <fdegir> hw_wutianwei_: thanks for bringing the onap topic!
13:42:30 <fdegir> epalper: ok, that seems a bit stretch for the timebeing
13:42:35 <electrocucaracha> epalper: at least for now
13:43:09 <epalper> electrocucaracha, fdegir: ok
13:43:30 <hw_wutianwei_> fdegir: I just concern onap, and thanks electrocucaracha
13:43:58 <fdegir> this was good
13:44:02 <fdegir> moving to the next topic
13:44:17 <fdegir> #topic Scenario Consolidation and SDF
13:44:48 <fdegir> #info Thanks to hw_wutianwei_, Taseer, and hwoarang, we now have 4 k8s scenarios that are crucial for scenario consolidation and SDF work
13:45:19 <fdegir> #info We are supporting that work with prototyping and if anyone is interested in it and have ideas, please provide them on the etherpad
13:45:31 <fdegir> #link https://etherpad.opnfv.org/p/scenario-consolidation
13:46:23 <fdegir> that was all for this topic for the timebeing
13:46:32 <fdegir> and the last topic is
13:46:35 <fdegir> #topic AoB
13:47:08 <fdegir> #info Some of you might be aware of this that David decided to stop working in XCI and stepping from committer role
13:47:08 <ttallgren> How is CentOS doing?
13:47:17 <fdegir> ttallgren: will come to that
13:47:22 <ttallgren> :-)
13:47:39 <fdegir> #info I want to thank David for all the contributions he made
13:47:58 <fdegir> committers, please vote on this so we can notify tsc and helpdesk
13:48:02 <electrocucaracha> this patch adds proxy support to kubespray, https://gerrit.opnfv.org/gerrit/#/c/56159/
13:48:07 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/56471/
13:48:19 <fdegir> ttallgren: now the centos
13:48:26 <ttallgren> Yes?
13:48:30 <fdegir> ttallgren: it needs some love and Taseer started looking into it
13:48:47 <hwoarang> i said it before that centos7 needs love also upstream
13:48:49 <hwoarang> the maintainer left
13:48:53 <fdegir> ugh
13:48:55 <hwoarang> so centos7 support is degrading
13:48:59 <fdegir> it was mhayden
13:49:03 <hwoarang> yes he left
13:49:08 <hwoarang> now mnaser said he will step up
13:49:16 <hwoarang> but fyi that centos is not doing well
13:49:24 <fdegir> so, Taseer ttallgren there seems to be an opening upstream ;)
13:49:44 <ttallgren> I can talk to my manager about that...
13:50:12 <fdegir> should i do #action ttallgren to talk to his manager?
13:50:32 <ttallgren> No need..
13:50:42 <fdegir> was joking...
13:50:50 <fdegir> so that was centos
13:51:09 <fdegir> electrocucaracha: you were talking about k8s proxy support?
13:51:28 <electrocucaracha> fdegir: yes, basically it needs more reviews
13:51:45 <fdegir> #info The change adding proxy support for k8s scenarios needs reviews
13:51:52 <fdegir> #link https://gerrit.opnfv.org/gerrit/#/c/56159/
13:52:04 <fdegir> electrocucaracha: about your kolla change and my comment
13:52:17 <fdegir> electrocucaracha: we currently only check if a scenario is supported on given distro
13:52:23 <fdegir> electrocucaracha: in releng scripts
13:52:43 <fdegir> electrocucaracha: that logic needs to be improved, allowing/checking if a given installer/scenario combination is supported or not
13:52:55 <fdegir> electrocucaracha: there might be other changes needed but I'm not so sure what those are
13:52:58 <electrocucaracha> fdegir: I was looking inside the folder but I could't find the job that you mentioned
13:53:14 <fdegir> electrocucaracha: without that, CI side of things will stop working properly I'm afraid
13:54:07 <electrocucaracha> fdegir: is there a way to create a Sandbox into OPNFV jenkins ?
13:54:32 <fdegir> electrocucaracha: what does this mean?
13:55:08 <fdegir> electrocucaracha: if you are asking a sandbox jenkins instance then yes we have one
13:55:17 <fdegir> electrocucaracha: http://sandbox.opnfv.org/
13:55:34 <electrocucaracha> fdegir: the onap community has a process to use the jenkins sandbox for testing jobs before submitting patches
13:55:47 <fdegir> electrocucaracha: ok - this is ours http://sandbox.opnfv.org/
13:56:13 <fdegir> electrocucaracha: you might want to look at this for details: https://gerrit.opnfv.org/gerrit/#/c/56165/
13:56:17 <fdegir> how to use
13:56:20 <jmorgan1> hey
13:56:30 <electrocucaracha> fdegir: that was my next question, thanks
13:56:42 <ttallgren> Good morning Jack!
13:56:44 <fdegir> electrocucaracha: about what to look for impacts of kolla
13:57:07 <jmorgan1> ttallgren: Good morning
13:57:09 <fdegir> electrocucaracha: any shell script in releng/jjb/xci that does something with opnfv-scenario-requirements.yml
13:57:30 <fdegir> electrocucaracha: we do things like this
13:57:31 <fdegir> if ! sed -n "/^- scenario: ${DEPLOY_SCENARIO[0]}$/,/^$/p" $OPNFV_SCENARIO_REQUIREMENTS | grep -q $DISTRO; then
13:57:54 <fdegir> as you see there, only scenario is grepped which is the thing we need to improve for multi-installer support
13:58:15 <fdegir> hello jmorgan1
13:58:25 <electrocucaracha> fdegir: got it
13:58:32 <fdegir> any last minute topic?
13:59:07 <fdegir> #endmeeting