#opnfv-pharos: xci-onap

Meeting started by morgan_orange at 15:02:13 UTC (full logs).

Meeting summary

    1. David Blaisonneua (David_Orange, 15:03:14)
    2. Jack Morgan (jmorgan1, 15:03:24)
    3. Fatih Degirmenci (fdegir, 15:03:44)
    4. Frank Brockners (frankbrockners, 15:03:58)
    5. Morgan Richomme (morgan_orange, 15:04:15)

  1. goal (morgan_orange, 15:04:23)
    1. Markos Chandras (hwoarang, 15:04:41)
    2. the intention is to deploy ONAP from master using OOM on XCI K8S scenarios and perform appropriate tests (morgan_orange, 15:04:51)
    3. Fatih suggests to start with virtual deployments. This is needed anyways in order to support the development of the scenario in XCI. We have resources with enough CPU/RAM in XCI. (88CPUs/256G RAM) (morgan_orange, 15:04:57)
    4. fdegir introduces xci (morgan_orange, 15:05:09)
    5. ONAP master branch is the working branch...does not really work (morgan_orange, 15:05:55)
    6. XCI aims to give feedback to upstream community (morgan_orange, 15:07:09)

  2. Short introduction on Orange CI chain for ONAP (morgan_orange, 15:08:13)
    1. https://gitlab.com/Orange-OpenSource/kubespray_automatic_installation (morgan_orange, 15:08:28)
    2. https://gitlab.com/Orange-OpenSource/onap_oom_automatic_installation (morgan_orange, 15:08:35)
    3. amdocs is contiusouly deploy ONAP using OOM (every 3h) (morgan_orange, 15:09:11)
    4. there is also a jenkins chain managed by LF (morgan_orange, 15:10:35)
    5. https://jenkins.onap.org/job/lab-aws-beijing-oom-deploy/ (morgan_orange, 15:10:41)
    6. https://jenkins.onap.org/job/lab-tlab-beijing-oom-deploy/ (morgan_orange, 15:11:02)
    7. deployment jobs moved from internal gitlab to gitlab.com yesterday (morgan_orange, 15:11:26)
    8. pipeline not fully working now (adaptation needed) (morgan_orange, 15:11:45)
    9. sylvain details current Orange gitlab pipelien for OOM deployement on top of K8S also automatically deployed using kubespray (morgan_orange, 15:12:41)
    10. 2 healtcheck at the end of the installation: 1st basic => all pods must be running, 2nd => robot healthcheck (morgan_orange, 15:14:43)

  3. resources (morgan_orange, 15:20:47)
    1. in Orange we are using pdf, idf files (as definied by OPNFV) (morgan_orange, 15:21:07)
    2. https://gitlab.com/Orange-OpenSource/kubespray_automatic_installation/blob/master/vars/pdf.yaml (morgan_orange, 15:21:46)
    3. used to define the infra (morgan_orange, 15:22:03)
    4. nb of workers is not optimized and different by AMdocs or ATT ...you can play on the number of workers / RAM (morgan_orange, 15:22:42)
    5. David_Orange working on kubespray deployement Bare Metal (morgan_orange, 15:23:31)
    6. question fdegir: kubernetes deployement and oom deployement are 2 independent ansible roles (morgan_orange, 15:28:58)
    7. question frankbrockners: question on NFS => perisitentn volume would be available on Casambla. Meanwhile NFS is needed to have a shared folder accros the workers (morgan_orange, 15:29:56)
    8. NFS is setup in auto-oom , part of the ansible role (if not present, we create it) (morgan_orange, 15:30:26)
    9. question on K8S networking plugin => Sylvain we are using Calico but we should not care..any networking solution should be OK, we just need the connectivity (morgan_orange, 15:32:22)
    10. k8S scenario => 5 possible networking plugins (morgan_orange, 15:34:00)
    11. good opportunity to see if networking plugin lead to issues (morgan_orange, 15:34:37)
    12. for the K8S installation => ranger is the OOM recommended installer , Orange is using kubespray (morgan_orange, 15:35:00)
    13. organization (morgan_orange, 15:39:44)
    14. ODL => they maintain ODL role within ODL repo (morgan_orange, 15:39:59)
    15. it would it make sense to host ONAP role in ONAP (morgan_orange, 15:40:23)
    16. ONAP there is an integration repo in ONAP => could make sense to create a directory here (morgan_orange, 15:41:50)
    17. several ways to automate the ONAP deployment: LF, Garry, Michael, Sylvain.. (morgan_orange, 15:42:41)
    18. ACTION: sylvain, michael, Gary + LF => discuss this topic during next ONAP dev event (morgan_orange, 15:43:30)
    19. CD must be refactored (for the moment docker build only once a day) (morgan_orange, 15:44:11)
    20. CI/CD startegy to be precised. Meanwhile possibility to use Orange public gitlab role to try. (morgan_orange, 15:48:58)
    21. let's use an etherpad to exchange on this (morgan_orange, 15:50:14)
    22. https://etherpad.opnfv.org/p/xci-oom (morgan_orange, 15:50:23)


Meeting ended at 15:51:37 UTC (full logs).

Action items

  1. sylvain, michael, Gary + LF => discuss this topic during next ONAP dev event


People present (lines said)

  1. morgan_orange (43)
  2. fdegir (4)
  3. collabot_ (3)
  4. electrocucaracha (2)
  5. frankbrockners (1)
  6. hwoarang (1)
  7. David_Orange (1)
  8. jmorgan1 (1)


Generated by MeetBot 0.1.4.