14:03:06 <GeraldK> #startmeeting Promise
14:03:06 <collabot> Meeting started Mon Aug  3 14:03:06 2015 UTC.  The chair is GeraldK. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:03:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:03:06 <collabot> The meeting name has been set to 'promise'
14:03:36 <corenova> hi everyone
14:03:45 <corenova> <- peter
14:04:12 <bryan_att> #info Bryan Sullivan
14:04:22 <r-mibu> #info Ryota Mibu
14:04:27 <bertys> #info Bertrand Souville
14:04:32 <GeraldK> #info Gerald Kunzmann
14:04:32 <corenova> #info Peter Lee
14:05:00 <r-mibu> has anyone type #startmeeting?
14:05:07 <GeraldK> yes
14:05:07 <corenova> GeraldK: did
14:05:11 <r-mibu> thanks!
14:05:22 <corenova> ok let's get started
14:05:25 <GeraldK> #chair r-mibu
14:05:25 <collabot> Current chairs: GeraldK r-mibu
14:05:35 <GeraldK> #chair bertys
14:05:35 <collabot> Current chairs: GeraldK bertys r-mibu
14:05:43 <corenova> I think ildiko mentioned she'll be traveling today and may not make the meeting this morning
14:05:54 <bertys> #chair corenova
14:05:54 <collabot> Current chairs: GeraldK bertys corenova r-mibu
14:06:29 <GeraldK> #topic Report from ETSI NFV TST and OPNFV hackfest
14:07:21 <GeraldK> #info ClearPath participated in ETSI NFV TST session to report on YANGFORGE tool
14:09:55 <GeraldK> #info see slideset ETSI_NFV_11_yangforge.pptx
14:17:37 <corenova> #info update on Promise OPNFV hackfest
14:18:15 <GeraldK> #info due to 5 parallel sessions and only few persons joining the Promise session, there had not been progress on Promise during the hackfest.
14:19:09 <GeraldK> #info deadline for OPNFV hackfest session at OpenStack Summit is this Wednesday. promise should propose a session.
14:20:44 <GeraldK> #info Peter had met with Intent project and thinks this is another important topic
14:22:53 <corenova> #info raised point on flavor framework and how it will align better with other domains beyond compute, such as network/quantum
14:27:09 <bertys> #link https://wiki.openstack.org/wiki/Neutron/FlavorFramework
14:29:46 <r-mibu> the page seems editied and updated one year ago, we have to check current state
14:29:54 <GeraldK> #info Bryan_att: what we look at is reservation for future usage at higher granularity
14:30:25 <GeraldK> r-mibu, I agree. but shows others also look(ed) into this
14:33:06 <GeraldK> #info Peter: resource reservation is not about a contract, but more like a dialogue: I want to reserve some resources in the future and get informed if somehting happens and the reservation cannot be fulfilled
14:33:31 <GeraldK> #info Bryan_att mentions this can be seen as a kind of contract
14:35:03 <GeraldK> #info "reservation/allocation priority" vs. "higher tier resources"
14:36:21 <GeraldK> #info we need to look into policies, e.g. which resources to terminate to allow for reserved resources to be allocated.
14:37:40 <GeraldK> #info first step is to describe logic around reservation. those "error cases/policies" are second step
14:39:52 <GeraldK> #info Bryan_att: discussed with YANG experts in his company. can people directly contribute on github?
14:41:32 <GeraldK> #info Peter: not yet.
14:43:50 <GeraldK> #info Peter suggests that YANGFORGE could become its own OPNFV project and be used as OPFNV cross-project
14:45:43 <GeraldK> #info GeraldK asks Peter to share title and abstract for OPNFV Summit by today, such that team can review before submitting it on Wednesday
14:47:21 <GeraldK> #info Bryan_att also proposed some presentation for the Summit, maybe parts can be merged.
14:47:47 <bertys> #topic YANGFORGE demo
14:48:48 <bertys> #link https://github.com/clearpath-networks/yangforge
14:54:31 <GeraldK> #info Peter is giving tool walk-through using yukebox example
14:57:07 <GeraldK> would be good to add "Promise" example
14:58:42 <GeraldK> #info as example, adding a new API in ODL is a very long workflow compared to yangforge
15:09:48 <GeraldK> #info Peter plans to create a second project for Promise, but some changes are needed (planned for this week)
15:11:01 <GeraldK> #info Bryan_att: coffee script is used to describe server-side processing. can other expressions also be used? yes, JS is also possible.
15:11:18 <GeraldK> #info coffee script gets compiled into JS
15:16:59 <GeraldK> #info ClearPath plans to do an "app store" where developers can share their modules.
15:17:52 <GeraldK> #topic AOB
15:18:27 <GeraldK> #info Ryota: can you build authentification / access-control in yangforge? not yet.
15:21:42 <GeraldK> #action Peter to share title and abstract for OPNFV Summit by today
15:26:12 <GeraldK> #info Peter looking for volunteers to address the open action items from last weeks. some of them could be expressed as Jira tickets.
15:27:20 <r-mibu> #endmeeting