06:35:07 <r-mibu> #startmeeting promise
06:35:07 <collabot`> Meeting started Tue Jan 12 06:35:07 2016 UTC.  The chair is r-mibu. Information about MeetBot at http://wiki.debian.org/MeetBot.
06:35:07 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
06:35:07 <collabot`> The meeting name has been set to 'promise'
06:46:26 <GeraldK> #info Marc was able to setup Promise with local Fuel plugin today.
06:47:00 <GeraldK> #info Still things to do to make it smarter and more robust. will work on this after this micro-MS.
06:47:43 <GeraldK> #info There had been a conflict with Promise port 4000, which is used by default by Keystone and thus was changed to port 5050
06:48:21 <GeraldK> #info Hiro is working on the Juju charms. Following the same steps (but using a startup script)
06:50:07 <bertys> #link https://github.com/opnfv/juju-plugin-promise Juju charm
06:50:22 <GeraldK> #info Peter asks team for support reviewing the other files/plugins in Promise github
06:50:31 <bertys> #link https://github.com/opnfv/fuel-plugin-promise Fuel plugin
06:54:33 <r-mibu> #chair GeraldK bertys
06:54:33 <collabot`> Current chairs: GeraldK bertys r-mibu
06:55:40 <GeraldK> #info plugins tested in local setups, but they do not have access to PODs (credentials) yet.
06:55:55 <GeraldK> #action review README.md for both plugins
06:57:07 <GeraldK> #topic Promise code
06:57:31 <GeraldK> #info Bertrand was providing few bug reports already fixed by Peter
06:58:40 <GeraldK> #info with the patches also small additional functionalities had been added
06:59:30 <GeraldK> #info Marc: we are currently using OpenStack Kilo
07:00:10 <GeraldK> #info OPNFV Brahmaputra will use Liberty, but for Promise Marc does not expect so much difference.
07:00:41 <GeraldK> #info Peter: we should be okay, but need to verify. Bertrand is working on Liberty.
07:03:26 <GeraldK> #info Peter: there might be a slight change to the APIs with respect to limiting the number of providers / internal handling of this, otherwise APIs are fixed for Brahmaputra
07:03:55 <GeraldK> #info Bertrand had been updating the documentation (see Gerrit patches)
07:05:04 <GeraldK> #topic test cases
07:10:23 <GeraldK> #info Excel sheet with 15 functests; less scenario based test but more basic tests
07:14:54 <GeraldK> #info we need to update http://213.77.62.197/test_projects/promise/cases with the new test cases
07:16:06 <GeraldK> #info Bertrand proposes to remove test cases 2-4, as this is not implemented in Promise yet
07:16:33 <GeraldK> #info proposal to add create/destroy instance test cases
07:20:50 <GeraldK> #topic AOB
07:21:57 <GeraldK> #info next meeting: discuss offline via email
07:25:50 <GeraldK> #info due to the time differences, ClearPath team should directly communicate with functest on the updated test cases
07:26:22 <GeraldK> #action Peter to send Promise milestone E.2 update to Debra CC mailing list
07:26:43 <GeraldK> #action Peter to invite for Promise call Thursday morning
07:28:36 <GeraldK> #endmeeting