15:54:56 <GeraldK> #startmeeting Promise
15:54:56 <collabot`> Meeting started Thu Jun  2 15:54:56 2016 UTC.  The chair is GeraldK. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:54:56 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:54:56 <collabot`> The meeting name has been set to 'promise'
15:55:04 <GeraldK> #topic Roll call
15:59:57 <GeraldK> #info Gerald Kunzmann
16:01:09 <bertys> #info Bertrand Souville
16:03:14 <ildikov> #info Ildiko Vancsa
16:03:56 <bertys> #topic Agenda check
16:04:05 <bertys> #link https://wiki.opnfv.org/display/meetings/Promise
16:08:26 <GeraldK> #info Peter will not be able to join. we will not show a demo during the Summit
16:08:36 <GeraldK> #topic Blazar
16:09:05 <GeraldK> #info ildikov: no progress due to resource issue and not ready Nova scheduler issues
16:09:56 <GeraldK> #topic YangForge
16:10:16 <GeraldK> #link https://github.com/corenova/yang-forge
16:10:32 <GeraldK> #info current Promise (Brahamputra) is based on December release of YangForge.
16:11:23 <GeraldK> #info Peter's new company is focusing on ability to more effectively model things.
16:12:01 <GeraldK> #info for Promise this is to model the resource reservation feature towards OpenStack in a shim-layer architecture
16:12:12 <GeraldK> #chair ildikov
16:12:12 <collabot`> Current chairs: GeraldK ildikov
16:12:19 <GeraldK> #chair bertys
16:12:19 <collabot`> Current chairs: GeraldK bertys ildikov
16:13:10 <GeraldK> #info YF allows to have a stand-alone abstraction layer for OpenStack. this will allow for better usage of -no only- Promise
16:14:05 <GeraldK> #info updates to make YF more flexible with goal to address synchronization issues between OpenStack and the shim-layer; being able to be more reactive to events in OpenStack
16:15:03 <GeraldK> #info has not looked into updating the Promise related code yet; Peter plans to do this as part of Colorado
16:16:34 <GeraldK> #info Prakash: is this model-based?
16:16:57 <GeraldK> #info Peter: yes. working also on ONOS side to support Yang in ONOS
16:18:59 <GeraldK> #info Prakash: is it a peer-to-peer template?
16:19:58 <GeraldK> #info Peter: basically you can even write a schema that is writing to another schema
16:21:03 <GeraldK> #info Prakash: this is interesting for the Domino project. you have a use case here to exchange templates incl translations
16:22:37 <GeraldK> #info Peter: for Promise want to break down the models and decouple the OpenStack from the Promise model
16:23:59 <GeraldK> #info this will allow different experts can work on different aspects independently
16:24:25 <GeraldK> #topic Open action points
16:24:37 <GeraldK> #link https://wiki.opnfv.org/download/attachments/6819702/colorado%20r6.pdf?version=1&modificationDate=1463782894000&api=v2
16:25:53 <GeraldK> #info feature freeze is currently targeting July 1st
16:26:27 <GeraldK> #link https://wiki.opnfv.org/display/promise/Promise+Colorado+planning
16:28:36 <GeraldK> #info Peter to update the Yang-related tasks in JIRA
16:32:22 <GeraldK> #action Gerald to update all "due dates" in Jira
16:32:42 <GeraldK> #link https://wiki.opnfv.org/display/SWREL/Colorado+scenario+inventory+and+dependencies
16:33:37 <GeraldK> #action Peter to update
16:33:52 <GeraldK> #link https://wiki.opnfv.org/display/SWREL/Releases+Colorado+Projects
16:35:46 <GeraldK> #action Peter to update Promise Colorado intent in the above link
16:36:53 <GeraldK> #action Peter to update the JIRA Sprints; maybe even completely remove it
16:38:44 <GeraldK> #action Peter to update JIRA version fields (see email David)
16:39:33 <GeraldK> #topic Relation to OPNFV-MANO
16:40:12 <GeraldK> #info question came up in OPNFV technical discussion meeting today
16:45:12 <GeraldK> #info Promise team can support OPNFV-MANO to see what is already there for the resource reservation I/F
16:45:56 <GeraldK> #info both Promise and Doctor try to align as much as possible to ETSI NFV specs
16:47:58 <GeraldK> #info Prakash asks for contributors from Promise to OPNFV-MANO
16:48:41 <GeraldK> #info first step could be to point OPNFV-MANO team to the Promise interface specification in the Promise documentation
16:52:21 <GeraldK> #info upcoming meetings: go back to regular schedule next week, i.e. 6pm CET, 9am PST
16:52:44 <GeraldK> #endmeeting