15:01:51 <VikramDham> #startmeeting Qtip weekly meeting 9/17/2015
15:01:51 <collabot> Meeting started Thu Sep 17 15:01:51 2015 UTC.  The chair is VikramDham. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:51 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:51 <collabot> The meeting name has been set to 'qtip_weekly_meeting_9_17_2015'
15:01:57 <iben> hi VikramDham
15:02:09 <iben> #info Iben Rodriguez - Spirent
15:02:43 <iben> Meeting Agenda for 8/13:
15:02:44 <iben> 
15:02:45 <iben> 1. Qtip status update
15:02:47 <iben> 2. Qtip demo
15:02:48 <iben> 3. Qtip test case discussions to identify benchmark candidates:
15:02:50 <iben> - CPU benchmarking related test cases
15:02:51 <iben> - Storage benchmarking related test cases
15:02:53 <iben> - Networking benchmarking related test cases
15:02:54 <iben> 
15:02:56 <iben> Please let me know if you want to add anything to agenda for discussion in the community.
15:02:57 <iben> 
15:02:57 <iben> this is from email invite
15:02:58 <iben> is it same adgenda for today?
15:03:02 <nahad> #info Nauman Ahad
15:03:18 <nahad> I think this was from August 13th
15:03:24 <nahad> I 'll post the agenda here:
15:03:45 <iben> yes - we can hear you
15:04:12 <nahad> 1. Discussion of Epics/Stories for QTIP – Identify QTIP deliverables for B release. Please review the proposals submitted on etherpad - https://etherpad.opnfv.org/p/Qtip
15:04:13 <nahad> 2. QTIP Distribution package discussion
15:04:13 <nahad> 3. Discussion about QTIP report generator
15:04:13 <nahad> 4. QTIP port to Python status update
15:04:21 <iben> please setup a few chairs
15:04:33 <VikramDham> #chair nahad iben
15:04:33 <collabot> Current chairs: VikramDham iben nahad
15:04:39 <iben> who else can do it?
15:04:42 <iben> yes - that is correct
15:05:11 <iben> yes
15:05:20 <iben> that is the correct way to add the chairs
15:05:26 <iben> charis
15:05:31 <iben> chairs
15:05:34 <iben> #chairs
15:05:40 <iben> #chair
15:05:40 <collabot> Current chairs: VikramDham iben nahad
15:06:17 <Patrick_> #info Patrick
15:06:46 <iben> link please?
15:06:50 <iben> ah
15:06:51 <iben> wait
15:06:56 <iben> I see it above - one sec
15:07:11 <iben> looking
15:07:20 <VikramDham> #info https://etherpad.opnfv.org/p/Qtip
15:07:25 <iben> #topic - review etherpad
15:07:33 <iben> i’m here - yes
15:07:36 <iben> i can hear you
15:07:53 <nahad> we can't hear you Iben
15:07:59 <iben> i’m not speaking nahad
15:08:34 <iben> sorry - in a quiet location now - i can listen in to what you say and type here in irc
15:09:15 <nahad> Sure. No problem
15:11:05 <iben> what’s the question?  Should we take the topics from etherpad and move into JIRA?
15:11:18 <iben> epics and stories
15:11:36 <VikramDham> yes
15:11:38 <iben> how can we tell from etherpad what is story and what is epi?
15:11:45 <iben> i don’t see that clearly
15:12:02 <iben> is it at the bottom?
15:12:10 <nahad> Yes they are the bottom
15:12:22 <iben> so so far these are just a draft for idea agreement
15:12:35 <iben> is someone sharing the screen on gotomeeting?
15:12:43 <VikramDham> let me do it
15:12:47 <iben> the etherpad is very long - it’s hard to tell which part you are talking about
15:12:54 <iben> BTW - I can hear you talk -
15:13:07 <iben> but just can’t reply - no microphone for me
15:14:22 <iben> you don’t have to assign them now
15:14:37 <iben> someone jsut needs to enter the epics first then link them to the stories
15:15:04 <iben> it’s okay to put in some things we are already doing too
15:15:12 <iben> so
15:15:15 <iben> there is a tag we apply
15:15:18 <iben> for r2
15:15:24 <iben> i think - let me check that
15:15:33 <nahad> Ok Thank you
15:15:57 <iben> Patrick_: on IRC?
15:16:39 <iben> VikramDham: Patrick_ is here
15:16:46 <iben> what did you want to ask him?
15:16:50 <Patrick_> I am here
15:17:01 <Patrick_> but I can't hear clearly
15:17:05 <VikramDham> IRC call on Monday 9:00 am to discuss milestone C status
15:17:12 <VikramDham> Is that ok with everyone?
15:17:24 <Patrick_> 9:00am UTC?
15:17:25 <iben> look at this issue as an example - you can see the “label” of R2 for release b.
15:17:26 <iben> https://jira.opnfv.org/browse/IPVSIX-9
15:17:35 <iben> what time zone?
15:17:50 <VikramDham> 9:00 am PST
15:17:56 <Patrick_> good
15:18:49 <iben> thanks!
15:18:50 <iben> your typing is very loud
15:18:54 <VikramDham> #action Vikram to send list of stories for B release so resources can identify what they want to conttribute to
15:19:18 <iben> send list or enter JIRA issues
15:19:31 <iben> it’s best to enter into JIRA fisrt with R2 lable
15:19:44 <VikramDham> #action for all in QTIP project - Please review the etherpad https://etherpad.opnfv.org/p/Qtip by EOD 9/18
15:19:48 <iben> then we can let the BGS teams know
15:20:01 <iben> we also need to focus on getting an installer or 2 working with qtip
15:20:13 <iben> so i can help with that on the MAAS JOID side
15:20:21 <Patrick_> total agree.
15:20:24 <VikramDham> list will be more abstract to identify how many resources we have
15:20:32 <VikramDham> and will follow up with JIRA tasks
15:20:47 <iben> we have 2 pods at intel now and also the spirent lab available for MaaS POC and BGS/Genisis installer
15:21:10 <iben> is anyone on the g2m audio that is not on the IRC?
15:21:13 <iben> can you please ask?
15:22:45 <VikramDham> yes there are few
15:23:47 <iben> #topic packages for upstream release installers to consume
15:24:13 <iben> OPNFV Installer does not have all the packages built-in
15:24:26 <iben> we must get some packages from another artifact repository
15:24:36 <iben> do we build from source?
15:24:44 <iben> do we consume binaries?
15:24:59 <iben> are tehy available in the native repos or third party repo?
15:25:03 <VikramDham> #info we do not build anything from source for QTIP
15:25:14 <iben> we jsut need to make a list of what we need and where we get it from today
15:25:15 <VikramDham> # we fetch tools from internet
15:25:29 <iben> we can pull those into our artifact repository
15:25:34 <VikramDham> #info benchmarking suite can or cannot rely on internet availability?
15:25:47 <iben> we will jsut push them here - http://artifacts.opnfv.org/
15:25:59 <iben> the installers build a local cache from here if needed
15:26:04 <VikramDham> #info do we assume we have internet access ?
15:26:21 <iben> some installers do not work behind a proxy
15:26:47 <iben> so we must build a local repo with all the needed binaries for those labs without direct internet access
15:26:50 <VikramDham> #do we do wget from this url or download from cache - this would be different behavior for benchmarks?
15:27:18 <iben> there is an email thread about this - it is a problem that has been identified and is being solved - we do not need to solve it here in qtip
15:27:24 <VikramDham> #would the OPNFV installer build repo?
15:27:44 <VikramDham> which QIP can leverage?
15:28:37 <VikramDham> can we assume that QTIP will have access to necessary tools submitted into repository?
15:28:49 <iben> yes - we can assume that
15:29:11 <Patrick_> I think Qtip can integrate with the installer project? so The installer can installer the tools when they deploy the infra?
15:29:14 <iben> we will have to adjust our download code as the solution is delivered
15:29:40 <iben> we should reach out to the various installer projects and ask them to integrate our code
15:29:51 <iben> we can start with one to get going and learn from there and improve
15:30:13 <VikramDham> our tools need to download software from internet
15:31:55 <iben> today the qtip project downloads binaries from the internet - we need to do that ahead of time and but them on our ARM (http://artifacts.opnfv.org/) so they can be consumed by our scripts
15:32:17 <VikramDham> #info from Nahad we cannot use Phoronix but will need to use the benchmarking packages directly such as dhrystone, whetsone and they can be distributed
15:32:22 <iben> the ARM is mirrored locally for organizations with labs and security policies that do not allow direct internet access
15:32:58 <VikramDham> #action nahad to confim no licensing issues with distribution of tools
15:33:28 <iben> do we have a list of tools we’re using?  where is this list published?
15:33:33 <Patrick_> maybe we can list the tools on wiki?
15:33:39 <iben> it should include the source URL and license for each tool
15:33:49 <Patrick_> totally agree
15:34:11 <VikramDham> #action nahad will list them in a seperate section on etherpad - https://etherpad.opnfv.org/p/Qtip
15:34:11 <iben> there should be a text file in our repo with this info
15:34:42 <VikramDham> #action also add this list into the QTIP repository
15:35:15 <iben> +1
15:35:45 <iben> we assume the installer has access to the repo or a mirror of the repo
15:36:04 <Patrick_> I think our etherpad seems too long. maybe we can create some special ether pad forcing on the different scopes?
15:36:13 <iben> so there will be a variable - where is the repo?  this is set based on the lab
15:36:59 <iben> no question
15:37:04 <Patrick_> ok
15:37:40 <iben> i looked for it but can’t find it now
15:37:43 <iben> i will find the email
15:37:51 <iben> and send to VikramDham
15:38:14 <VikramDham> #action Vikram identify the local repo/variable in lab to access the artifacts
15:38:49 <iben> #topic 3. Discussion about QTIP report generator
15:39:39 <iben> sorry - you’re asking for suggestions?
15:39:44 <iben> like splunk?
15:39:54 <iben> or a graphing program?
15:40:00 <VikramDham> yes inputs / experiences with human readable report generators
15:40:12 <iben> logstash - does that count?
15:41:03 <iben> look at #https://wiki.opnfv.org/wiki/jenkins#logging_and_graphing for a simple starting point
15:42:02 <iben> to collect underlying platform metrics can we look at this? #link https://apps.splunk.com/app/1803/  <-- for Linux (KVM) uses Sysstat
15:42:32 <iben> iostat(1) reports CPU statistics and input/output statistics for devices, partitions and network filesystems.
15:42:33 <iben> mpstat(1) reports individual or combined processor related statistics.
15:42:35 <iben> pidstat(1) reports statistics for Linux tasks (processes) : I/O, CPU, memory, etc.
15:42:36 <iben> sar(1) collects, reports and saves system activity information (CPU, memory, disks, interrupts, network interfaces, TTY, kernel tables,etc.)
15:42:38 <iben> sadc(8) is the system activity data collector, used as a backend for sar.
15:42:39 <iben> sa1(8) collects and stores binary data in the system activity daily data file. It is a front end to sadc designed to be run from cron.
15:42:41 <iben> sa2(8) writes a summarized daily activity report. It is a front end to sar designed to be run from cron.
15:42:42 <iben> sadf(1) displays data collected by sar in multiple formats (CSV, XML, etc.) This is useful to load performance data into a database, or import them in a spreadsheet to make graphs.
15:42:44 <iben> sysstat(5) is just a manual page for sysstat configuration file, giving the meaning of environment variables used by sysstat commands.
15:42:45 <iben> nfsiostat-sysstat(1) reports input/output statistics for network filesystems (NFS).
15:42:46 <iben> cifsiostat(1) reports CIFS statistics.
15:42:47 <iben> sorry for long post
15:42:47 <iben> there are many metrics we can collect
15:43:04 <iben> these are graphed and reported wtih free app from splunk
15:43:15 <iben> we can use that or reproduce something similar
15:43:34 <iben> do you see the graph?
15:43:53 <VikramDham> something like jsreport or jinja
15:43:54 <iben> a report would be html of graphs and data summary
15:44:10 <iben> you mentioned a pdf file - this is static report
15:44:13 <VikramDham> yes
15:44:26 <iben> if you want a dynamic query tool that’s using java or some web ui
15:44:28 <iben> more work
15:44:30 <VikramDham> yes we will static pdf output for each run
15:45:47 <VikramDham> #action send inputs for report template
15:45:47 <iben> is there a template or example report we like?
15:46:07 <iben> maybe we don’t work on this as some other project is doing this?
15:46:30 <iben> i suggest we use the jenkins for now as linked above
15:46:33 <VikramDham> we only know the sections which should be but not the template yet
15:46:36 <iben> then expand on that
15:46:57 <iben> each jenkins job run can store it’s own data and graph that
15:48:11 <iben> do we go to last topic now?
15:48:31 <VikramDham> for jenkins is there work required other than providing output?
15:48:50 <iben> no other work
15:48:51 <iben> it is a simple addition
15:48:53 <Patrick_> In yardstick, they are working on to store the test result into MongoDB. and generate the json file to show on the test_dashboard.
15:49:01 <iben> another step in the jenkins job
15:49:29 <iben> has yardstick got their tests running in jenkins yet?
15:49:41 <iben> if we want to be part of CI process we need to automate
15:49:46 <VikramDham> so QTIP will generate output in json, we can assume Jenkins can use it.
15:49:53 <iben> and integrate with installers
15:49:55 <Patrick_> not all of the test case.
15:49:58 <iben> then we can build from there
15:50:12 <iben> if we’re not running from jenkins in LF then we’re not “core”
15:50:29 <VikramDham> #info Nauman mentioned QTIP is part of CI
15:50:50 <VikramDham> #info the code being ported to Python needs to be enabled for CI
15:50:53 <iben> can we get a link here to the jenkins jobs?
15:52:14 <iben> https://build.opnfv.org/ci/job/qtip_dhrystone-BM_vs_BM-dell-build/
15:52:34 <iben> https://build.opnfv.org/ci/job/qtip_dhrystone-BM_vs_BM-dell-build/10/console
15:53:14 <iben> so these can just be updated to graph their results
15:54:51 <VikramDham> can jenkins consume json data?
15:54:54 <iben> After each build completes the plots' data series latest values are pulled from Java properties file(s), CSV file(s), or XML file(s) via an XPath (which you should have generated during the build) somewhere below you workspace.
15:55:22 <iben> It can generate various kind of plots, including Area, Bar, Line, Stacked Bar, Waterfall…
15:55:53 <iben> the html can be generated automaticlly after the job
15:56:05 <iben> then the pdf can be automatically created too as part of the build
15:56:12 <iben> these can all be uploaded to the ARM
15:56:31 <VikramDham> what is ARM?
15:56:45 <iben> jenkins should be used to automate everything and even for manual job runs
15:57:03 <iben> our whole goal with OPNFV is to use jenkins to automate all the things
15:57:18 <iben> let’s not consider this manual use case
15:57:54 <iben> anyone can make a PDF from a web page today
15:58:03 <iben> I jsut open my browser and save as PDF
15:58:20 <iben> jenkins slaves communicate with jenkins masters
15:58:27 <iben> that is how the data is transfered
15:58:34 <VikramDham> ok
15:59:26 <nahad> https://gerrit.opnfv.org/gerrit/#/c/1585/
15:59:54 <VikramDham> #info Nauman integrating orchestration with python code
16:00:16 <iben> #topic 4. QTIP port to Python status update
16:00:42 <VikramDham> #info gerrit for Python code - https://gerrit.opnfv.org/gerrit/#/c/1585
16:01:06 <Patrick_> great work. I will check these codes.
16:02:41 <iben> thanks guys!
16:02:47 <Patrick_> thanks
16:02:49 <nahad> Thank you Everyone!
16:02:52 <iben> no comments
16:02:55 <iben> no suggestions
16:02:57 <Patrick_> not comments
16:02:58 <iben> out of time for now
16:03:03 <iben> we will regroup
16:03:11 <iben> #endmeeting