15:04:11 <VikramDham> #startmeeting Qtip meeting 10/15/2015
15:04:11 <collabot> Meeting started Thu Oct 15 15:04:11 2015 UTC.  The chair is VikramDham. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:04:11 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:04:11 <collabot> The meeting name has been set to 'qtip_meeting_10_15_2015'
15:04:12 <iben> anyone here?
15:04:26 <iben> #info Iben Rodriguez
15:04:34 <VikramDham> #info Vikram Dham
15:05:12 <smalleni> anyone there?
15:05:17 <iben> GoTo Meeting: https://global.gotomeeting.com/join/741216893
15:05:29 <iben> I’m here - are you there?
15:06:47 <iben> VikramDham: can you hear us talking?
15:10:00 <VikramDham> Mofassir: can you give demo today as per plan?
15:10:02 <iben> 8/13:
15:10:04 <iben> 
15:10:05 <iben> 1. Qtip status update
15:10:07 <iben> 2. Qtip demo
15:10:08 <iben> 3. Qtip test case discussions to identify benchmark candidates:
15:10:10 <iben> - CPU benchmarking related test cases
15:10:11 <iben> - Storage benchmarking related test cases
15:10:12 <iben> - Networking benchmarking related test cases
15:10:13 <iben> 
15:10:23 <VikramDham> Nauman can you provide status update?
15:11:15 <Guest46645> yes Vikram we are here
15:11:28 <ljlamers__> #info Larry Lamers (VMware)
15:11:47 <nahad_1> Hi Vikram. Yes we can provide Staus update
15:12:20 <nahad_1> Sorry about the difficulties on GTM. Me and mofassir are facing severe technical problems
15:12:24 <nahad_1> so we 'll continue here
15:12:58 <iben> nahad_1: smalleni - please info in to the meeting so we know who you are.
15:13:10 <nahad_1> #info Nauman Ahad
15:13:30 <iben> you can do this any time - no rush
15:13:32 <smalleni> #info Sai Sindhur Malleni (Red Hat)
15:13:44 <iben> hello! welcome
15:13:46 <VikramDham> #info from Mofassir: QTIP:
15:14:42 <VikramDham> Mofassir QTIP Status Update:
15:14:48 <nahad_1> QTIP framework: Heat integration completed. We can bring up multiple VMs as we saw in last weeks demo.
15:14:53 <nahad_1> Additionally, we can now ssh into machines to drive benchmarks
15:15:31 <nahad_1> System Information collection scripts have also been written that collect information for the machine on which the test case is to be conducted
15:16:11 <nahad_1> This information outputs results in json files for the machines
15:17:05 <nahad_1> We planned to demo the framework today, that would drive dpi benchmark today.
15:17:25 <smalleni> https://drive.google.com/file/d/0B5VB0MQ_i9vaWHk3SGhROHY5QUU/view?usp=sharing
15:17:29 <nahad_1> but the connectivity issues may make this a difficult task
15:18:19 <iben> #info Brian from Spirent to publish scripts on https://github.com/Spirent next week so they can be shared and integrated into qtip, vsperf, and other projects as desired
15:20:00 <iben> #info the rfc2544 test can run a set of tests with certain parameters - the test will run until it is finished - there is no set time duration for this. A faster system will complete the tests in less time.
15:20:56 <VikramDham> Nauman: Did you hear the issue being discussed by me and Brian?
15:21:42 <VikramDham> Networking generator doesn't run for fixed duration
15:21:59 <VikramDham> how can it be integrated with QTIP framework
15:22:13 <VikramDham> if we do not know beforehand how long the test will run for
15:22:39 <nahad_1> Yes i did. Ansible playbooks are just a mechanism to do things in the machines using ssh. They can run scripts within the machine.
15:23:30 <nahad_1> And these scripts can write variables to values , which can be used to signal between machines. This is just one way. There can be many ways
15:24:00 <VikramDham> Can we listen for events from scripts
15:24:23 <Mofassir> yes we can Vikram.
15:25:26 <Mofassir> Thanks Iben. that would be very helpful
15:29:02 <Mofassir> Python is nearly done.
15:29:44 <VikramDham> #info get pod up and running to start integration with vsperf
15:29:50 <Mofassir> We will be checking in the code on Monday after Sprint 1 ends on the 18th. We will be adding a jenkin's job early next week.
15:30:14 <VikramDham> #action JIRA issue for tracking jenkins integration
15:31:29 <iben> #topic
15:31:37 <iben> #topic pbench
15:31:51 <iben> VikramDham: please make me a chair so I can help take notes
15:32:34 <iben> #info  PBench (an open source performance analysis framework) to monitor, collect stats and present visual representations of data collected from various tools like sar, vmstat, iostat and perf while the benchmark is running. This would give the ability to not only benchmark but also obtain vital system information while the benchmark is running. The link for the project on GitHub is https://github.com/distributed-system-analysis/pbench
15:32:35 <iben> it is also packaged as an RPM. The version on GitHub doesn't seem ready to pick up and go (may need changes based on our use case). The readme contains links to tutorials and what all could be accomplished using the tool.
15:35:19 <iben> #link https://drive.google.com/file/d/0B5VB0MQ_i9vaWHk3SGhROHY5QUU/view?usp=sharing <— presentation on pbench from redhat
15:35:59 <iben> #info the pbench tool has not been testing under debian or ubuntu today - it might not work well - this support could be looked at and added later
15:37:50 <iben> #info pbench does not today have a configuration file but there are plans to add this so we cna have results pushed to different servers
15:40:02 <spirentbrian> I have a hard stop now. I don't want to drop off because pbench is very interesting. Thank you for bringing it to our attention!
15:52:35 <iben> #info RedHat has 2 almost full time engineers working on pbench and they are adding features and enhacements
15:55:13 <Mofassir> I think pbench could be really useful for us
15:55:43 <Mofassir> and yes sure Sindhur, we would like to see how it could integrate with QTIP
16:00:50 <Mofassir> Thanks Sindhur!
16:00:59 <iben> updated https://etherpad.opnfv.org/p/Qtip
16:01:00 <Mofassir> Thanks everyone
16:03:11 <VikramDham> #endmeeting