14:32:06 <debrascott> #startmeeting Brahmaputra Release Daily
14:32:06 <collabot`> Meeting started Tue Jan 12 14:32:06 2016 UTC.  The chair is debrascott. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:32:06 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:32:06 <collabot`> The meeting name has been set to 'brahmaputra_release_daily'
14:32:23 <[1]JonasB> #info Jonas Bjurel
14:32:25 <anac1> #info Ana Cunha
14:32:42 <morgan_orange> #info Morgan Richomme
14:32:50 <debrascott> #topic roll call
14:32:51 <trozet> #info Tim Rozet
14:32:51 <trevor_intel> #info Trevor Cooper
14:33:10 <fdegir> #info Fatih Degirmenci
14:33:15 <frankbrockners> #info Frank Brockners
14:33:16 <florind-enea> #info Florin Dumitrascu
14:33:26 <debrascott> I’m multitasking 2 meetings today so sorry if I’m a bit slow
14:34:00 <frankbrockners> folks - i just took the effort to craft a draft agenda for our meeting today... - pretty much what we did so far - only posted on a wiki
14:34:19 <anac1> great ! link ?
14:34:22 <debrascott> Thanks Frank
14:34:24 <frankbrockners> should we go with https://wiki.opnfv.org/releases/brahmaputra/minutes#jan122016? Anything we should add?
14:34:40 <bin_> #info Bin Hu
14:34:40 <trevor_intel> Nice!
14:34:50 <fdegir> +1
14:34:53 <anac1> great!
14:35:21 <frankbrockners> ok then let's go with that one
14:35:40 <frankbrockners> debrascott - if you #chair me, i could drive the agenda while you're on the other call
14:36:17 <debrascott> #chair frankbrockners
14:36:17 <collabot`> Current chairs: debrascott frankbrockners
14:36:27 <frankbrockners> #topic HW/POD status
14:36:43 <ashyoung> #info Ashlee Young (onosfw)
14:36:45 <frankbrockners> fdegir - is https://wiki.opnfv.org/pharos_rls_b_labs#status_of_production_ci_resources_for_release_b accurate?
14:36:46 <trevor_intel> Fatih: This link is not current, do you want to still use it? https://wiki.opnfv.org/pharos/hw_resource_allocation
14:37:07 <debrascott> Thanks for adding scenario- that was my plan to start discuss today
14:37:08 <fdegir> trevor_intel: that link is outdated
14:37:22 <fdegir> trevor_intel: frankbrockners: the most up to date status is followed in pharos
14:37:29 <fdegir> frankbrockners: yes
14:37:45 <frankbrockners> then we can use https://wiki.opnfv.org/pharos_rls_b_labs#status_of_production_ci_resources_for_release_b as single source of truth?
14:37:51 <fdegir> frankbrockners: yes
14:37:52 <trevor_intel> Fatih: I will make a note on the outdated link so as not to confuse
14:38:01 <frankbrockners> perfect
14:38:07 <trevor_intel> frankbrockners: yes
14:38:32 <fdegir> trevor_intel: just wiped it out
14:38:37 <frankbrockners> on current lab status: do we expect any further changes - things look stable by now
14:39:12 <fdegir> #info All PODs except Intel POD2 are up and running on Jenkins
14:39:21 <fdegir> #link https://wiki.opnfv.org/pharos_rls_b_labs#status_of_production_ci_resources_for_release_b
14:39:27 <frankbrockners> cool - thanks
14:39:35 <frankbrockners> then let's move to scenarios
14:39:48 <frankbrockners> #topic scenarios status
14:40:20 <frankbrockners> https://wiki.opnfv.org/brahmaputra_testing_page#available_scenarios and https://wiki.opnfv.org/brahmaputra_testing_page#candidate_scenarios
14:40:27 <frankbrockners> look confusing to me
14:40:33 <trevor_intel> Fatih: Did you already just remove https://wiki.opnfv.org/pharos/hw_resource_allocation?
14:40:55 <fdegir> trevor_intel: yep, 15:38 <fdegir> trevor_intel: just wiped it out
14:41:06 <frankbrockners> not sure who created those tables (morgan_orange - was this you?)
14:41:09 <fdegir> trevor_intel: we already have the history if needed
14:41:13 <fdegir> frankbrockners: me and morgan_orange
14:41:15 <trevor_intel> Fatih: That explains that :)
14:41:17 <morgan_orange> frankbrockners: due to last upadte on jenkins, it is no more up to date
14:41:29 <fdegir> frankbrockners: the idea is to have a list of realized scenarios and candidate scenarios
14:41:36 <morgan_orange> the ref is the jenkins dashboard
14:41:39 <fdegir> frankbrockners: so we reflect the reality
14:42:19 <morgan_orange> when a jenkins job covering a scenario we move it from candidate to available scenario
14:42:25 <frankbrockners> yeah - but the candidate table references a lot of things which no longer exist on the page (A.3..)
14:42:46 <frankbrockners> morgan_orange - thanks - got it
14:43:34 <frankbrockners> morgan_orange: you mentioned that the table is no longer in synch with Jenkins. Could you reflect the latest... then we have this as a single source of truth.
14:43:44 <morgan_orange> yes i take the point
14:44:03 <frankbrockners> question: By when would be the latest date to move scenarios from candidate to active?
14:44:18 <frankbrockners> i.e. when do we need to freeze "active"?
14:44:33 <frankbrockners> in theory this would be today...
14:44:46 <frankbrockners> per https://etherpad.opnfv.org/p/steps_to_brahmaputra
14:45:08 <frankbrockners> thoughts?
14:45:21 <frankbrockners> can we keep the door open till the end of the week?
14:45:27 <frankbrockners> fdegir - any thoughts?
14:45:38 <fdegir> frankbrockners: I think we should
14:45:45 <morgan_orange> I think that other scenario are ready ... but needs to be integrated....
14:45:49 * frankbrockners thinks the same
14:45:50 <fdegir> frankbrockners: I see more and more scenarios getting activated
14:46:10 <debrascott> +1 if there is abiity to do so without compromising release lets do
14:46:17 <frankbrockners> let's keep the door open till Friday
14:46:50 <frankbrockners> #info All scenarios to be finalized by Friday Jan/15 (moving date out from Jan/12)
14:47:16 <frankbrockners> #action morgan_orange to "beautify" and update https://wiki.opnfv.org/brahmaputra_testing_page#candidate_scenarios
14:47:25 <frankbrockners> let's keep rolling
14:47:32 <frankbrockners> #topic installer status
14:47:48 <frankbrockners> quick 1 line status from all installer tools?
14:47:52 <morgan_orange> question, the tables does not reflect the branches stable/master
14:47:57 <morgan_orange> shall we add also this info
14:48:09 <fdegir> morgan_orange: +1 - if we can keep the table sane
14:48:09 <frankbrockners> morgan_orange - that would be brilliant
14:48:12 <morgan_orange> or asusming that once it is either on stable or in master, it is available
14:48:51 <frankbrockners> [1]JonasB, trozet, narindergupta... could you speak up and chime in with a 1-liner on status (what works, what does not)?
14:49:41 <narindergupta> frankbrockners, with joid deploy and functest jobs passing. There are failed test cases which are in investigation
14:49:41 <trozet> #info Apex status: fixed 2 issues with functest, which uncovered another - have a fix for it and will try now, waiting on ceph patch and one other to be ready for RC0
14:50:04 <frankbrockners> trozet - ok to code freeze today?
14:50:14 <[1]JonasB> #info just finishe a run with 2 deployment scenarios os_ha and os_odl-l2_ha
14:50:36 <[1]JonasB> #info next scenario which will run is os_onos_ha
14:50:36 <frankbrockners> #undo
14:50:36 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x1ddd9d0>
14:50:51 <frankbrockners> #info (per Jonas): Fuel just finished a run with 2 deployment scenarios os_ha and os_odl-l2_ha
14:51:19 <frankbrockners> [1]JonasB: You plan to scale to 7 scenarios soon, are you?
14:52:03 <[1]JonasB> frankbrokners: We have tham, its just a matter of runtime, it is not fast you know
14:52:12 <frankbrockners> cool
14:52:23 <frankbrockners> any info for Joid and Compass?
14:52:33 <frankbrockners> are installers ready to code freeze today?
14:52:46 <frankbrockners> or do we need a few extra days?
14:52:53 <trozet> frankbrockners: well i mean we are still going to commit...
14:53:15 <trozet> frankbrockners: these are mainly fixes right now and nothing new
14:53:18 <[1]JonasB> frankbrockners: No, our plan was always on Fri - since september
14:53:21 <frankbrockners> trozet: You can still fix bugs ;-)
14:53:47 <frankbrockners> everyone ok to also move installer code freeze to Jan/15?
14:53:49 <trozet> frankbrockners: would integrating contrail be considered new?
14:53:56 <frankbrockners> yes
14:53:57 <trozet> frankbrockners: if so i would like a few more days to see if that is possible
14:54:00 <frankbrockners> trozet: yes
14:54:03 <frankbrockners> this is new code
14:54:17 <fdegir> should we extend 1 more week instead of friday?
14:54:30 <frankbrockners> fdegir - works for me
14:54:31 <fdegir> like 19th of january so people can work over the weekend if necessary
14:54:39 <frankbrockners> good idea
14:54:46 <frankbrockners> everyone ok?
14:54:53 <[1]JonasB> Thanks for the week-end :-)
14:54:54 <ashyoung> I like it
14:54:57 <frankbrockners> 1....
14:54:59 <frankbrockners> 2...
14:55:02 <frankbrockners> 3..
14:55:10 <fdegir> since test projects have some scenarios to deal with as well
14:55:15 <fdegir> so they won't idle
14:55:17 <frankbrockners> #info code freeze for deploy tools / installers moved to Jan/19
14:55:18 <debrascott> This is also doc freeze date
14:55:22 <frankbrockners> yup
14:55:31 <frankbrockners> let's briefly do test projects as well
14:55:45 <frankbrockners> I do expect that they'd also love to move code freeze to Jan/19
14:56:00 <morgan_orange> which year?
14:56:02 <anac1> i woudln't say no to that
14:56:15 <frankbrockners> #topic Testing and testing tools status
14:56:24 <frankbrockners> anac1 :-)
14:56:46 <frankbrockners> quick 1-liner from anac1, morgan_orange, --- please?
14:56:56 <anac1> #info yardstick working on fuel, troubleshooting compass and joid
14:57:13 <frankbrockners> anac1 - what about apex?
14:57:14 <anac1> #info test cases not ready for sfc, sdnvpn, vnffg
14:57:27 <anac1> #info waiting for apex on baremetal
14:57:34 <morgan_orange> #info functest:  working (from CI perspective) on fuel and joid, manually on compass, investigation on apex
14:57:35 <frankbrockners> thanks
14:58:04 <frankbrockners> do we have any rep from qtip, vsperf, etc.?
14:58:13 <frankbrockners> if so - speak up and chime in please...
14:58:18 <morgan_orange> #info internal testcases ok (even if odl extension deprioritized today - keep odl Arno suite), worl on companion projects (doctor, promise, onos) initiated
14:58:32 <anac1> #info qtip, bottlenecks to work on non-CI PODs
14:58:33 <morgan_orange> #info copper not ready
14:58:47 <frankbrockners> thanks
14:58:54 <debrascott> Frankbrockners: probably not here. We will have them on Release Team Meeting in an hour
14:59:03 <morgan_orange> #info table added in the Brahamuptra page to list the test on non CI PODs
14:59:05 <anac1> #info yardstick test cases for HA, KVM, IPv6, PARSER, +14 internal ready and documented
14:59:17 <frankbrockners> anac1 - link?
15:00:11 <anac1> #link http://artifacts.opnfv.org/yardstick/brahmaputra/docs/configguide_yardstick_testcases/index.html
15:00:20 <anac1> #info working on userguides
15:00:21 <frankbrockners> thanks anac1
15:00:34 <morgan_orange> #info functest user and install guide initiated
15:00:43 <frankbrockners> let's cover the project status in debra's release call...
15:00:48 <morgan_orange> #link http://artifacts.opnfv.org/functest/brahmaputra/userguide/index.html
15:00:52 <frankbrockners> and close for now... TSC is waiting...
15:01:01 <frankbrockners> many thanks to all of you...
15:01:04 <[1]JonasB> Question on KVM - It apeaer that KVM installs a Linux kertel to which there is no OVS kernel module, did I get that right?
15:01:20 <frankbrockners> [1]JonasB
15:01:28 <frankbrockners> let's chat in 1hr about that
15:01:33 <frankbrockners> I'll end for now
15:01:35 <[1]JonasB> Ok!
15:01:36 <frankbrockners> #endmeeting