14:30:32 <debrascott> #startmeeting Brahmaputra daily standup
14:30:32 <collabot`> Meeting started Wed Jan 13 14:30:32 2016 UTC.  The chair is debrascott. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:32 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:32 <collabot`> The meeting name has been set to 'brahmaputra_daily_standup'
14:30:41 <[2]JonasB> #info Jonas Bjurel
14:30:41 <debrascott> #topic roll call
14:30:42 <anac1> #info Ana Cunha
14:30:48 <frankbrockners> #info Frank Brockners
14:30:51 <HKirksey> #info Heather Kirksey
14:30:54 <fdegir> #info Fatih Degirmenci
14:31:03 <frankbrockners> debrascott - could you #chair me?
14:31:08 <morgan_orange> #info Morgan Richomme
14:31:09 <trevor_intel> #info Trevor Cooper
14:31:10 <StuartMackie> #info Stuart Mackie
14:31:15 <bin_> #info Bin Hu
14:31:17 <debrascott> #chair franbrockners
14:31:17 <collabot`> Warning: Nick not in channel: franbrockners
14:31:17 <collabot`> Current chairs: debrascott franbrockners
14:31:23 <joekidder> #info Joe Kidder
14:31:44 <frankbrockners> Similar to yesterday...
14:31:57 <frankbrockners> #info draft agenda: https://wiki.opnfv.org/releases/brahmaputra/minutes#jan132016
14:32:01 <debrascott> yes,
14:32:22 <frankbrockners> debrascott - try again #chair frankbrockners
14:32:40 <frankbrockners> folks - anything else we should add the the agenda?
14:32:44 <debrascott> #info we agreed on the first meeting that agenda should be: 1. lab status 2. hottest issues 3. test status 4. all other project status as time available
14:32:56 <ashyoung> #info Ash Young (onosfw)
14:32:58 <debrascott> #chair franbrockners
14:32:58 <collabot`> Current chairs: debrascott franbrockners
14:33:15 <frankbrockners> missing the "k" in frank :-)
14:33:21 <debrascott> #info do we need to revisit the agendas?
14:33:38 <debrascott> #chair frankbrockners
14:33:38 <collabot`> Current chairs: debrascott franbrockners frankbrockners
14:33:39 <HKirksey> We’ve only got 30 minutes here…let’s not spend the meeting agenda bashing
14:33:46 <frankbrockners> debrascott - let's got a bit more detailed...
14:33:52 <frankbrockners> let's go...
14:34:02 <debrascott> Ok
14:34:08 <frankbrockners> #topic lab/pod status
14:34:14 <fdegir> #info Same status as yesterday with the PODs
14:34:20 <fdegir> #info No new issue has been reported with the PODs
14:34:28 <frankbrockners> cool - thanks fdegir
14:34:30 <HKirksey> Rocking and rolling?
14:34:39 <fdegir> #info A new server is currently WIP for Joid Virtual Deployments
14:34:42 <frankbrockners> #topic scenarios status
14:34:45 <debrascott> hkirksey yes
14:34:47 <fdegir> trevor_intel: want to add anything
14:34:51 <fdegir> ?
14:35:10 <trevor_intel> POD 2 is still a mystery
14:35:25 <fdegir> trevor_intel: then I wasn't wrong with the report
14:35:26 <trevor_intel> Tim is only using one POD (LF 1)
14:35:29 <fdegir> thx
14:35:43 <trevor_intel> Well we don't know if ther eis a problem or not
14:36:04 <debrascott> trevor_intel: do we still have 8 pods up and 2 addiitonal in progress?
14:36:12 <fdegir> trevor_intel: can discuss during pharos meeting perhaps
14:36:16 <trevor_intel> Need help form Tim to reproduce the issue .. we have tried without success
14:36:29 <frankbrockners> yeah - lets do this on the pharos call
14:36:36 <trevor_intel> and feel it may just be realted to internet bandwidth
14:36:37 <frankbrockners> let's move to scenarios
14:36:42 <trevor_intel> ok
14:36:42 <fdegir> will try to fetch trozet there
14:36:43 <debrascott> #topic scenarios
14:37:00 <morgan_orange> I tried to update https://wiki.opnfv.org/brahmaputra_testing_page
14:37:05 <morgan_orange> the tables
14:37:25 <morgan_orange> not fully convinced, I will use the naming discussed recently
14:37:26 <debrascott> fdegir: trozet sent his update on tech discuss said he’d be late
14:37:50 <fdegir> debrascott: pharos meeting is in 1,5 hours
14:38:05 <frankbrockners> https://wiki.opnfv.org/brahmaputra_testing_page#candidate_scenarios still references A.3 etc which confuses stuff
14:38:13 <debrascott> fdegir: got it
14:38:52 <morgan_orange> yep could change to same remake than for Apex ?
14:38:59 <morgan_orange> as it is common to all the installers
14:39:37 <frankbrockners> that would make sense
14:39:51 <morgan_orange> is the naming commonly shared among all the installers?
14:39:59 <frankbrockners> IMHO you need to spell out the notes explicitly given that you removed the earlier scenario table
14:40:11 <frankbrockners> which naming?
14:40:25 <frankbrockners> Fatih's jenkins job naming?
14:40:36 <fdegir> morgan_orange: I contacted Tim and Dan regarding this offline
14:40:36 <frankbrockners> IMHO this is a good way to describe the scenarios
14:40:42 <morgan_orange> scenario naming
14:40:45 <fdegir> morgan_orange: will probably have an update tomorrow
14:40:48 <debrascott> +1  difficult to read now. What does A.3 reference now?
14:40:51 <morgan_orange> https://gerrit.opnfv.org/gerrit/#/c/6323/7/jjb/joid/joid-deploy.sh L72-82
14:41:01 <fdegir> scenario naming patch: https://gerrit.opnfv.org/gerrit/#/c/6323/
14:41:03 <fdegir> thx morgan_orange
14:41:06 <morgan_orange> A = Apex 3 = scenario 3
14:41:21 <frankbrockners> let's info that
14:41:25 <debrascott> OK, maybe a key is needed
14:41:36 <fdegir> #info The scenario naming will be under discussion and the format is
14:41:37 <frankbrockners> #info scenario naming patch - https://gerrit.opnfv.org/gerrit/#/c/6323/
14:42:04 <fdegir> #info os-[controller]-[feature]-[mode](-[optional-field])
14:42:16 <fdegir> #info example: os-onos-nofeature-ha
14:42:26 <fdegir> #info example: os-nosdn-ovs_kvm-noha
14:42:30 <frankbrockners> #action morgan_orange: Clean up https://wiki.opnfv.org/brahmaputra_testing_page#candidate_scenarios table (explain references such as A.3)
14:42:50 <frankbrockners> #info naming convention proposal is also included in the draft agenda for today
14:43:08 <fdegir> #info Job Installer main job naming would be [installer]-[scenario]-[pod]-[loop]-[branch]
14:43:23 <frankbrockners> in addition - did any scenarios move from "candidate" to "available"?
14:43:38 <frankbrockners> [2]JonasB - you were planning to add additional scenarios?
14:44:03 <morgan_orange> I think several ones move yesterday
14:44:14 <[2]JonasB> frankbrockners: We have 7, I dont have any more in mind right now
14:44:18 <morgan_orange> it is growing as the jenkins job
14:44:46 <frankbrockners> ok.. could we also get the https://wiki.opnfv.org/brahmaputra_testing_page#available_scenarios table updated?
14:44:53 <morgan_orange> doe sit cover doctor/scenario ?
14:45:12 <frankbrockners> that way everyone who is interested can get a quick status view
14:45:30 <frankbrockners> morgan_orange or fdegir - could you do this?
14:45:34 <morgan_orange> naming will change according to Fatih description
14:45:40 <fdegir> i nominate morgan_orange :)
14:45:48 <morgan_orange> for what?
14:46:05 <fdegir> wiki table update
14:46:09 <frankbrockners> update https://wiki.opnfv.org/brahmaputra_testing_page#available_scenarios to reflect current state
14:46:15 <morgan_orange> oh yes ok, that is my duty after this meeting...
14:46:24 <morgan_orange> I am just above jenins in the evolution tree
14:46:31 <frankbrockners> #action morgan_orange - https://wiki.opnfv.org/brahmaputra_testing_page#available_scenarios: update to reflect current status
14:46:36 <fdegir> :)
14:46:39 <frankbrockners> haha
14:46:49 <frankbrockners> let's keep rolling
14:46:58 <frankbrockners> #topic installer updates
14:47:33 <frankbrockners> can we have a 1-line status from trozet, [2]JonasB, narindergupta, weidong?
14:48:17 <[2]JonasB> #info: Getting al scenarios to deploy + still some fuel rebase + docs
14:48:43 <frankbrockners> [2]JonasB - this is inspiring!
14:48:53 <frankbrockners> anyone else around from installers?
14:49:18 <frankbrockners> I don't see Tim/Narinder/Weidong ... :-( probably too early...
14:49:19 <fdegir> ping narinder
14:49:28 <fdegir> he's around
14:49:29 <debrascott> from trozet:3.  Was able to get functest to run with 118 pass/27 fail (Thanks Jose and Morgan for the help).  There was a slight error in functest where some of our keystone users got deleted, so I am hoping on the next run there will be more passes: http://213.77.62.197/results?project=functest&case=Tempest&installer=apex
14:49:44 <frankbrockners> #info from trozet:3.  Was able to get functest to run with 118 pass/27 fail (Thanks Jose and Morgan for the help).  There was a slight error in functest where some of our keystone users got deleted, so I am hoping on the next run there will be more passes: http://213.77.62.197/results?project=functest&case=Tempest&installer=apex
14:49:59 <ashyoung> I believe Weidong is in China
14:50:01 <debrascott> #info from trozet: Current status for RC0:
14:50:01 <debrascott> I believe all the patches are in place to provide us an RC0 artifact.  The only remaining issue is functest failed to start again on our daily last night, so we need to fix that so we can get a valid artifact.
14:50:27 <frankbrockners> #info on apex (from trozet): I believe all the patches are in place to provide us an RC0 artifact.  The only remaining issue is functest failed to start again on our daily last night, so we need to fix that so we can get a valid artifact.
14:50:44 <debrascott> #info from trozet: TODO for RC0:1.  Fix functest execution in our daily.2.  Merge current master code to stable/b and produce RC0 candidate via daily job.
14:50:54 <frankbrockners> ok.. - let's keep rolling - would like to get to testing
14:51:00 <fdegir> #info Joid odl seems to be broken today, work with onos seems to be starting (reporting based on Jenkins and what I've seen on irc)
14:51:03 <morgan_orange> I think an update is also needed on jenkins, for the oment, apex job naming is different
14:51:19 <fdegir> morgan_orange: I contacted to trozet and radez offline
14:51:21 <frankbrockners> debrascott - could you ask Narinder and Weidong to attend the daily synch? thanks
14:51:27 <fdegir> morgan_orange: will update the status tomorrow
14:51:36 <HKirksey> ashyoung, do you have any Compass update insight?
14:51:44 <debrascott> #frankbrockners: will send a reminder
14:51:47 <frankbrockners> let's move to testing...
14:51:58 <ashyoung> nope, other than they say all scenarios are looking good there
14:51:59 <frankbrockners> #topic testing projects status
14:52:02 <anac1> #info troubleshooting compass and joid, activation of new scenarios caused failures yardstick to fail in LF POD2
14:52:10 <ashyoung> That team is currently in China for the week
14:52:18 <ashyoung> They should be back this weekend
14:52:24 <frankbrockners> anac1 was waiting for this topic :-)
14:52:28 <anac1> i think we need a structured way to activate scenarios
14:52:32 <ashyoung> But I will chat with Weidong this evening
14:52:32 <frankbrockners> very good
14:52:52 <ashyoung> I'll get him to either update compass status or I'll get the info and update
14:52:59 <ashyoung> for tomorrow
14:53:13 <frankbrockners> anac1 - agreed. Let's first see what can be activated - and with consistent naming, we can also get to more structure
14:53:15 <HKirksey> Thanks ashyoung
14:53:15 <debrascott> #action debrascott contact weidong & narinder to join status mtgs
14:53:29 <morgan_orange> #info Functest has been run accross all the installers. Troubleshooting in progress in the different internal test case
14:53:33 <frankbrockners> a few Qs on testing
14:53:48 <morgan_orange> #info integration of companion projects just started
14:53:55 <frankbrockners> morgan_orange: is 213.77.62.197 DB up to date with test results from all projects?
14:53:59 <fdegir> anac1: +1
14:54:21 <morgan_orange> frankbrockners: what do you mean by up to date?
14:54:37 <morgan_orange> it is not the target DB (it is is a DB on an Orange VM) but it is up to date
14:54:42 <frankbrockners> morgan_orange: does everyone publish results into the DB by now?
14:54:51 <anac1> we don't have the target db yet
14:54:52 <morgan_orange> for the results as tests in CI push their results there (if they want)
14:55:31 <morgan_orange> we collect new results every day. it is not mandatory to push all you results (depends on your test cases, ...) I know that yardstick do not push everything
14:55:43 <morgan_orange> Functest pushes vPing, tempest, rally and vIMS (odl missing)
14:55:45 <frankbrockners> there is another topic which came up during discussions recently: documentation of test results per scenario
14:55:48 <morgan_orange> qtip pushed results
14:55:53 <morgan_orange> bottleneck as well
14:55:55 <debrascott> anac1: what is plan to get the target DB in place?
14:55:57 <morgan_orange> and vsperf also
14:56:10 <frankbrockners> #info some projects push results into results DB - but not everyone
14:56:11 <anac1> yes, we need to document the test results, i think
14:56:22 <frankbrockners> anac1 - yes we do
14:56:26 <morgan_orange> debrascott: the plan is to finalize integration first..
14:56:29 <debrascott> morgan_orange: does storperf need to be part of that too
14:56:36 <frankbrockners> at a minimum we need to create a tar ball of the outcomes of all the tests
14:56:45 <anac1> in a structured, common way
14:56:48 <frankbrockners> ideally it should be one format, e.g. RST
14:56:50 <frankbrockners> but....
14:56:56 <anac1> yes, rst
14:56:57 <frankbrockners> we don't have time here... so
14:57:07 <frankbrockners> Morgan has this as a topic for tomorrows test meeting....
14:57:11 <morgan_orange> plan a slot tomorrow during the test meeting to discuss that
14:57:16 <morgan_orange> yep
14:57:29 <morgan_orange> anac1: already provided a template and there are examples
14:57:35 <frankbrockners> #info Scenario test results need to be published: Discussion to happen on the test call tomorrow...
14:57:40 <morgan_orange> the question is do we want to create document for all the results?
14:57:50 <morgan_orange> we will have a simplified dashboard (demo tomorrow...)
14:58:06 <anac1> i think we need a summary + conclusion on the release testing
14:58:18 <frankbrockners> morgan_orange - results should be documented... -how is a second question. Online DB isn't really documentation...
14:58:24 <debrascott> anac1: +1
14:58:27 <frankbrockners> but let's discuss this in the meeting tomorrow
14:58:39 <frankbrockners> we have 2 more min...
14:58:45 <frankbrockners> let's move to the projects issues
14:58:50 <frankbrockners> #topic project issues
14:59:05 <frankbrockners> StartMackie - any progress on OpenContrail?
14:59:40 <frankbrockners> In addition, do we have updates on Doctor needs, Promise needs?
14:59:51 <fdegir> StuartMackie: ^
15:00:01 <StuartMackie> Compass deployed (has a nova issue)
15:00:05 <frankbrockners> ouch - thanks fdegitr
15:00:18 <frankbrockners> fdegir - fat fingers
15:00:24 <fdegir> :)
15:00:37 <StuartMackie> Apex has  a build, I just sent them details of how to modify for Liberty
15:00:43 <frankbrockners> #info Compass deployed OpenContrail (some nova issues)
15:01:08 <debrascott> #info Apex has  a build, I just sent them details of how to modify for Liberty
15:01:09 <StuartMackie> Need to patch Juju charm for JOID
15:01:10 <frankbrockners> #info Apex has  a build for OpenContrail, Stuart just sent them details of how to modify for Liberty
15:01:10 <anac1> have to leave for another meeting
15:01:23 <frankbrockners> yeah... top of the hr....
15:01:27 <frankbrockners> thanks everyone...
15:01:35 <debrascott> #endmeeting