14:30:13 <debrascott> #startmeeting Brahmaputra Daily Standup
14:30:13 <collabot`> Meeting started Fri Jan 15 14:30:13 2016 UTC.  The chair is debrascott. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:13 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:13 <collabot`> The meeting name has been set to 'brahmaputra_daily_standup'
14:30:22 <frankbrockners> #info Frank Brockners
14:30:24 <debrascott> #topic roll call
14:30:31 <morgan_orange1> #info Morgan Richomme
14:30:53 <[1]JonasB> #info Jonas Bjurel
14:30:55 <trozet> #info Tim Rozet
14:31:01 <uli-k_> #info Uli Kleber
14:31:03 <debrascott> #info draft agenda https://wiki.opnfv.org/releases/brahmaputra/minutes
14:31:05 <HKirksey> #info Heather
14:31:09 <debrascott> #info Debra
14:31:17 <narindergupta> #info Narinder Gupta
14:31:17 <frankbrockners> #link - draft agenda for today: https://wiki.opnfv.org/releases/brahmaputra/minutes#jan152016
14:31:51 <anac1> #info Ana Cunha
14:32:04 <debrascott> #topic Hardware / POD status
14:32:05 <debrascott> #link  https://wiki.opnfv.org/pharos_rls_b_labs#status_of_production_ci_resources_for_release_b up to date?
14:32:15 <frankbrockners> i believe fdegir is on pto
14:32:22 <frankbrockners> is trevor_intel here?
14:32:30 <ChrisPriceAB> #info Chris
14:32:35 <bin_> #info Bin Hu
14:32:37 <StuartMackie> #info Stuart Mackie
14:33:12 <frankbrockners> debrascott - i don't think there are changes to the hw - and fdegir is on pto
14:33:18 <frankbrockners> let's move on
14:33:35 <ashyoung> #info Ashlee Young
14:33:37 <morgan_orange1> hmm
14:33:38 <debrascott> #topic Scenarios status (Definition, Deployment status) -
14:33:47 <morgan_orange1> LF POD 2 disconnected this morning
14:33:58 <frankbrockners> did it?
14:33:59 <morgan_orange1> => not possible to run fuel Stable scenario
14:34:01 <joekidder> #info Joe Kidder
14:34:02 <frankbrockners> ouch
14:34:15 <frankbrockners> let's info that and follow up
14:34:23 <frankbrockners> #info LF POD 2 disconnected this morning
14:34:24 <morgan_orange1> intelpod2 still offline (no Apex stable)
14:34:45 <[1]JonasB> morgan_orange1: Is someone looking in to it?
14:34:57 <morgan_orange1> do not know
14:35:05 <debrascott> #info not possible to run fuel Stable scenario
14:36:04 <frankbrockners> I'll ask pbandzi to see whether he can take a look - but he's also on PTO today
14:36:55 <frankbrockners> let's move to scenarios..
14:37:05 <frankbrockners> are we ready to freeze things today?
14:37:33 <trozet> i thought it was the 19th?
14:37:46 <ashyoung> It seems we have stuff in the scenarios queue that still aren't live and testing
14:37:54 <debrascott> trozet: only scenarios freeze today
14:37:58 <ashyoung> Does that mean they're going to be dropped?
14:38:33 <trozet> debrascott: sorry, what does that mean exactly? just no more new scenarios defined?
14:38:37 <debrascott> It is supposed to be a freeze for identifying any scenarios needed for test
14:38:38 <frankbrockners> trozet: installers & test would do code freeze on 19
14:38:51 <ashyoung> ok cool
14:39:06 <debrascott> so that test teams can map resources and tests to scenarios
14:39:39 <ashyoung> Thanks for the clarification
14:39:40 <frankbrockners> that said - if you have a scenario up which does not have an owner, then it is likely to not happen
14:40:11 <debrascott> I think that we freeze now
14:40:17 <ashyoung> I'm not sure what the current link is that we're using. I
14:40:39 <debrascott> #link https://wiki.opnfv.org/brahmaputra_testing_page#candidate_scenarios
14:40:52 <morgan_orange1> available scenario https://build.opnfv.org/ci/view/OPNFV%20Platform%20CI%20-%20Alternative%20View/
14:41:22 <morgan_orange1> opencontrail is missing, as far as understood last time, integration was in progress with several installers
14:41:39 <debrascott> If candidate is not moved to available then it will be dropped
14:41:42 <ashyoung> apparently most of that has no owner
14:42:31 <debrascott> ashyoung: yes that’s why the call has been made several times to TSC and PTLs
14:42:38 <frankbrockners> so call to action... - we're not at COB :-)
14:42:52 <frankbrockners> so let's check where we are in our next synch on Monday
14:43:15 <ashyoung> So, we need to identify owners ASAP
14:43:21 <frankbrockners> yup
14:43:32 <trozet> sorry if im bringing this up late...
14:43:38 <frankbrockners> identify owners and get the stuff into the pipeline...
14:43:42 <ashyoung> And how to do things go from candidate to available?
14:43:45 <debrascott> frankbrockners: makes sense but we freeze at COB tonight no matter what
14:43:46 <trozet> why are scenarios 12,13 ubuntu?
14:43:48 <ashyoung> got it
14:44:09 <ashyoung> which time zone for COB?
14:44:19 <debrascott> ashyoung: PST
14:44:23 <ashyoung> Thanks
14:44:33 <frankbrockners> trozet - likely because noone put a centos equivalent in
14:44:38 <frankbrockners> and they don't have owners
14:44:48 <trozet> why even put ubuntu in the name?
14:44:49 <debrascott> #action Debra to send one final reminder about scenario freeze
14:44:52 <frankbrockners> could you extend the table with centos based scenarios
14:45:11 <frankbrockners> trozet - this is a nomenclature thing
14:45:28 <debrascott> frankbrockners: was that action request to trozet?
14:45:53 <frankbrockners> in case trozet would like to put the scenarios in for centos...
14:46:08 <frankbrockners> trozet - do you plan  to?
14:46:16 <trozet> well im certainly going to add something here
14:46:24 <frankbrockners> perfect  - thanks
14:46:46 <trozet> kind of odd to me
14:46:49 <debrascott> #action trozet to add centos based scenarios to table
14:46:53 <trozet> doctor is not there?
14:46:57 <trozet> contrail?
14:47:24 <trozet> sdn vpn?
14:47:27 <ChrisPriceAB> trozet: if you can support those scenario's add them.
14:47:54 <trozet> i dont think folks understand this is page decides something, StuartMackie shouldnt contrail be there in your opinion?
14:48:21 <frankbrockners> trozet - i believe doctor was planning to install as part of one of the existing scenarios (assuming the aodh question got resolved)
14:48:40 <StuartMackie> Yes - but I thought yesterday we said that the Jenkins web page was the place of record
14:48:50 <trozet> StuartMackie: i think this wiki matters
14:48:58 <trozet> StuartMackie: can you add a row for contrail?
14:49:09 <StuartMackie> Sure - will add
14:49:13 <morgan_orange1> trozet: StuartMackie wiki matters only for candidate
14:49:32 <trozet> so SDNVPN team is only supporting Fuel then?
14:49:37 <trozet> anyone here from SDN VPN that can comment?
14:49:38 <morgan_orange1> ocl already available on jenkins
14:49:54 <debrascott> #action StuartMackie to add contrail to scenarios
14:50:06 <frankbrockners> good point... the table does not list what is already available as a jenkins job
14:50:16 <morgan_orange1> why, opencontrail is already available trhough jenkins job...
14:50:17 <trozet> frankbrockners: if SDN VPN is only supported by Fuel, going to drop https://gerrit.opnfv.org/gerrit/#/c/5505/
14:50:22 <frankbrockners> so the table is really a "stanging area" for jenkins jobs
14:50:35 <morgan_orange1> it is hard to maintain the wiki
14:50:49 <morgan_orange1> jenkins reflects more the reality
14:51:18 <frankbrockners> trozet - we'll need to check these on Monday - SDN VPN was a candidate in our last meeting as you remember
14:51:28 <debrascott> so call to action for PTLs then is to make sure a scenario exist in Jenkins that supports their validation needs?
14:51:43 <trozet> debrascott: i think both in jenkins and this wiki
14:52:02 <trozet> i wouldnt want SDN VPN team to not get support in other installers cause they forgot to update this wiki
14:52:06 <frankbrockners> if you have a job in jenkins you no longer need to worry about the wiki
14:52:10 <trozet> or contrail, or anybody esle
14:52:12 <trozet> else*
14:52:19 <debrascott> wiki for those not implemented in Jenkins right?
14:52:43 <trozet> debrascott: i think both need to be updated
14:52:47 <frankbrockners> trozet - the wiki was there to capture interest and do planning
14:52:55 <trozet> oh ok
14:53:14 <trozet> well then i can safely ignore the wiki and just add jobs to jenkins?
14:53:27 <frankbrockners> and it was expected that the owner of a scenario would drive jenkins job creation
14:53:32 <morgan_orange1> until you did not add them, they should have been on the wiki :)
14:53:35 <frankbrockners> trozet - yes you can do this
14:53:38 <debrascott> Will try to make that clear in my message out to PTLs
14:53:44 <ashyoung> So, are we freezing the wiki at COB or are we freezing what goes from wiki to Jenkins, or both?
14:54:02 <frankbrockners> we "freeze" the wiki
14:54:06 <debrascott> We are freezing “new” scenarios so wiki
14:54:10 <ashyoung> okie dokie
14:54:19 <frankbrockners> so that we understand what scenarios are asked for
14:54:27 <ashyoung> awesome
14:54:28 <uli-k__> Please note that Asia is in weekend now.
14:54:32 <debrascott> 6 min left are we ready to move on?
14:55:01 <debrascott> noted Uli- will give Asia until Sunday morning our time
14:55:12 <frankbrockners> yeah
14:55:18 <uli-k__> Thanks!
14:55:19 <frankbrockners> let's touch on a couple of key issues
14:55:41 <frankbrockners> can we jump to projects right away
14:55:52 <frankbrockners> e.g. check on Doctor, OpenContrail, etc?
14:55:59 <debrascott> I’d really like to hear about docs framework from ChrisPriceAB
14:56:12 <frankbrockners> then do docs real quick
14:56:16 <ChrisPriceAB> Surely
14:56:19 <frankbrockners> #topic docs update
14:56:39 <frankbrockners> debrascott --- please #topic...
14:56:47 <ChrisPriceAB> Ok, for Docs we now have the composite toolschain working and I will be adding the ready configguide files from other repo's to the master file over the wekend.
14:56:56 <debrascott> #topic Docs Framework
14:57:13 <frankbrockners> #info (ChrisPriceAB:) for Docs we now have the composite toolschain working and I will be adding the ready configguide files from other repo's to the master file over the wekend.
14:57:13 <debrascott> #info or Docs we now have the composite toolschain working and I will be adding the ready configguide files from other repo's to the master file over the wekend.
14:57:13 <ChrisPriceAB> #info the docs composite document toolchain is now ready
14:57:19 <ChrisPriceAB> lol
14:57:32 <debrascott> typos and all :)
14:57:35 <frankbrockners> cool
14:57:48 <debrascott> awesome progress thanks!
14:57:49 <frankbrockners> move to projects now?
14:58:06 <debrascott> #topic Doctor install
14:58:11 <ChrisPriceAB> #info work is ongoing to get feature desciption documents in place for the central release docs an ensure they reflect and refer to in a meaningful way the project specific documentation
14:58:16 <ChrisPriceAB> too fast for me
14:58:31 <debrascott> sorry to type ove we only have 2 min
14:58:38 <ChrisPriceAB> np
14:58:53 <frankbrockners> is there anyone from doctor around?
14:59:04 <debrascott> installers maybe can answer this one
14:59:11 <frankbrockners> otherwise - can we get a quick OpenContrail status from StuartMackie?
14:59:39 <trozet> for doctor Apex has a patch up, we are trying to get it to work
14:59:43 <morgan_orange1> for Doctor the key is the support of aodh
14:59:50 <StuartMackie> Compass got vrouter and GUI up, Apex has a build and will test, JOID waiting for a patch
14:59:50 <frankbrockners> trozet - awesome!
15:00:00 <ChrisPriceAB> One last thing, we will likely request a docs exemption on code freeze until we have a accurate reflection of the complete functionality of the Brahmaputra release.  (including stability etc)
15:00:04 <morgan_orange1> ryota told me this morning that candidate installer were apex and fuel I think
15:00:16 <ashyoung> trozet: do you have what you need for onos?
15:00:17 <frankbrockners> #info for doctor Apex has a patch up, we are trying to get it to work
15:00:33 <trozet> ashyoung: yeah onos is looking good, our rpm split patch just verified last night
15:00:36 <frankbrockners> #info OpenContrail (per StuartMackie): Compass got vrouter and GUI up, Apex has a build and will test, JOID waiting for a patch
15:00:42 <trozet> ashyoung: so now we can push that then try to get onos working
15:00:45 <debrascott> ok good. will capture these in my daily update wiki
15:00:48 <ashyoung> trozet: awesome!
15:00:54 <trozet> ashyoung: will be working on that today and let you know if hit anything
15:01:00 <trozet> ashyoung: Bob is very helpful btw
15:01:18 <ashyoung> trozet: good to hear and thanks!!!
15:01:22 <debrascott> Please send updates/accomplishments to me if you didn’t get a chance to chime in today
15:01:34 <debrascott> at the top of the hour so closing meeting.
15:01:39 <frankbrockners> debrascott - could you #link your daily wiki?
15:01:39 <morgan_orange1> hopefully we will have lots of things integrated very soon, we will have a problem to get all the env to test everything...(not sure all the tests will work immediately in CI...)
15:01:43 <debrascott> thanks again everyone
15:01:58 <ashyoung> Thanks!
15:02:17 <debrascott> #link https://wiki.opnfv.org/releases/brahmaputra/daily_status
15:02:29 <debrascott> #endmeeting