#opnfv-release: C-release milestones

Meeting started by debrascott at 15:01:55 UTC (full logs).

Meeting summary

    1. https://global.gotomeeting.com/join/977976589 (debrascott, 15:02:55)

  1. what went well/and not well, short list of where improvements need to be made (debrascott, 15:05:30)
    1. Fatih Degirmenci (fdegir, 15:06:14)
    2. https://wiki.opnfv.org/releases/brahmaputra/release_plan (debrascott, 15:06:57)
    3. need to start earlier with project definition (whose participating) (debrascott, 15:07:51)
    4. milestones A & B were to close together (debrascott, 15:09:08)
    5. some dependencies were unclear early on and needed to be clarified to all projects earlier (debrascott, 15:11:45)
    6. example: projects did not understand the need to create installer plugins until quite late (debrascott, 15:12:18)
    7. in some cases these were not a lack of planning but lack of visibility to new requirements with regard to supporting installation of new features. (debrascott, 15:13:49)
    8. tool chain & installer & pod processes were being developed at same time that feature projects needed to understand how to work with them (debrascott, 15:15:59)
    9. should infrastructure & tool chain be run through a separate release process from feature integration & release work? (debrascott, 15:18:01)
    10. CI toolchain is already separate from the release (debrascott, 15:20:03)
    11. tool chain can be used because they are tagged by release but they are not part of the release itself (debrascott, 15:21:35)
    12. milestone C, need more detailed and better checklists (debrascott, 15:23:23)
    13. example when do the plugins have to be done (debrascott, 15:23:50)
    14. need to allow more time in backend for testing and integration (debrascott, 15:24:15)
    15. need earlier understanding of integration, deploy & test so things like scenario definition needs to be earlier (debrascott, 15:25:34)
    16. writing of code can be done in parallel or even after these definitions are completed (debrascott, 15:26:55)
    17. need to look after C-release regarding how it is working to have pre-upstreamed code included (debrascott, 15:28:25)
    18. need to enable more plugins, even for things that are not oss (debrascott, 15:28:53)
    19. make sure we always use reproducable upstream code (debrascott, 15:31:53)
    20. challenge aligning to upstream project development cycle (debrascott, 15:33:06)
    21. need to pick baselines early (debrascott, 15:33:25)
    22. Trevor Cooper (trevor_intel, 15:34:34)
    23. need to define scenarios much earlier (debrascott, 15:41:05)
    24. identify which installler you intend to operate with (debrascott, 15:42:46)
    25. have plugin for the installer ready by D: emphasise it (debrascott, 15:43:53)
    26. need checklists for milestones to be clearer (debrascott, 15:44:41)
    27. pharos lab resources identified at milestone C (debrascott, 15:47:10)
    28. need stable environments available for feature projects to use for dev, test, & integration work (debrascott, 15:48:09)
    29. need installers supporting consistent model (debrascott, 15:48:24)
    30. latest and stable need to be supported by projects so we know which branch that installers really work, (debrascott, 15:50:19)
    31. use “promotion” process to move installer stable up to where other projects use it knowing it is reliable (debrascott, 15:51:37)
    32. : separate checklists for each type of project earlier, notably intstallers are very different (debrascott, 15:53:18)
    33. what do we need to have functioning before freezing code? (debrascott, 15:56:56)
    34. keep this at scenario level (debrascott, 15:57:05)
    35. project box based on scenarios (debrascott, 15:58:00)
    36. need to keep quality on master (today’s C relase) (debrascott, 15:59:41)
    37. get CI process defined/communicated better (debrascott, 16:01:24)
    38. ACTION: Chris & Debra to draft proposal on C release criteria (debrascott, 16:01:55)
    39. ACTION: Debra to set next meeting (debrascott, 16:02:17)


Meeting ended at 16:02:31 UTC (full logs).

Action items

  1. Chris & Debra to draft proposal on C release criteria
  2. Debra to set next meeting


People present (lines said)

  1. debrascott (44)
  2. ChrisPriceAB (15)
  3. fdegir (10)
  4. collabot (3)
  5. trevor_intel (1)
  6. edgarstp (1)


Generated by MeetBot 0.1.4.