14:30:11 <debrascott> #startmeeting Brahmaputra Daily Standup
14:30:11 <collabot> Meeting started Wed Jan 27 14:30:11 2016 UTC.  The chair is debrascott. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:11 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:11 <collabot> The meeting name has been set to 'brahmaputra_daily_standup'
14:30:16 <debrascott> #topic roll call
14:30:32 <ashyoung> #info Ashlee Young
14:30:39 <bin_> #info Bin Hu
14:30:47 <anac1> #info Ana Cunha
14:30:50 <ChrisPriceAB> #info Chris Price
14:30:58 <debrascott> #link agenda https://wiki.opnfv.org/releases/brahmaputra/minutes
14:30:59 <narindergupta> #info Narinder Gupta
14:31:14 <uabjonb> #info Jonas Bjurel
14:32:11 <debrascott> #topic Install/Deploy tools status
14:32:27 <debrascott> uabjonb: How is Fuel doing today?
14:32:31 <HKirksey> #info HEather Kirksey
14:32:38 <morgan_orange> #info Morgan Richomme
14:32:51 <ChrisPriceAB> I spoke with Jonas today, can fill in if no-one else is on
14:32:56 <fdegir> #info Fatih Degirmenci
14:32:57 <uabjonb> #info We are ready with all Fuel rebasement and have started regression test of scenarios.
14:33:08 * ChrisPriceAB wipes his brow in relief
14:33:24 <debrascott> ChrisPriceAB +1
14:33:35 <uabjonb> #info Hope that we are lucky with regressin and can start to cherry-pick tomorrow.
14:33:53 <uabjonb> #info Today it looks good, but one day at the time
14:33:56 <uabjonb> end
14:33:58 <debrascott> uabjonb: prognosis toward freezing on Friday?
14:34:09 <uabjonb> Looks good
14:34:26 <debrascott> uabjonb: should we set freeze time end of day Pacific?
14:35:07 <uabjonb> I dont understand what that means, but we should have all in stable by then
14:35:46 <ChrisPriceAB> #info I would like to get input on freezing as I will address the TSC to vote on that today.  Is end of day Friday (PST) suitable?
14:36:14 <ChrisPriceAB> more to the point are there issue with setting that time/date for anyone?
14:37:12 * ChrisPriceAB senses consensus that this is not an issue and just to go ahead.
14:37:16 <anac1> what does that mean to testing ? can we do changes in the code (fix bugs) for scenarios that are not working after the freeze date ?
14:37:24 <uabjonb> I dont have an issue with that
14:37:37 <ChrisPriceAB> anac1:  Bugfixes yes, but all test cases should be merged by then.
14:38:34 <anac1> yes, merged - but not all have been successfully run  yet, so we will need to push code changes to fix
14:38:48 <anac1> is the permitted ?
14:38:54 <anac1> this*
14:39:16 <ChrisPriceAB> I would hope the test case is functional but I can understand the race condition to getting the scenario's in place to validate the test cases.
14:39:32 <debrascott> ChrisPriceAB: another thing discussed yesterday is a need to define what “critical” bugs are. We don’t want anyone to waste time on something that can be documented. Could you bring this discussion up with TSC as well? With distinction between what is critical to feature project vs what is critical to test project?
14:39:35 <uabjonb> Same with Fuel, there will be bug patches comming in as we continue to test and find fault
14:39:52 <ChrisPriceAB> So if I interpret the question the way I want to then it's fine.  :D
14:40:26 <ChrisPriceAB> debrascott:  Ok I will draft something on the thread that we should repond to if it seen to be unreasonable.
14:40:45 <debrascott> ChrisPriceAB: thanks!
14:41:06 <ChrisPriceAB> I do believe the project committers are generally the most competent people to identify what is critical to getting across the line.  I prefer to make sure the line is well defined.  :D
14:41:07 <debrascott> Quick updates from Apex/Joid/Compass please…
14:41:46 <debrascott> ChrisPriceAB: +1
14:41:57 <debrascott> trozet: Apex?
14:42:06 <debrascott> narindergupta: JOID?
14:42:09 <narindergupta> debrascott: for JOID no status change from yesterday. We are good and functest are running on all deployments
14:42:52 <narindergupta> end
14:42:55 <morgan_orange> narindergupta: and ODL test suite was fully OK on Orange POD yesterday, so shall be OK on all joid PODs
14:42:56 * ChrisPriceAB cheers !
14:43:24 <debrascott> looks like we are missing trozet today, expect Apex is still working on plugin for Contrail
14:43:37 <debrascott> #Topic test status
14:43:46 <debrascott> morgan_orange: functest?
14:44:18 <morgan_orange> for apex as mentioned yesterday it would be great to have jobs with ocl not opencontrail, otherwise we will need to distinguish both for the same scenario
14:44:37 <morgan_orange> it will be easy for tests..
14:44:45 <morgan_orange> #info functest frozen since several weeks.. (no new testcases, only bug fix + integration in progress)
14:44:50 <morgan_orange> #info functest: first succesful run of promise test suite last night! next step could consist in pushing the results in DB (but is it allowed under code freeze...)
14:44:57 <morgan_orange> #info functest: first test on scenario sdnvpn in progress at the moment...
14:45:02 <morgan_orange> #info functest: no news on ocl integration
14:45:07 <morgan_orange> #info functest: testcases onos, odl, tempest and rally almost OK ..need to run on stable SUT 4 times in a raw
14:45:12 <morgan_orange> #info functest: troubleshooting on vPing (impossible to retrieve floating iP with odl_l3 and onos scenario) and vIMS (if no vPing, no vIMS...)
14:45:17 <morgan_orange> #info functest: difference on the results despite same installer/same test/same scenario => influence of Hardware probably understimated (show a Jira on intel POD 5 & 6 connectivity issues)
14:45:21 <morgan_orange> #info functest: wiki pages updated
14:45:31 <morgan_orange> #info functest: alternate dashboard in progress (less nice than Kibana but better than wiki manual update)  - hope could show something tomorrow.
14:45:38 <anac1> morgan_orange: you don't have any problem to run SSH ?
14:46:06 <morgan_orange> yes we have trouble for the vPing/ssh
14:46:13 <morgan_orange> for old_l3 scenario
14:46:35 <anac1> and works for odl_l2 scenario ?
14:46:56 <morgan_orange> I think so, need to sync with Jose, he is struggling with vPing/SSH scenario
14:47:09 <uabjonb> ONOS need an to own an public interface to get L3 and floating working. Not according to Pharos setup.
14:47:26 <anac1> morgan_orange: ok, thanks
14:47:43 <morgan_orange> we ecluded vPing /ssh and vIMS from ONOS scenario
14:48:05 <debrascott> morgan_orange: applause! good progress with scenarios
14:48:40 <debrascott> morgan_orange: done?
14:48:45 <morgan_orange> yes
14:48:54 <debrascott> anac1: yardstick?
14:49:44 <anac1> #info yardstick has similar, if not the same problem, as functest - with SSH
14:50:07 <anac1> #info problems to troubleshoot on CI POD
14:50:33 <anac1> #info the time proposed here: https://wiki.opnfv.org/pharos_rls_b_labs#production_ci_resources_reservation is not followed
14:51:17 <anac1> #info during joid run last night, strange interruption on CI POD caused yardstick no-sdn scenario to fail after running 3 test cases succesffully
14:51:18 <uabjonb> It is super important that we respect this and dont jump on each others toes!
14:52:03 <debrascott> #Action Debra to send notice to community on importance to adhere to schedule https://wiki.opnfv.org/pharos_rls_b_labs#production_ci_resources_reservation
14:52:13 <fdegir> that table for POD reservation was sent out for review/comments and no feedback has been recevied yet
14:52:17 <fdegir> except from yardstick
14:52:20 <anac1> we need to have guidelines/procedure to not interrupt each other truobleshooting actibvities or CI runs
14:52:41 <uabjonb> anac1: +1
14:52:50 <debrascott> fdegir: no feedback means accepted
14:52:58 <anac1> we test on virtual before going to baremetal
14:53:11 <fdegir> debrascott: then people should go there and book timeslots
14:53:20 <fdegir> which hasn't happened as of yet
14:53:24 <fdegir> except yardstick
14:53:29 <debrascott> fdegir: yes- hence my action to send out a notice
14:53:35 <fdegir> thanks
14:53:44 <fdegir> it is important to stress that
14:54:01 <debrascott> anac1: more on yardstick?
14:54:11 <fdegir> the stable PODs will be busy with automatic runs so it is good to keep this in ming while adding times/reservation there
14:54:19 <fdegir> mind
14:54:37 <anac1> debrascott: when we get time to troubleshoot in the POD, i will have more info
14:54:40 <debrascott> fdegir: will make sure to emphasis this
14:54:52 <debrascott> anac1: ok
14:55:30 <debrascott> anac1: readiness to freeze test cases on Friday?
14:55:57 <anac1> no new test cases are being added - bug fixes on test cases and scenarios
14:56:11 <debrascott> anac1: is sfc test case complete then?
14:56:27 <anac1> no, not run yet, but is under troubleshooting
14:56:50 <debrascott> anac1: ok, I understand. It is coded and merged, not validated
14:57:15 <anac1> not validated, correct
14:57:32 <debrascott> lets move on to project status then
14:57:45 <debrascott> #topic feature project status
14:58:09 <debrascott> StuartMackie: anything new from Apex on the Contrail plugin?
14:58:49 <StuartMackie> I didn't hear anything
14:59:08 <debrascott> OK will ping trozet later
14:59:20 <debrascott> Do we have anyone on for ARM today?
14:59:46 <debrascott> Any other projects want to give us an update?
14:59:48 <morgan_orange> debrascott: fdegir: anac1 we will have an issue for troubleshooting on Apex - only 1 POD and not able to start before 18 UTC...
14:59:53 <ChrisPriceAB> #info opnfvdocs have work ongoing for all central docs and are working on scenario explanation and definition aspects.
15:00:20 <fdegir> morgan_orange: debrascott: I think trozet and jmorgan1 are working on it
15:00:21 <ChrisPriceAB> #info opnfvdocs pending working on outstanding project docs patches. to do tonight/tomorrow
15:00:39 <ChrisPriceAB> all for now
15:00:40 <fdegir> morgan_orange: debrascott: the details are on #opnfv-pharos channel
15:01:03 <debrascott> fdegir: thanks will take a look. I know you were waiting for validation, correct?
15:01:05 <fdegir> to get Intel POD2 working
15:01:21 <fdegir> according to trozet, Internet connectivity to the pod seems more stable now
15:01:29 <fdegir> and he will try virtual deployment there
15:01:46 <fdegir> debrascott: that's right, we need trozet to try bare metal deploy there
15:01:50 <fdegir> and come back with updates
15:02:02 <debrascott> fdegir: ok will ping him about that when I get other status
15:02:07 <fdegir> ok
15:02:16 <debrascott> top of the hour again….fun continues
15:02:25 <debrascott> thanks all for attending!!
15:02:31 <debrascott> #endmeeting