14:30:59 <debrascott> #startmeeting Brahmaputra Daily Standup
14:30:59 <collabot> Meeting started Fri Jan 29 14:30:59 2016 UTC.  The chair is debrascott. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:30:59 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:30:59 <collabot> The meeting name has been set to 'brahmaputra_daily_standup'
14:31:22 <debrascott> #link agenda https://wiki.opnfv.org/releases/brahmaputra/minutes
14:31:28 <debrascott> #topic roll call
14:31:47 <uabjonb> #info Jonas Bjurel
14:32:04 <anac1> #info Ana Cunha
14:33:48 <StuartMackie> #info Stuart Mackie
14:33:55 <fdegir> #info Fatih Degirmenci
14:34:11 <ashyoung> #info Ashlee Young
14:35:11 <debrascott> #topic TSC vote on freeze
14:35:20 <narindergupta1> #info Narinder Gupta
14:35:34 <debrascott> ChrisPriceAB: have we got a quarum agreeing to freeze today?
14:35:48 <uabjonb> +1
14:36:00 <trevor_intel> #info Trevor Cooper
14:37:01 <debrascott> OK, waiting for Chris to checkin
14:37:03 <HKirksey> #info Heather Kirksey
14:37:08 <debrascott> Let’s move on until he joins us
14:37:42 <debrascott> #topic Install/Deploy tools status
14:38:07 <debrascott> JonasAB: fuel?
14:38:09 <uabjonb> #info Everything on Fuel is in stable/brahmaputra
14:38:12 <morgan_orange> #info Morgan Richomme
14:38:38 <uabjonb> #info No more functional code expected, only bug-fixes.
14:38:48 <debrascott> claps and cheers!!!
14:39:12 <uabjonb> #info We will start regression of all scenarios on Monday.
14:39:30 <uabjonb> #info All in all in OK shape.
14:39:32 <uabjonb> end
14:39:37 <debrascott> trozet: Apex?
14:39:46 <trozet> hi debrascott
14:40:16 <trozet> #info process for freezing is still unclear, not sure if we are allowed to recreate our stable/b branch or not, implications seem to point to we are, waiting for ChrisPriceAB input
14:40:56 <trozet> #info on coding side, we have fixed a bunch of bugs, and working with Doctor team to verify aodh is functioning as expected
14:41:12 <debrascott> he’s not answering ping yet. Let’s follow up on email
14:41:16 <trozet> #info would also like to figure out what why yardstick seems to fail
14:41:22 <debrascott> unless he joins later
14:41:25 <fdegir> I thought we had an agreement regarding stable cherrypickinbg
14:41:36 <fdegir> so I don't understand the reason for this quesiton
14:41:49 <trozet> fdegir: it seems that opnfv is not always as transparent as it should be :)
14:41:56 <fdegir> meaning?
14:42:36 <trozet> fdegir: I guess there has been some background conversation between dneary, uli-k and ChrisPriceAB saying they are OK if we recreate our branch, and the TSC email yesterday implied cherry picking was only enforced post code freeze
14:43:14 <fdegir> ok, if that's the case I can be open than
14:43:19 <fdegir> as I've always been
14:43:24 <fdegir> I'm still where I am
14:43:29 <fdegir> and I object to this request
14:43:35 <trozet> "After code freeze we will follow the stable branch handling as described on https://wiki.opnfv.org/releases/stablebranch."
14:43:37 <fdegir> just like what we discussed trozet
14:44:09 <fdegir> TSC can obviously override stuff
14:44:13 <debrascott> Let’s take that discussion offline for now. this is a short meeting and that probably needs more discussion.
14:44:17 <fdegir> and then I have to stand by my principles
14:44:41 <debrascott> narindergupta: Joid still ready for freeze?
14:44:48 <trozet> fdegir: if you see my quote above ChrisPriceAB wrote that in his email
14:45:06 <fdegir> I'm responding to his mail here openly
14:45:42 <trozet> fdegir: ok, thanks
14:45:45 <debrascott> narindergupta1: joid still ready for freeze?
14:45:58 <narindergupta1> yes
14:46:05 <debrascott> thanks
14:46:14 <debrascott> #topic test status
14:46:30 <debrascott> morgan_orange: how is functest today?
14:46:43 <morgan_orange> info functest: doc updated, under refactoring by doc team
14:46:43 <morgan_orange> #info functest: refactoring of the traces in jenkins (look very nice..let's have a look..)
14:46:43 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/job/functest-compass-huawei-us-deploy-bare-1-daily-brahmaputra/lastSuccessfulBuild/
14:46:43 <morgan_orange> #info functest: integration for ocl ready ..wait for a deployed scenario to continue
14:46:43 <morgan_orange> #info functest: still issue on vPing (Floating IP)
14:46:43 <morgan_orange> #info functest: push logs and additional results to artifacts to be finalized
14:46:44 <morgan_orange> #info functest: run on all the last deployed scenario but CI very quiet at the moment...not lots of deployments performed since 2 days (so no new test results...)
14:46:44 <morgan_orange> #info functest: instability of test DB due to external operations...
14:47:27 <ChrisPriceAB> #info Chris Price (on multiple chanels and activities)
14:47:55 <debrascott> ChrisPriceAB: totally understand, me too
14:48:14 <debrascott> ChrisPriceAB: did tsc reach quarum on vote to freeze?
14:48:15 <morgan_orange> good summary of convergence towards some stbaility => http://testresults.opnfv.org/proto/ see tempest nb tests/nb failures
14:48:49 <ChrisPriceAB> I have not counted final votes.  There is no objection to code freezing, so I suggest we proceed as planned to freeze today.
14:49:17 <ashyoung> Looked like you hit a quorum yesterday
14:49:30 <ashyoung> agree
14:50:29 <trozet> ChrisPriceAB: are we allowed to recreate the branch, since your email implies so?
14:50:38 <ChrisPriceAB> Hi Tim,
14:51:32 <ChrisPriceAB> As mentioned in my response the TSC is not in a position to provide guidance on a per-project basis as to the best way to get to stable for all projects.
14:51:51 <ChrisPriceAB> I suggest we talk to fatih and see if there is a technical issue with establishing the stable as of today on master.
14:51:59 <ChrisPriceAB> off
14:52:46 <debrascott> morgan_orange: ok back to functest, not sure what i’m looking at on your link.
14:52:55 <uli-k> We need a confirmation that everybody will follow rules and keep the code freeze now. We need to be fair to all the projects who followed process.
14:53:02 <trozet> ChrisPriceAB: i dont even know what that means
14:53:21 <trozet> ChrisPriceAB:  "After code freeze we will follow the stable branch handling as described on https://wiki.opnfv.org/releases/stablebranch." applies to all projects, and suggests no policy before code freeze
14:53:27 <ChrisPriceAB> uli-k, that is documented in the vote that the rules apply from the code freeze.
14:53:41 <uli-k> Thanks.
14:54:04 <ChrisPriceAB> trozet, some projects are at stable based on cherry picking, some are in between, some are not.  I expect the answer for each project will be different.
14:54:19 <frankbrockners> question: what do we do with the "old" stable branch that was pulled in early Jan?
14:54:34 * ChrisPriceAB is unable to provide a blanket statement on the topic :D
14:54:40 <trozet> ChrisPriceAB: so then that means each project is allowed to do what it wants before code freeze, so the answer to recreate the branch is a YES PLEASE CONFIRM
14:54:41 <uli-k> We need a clear answer that is followed by all projects from code freeze.
14:55:15 <ChrisPriceAB> uli-k from code freeze there is a clear statement.  getting everyone to stable today needs to be done practically,.
14:55:32 <fdegir> the branch is pulled in based on Steps to Brahmaputra
14:55:49 <fdegir> and all the projects have been following it no matter how bad/stupid/wrong it is
14:56:00 <trozet> fdegir: the tsc voted those steps only apply after code freeze
14:56:14 <fdegir> and we messed up with the freeze
14:56:25 <fdegir> but milestone dates are clear and steps are documented
14:56:47 <fdegir> if this was discussed just before the branch creation
14:56:51 <fdegir> we could have adjusted this
14:56:51 <frankbrockners> guys - can we find a pragmatic solution here?
14:57:02 <fdegir> but noone, including you highlighted this
14:57:14 <debrascott> frankbrockners: +1
14:57:22 <trozet> i give up, even with a new tsc vote, I can't get a straight answer, going to go back to fixing code now
14:57:24 <frankbrockners> there are some projects which "froze" in early Jan
14:57:31 <frankbrockners> there are some projects who are about to freeze
14:58:14 <frankbrockners> for those who froze in early jan we can go with the existing stable branch
14:58:27 <uli-k> Yes. many projects did that. Some projects even reduced their content so they could make it. Therefore it is also important to be fair to those people.
14:58:28 <ashyoung> yes
14:58:28 <frankbrockners> for those who are about to freeze, we'd pull a new stable branch
14:59:01 <ashyoung> other than installers, tests, and docs, all other projects should have froze then
14:59:17 <frankbrockners> yeah - but those are quite a few
14:59:28 <ashyoung> true
14:59:49 <frankbrockners> we need a view who is in which camp
15:00:04 <debrascott> Question: I don’t understand what the angst is about pulling a new stable branch. Can someone please explain?
15:00:15 <uli-k> .. and start fighting between the camps?
15:00:19 <frankbrockners> there is no angst
15:00:40 <frankbrockners> folks who have frozen already have two development trains
15:00:45 <frankbrockners> c-river on master
15:00:56 <frankbrockners> brahma on stable/brahma
15:01:40 <debrascott> so are the c-river things tagged such that they won’t be pulled in while creating a new branch for b? It should have no effect right?
15:01:56 <frankbrockners> so we need a view on who would only be ready to branch now
15:02:12 <frankbrockners> and who already works on c-river in parallel with b-river
15:02:15 <trozet> debrascott: there is no c-river work on Apex master
15:02:34 <frankbrockners> debrascott - could you ping the teams and summarize in an etherpad?
15:02:48 <trozet> frankbrockners: why cant we just leave this stuff up to projects themselves to decide waht they want to do pre-freeze?
15:02:50 <uli-k> And most other projects already work strictly with cherry-picking.
15:03:14 <frankbrockners> trozet - am trying to follow the rules/decisions here...
15:03:33 <trozet> frankbrockners: but the decision says the process is only followed post freeze?
15:03:49 <debrascott> #Action: Debra to create an etherpad to summarize this discussion and continue
15:04:10 <frankbrockners> trozet - which is why I was asking "who is already frozen" back on the old date - and who works with the new freeze date
15:04:17 <debrascott> We’ll need to come to agreement today.
15:04:24 <frankbrockners> the two freeze dates are what screw us here
15:04:24 <debrascott> OK, well after the hour.
15:04:39 <trozet> frankbrockners: im sorry that is ridiculous
15:04:49 <trozet> frankbrockners: the new freeze date should be the only thing that matters
15:04:56 <debrascott> anac1: please send email iwth yardstick status
15:05:10 <frankbrockners> trozet: yes it is - but some teams have already branched in the past
15:05:16 <trozet> frankbrockners: so then let them do what they want!
15:05:19 <debrascott> All others, if you didn’t have a chance to share status please email it to me today.
15:05:19 <frankbrockners> don't force them to now rebranch
15:05:25 <debrascott> #endmeeting