13:29:35 <ChrisPriceAB> #startmeeting Brahmaputra.2.0 release standup
13:29:35 <collabot`> Meeting started Tue Mar 29 13:29:35 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:29:35 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:29:35 <collabot`> The meeting name has been set to 'brahmaputra_2_0_release_standup'
13:29:40 <ChrisPriceAB> #topic roll call
13:29:51 <narindergupta1> #info Narinder Gupta
13:30:58 <ebrjohn> #info Brady Johnson, SFC Project Lead
13:31:00 <anac1> #info Ana Cunha
13:31:32 <dmcbride> #info David McBride
13:31:48 <Guest60250> #info Jonas Bjurel
13:32:05 <ChrisPriceAB> Hi Folks, let's check the status of the 2.0 labeling (if any) and set a plan for the 3.0 work.
13:32:23 * ChrisPriceAB is not convinced monthly cadence is the right cadence based on 2.0...
13:32:47 <anac1> ChrisPriceAB: not labelled yet, can we still do it for 2.0? or wait for 3.0?
13:33:38 <ChrisPriceAB> That's one thing I would like to discuss as well.  I wanted to hold off on docs with the wiki updates and potential churn on links.  Would like to get a read-out on the projects.
13:34:03 <ChrisPriceAB> #topic agenda bashing
13:34:22 <ChrisPriceAB> #info Topics to cover include, scenario status for b.2.0
13:34:47 <ChrisPriceAB> #info we should additionally discuss the status of labelling of b.2.0
13:35:01 <ChrisPriceAB> #info we should set our b.3.0 plan
13:35:06 <ChrisPriceAB> anything else to cover?
13:35:18 <bryan_att> #info Bryan Sullivan
13:35:47 <ebrjohn> It would be interesting to know the dates of 2.0 and 3.0 (sorry if its already documented somewhere)
13:36:19 <ChrisPriceAB> #link https://wiki.opnfv.org/display/SWREL/2.0.release.plan current B.2.0 plan
13:36:28 <ChrisPriceAB> for 2.0 they are all in the past Brady.
13:36:45 * ebrjohn ya, I imagined so
13:37:04 * ebrjohn still getting up to date after last week's vacation
13:37:07 <ChrisPriceAB> #topic Brahmaputra.2.0 scenario readiness
13:37:12 <anac1> #info Yardstick: updates done on user guide and added test cases for VTC, not yet labelled 2.0 - no additional scenarios verified
13:37:28 <ebrjohn> #info SFC : no progress made in 2.0
13:38:41 <bryan_att> #info copper: no progress in 2.0 at least not for release. Can't seem to cherry pick anymore
13:38:57 <ChrisPriceAB> #link https://wiki.opnfv.org/display/SWREL/2.0.release.plan the link to the current scenario status shows consistent state for all scenarios from the Brahmaputra.1.0 release
13:39:14 <ChrisPriceAB> What's going on with the cherry picking Bryan?
13:39:45 <bryan_att> Gerrit won't allow me to cherry pick from master to B
13:39:54 <ChrisPriceAB> #info iterative improvements to some scenarios and testing suites that will be captured in release notes.
13:39:59 <bryan_att> So the changes I have made are on master
13:40:17 <ChrisPriceAB> hmm, OK.  Let's solve that so we can get your updates onto stable.
13:40:52 <ChrisPriceAB> #topic Brahmaputra.2.0 labeling status per project
13:41:10 <anac1> #info Yardstick: not yet labelled 2.0
13:41:28 <ChrisPriceAB> #info docs has not yet labelled 2.0 (due to ongoing wiki work across the last 4 days, vacation time and travel)
13:41:51 <ChrisPriceAB> narindergupta did you get your ranch labelled over the weekend?
13:41:54 <ebrjohn> #info SFC : nothing to label, since no changes were made
13:42:13 <ebrjohn> I guess we could just label 2.0 on the same point as Brahmaputra??
13:42:13 <bryan_att> Link a guide on labeling? Not sure I know or remember how.
13:43:07 <bryan_att> If not don't worry I'll search.
13:43:09 <anac1> ChrisPriceAB: deadline for labelling 2.0 has passed, will it be extended (suggestion until tomorrow)?
13:44:02 <ebrjohn> Do we need to label if nothing has changed?
13:44:18 <ChrisPriceAB> Yeah sorry bryan_att I can't see it in the new structure, the release section of the wiki is not something I have maneged to get to spend time on.
13:44:37 <bryan_att> Ok if it's there I will find it
13:44:49 <ChrisPriceAB> anac1 I think that is a good idea, as I don't think we had everyone available to get the labels in place over the easter weekend.
13:45:30 <anac1> ChrisPriceAB: ok
13:45:32 <ebrjohn> BTW is the OPNFV wiki working for anybody else??? I cant see my project wiki today: https://wiki.opnfv.org/service_function_chaining
13:45:47 <ChrisPriceAB> #info Labels should be applied to the stable for projects that have new content to be made available for the Brahmaputra.2.0
13:45:56 <anac1> ebrjohn: we moved to confluence
13:46:16 * ebrjohn still getting a clue after vacation ;)
13:46:54 <bryan_att> Ebrjohn: start from the main page and navigate to your project as normal. The URL is different.
13:47:04 <ebrjohn> bryan_att: ok, thanks!
13:47:19 <ChrisPriceAB> there is a little teething involved, check here: https://wiki.opnfv.org/display/sfc/Service+Function+Chaining+Home
13:47:20 <bryan_att> Bookmarks are great if nothing ever changes
13:47:50 <bryan_att> You can just enter that up to /sfc that works also
13:48:09 <ChrisPriceAB> Ok, so anac1 & narindergupta1 are you OK to set labels by tomorrow?  I will respin the release docs tomorrow evening and pick up the new content for B.2.0.
13:48:22 <anac1> ChrisPriceAB: ok
13:48:37 <narindergupta1> ChrisPriceAB: we do not have anything new to release for B2.0
13:48:51 <narindergupta1> ChrisPriceAB: so should be fine now
13:48:57 <ChrisPriceAB> no bug fixes made it into stable that you want to expose?
13:49:10 <narindergupta1> no
13:49:29 <narindergupta1> we were looking for onos but that did not pass the release creteria
13:49:36 <ebrjohn> Im wondering if it makes sense for only those projects that have changes to label. Later it could be confusing to see some projects with labels and others without
13:49:37 <narindergupta1> and still in debug mode
13:49:38 <ChrisPriceAB> #action chrispriceab to send an e-mail to project leads to set a revised label deadline for Wendesday 30th march.
13:49:41 <bryan_att> Chris, I have improvements to the post-install scripts, tests, etc. I will label and may need help if the cherry picking still doesn't work
13:50:03 <ChrisPriceAB> #info release docs will be re-spun Wednesday evening PST for Brahmaputra.2.0
13:50:08 <bryan_att> Seemed that B/stable was locked or something
13:50:37 <ChrisPriceAB> ok, let's get aricg onto that today and get it solved.
13:50:43 <ebrjohn> bryan_att: any changes related to the SFC testing on Apex?
13:51:04 <ChrisPriceAB> #topic Brahmaputra.3.0 release planning
13:51:05 <bryan_att> No, still trying to get apex installed. Flat is not working.
13:51:23 <ebrjohn> bryan_att: that's a bummer!! Thanks, though :)
13:51:25 <bryan_att> Trying to get access to some other pod for testing.
13:51:32 <bryan_att> I will keep trying.
13:52:39 <ebrjohn> bryan_att: ACK
13:52:51 <ChrisPriceAB> #info Brahmaputra.3.0 will be executed in a similar fashion to Brahmaputra.2.0
13:53:16 <ebrjohn> ChrisPriceAB: any thoughts on having all projects label, even though no content was changed? Thus having labels for all projects.
13:53:35 <ChrisPriceAB> #info the etherpad date for release is listed as April 19th, although this seems a little close to today.  Shall we maybe prefer to set a release date on the 28th?
13:53:53 <anac1> April 28th sounds better
13:53:59 <ChrisPriceAB> ebrjohn, we could label across all projects but I don't know that it is completely necessary.
13:54:12 <ChrisPriceAB> happy to hear thoughts on the topic.
13:54:22 <ebrjohn> ChrisPriceAB: Like I said above: Later it could be confusing to see some projects with labels and others without
13:54:29 <bryan_att> +1 for the 28th
13:55:13 <ebrjohn> +1 April 28th
13:55:24 <ChrisPriceAB> #action chrispriceab to publish a new simple wiki for planning and reporting of Brahmaputra.3.0 for release on April 28th.
13:56:39 <ChrisPriceAB> I get the point ebrjohn but at the end of the day it's only the feature docs that would expose the label and if nothing has changed the impact should not be significant.  We can adjust for 3.0 if it is messy like this.
13:56:55 <Guest60250> I would not advise to label projects that is not participating with updates. That requires reverification.
13:57:26 <JonasBjurel> ^^ Thats me :-)
13:57:47 <ebrjohn> ok, lets see how it works
13:58:09 <ChrisPriceAB> yes I can agree with that too Jonas, but at this time I don't think any scenario has any updates to publish for 2.0 so it is iterative doc and test tooling improvements only.
13:58:40 <ChrisPriceAB> Mind you I am making excuses to not do work, if we think it is important I can herd all projects (or force) to label.
13:59:06 <ChrisPriceAB> Ok, let's take it to the list.  I'll send the mails and get the 3.0 started.
13:59:12 <ChrisPriceAB> #endmeeting