14:01:13 <ChrisPriceAB> #startmeeting Brahmaputra.3.0 release standup
14:01:13 <collabot`> Meeting started Fri Apr  1 14:01:13 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:13 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:13 <collabot`> The meeting name has been set to 'brahmaputra_3_0_release_standup'
14:01:35 <ChrisPriceAB> morning/afternoon/evening all
14:02:13 <ChrisPriceAB> Based on this meeting result I think we may see if we want to reduce our cadence to a weekly one.  the Friday timeslot does not seem ideal...
14:02:39 <trozet> hi ChrisPriceAB
14:02:59 <ChrisPriceAB> hi trozet, thanks for showing up :)
14:03:10 <trozet> ChrisPriceAB: meeting topic is 3.0, where is 2.0? :)
14:03:11 <bryan_att> #info Bryan Sullivan
14:03:19 <radez> #info Dan Radez
14:03:23 <trozet> #info Tim Rozet
14:03:57 <ChrisPriceAB> 2.0 was last month, labels were due on Sunday but we allowed some delays (and unfirtunately I have caused some more)
14:04:58 <ChrisPriceAB> #topic action point follow up
14:05:00 <trozet> ChrisPriceAB: so someone tagged Apex builds? or
14:05:26 <ChrisPriceAB> no, we only tagged repo's that participated in pushing content for 2.0
14:05:42 <trozet> oh
14:05:49 <ChrisPriceAB> #info action: chrispriceab to send an e-mail to project leads to set a revised label deadline for Wendesday 30th march
14:06:15 <ChrisPriceAB> #info action not done, to be done today and with a delayed date due to the late action follow up.
14:06:20 <[1]JonasB> #info Jonas Bjurel
14:06:23 <trozet> ChrisPriceAB: so we can just choose to participate in only major releases and not SRs?
14:06:38 <trozet> or i guess thats the default, unless we provide a tag
14:06:57 <bryan_att> ChrisPriceAB: you don't mean the 30th do you?
14:07:26 <ChrisPriceAB> Well the discussion was around the scenario's being released in 2.0 and the need to tag stable branches that were the same as for 1.0.  The result was that there was only a need to tag those repo's that had changes to publish on stable for 2.0
14:08:06 <bryan_att> ChrisPriceAB: fyi I tried again to cherry pick to stable but it's not working
14:08:38 <ChrisPriceAB> I did mean the 30th, but this week has gotten away from me.  too much happening and I wasn't able to get everything done.
14:08:57 <ChrisPriceAB> Will need to move the date based on the fact that I still need to send the mail.
14:09:08 <bryan_att> So you mean now next Wed?
14:09:11 <trozet> bryan_att: if you cherry pick in git you can resolve the conflicts
14:09:28 <trozet> bryan_att: i mean not via the gerrit gui button, but in git CLI
14:09:37 <bryan_att> I get "Cherry pick failed"
14:09:45 <trozet> bryan_att: means there is a conflict and you have to do it via cli
14:10:12 <bryan_att> is there a guide to doing that somewhere?
14:10:19 <ChrisPriceAB> Ok, so let's discuss the cutoff date for the label  (which was postponed to the 30th previously until I failed to send an update.
14:10:33 <ChrisPriceAB> trozet do you have content you intend to release on stable for 2.0?
14:10:45 <[1]JonasB> bryan_att:Probably the patch you try to pick is dependant on another that is not on stable
14:10:52 <trozet> ChrisPriceAB: yeah we have fixes we would like to publish in an SR
14:10:58 <trozet> if there is still time
14:11:21 <radez> bryan_att: there are guides... I'll see if I can dig one up for you
14:11:27 <ChrisPriceAB> Well my lack of action has created a window.  but a very short one...
14:11:53 <ChrisPriceAB> are your patches all verified?  have they been merged to stable?
14:11:58 <bryan_att> ChrisPriceAB: in my case the wiki snafu slowed me down so I would be asking for more time anyway
14:12:49 <ChrisPriceAB> yes that is part of the reason that I have not even sent the mail, I've been dealing with a few critical items this week that have created this delay )wiki included)
14:13:10 <bryan_att> JonasBjurel: how do I determine if there is a dependency? I don't see anything that says that in gerrit
14:14:14 <trozet> bryan_att: in your git repo, checkout your stable branch, the git cherry-pick -x <commit ID>
14:14:28 <ChrisPriceAB> Due to the delays I have incurred and the fact we have some content yet to be merged I might propose we move the label deadline for Brahmaputra.2.0 until the start of Tuesday's meeting next week.
14:14:29 <[1]JonasB> bryan_att: Do the cherrypick in git, then it will ask you to resolve the conflict.
14:14:32 <trozet> bryan_att: it will then say there is a conflict, open up the file and search for <<< it will show you the issue
14:14:48 <ChrisPriceAB> trozet, bryan_att, anac1 (if you are on) would that be OK?
14:15:08 <trozet> ChrisPriceAB: that's fine with me
14:15:11 <bryan_att> ChrisPriceAB: WFM
14:15:25 <trozet> ChrisPriceAB: just a clear email to project leads stating exactly what each project needs to do
14:16:29 <ChrisPriceAB> #action chrispriceab to revise tuesdays actions point to send a revised label date to now set a final cutoff of Tuesday April 5th with clear instructions
14:16:50 <ChrisPriceAB> #info Action: chrispriceab to publish a new simple wiki for planning and reporting of Brahmaputra.3.0 for release on April 28th.
14:17:10 <ChrisPriceAB> #info action not yet done, will be ready and communicated by next Tuesday
14:17:41 <ChrisPriceAB> #topic Brahmaputra.3.0 planning and readiness
14:18:26 <ChrisPriceAB> Ok, so we agreed last meeting to set a 3.0 date of April 28th.
14:18:38 <[1]JonasB> WFM
14:19:03 <ChrisPriceAB> I hope this is the last coordinated stable release we need to produce and from there we can enter continuous support mode.
14:19:03 <bryan_att> +1
14:20:04 <ChrisPriceAB> #info We extect this to be the last lebelled brahmaputra stable release activity.
14:20:24 <ChrisPriceAB> #info after this point we expect to enter continuous support on btahmaputra/stable
14:21:06 <ChrisPriceAB> #info motivation for a Brahmaputra.4.0 release activity would need to be raised prior to the brahmaputra.3.0 release date to motivate the coordination of another iteration
14:21:37 <ChrisPriceAB> #info we will review the timeline for B.3.0 based on the prepared wiki on Tuesdays release meeting.
14:22:13 <radez> ChrisPriceAB: note that's in the middle of Openstack Summit, so you'll have low attencance from folks at summit
14:22:20 <ChrisPriceAB> Ok, so sorry about not geting my actions done this week and dragging out the 2.0 timeline.
14:23:09 <ChrisPriceAB> Well we can hopefully get the labelling done for most repo's the week before.  It all goes to plan the actualt release date should not incur significant effort.
14:23:52 <ChrisPriceAB> The only thing I could think of would be to push it backwards which would not increase the content significantly I assume due to the conference anyway.
14:24:47 <trozet> yeah
14:25:10 <ChrisPriceAB> Does anyone think os-austin will be an issue for brahmaputra.3.0 or should be plan for the dates proposed being aware of the constraints we have around events?
14:26:10 <ChrisPriceAB> ok, silence is acquiescence. :)  let's continue with the current plan.
14:26:16 <ChrisPriceAB> #topics AoB
14:26:25 <trozet> ChrisPriceAB: I think if the email is just sent out before the week of summit, projects can tag early if they are going to be busy at OS summit
14:27:05 <ChrisPriceAB> #action chrispriceab to ensure we have a plan for repo tagging for b.3.0 that accomodates travel around the time of b.3.0
14:27:50 <ChrisPriceAB> ok guys anything else in the last 3 minutes?
14:28:54 <trozet> nope
14:29:28 <ChrisPriceAB> ok thanks all.   I will get my work done over the week-end so we can move forward
14:29:38 * ChrisPriceAB finds that statement depressing...
14:29:48 <ChrisPriceAB> #endmeeting