13:32:16 <ChrisPriceAB> #startmeeting Brahmaputra release meeting
13:32:16 <collabot`> Meeting started Tue Apr  5 13:32:16 2016 UTC.  The chair is ChrisPriceAB. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:32:16 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:32:16 <collabot`> The meeting name has been set to 'brahmaputra_release_meeting'
13:32:21 <trozet> ChrisPriceAB: pong ? :)
13:33:56 <ChrisPriceAB> finally...
13:34:01 <ChrisPriceAB> #topic roll call
13:34:14 * ChrisPriceAB was locked out of IRC fgor the last 15 minutes for some reason...
13:34:31 <anac_> #info Ana Cunha
13:34:33 <ChrisPriceAB> #info Chris Price
13:35:30 <mbeierl> #info Mark Beierl (StorPerf)
13:35:56 <ChrisPriceAB> ok, looks like limited participation...
13:36:11 <ChrisPriceAB> or I'm not the only one with IRC issues at the moment
13:36:35 <ChrisPriceAB> you still around trozet?
13:37:10 <mbeierl> apparently not...
13:37:13 <uli-k> #info Uli Kleber (Octopus)
13:37:19 <ChrisPriceAB> #topic Brahmaputra.2.0 completion
13:37:23 <uli-k> sorry for being late
13:37:36 <anac_> #info Yardstick tagged 2.0 last week
13:37:50 <ChrisPriceAB> #info label deadlines for brahmaputra.2.0 passed (again) this morning.
13:38:13 <ChrisPriceAB> #info Yardstick, Apex & docs have been updated with the latest B.2.0 label
13:38:30 <ChrisPriceAB> #info end the brahmaputra.2.0 stability activity
13:38:43 <ChrisPriceAB> #topic Brahmaputra.3.0 planning and timeline
13:38:54 <mbeierl> Question: if I have some bugs that I want to get into the next Brahmaputra release, do I just announce my intent, or what is the process?
13:39:00 <mbeierl> bug fixes that is
13:39:18 <ChrisPriceAB> #link https://wiki.opnfv.org/display/SWREL/3.0.release.plan The Brahmaputra.3.0 release plan
13:39:43 <ChrisPriceAB> mbeirl; you need to follow stable handling and participate in the release and verification activity.
13:40:34 * ChrisPriceAB thinks his computer is about to give up... looking for the right links
13:41:19 <ChrisPriceAB> #link https://wiki.opnfv.org/display/SWREL/Stablebranch stable branch handling for brahmaputra stable
13:41:47 <ChrisPriceAB> #info the development process for stable Brahmaputra releases follows the stable branch handling processes.
13:42:23 <timirnich> #info Tim Irnich
13:42:29 <timirnich> Hi folks sorry for being late
13:42:38 <ChrisPriceAB> Question on the timeline for B.3.0:  The plan provides around 2 weeks for scenarion owners to complete troubleshooting activities on stable prior to the verification activities.  Is this OK for all concerned
13:42:38 <[1]JonasB> #info Jonas Bjurel
13:43:03 <ChrisPriceAB> welcome folks, I was wanting everyone to have a look at the time for b.3.0
13:43:09 <[1]JonasB> OK with me
13:43:11 <ChrisPriceAB> https://wiki.opnfv.org/display/SWREL/3.0.release.plan
13:43:26 <timirnich> need to check - we have a dep on ODL Be SR2
13:43:46 <timirnich> found another bug yesterday
13:43:56 <ChrisPriceAB> SR2?  Ok then we have an issue.  Be-SR2 will be SR1 + 6w so will be after our b.3.0
13:44:15 <timirnich> I can ask for an early build
13:44:17 <ChrisPriceAB> can we work off a pre-Be3 build for SDNVPN?
13:44:22 <ChrisPriceAB> :)
13:44:45 <timirnich> folks are playing around with different baselines and patches currently since the fix as such is already there
13:44:59 <anac_> B.3.0 time plan Ok for Yardstick
13:45:01 <trozet> yeah i think theres already some SR2 build
13:45:11 <ChrisPriceAB> well we would want to be based on a merged stable branch version.
13:45:43 <ChrisPriceAB> happy to go pre-release but for stable I would assert that we need to draw the line at a merged/verified patch.
13:46:07 <ChrisPriceAB> documented.  :D  (of course)
13:46:51 <[1]JonasB> I hesitate to go back to private builds of ODL.
13:46:53 <ChrisPriceAB> Ok, well.  I hear no objections so we can move forward with the planning for b.3.0
13:47:00 <timirnich> getting the fixed merged onto stable is not the problem - unfortunately we seem to have a regression when applying the patch which is not yet fully understood
13:47:11 <ChrisPriceAB> Yeah I know Jonas but in this case it would be specifically and only for one scenario.
13:47:40 <ChrisPriceAB> others should remain on SR1.
13:47:44 <[1]JonasB> Cant be for one scenario only
13:47:59 <ChrisPriceAB> Can't be?  ok then we have an issue...
13:48:10 <[1]JonasB> Then we would need to provide two plugins for ODL.
13:48:17 <timirnich> JonasB let's take that offline, Niko has some ideas...
13:48:26 <[1]JonasB> Ok :-)
13:49:09 <ChrisPriceAB> Ok, good to discuss.  I'll provide the six shooters for this mexican stand-off :D
13:49:31 <ChrisPriceAB> #topic scenario planning for brahmaputra.3.0
13:50:05 <ChrisPriceAB> #info not all scenario's have defined and present owners at this time for b.3.0, scenario owners will need to attend the b.3.0 calls
13:50:27 <ChrisPriceAB> #action All scenario owners to provide input into the scenarion activity for b.3.0
13:50:58 <ChrisPriceAB> #action chrispriceab to ensure scenario owners are aware of the project meeting and are in attendance.
13:51:07 * ChrisPriceAB seems to like cat herding
13:51:27 <ChrisPriceAB> any other info on scenario planning for b.3.0 from owners present?
13:51:32 <timirnich> yes
13:51:50 <timirnich> Can we rename the sdnvpn scenario?
13:52:05 <timirnich> Current name is misleading since VPNService has its own L2 backend
13:52:13 <timirnich> replacing Netvirt
13:52:28 <ChrisPriceAB> in Colorado sure, I think it's a bit late for Brahmaputra.
13:52:43 <ChrisPriceAB> freeze was a while ago now.  ;)
13:52:55 <timirnich> even if it's just a naming clarification?
13:53:03 <timirnich> since the content would actually not change
13:53:57 <ChrisPriceAB> well we can update the docs to describe the scenario in more detail, but as changing the name affects other projects like the installers, releng, docs, etc it's not so simple
13:54:25 <timirnich> ok fine with me - it's just a string after all
13:54:33 <ChrisPriceAB> :)
13:55:04 <ChrisPriceAB> Let's fix it in Colorado planning, is trivial then and very close in time at the end of the day
13:55:39 <ChrisPriceAB> Ok, have to get to TSC preparation.  Any other items to discuss today?
13:56:00 <ChrisPriceAB> Next week I will focus on scenario and test status updating as we have around 14 days to freeze for B.3.0
13:56:25 <ChrisPriceAB> Ok, thanks all.
13:56:29 <ChrisPriceAB> #endmeeting