14:50:35 <dmcbride> #startmeeting Colorado Release
14:50:35 <collabot`> Meeting started Tue May 10 14:50:35 2016 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:50:35 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:50:35 <collabot`> The meeting name has been set to 'colorado_release'
14:51:31 <dmcbride> #chair ChrisPriceAB
14:51:31 <collabot`> Current chairs: ChrisPriceAB dmcbride
14:52:17 <dmcbride> #chair frankbrockners
14:52:17 <collabot`> Current chairs: ChrisPriceAB dmcbride frankbrockners
14:52:37 <ChrisPriceAB> #topic Roll Call
14:53:13 <dmcbride> #info David McBride
14:53:29 <ChrisPriceAB> #info Chris Price
15:00:24 <sofiawallin> #info Sofia Wallin
15:00:51 <bin_> #info Bin Hu
15:02:19 <jose_lausuch> #info Jose Lausuch
15:03:17 <bryan_att> #info Bryan Sullivan
15:03:54 <r-mibu> #info Ryota Mibu
15:04:09 <morgan_orange> #info Morgan Richomme
15:07:22 <frankbrockners> #info Frank Brockners
15:07:30 <jose_lausuch> can you get closer to the mic?
15:09:22 <jose_lausuch> #link https://wiki.opnfv.org/display/SWREL/Test+Release+Criteria
15:09:37 <billyo> #info Billy O'Mahony
15:10:56 <jmorgan1> #info Jack Morgan
15:11:21 <trevor_intel_> #info Trevor Cooper
15:11:31 <mbeierl> #info Mark Beierl
15:14:38 <ChrisPriceAB> #topic test release criteria
15:15:31 * ChrisPriceAB needs mbeierl & jose_lausuch & dmcbride to scribe as he is struggling to follow the audio
15:15:38 <ChrisPriceAB> #chair mbeierl
15:15:38 <collabot`> Current chairs: ChrisPriceAB dmcbride frankbrockners mbeierl
15:15:45 <jose_lausuch> morgan_orange: you sound like being in a bathroom :)
15:15:49 <ChrisPriceAB> #chair jose_lausuch
15:15:49 <collabot`> Current chairs: ChrisPriceAB dmcbride frankbrockners jose_lausuch mbeierl
15:16:11 <mbeierl> it's a large room with a three remote mic speakerphone :)
15:16:13 <ChrisPriceAB> yeah there is a bit of resonance in the room at times
15:16:38 <jose_lausuch> ok
15:18:27 <mbeierl> #link https://wiki.opnfv.org/display/SWREL/Colorado+Testing+-+Discussion+and+Proposals
15:19:56 <mbeierl> #info page listed above is for the test projects is to help us get to a common understanding of release criteria
15:20:21 <mbeierl> #info release criteria maps to test projects, which execute which test cases
15:20:49 <mbeierl> #info need clear demarcation to state when C is ready to go out
15:21:50 <mbeierl> #info what scenarios are required and what hardware resources are required to fulfill the release testing
15:23:34 <mbeierl> #experience in B was that the time was getting out of realistic range, so this criteria is needed to help control the scope and duration of the test runs
15:23:43 <mbeierl> #info experience in B was that the time was getting out of realistic range, so this criteria is needed to help control the scope and duration of the test runs
15:24:45 <mbeierl> #info this discussion is to continue in the next test projects meeting
15:24:45 <jose_lausuch> this topic has been around more than 1 month :)
15:25:55 <mbeierl> #info about 40 projects have indicated C participation
15:28:58 <mbeierl> #info should the test group have release go/no go authority?
15:29:17 <mbeierl> #info Right now it is with TSC
15:29:39 <mbeierl> #info test projects have input into the process
15:31:10 <mbeierl> #info due to B release experience, David is calling for more discussion from the installer PTLs
15:40:33 <mbeierl> #info What exactly is the release criteria has yet to be determined
15:41:27 <mbeierl> #info intent was to have install, functest, yardstick, but this was not always possible
15:41:42 <jose_lausuch> Mark Beierl: that's what we are trying to determine in that wiki with all those ugly tables :)
15:42:35 <mbeierl> #info separate test case definition and implementation should be separate from test execution
15:42:46 <mbeierl> #undo
15:42:46 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2fdd090>
15:42:53 <mbeierl> #info test case definition and implementation should be separate from test execution
15:44:22 <mbeierl> #info David's intent is to go towards a JIRA scrub for C
15:48:29 <jose_lausuch> I created a JIRA best practices for Functest where I explain how to put those tags: https://wiki.opnfv.org/display/functest/JIRA+management#JIRAmanagement-HowtocreateaTASKinJIRA?
15:49:51 <mbeierl> #info can project leads create the Version "Colorado 1.0" in their respective JIRA projects?
15:50:27 <mbeierl> #info tracking upstream projects is manual and a fair amount of replication
15:50:45 <mbeierl> #info can JIRA be federated within Linux Foundation?
15:51:47 <mbeierl> #info Pharos uses Components for sub-caterogizing
15:52:10 <mbeierl> #info This does not help the replication problem though
15:52:31 <mbeierl> #info Frank offering to collect info from other projects to see how to improve this
15:53:03 <mbeierl> #info HTTP link is still not visible enough within JIRA
15:54:30 <mbeierl> #info The copy/paste worked in B with the wiki, can it work for JIRA?
15:55:25 <mbeierl> #info Federating our JIRA instances within LF will provide a way of resucing the copy/paste
15:56:11 <mbeierl> #info Frank has offered to help drive improvements in this area, but if there is no interest, the existing methods will suffice for C
15:57:51 <jose_lausuch> trozet: sorry :)
15:58:39 <trozet> jose_lausuch: np :) busy trying to fix jenkins anyway
15:59:08 <jose_lausuch> we dont upgrade to mitaka, but need some time to develop/refactor the framework and sometimes that breaks things
15:59:17 <jose_lausuch> it has been working now last times
15:59:26 <jose_lausuch> hopefully you can enable it soon for your verify jobs
15:59:44 <trozet> jose_lausuch: yeah thats cool. Just let me know
16:02:40 <jose_lausuch> trozet: yes :)
16:06:33 <dmcbride> #action Installer PTLs - Jose L indicates that FuncTest installer smoke tests have been fixed.  Please integrate these tests with your CI and report on results.
16:07:25 <dmcbride> #endmeeting