15:02:46 <dmcbride> #startmeeting OPNFV Colorado Release
15:02:46 <collabot`> Meeting started Tue Jun 14 15:02:46 2016 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:02:46 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:02:46 <collabot`> The meeting name has been set to 'opnfv_colorado_release'
15:03:14 <dmcbride> #chair frankbrockners
15:03:14 <collabot`> Current chairs: dmcbride frankbrockners
15:03:30 <dmcbride> #topic roll call
15:04:57 <Simona> #info Simona Coppola (Intel)
15:04:59 <bryan_att> #info Bryan Sullivan
15:05:01 <jmorgan1> #info Jack Morgan
15:05:02 <sofiawallin> #info Sofia Wallin
15:05:06 <florind> #info Florin Dumitrascu (ENEA)
15:05:07 <morgan_orange> #info Morgan Richomme (Functest)
15:05:18 <fzhadaev> # Fedor Zhadaev
15:05:25 <fzhadaev> #info Fedor Zhadaev
15:07:53 <dmcbride> #topic JIRA update
15:08:38 <StuartMackie> #info Stuart Mackie
15:11:21 <trevor_intel_> #info Trevor Cooper
15:11:48 <fdegir> #info Fatih Degirmenci
15:12:07 <dmcbride> #info JIRA breakout session at OPNFV summit - June 21 - 1 - 2 p.m.
15:13:13 <jmorgan1> might good to have a quick dmoe on how to do filters in JIRA
15:13:19 <jmorgan1> mbeierl: ^^
15:13:27 <jmorgan1> in breakout session
15:13:46 <jmorgan1> demo rather
15:16:38 <dmcbride> #topic installer / OpenStack integration
15:19:01 <fdegir> I don't see how smoke test can be part of milestone
15:19:10 <fdegir> dmcbride: ^
15:19:22 <fdegir> not that I object to it
15:19:28 <fdegir> but we lack alignment
15:20:12 <dmcbride> #info Apex stable but has not turned on smoke tests
15:21:03 <dmcbride> #action - enable FuncTest smoke tests for Apex and report results [Tim R]
15:24:22 <mbeierl> jmorgan1: will add that the the JIRA overview plan :)
15:25:09 <jmorgan1> mbeierl: auesome
15:25:31 <fdegir> some questions are
15:25:41 <fdegir> when to run smoke test
15:27:25 <fdegir> what to run where
15:35:34 <jmorgan1> senario might be different an installer
15:38:31 <trozet> i think the point of smoke tests is to validate what we install actually works at a basic level, rather than it just passes CI because it installed
15:38:46 <fdegir> long story short: catch problems earlier and often :)
15:39:08 <fdegir> trozet: +1
15:39:15 <jmorgan1> next steps are to draw out this workflow
15:46:16 <fdegir> just to record
15:46:42 <fdegir> #info we should run virtual deploy + functest smoke test for commit gating
15:51:43 <fdegir> morgan_orange: can we take the time down even further without losing the value?
15:51:46 <fdegir> :)
15:54:38 <dmcbride> #action create how-to in confluence for applying tiered testing in FuncTest to scenario [Morgan R]
16:00:38 <morgan_orange> fdegir: based on last Apex healthcheck ~3', vping_ssh 1', vping_userdata 50'', tempest smoke (serial) ~ 13', rally_sanity: ~ 13' cleaning 1' =~32' ....
16:01:13 <fdegir> morgan_orange: I'm into total time
16:01:14 <morgan_orange> fdegir: we could maybe clean once at the end, reduce Tempest tests we still have 169 tests but that is teh default smoke suite from OpenStack
16:01:18 <fdegir> sorry
16:01:21 <fdegir> 32
16:01:50 <fdegir> 32 is a good start
16:02:05 <morgan_orange> I said more because I had a look at the daily which includes feature tests such as dcotor, odl, ...
16:02:12 <morgan_orange> but 32 is for smoke
16:02:13 <fdegir> i'd be happy to take it down to ~15
16:02:30 <fdegir> but evolution nor revolution
16:02:36 <fdegir> not^
16:02:51 <fdegir> we need some work for you for d-release as well :)
16:02:58 <morgan_orange> to reduce to 15, the only way will be to reduce the number of tests in Tempest and/or do not consider Rally_sanity ..both are testing openStack API
16:03:20 <fdegir> yep
16:03:41 <fdegir> but I'm happy with ~30
16:03:45 <fdegir> so not complaining
16:03:45 <morgan_orange> cool
16:03:49 <fdegir> good start
16:13:56 <morgan_orange> fdegir: and we use also serial option in tempest smoke, ..disabling this option will save also time..
16:16:10 <fdegir> morgan_orange: can we try that to sed if things impact each other and how much it saves?
16:17:22 <morgan_orange> we could try it manually on a POD to test, not sure we will save a lot, in Brahmaputra, enabling this option lead to better results especially with controllers....
16:56:22 <dmcbride> #endmeeting