#opnfv-release: OPNFV Release

Meeting started by dmcbride at 15:00:55 UTC (full logs).

Meeting summary

  1. roll call (dmcbride, 15:01:13)
    1. David McBride (dmcbride, 15:01:18)
    2. Uli (uli-k, 15:04:33)
    3. https://www.gotomeeting.com/join/285662629 (dmcbride, 15:05:02)
    4. Sofia Wallin (sofiawallin_, 15:06:00)
    5. Tim Rozet (trozet, 15:06:23)
    6. Greg E (Greg_E_, 15:06:33)
    7. Frank Brockners (frankbrockners, 15:06:45)
    8. Bryan Sullivan (bryan_att, 15:08:41)

  2. Mllestone 10 (dmcbride, 15:12:28)
    1. preliminary documentation requirement at MS6 was only partially successful (dmcbride, 15:13:44)
    2. sofiawallin_ says that we still need clarification around roles and requirements (dmcbride, 15:14:05)
    3. ACTION: sofiawallin_ to add topics to docs meeting for doc requirements and release roles (dmcbride, 15:20:16)
    4. Maryam pointed out that it doesn't make sense to have JIRA ms before docs ms, since JIRA are often associated with JIRA (dmcbride, 15:21:43)

  3. baremetal vs virtual deployment (dmcbride, 15:24:17)
    1. frankbrockners says that we've had a requirement since Arno to deploy to baremetal (dmcbride, 15:25:45)
    2. bryan_att says that baremetal should be the goal (dmcbride, 15:26:33)
    3. Greg_E_ points out that there is a resource issue. Do we have sufficient resources to deploy to baremetal? (dmcbride, 15:28:17)
    4. trozet agrees that there is a resource issue. Adding an additional pod for Euphrates. (dmcbride, 15:28:52)
    5. consensus that HA scenarios must deploy to baremetal to qualify for release (dmcbride, 15:31:50)

  4. release noha, based on successful release of ha? (dmcbride, 15:34:51)
    1. noha scenarios should be tested in virtual, as a minimum requirement (dmcbride, 15:36:31)
    2. bryan_att says that we should not set a requirement around the number of nodes required for baremetal deployment (dmcbride, 15:39:57)
    3. In particular let's be careful about setting expectations that limit where we can take NFV platforms in the future, e.g. highly optimized edge deployments that may take 1-2 nodes or even exist as a virtual deploy in a single node, or on low-power servers with a single NIC, in some edge whitebox server resource. But let's discuss the usecases/options in (bryan_att, 15:42:42)

  5. minimum test requirements? (dmcbride, 15:43:48)
    1. dneary says that we should continue to have a low bar for testing (dmcbride, 15:44:42)
    2. jose_lausuch would like to have some requirements but agrees with having scenario owners make the judgment about release (dmcbride, 15:45:51)

  6. experimental scenarios (dmcbride, 15:47:59)
    1. jose_lausuch says that we should support experimental scenarios, as long as they are documented as such in the release notes (dmcbride, 15:48:51)
    2. bryan_att says that experimentation is important (dmcbride, 15:49:34)
    3. jmorgan1 asks about entry criteria for experimental scenarios (dmcbride, 15:50:39)
    4. should we limit experimental scenarios to 1 or 2 releases? i.e., cannot go on forever as experimental. (dmcbride, 15:51:27)

  7. release/license scanning (dmcbride, 15:56:00)
    1. informational only for Euphrates, but gating for 'F' release (dmcbride, 15:56:21)
    2. https://wiki.opnfv.org/pages/viewpage.action?pageId=10294496 (jmorgan1, 16:00:46)
    3. CI Gate securoty link above (jmorgan1, 16:01:00)


Meeting ended at 20:56:55 UTC (full logs).

Action items

  1. sofiawallin_ to add topics to docs meeting for doc requirements and release roles


Action items, by person

  1. sofiawallin_
    1. sofiawallin_ to add topics to docs meeting for doc requirements and release roles


People present (lines said)

  1. dmcbride (30)
  2. Greg_E_ (10)
  3. jmorgan1 (6)
  4. bryan_att (4)
  5. collabot (3)
  6. dneary (2)
  7. frankbrockners (1)
  8. sofiawallin_ (1)
  9. uli-k (1)
  10. trozet (1)


Generated by MeetBot 0.1.4.