13:31:13 <dmcbride> #startmeeting OPNFV Danube 3 release daily
13:31:13 <collabot`> Meeting started Wed May 31 13:31:13 2017 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:31:13 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:31:13 <collabot`> The meeting name has been set to 'opnfv_danube_3_release_daily'
13:31:23 <dmcbride> #topic roll call
13:31:29 <dmcbride> #info David McBride
13:31:45 <mbeierl> #info Mark Beierl
13:33:08 <dmcbride> #topic release schedule
13:33:33 <dmcbride> #info Tuesday, June 6 ==> end of formal testing
13:34:06 <dmcbride> #info Weds, June 7 ==> finish documentation updates / JIRA cleanup
13:34:25 <dmcbride> #info Thurs, June 8 ==> repo tagging
13:35:01 <dmcbride> #info the download page is expected to go live June 12 or 13
13:35:55 <dmcbride> #info there is some uncertainty due to the fact that the release intersects with the OPNFV summit and many people involved in the release are traveling and involved in the summit
13:38:39 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Git+Tagging+Instructions+for+Danube tagging instructions
13:39:09 <dmcbride> I'd like to see more projects have their repos tagged on time for this release
13:39:42 <dmcbride> in the last release, I think that less than half of the projects had tagged their repos by the release date
13:40:06 <dmcbride> #topic scenarios
13:41:10 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Danube+Scenario+Status scenario status
13:41:54 <dmcbride> scenario owners - please make sure that you have updated the "intent-to-release" column for Danube 3 for your scenarios
13:42:06 <dmcbride> looking at the wiki page, I only see 1 recent update
13:43:07 <dmcbride> trozet: have you updated "intent-to-release" for Apex scenarios for D3 next week?
13:43:22 <dmcbride> narinder: same question
13:44:18 <dmcbride> frankbrockners: do you need to update intent-to-release for your scenarios for D3?
13:45:43 <dmcbride> AlexAvadanii: remember that we will need another artifact from Armband for the release next week
13:46:20 <dmcbride> don't everyone respond at once!
13:47:19 <dmcbride> timirnich: ping
13:47:23 <narinder> dmcbride, i have updated JOID scenario, it seems ODL, OCL and ONOS were not verified working with functest so we can not release.
13:48:14 <dmcbride> narinder: verified by whom? Please clarify.
13:48:41 <narinder> verified by functest.
13:49:01 <narinder> since verification failed so we can not release even it is deployed for ODL
13:49:06 <dmcbride> Not running or not passing?
13:49:24 <dmcbride> is this a functest issue?
13:49:33 <narinder> no this is ODL issue
13:49:40 <narinder> not passing
13:49:46 <narinder> even health check
13:50:05 <dmcbride> this is a change since we released D2, correct?
13:50:10 <frankbrockners> dmcbride: For FDS some scenarios are still uncertain ... we'll decide towards the end of this week, once the APEX pipeline if fully operational again
13:50:17 <narinder> no we did not released D2 also
13:51:48 <dmcbride> is this unique to Joid?
13:52:31 <narinder> looks like so far.
13:53:00 <dmcbride> narinder: if it's a problem with ODL, why is it only affecting Joid?
13:53:30 <narinder> dmcbride, looks like ODL integration charm are not upto date.
13:53:50 <narinder> dmcbride, so it is specific to joid odl scenarios only
13:53:56 <dmcbride> ok - so it's peculiar to Ubuntu?
13:54:20 <dmcbride> phrobb: ping
13:54:26 <narinder> dmcbride, no it is juju charms which JOID uses to deploy.
13:55:14 <dmcbride> narinder: have Jira tickets been generated for this?
13:55:31 <dmcbride> dfarrell07: ping
13:55:46 <dfarrell07> dmcbride: pong
13:56:27 <dmcbride> dfarrell07: are you aware of this juju charm / ODL integration issue that narinder is talking about?
13:56:51 <dfarrell07> dmcbride: no, I don't follow the status of the juju charm closely
13:57:00 <phrobb> Who maintains the ODL charm?... I don't believe it's a deliverable from ODL... if I'm understanding the issue.
13:57:01 <dmcbride> dfarrell07: apparently, it's gating ODL scenarios from Joid
13:57:20 <dfarrell07> phrobb: narinder maintains it as far as I know
13:57:42 <narinder> dfarrell07, Canonical did only one time work and no one is doing it now.
13:58:07 <dfarrell07> narinder: okay
13:58:11 <narinder> dfarrell07, we request ODL community to maintain but it did not happen so it falls out of support now
13:58:45 <dfarrell07> narinder: we can see if Akshita wants to try to take it on
13:59:15 <dfarrell07> but her internship is technically over
13:59:26 <dfarrell07> Akshita - zenith158@gmail.com
14:01:04 <dmcbride> narinder: this will still be an issue for Euphrates, as well, correct?
14:01:18 <narinder> dmcbride, correct that will still an issue
14:02:01 <jmorgan1> narinder: so the issue is just making a newer juju charm correct? or is it that the juju charm is broken, needs to be fixed, then new charm created?
14:02:04 <narinder> i have made changes to use Carbon tar ball and we can test using master branch.
14:02:48 <dmcbride> #issue narinder points out that juju charm / ODL integration is currently broken.  This precludes ODL scenarios from Joid.
14:02:50 <narinder> jmorgan1, modify charm to follow the changes in ODL so that configuraiton does not break.
14:03:07 <dmcbride> #info narinder points out that juju charm / ODL integration is currently broken.  This precludes ODL scenarios from Joid.
14:03:14 <dfarrell07> I guess this isn't a good answer now, but longer-term, is it feasible for JOID to use something like ansible-opendaylight (which is used by others, and is easier to justify me supporting)?
14:03:57 <narinder> dfarrell07, If charms can be made to use ansible-opendaylight then yes we can use that.
14:04:22 <dmcbride> #info Canonical did the original work to develop the juju charm for ODL, then requested that the ODL community maintain it.
14:04:44 <dmcbride> #info however no additional work has been done and the integration is now broken
14:05:16 <narinder> dfarrell07, charms has flexibillity to use anything as charms has hooks and under that hooks we can use any scripting language
14:05:18 <dmcbride> narinder: have you documented this in a Jira ticket or other bug report somewhere?
14:05:29 <narinder> dmcbride, i have to check it
14:05:51 <jmorgan1> dmcbride: i wouldn't say its broken per say but not maintained, odl juju charm needs updating as odl changes
14:05:58 <dfarrell07> narinder: okay, well then it does seem good to make the charm as light as possible and consume config mgmt from something we do actually support
14:06:17 <dmcbride> #action narinder Verify that a Jira ticket has been filed for the juju charm / ODL integration issue.  If not, create a new ticket.
14:07:08 <dmcbride> jmorgan1: understood
14:07:10 <narinder> dfarrell07, yes sounds good to me and ODL controller we do deploy it on containers.
14:08:32 <dfarrell07> it's hard for me to justify putting cycles into charm maintenance, so again I suggest emailing Akshita to see if she can help if Canonical can't provide support
14:08:53 <dfarrell07> or hire akshita ;)
14:09:50 <dmcbride> ok - team, next daily release meeting will be tomorrow at the same time
14:09:57 <dmcbride> #endmeeting