02:27:56 <dmcbride> #startmeeting OPNFV APAC release
02:27:56 <collabot> Meeting started Wed Jul 26 02:27:56 2017 UTC.  The chair is dmcbride. Information about MeetBot at http://wiki.debian.org/MeetBot.
02:27:56 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
02:27:56 <collabot> The meeting name has been set to 'opnfv_apac_release'
02:28:06 <dmcbride> #topic roll call
02:28:11 <dmcbride> #info David McBride
02:28:18 <dmcbride> hello team!
02:29:48 <dmcbride> agenda may be found here;  https://wiki.opnfv.org/pages/viewpage.action?pageId=8690599
02:30:10 <chigang> #info Justin
02:30:11 <dmcbride> we will start off talking about Milestone 5 this Friday, July 28
02:30:29 <dmcbride> hi Justin
02:30:30 <chigang> Hi David
02:31:44 <dmcbride> fuqiao: ping
02:32:42 <gabriel_yuyang> #info gabriel
02:32:54 <dmcbride> hello Gabriel
02:32:56 <dmcbride> welcome
02:33:34 <dmcbride> ok - lets go ahead
02:33:56 <dmcbride> #topic MS5 - scenario integration and feature freeze
02:34:18 <dmcbride> chigang: how are things looking for compass as you approach MS5 this Friday?
02:35:17 <chigang> dmcbride: scenario kvm, odl are online in Jenkins
02:35:54 <chigang> dmcbride: sfc,k8s, dpdk are working in progress
02:36:30 <dmcbride> chigang: how about moon?
02:36:45 <dmcbride> I haven't heard from Ruan for a while
02:37:21 <chigang> dmcbride: regarding to ocl, I sent mail to stuart,he is on vacation, will give me a reply after vacation
02:37:24 <dmcbride> hello Yujun
02:38:32 <dmcbride> I received this message from Stuart, yesterday:  "We do still plan to participate. We believe we now have all the pieces we need. Am working with Narinder to update joid with new bundles, charms etc."
02:38:45 <dmcbride> he seems to be focused on Joid at the moment
02:38:53 <yujunz> Hi dmcbride
02:38:57 <chigang> dmcbride: regarding to moon, may be after k8s scenarios
02:39:44 <dmcbride> chigang: please tell Ruan that he needs to consider submitting an exception requests if he won't be ready on Friday
02:40:00 <chigang> dmcbride: sure
02:40:16 <dmcbride> #info chigang reports that scenario kvm, odl are online in Jenkins
02:40:34 <dmcbride> #iinfo furthermore, sfc,k8s, dpdk are working in progress
02:41:42 <dmcbride> yujunz: what's the status of QTIP?
02:42:11 <yujunz> We intergrate storperf for storage performance indicator locally
02:42:27 <yujunz> Next step is to get it validated in CI job
02:42:39 <dmcbride> ok - cool
02:42:45 <dmcbride> the Doctor has arrived
02:42:47 <yujunz> Currently fuel deployment has been failing for over 1 week
02:42:48 <chigang> dmcbride: could you talk with Stuart, if he can spent some resource, we can support ocl in Compass, and there has been an ansible script to run ocl in ocl offical github
02:43:00 <dmcbride> chigang: will do
02:43:01 <yujunz> So we may probably turn to apex instead
02:43:18 <chigang> dmcbride: thanks
02:43:22 <r-mibu> dmcbride, sorry for the late, again
02:43:22 <dmcbride> #action dmcbride follow up with Stuart Mackie about OCL / Compass
02:43:33 <dmcbride> hi Ryota
02:43:48 <yujunz> Another topic about doctor profiler integration met some difficulty on upstream supporting
02:44:00 <yujunz> So I may have to defer it to next release
02:44:25 <dmcbride> yujunz: you mean defer that one feature?
02:44:54 <dmcbride> #info yujunz may defer doctor profiler integration to next release
02:44:56 <yujunz> Yes, doctor profiling in qtip. Not sure we call it a feature or not
02:45:18 <yujunz> It is a feature for qtip, but not the same one as doctor feature on OPNFV
02:45:47 <dmcbride> Hopefully, everyone saw my email about the update to the MS exception request
02:46:02 <dmcbride> It is now submitted by wiki form, instead of email
02:46:26 <yujunz> OK, should I send one exception request for it? dmcbride
02:46:34 <r-mibu> yujunz, as doctor, we already have that feature, so bug fixes are always welcome
02:47:04 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Milestone+Exception+Requests+for+Euphrates new MS exception request form
02:47:41 <dmcbride> yujunz: you don't need to submit MS exceptions for features that you've decided to defer to the next major release
02:47:59 <yujunz> I see. Thanks dmcbride
02:48:18 <dmcbride> yujunz: only for work that is delayed, that you still intend to release for the current release
02:49:10 <yujunz> OK. r-mibu I'll check if it is ready to merge the profiler feature into python jobs
02:49:11 <dmcbride> r-mibu: what is the status of Doctor.  Two weeks ago, you said that you were short on dev resources.  Any improvement?
02:49:36 <yujunz> Currently it seems the doctor verification job is blocked by some major changes in functest. Is that so?
02:51:15 <r-mibu> dmcbride, nothing changed, we don't have sufficient resource, so we'll deffer features...
02:51:37 <dmcbride> r-mibu: ok - thanks for the update
02:51:42 <r-mibu> yujunz, right
02:51:52 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/38053/
02:52:18 <dmcbride> #info r-mibu reports that the Doctor project still lacks sufficient dev resources to complete planned work.  Will defer features.
02:52:50 <dmcbride> yujunz: and r-mibu what is the issue with functest?
02:52:57 <dmcbride> is this something that I could help with?
02:53:02 <yujunz> Some packages are required for doctor verification job, but it is not available in functest environment
02:53:30 <dmcbride> yujunz: have to talked with Jose about this?  Is there a JIRA issue documented?
02:53:43 <yujunz> #link https://gerrit.opnfv.org/gerrit/#/c/38053/
02:53:44 <chigang> r-mibu: I have 3 students who are studying the doctor, maybe they can help some of the short term, but do not expect too much
02:54:10 <yujunz> It seems functest has a strict policy on what packages can be used in verification script
02:54:40 <yujunz> It is still under discussion in the gerrit review
02:54:58 <dmcbride> #info  doctor verification job is blocked by some major changes in functest.  See gerrit link above ^^
02:55:20 <r-mibu> chigang, cool
02:55:36 <chigang> r-mibu: They have just started and may also need some guiding from you
02:55:48 <r-mibu> yujunz, i have one idea to solve in doctor repo, which is not relevant though
02:56:39 <r-mibu> if we cannot get acceptance in functest, I'll add a quick hack in doctor repo, which may done in few days
02:56:39 <dmcbride> ok - I also wanted to touch on MS6, which is Aug 11, so switching topics
02:56:55 <shangxdy> @yujunz the same problem for parser project, since parser will uninstall and install some packages during the test.
02:56:55 <collabot> shangxdy: Error: "yujunz" is not a valid command.
02:57:32 <dmcbride> #topic MS6 - test case implementation / preliminary documentation / stable branch opens
02:58:09 <dmcbride> I wanted to talk about a new form that we are using to track documentation compliance
02:58:12 <shangxdy> but the internet will not be available, so i think it's a common question.
02:58:51 <dmcbride> #link https://wiki.opnfv.org/display/SWREL/Documentation+Compliance+for+Euphrates documentation compliance tracking
02:59:52 <dmcbride> look at the top row and notice that there is a section for MS6 (preliminary) and MS10 (final)
03:00:07 <gabriel_yuyang> dmcbride: MS6 means test cases should be recorded in docs before Jul 28, right?
03:01:00 <dmcbride> gabriel_yuyang: three things: 1) test case implementation; 2) preliminary documentation 3) stable branch window opens
03:01:27 <dmcbride> so, the test cases that you documented in the test case database for MS2 need to be implemented for MS6
03:01:54 <dmcbride> which means that they should be running in a job in CI
03:02:19 <dmcbride> gabriel_yuyang: did that answer your question?
03:02:31 <gabriel_yuyang> Yes, very clearly!
03:02:50 <dmcbride> preliminary documentation means that you have the directory structure and placeholder documents
03:02:52 <gabriel_yuyang> We will work on it!
03:03:34 <dmcbride> the placeholder documents could simply be a blank document with a title and file name
03:03:48 <huzhj> #info Zhijiang Hu
03:03:58 <huzhj> sorry to be late
03:04:08 <dmcbride> the idea is to get  the structure in place for MS6 so that you just need to worry about the content for MS10
03:04:46 <dmcbride> #info as you complete your documentation tasks for MS6, fill in the documentation table linked above
03:06:01 <dmcbride> huzhj: welcome - glad you could make it
03:06:14 <dmcbride> huzhj: what is the status of Daisy on master?
03:07:08 <dmcbride> huzhj: do you have any dependent projects for this release?
03:07:55 <dmcbride> #topic vacation
03:08:31 <dmcbride> #info dmcbride will be out from Aug 7 - Aug 18
03:08:53 <dmcbride> #info Aug 8 meeting is cancelled
03:09:20 <chigang> dmcbride: enjoy your vacation
03:09:22 <dmcbride> #info next OPNFV APAC release meeting will be Aug 22
03:09:26 <dmcbride> thanks, man
03:09:38 <dmcbride> taking the kids to Yellowstone
03:09:58 <yujunz> Cool
03:10:26 <dmcbride> BTW - I will have my photos up on flickr soon from my sightseeing in Beijing
03:10:43 <dmcbride> I will share with you guys and you can make fun of me as a tourist :)
03:11:21 <dmcbride> ok - any last questions or comments?
03:11:54 <chigang> Clear for me
03:12:16 <dmcbride> alright - thanks for attending.  We will talk again in late August
03:12:33 <dmcbride> huzhj: if you have any updates on Daisy, please email me or catch me on IRC
03:12:42 <dmcbride> #endmeeting