13:01:54 <dmcbride_> #startmeeting OPNFV Release Process Working Group
13:01:54 <collabot`> Meeting started Fri Oct 19 13:01:54 2018 UTC.  The chair is dmcbride_. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:01:54 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:01:54 <collabot`> The meeting name has been set to 'opnfv_release_process_working_group'
13:02:03 <dmcbride_> #topic roll call
13:02:09 <bramwelt> #info Trevor Bramwell
13:02:33 <dmcbride_> #info David McBride
13:03:09 <efoley> #info Emma Foley
13:05:53 <dmcbride_> #info Rama
13:11:25 <efoley> #topic CD cadence and milestones
13:12:50 <efoley> #info We will still have a twice yearly release, to help with project promotion and marketing
13:13:16 <efoley> #info The CD release model will server as meta releases throughout the cycle
13:13:16 <mbeierl> #info Mark Beierl
13:14:00 <efoley> #info Release process should be lightweight for "official" and "intermediate" releases, as the current process is considered burdensome for some
13:18:36 <bramwelt> #link https://jenkins.io/download/lts/
13:18:38 <dmcbride_> #info every 6 months take the "best" release and make that part of an OPNFV release
13:19:29 <dmcbride_> #info bramwelt describes Jenkins release cycle - every 2 weeks plus major release every 12 weeks
13:21:29 <efoley> #info Trevor suggested that there should be two separate independant for CD and traditional release. Every 6 months, pick a previous CD release and "upgrade" it to LTS
13:25:03 <efoley> #info for the traditional release, choose a CD release, and promote that as the "big" release; Some additional testing/validation/collatoral may be needed to package this big release.
13:26:16 <efoley> #info How does a CD release get chose as the "big"/official release? We need to define criteria for choosing an official release from the set of CD releases
13:44:09 <dmcbride_> #info bramwelt suggests two levels of process: 1) individual project releases; and 2) OPNFV major releases
13:48:18 <dmcbride_> #info bramwelt says define requirements first, then determine process
13:50:46 <efoley> #link https://wiki.opnfv.org/display/SWREL/Continuous+Delivery+Release+Planning
13:52:33 <dmcbride_> #action dmcbride to locate CD process documentation from the last plugfest
13:53:05 <efoley> #info Release requirements need to be defined per type of project
13:54:49 <mbeierl> Sorry, need to drop now.
13:55:18 <efoley> #info test projects need to be validated separately, so that the validation they provide is credible
13:56:32 <dmcbride_> #topic do we need release artifacts?
14:05:39 <dmcbride_> #endmeeting