07:04:31 <rex_lee> #startmeeting RS Team Weekly Meeting Jun 16
07:04:31 <collabot> Meeting started Tue Jun 16 07:04:31 2015 UTC.  The chair is rex_lee. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:04:31 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:04:31 <collabot> The meeting name has been set to 'rs_team_weekly_meeting_jun_16'
07:04:47 <r-mibu> hi!
07:05:09 * rex_lee #topic use case bandwidth
07:05:41 <r-mibu> #link https://etherpad.opnfv.org/p/rs_usecase_collect_network_bandwidth_info
07:13:52 <rex_lee> #info any implimentation suggestion about case 1?
07:17:58 <rex_lee> #info need to dig more about case 1 from the view of NFV
07:21:21 <r-mibu> #info case 2 is seems to be good topic in NFV context
07:22:14 <r-mibu> #info question on HOW: does system need to aware of host ststus including network load/usage
07:23:12 <r-mibu> if we calcurate available BW from exixting port's BW
07:23:51 <r-mibu> then we don't have to get actual usage of NIC on host
07:24:50 <rex_lee> if we can calcurate the available
07:25:08 <rex_lee> BW
07:27:38 <rex_lee> that would be better if we can get the available bandwidth by calculaiton
07:28:02 <r-mibu> OK
07:29:41 <rex_lee> we first thought to record the bandwidth info in the db, when new vm create, minus the quantity
07:29:59 <r-mibu> +1
07:31:29 <r-mibu> So, I propose to describe this use case without collecting network load/usage on each host
07:32:21 <r-mibu> this case should be tipical use case in RS
07:32:37 <qiliang> without collecting network load/usage on each host, how can we make sure bw is enough?
07:33:09 * rex_lee about the calculation, is it dynamic?
07:33:33 <r-mibu> it should be the same as CPU pinning
07:33:51 <r-mibu> nova get information of NICs when it starts
07:34:13 <r-mibu> bw of network will be stored into the db
07:34:33 <rex_lee> #link http://specs.openstack.org/openstack/nova-specs/specs/kilo/implemented/virt-driver-cpu-pinning.html https://usercontent.irccloud-cdn.com/file/ib71NH8z/
07:34:38 <r-mibu> in each allocation, available BW of host will be consumed
07:36:10 <r-mibu> so, nova will gather HW information but will not collect load/usage of network
07:36:26 <qiliang> you mean nova already support bw usage record ?
07:37:09 <r-mibu> no
07:37:34 <r-mibu> it's just plan that we can work on
07:38:32 <rex_lee> you mean we don't need to collect load/usage of network, but only gather HW info?
07:38:56 <r-mibu> yes, for this use case
07:39:09 <rex_lee> and the bandwidth can be calculated in this way?
07:39:21 <r-mibu> i think so
07:39:58 <r-mibu> i guess we need another use case to explain need of collecting load/usage of network
07:40:04 <rex_lee> it seems to me the calculation is not enough to know the current bandwidth cost
07:42:49 * rex_lee for the load/usage of network, it's not in this use case, i think you are right about is.
07:42:57 <rex_lee> about it.
07:43:19 <rex_lee> it's more of dynamic situation.
07:44:17 <rex_lee> we can do calculation and update db with the result
07:45:32 <r-mibu> i can hear you
07:46:00 <r-mibu> sorry - i muted myself
07:46:05 <rex_lee> i see
07:47:04 <r-mibu> #info we need  collecting load/usage of network for case 1
07:47:13 <rex_lee> #agree the collection of load/usage of network can be in case 1
07:48:44 <r-mibu> #topic use case: isolation
07:49:47 <rex_lee> it's right in IRC
07:50:07 <r-mibu> #link https://etherpad.opnfv.org/p/rs_usecase_resource_isolation
08:00:46 <r-mibu> #info isolation use cases are explaind in use case overview/map
08:02:49 <rex_lee> #info there're two examples in use case of isolation
08:08:03 <r-mibu> #info agree list items first, then figure out detail of those use cases
08:08:55 <r-mibu> thank you - bye
08:10:19 <rex_lee> #agree list more use case items from different levels of view in the next meeting
08:10:25 <rex_lee> #endmeeting