07:02:17 <rex_lee> #startmeeting Resource Scheduler
07:02:18 <collabot> Meeting started Tue Sep  8 07:02:17 2015 UTC.  The chair is rex_lee. Information about MeetBot at http://wiki.debian.org/MeetBot.
07:02:18 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
07:02:18 <collabot> The meeting name has been set to 'resource_scheduler'
07:03:40 <rex_lee> #topic last meeting AI review
07:03:55 <r-mibu> do you have link?
07:04:12 <r-mibu> the link to the last meeting minuts
07:05:44 <r-mibu> i found
07:05:46 <r-mibu> #link http://meetbot.opnfv.org/meetings/opnfv-rs/2015/opnfv-rs.2015-09-01-07.00.html
07:06:11 <rex_lee> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-rs/2015/opnfv-rs.2015-09-01-07.00.txt
07:09:19 * rex_lee about solver scheduler, it's first proposed by Cisco in icehouse , and is now a incubation project in OpenStack
07:09:43 * rex_lee #link https://github.com/stackforge/nova-solver-scheduler
07:11:03 * rex_lee It provide a new OpenStack Nova scheduler driver based on constraints-based optimization solvers.
07:12:58 <r-mibu> can we use that solver-scheduler without hacking in nova but by adding config in nova.conf?
07:17:10 <rex_lee> currently it can support more complex constrains, and it use nova.conf to config
07:19:14 <r-mibu> ok, so we might use those advanced schedulers
07:19:47 <r-mibu> how about gaps regarding this scheduler seems to be solved but test requires?
07:20:02 <r-mibu> tests in NFV point of view
07:20:51 <rex_lee> still need to review the code to see what specific  constraints it support
07:21:31 * rex_lee what do you mean by tests in NFV point?
07:25:00 <r-mibu> i mean create our own test scenarios and run them in OPNFV labs
07:25:43 <r-mibu> if you can review code that would be better
07:27:04 * rex_lee i'll do the review this week and test it in an openstack environment to see how it works
07:27:22 <r-mibu> cool
07:28:56 <rex_lee> about the test scenarios, we can talk later, it's truly valuable in OPNFV, we have need lots of work to do first
07:29:16 <r-mibu> agree
07:30:33 <rex_lee> #action Rex review solver-scheduler code and test it in local openstack environment.
07:31:20 <rex_lee> about use case 2, you got any update?
07:31:33 <r-mibu> yp
07:31:45 <r-mibu> it seems already available
07:32:01 <r-mibu> #link http://developer.openstack.org/api-ref-compute-v2.1.html#os-server-groups-v2.1
07:32:43 <r-mibu> this is link to API reference, and how to configure server_group
07:33:20 <r-mibu> you can see 'anti-affinity' policy is set
07:33:26 <r-mibu> #link http://dev.cloudwatt.com/en/blog/affinity-and-anti-affinity-in-openstack.html
07:34:05 <r-mibu> this blog post shows how we can use this feature via nova API
07:34:58 <r-mibu> so, we can say there is no gap
07:36:35 <rex_lee> #info anti-affinity policy supported already for server-group
07:39:10 * rex_lee can you draft the use case 2, or we go to the candidate use case you mentioned last week?
07:40:25 <r-mibu> ok, i will draft the use case 2 as one of NFV requirements
07:40:41 <rex_lee> great
07:40:44 <r-mibu> i will also add new use case
07:40:50 <r-mibu> as 2.1?
07:41:47 <r-mibu> #action Ryota to describe use case 2 as well as solution exists in nova
07:43:02 * rex_lee about new use case, i think it can be inserted between previous usecase 1&2
07:43:45 <r-mibu> ok
07:43:45 <rex_lee> or just list as use case 4, we can arrange the order later if necessary
07:44:40 <r-mibu> umm, i've found those are *tyipical use cases*
07:44:50 <r-mibu> so let's drop old use case 2
07:45:05 * rex_lee #info new use case on board: scheduler make sure specified bandwidth between some VMs
07:45:11 <r-mibu> but move it to somewhere in requirement docs
07:45:30 <rex_lee> good idea
07:45:37 <r-mibu> so, i will add new use case as #2
07:45:45 <rex_lee> ok
07:46:32 <r-mibu> #action Ryota to drop replace current use case 2 by newly proposed one
07:47:12 <r-mibu> #undo
07:47:18 <r-mibu> #action Ryota to replace current use case 2 by newly proposed one
07:47:53 <rex_lee> fine, draft here:
07:47:56 * rex_lee #link https://etherpad.opnfv.org/p/rs_usecases
07:48:31 <r-mibu> got it
07:50:17 * rex_lee i'll close this meeting, you got other things to talk?
07:50:32 <r-mibu> nothig
07:50:39 <r-mibu> thanks, rex
07:50:49 <rex_lee> ok, thank you.
07:50:55 <rex_lee> see you next week.
07:51:14 <r-mibu> bye
07:51:16 <rex_lee> bye
07:51:25 <rex_lee> #endmeeting