14:01:21 <LukeH> #startmeeting Security Group 27-01-16
14:01:21 <collabot> Meeting started Wed Jan 27 14:01:21 2016 UTC.  The chair is LukeH. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:21 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:21 <collabot> The meeting name has been set to 'security_group_27_01_16'
14:01:26 <LukeH> Hi Sona
14:01:33 <mazdak> Hello
14:01:42 <LukeH> Hi Mazdak, welcome!
14:01:47 <mazdak> Thanks
14:01:49 <Sona> Hi Luke
14:01:51 <LukeH> #topic agenda
14:01:58 <Sona> I asked Mazdak to join us
14:02:27 <LukeH> ok for today, I only have one topic, which is the security guide, everything else is on hold while they all work on getting everything ready for the release
14:02:49 <LukeH> anyone else have another topic they wish to bring up / discuss?
14:03:17 <Sona> I have some question about security guide
14:03:23 <Sona> how to send for review
14:03:45 <LukeH> #topic security-guide
14:04:02 <LukeH> ok, my vps is playing up a bit here, so I might be intermittent
14:04:17 <LukeH> go for it Sona..so you have some questions on review?
14:05:14 <Sona> I have added some text trust.rst
14:05:21 <Sona> commited
14:05:39 <Sona> and when I run ~/opnfvdocs/docs/opnfvsecguide$ git review
14:05:53 <Sona> I get this error: fatal: Upload denied for project 'opnfvdocs' fatal: Could not read from remote repository.  Please make sure you have the correct access rights and the repository exists.
14:06:08 <LukeH> ahh ok
14:06:17 <LukeH> so did you run $ git review -s
14:06:25 <Sona> yes
14:06:46 <LukeH> oh, I think I might know what this is.
14:06:59 <LukeH> my bad, I should have thought of this...
14:07:10 <LukeH> we might need to get aric to assign you as a commmiter
14:07:21 <Sona> ok :)
14:07:22 <LukeH> I will drop an email off right after this, and CC you
14:07:30 <Sona> thanks
14:07:38 <LukeH> but you're going about it the right way
14:07:46 <LukeH> one tip I have is this...
14:08:08 <LukeH> once you have done your first commit, and it's +1 by jenkins, and chris price etc
14:08:19 <LukeH> what you can do is $ git commit --amend
14:08:26 <LukeH> followed by $ git review
14:08:33 <Sona> another issue is that some files in the python2.7.3/ folder had trailing whitespace
14:08:48 <Sona> or No newline at the end of file
14:08:59 <LukeH> with --amend, you don't need to go through the +1 review then, your just making a patch, so it will go right to the build system
14:09:15 <Sona> ok
14:09:25 <LukeH> ok, for your python2.7 issues, you can do this
14:10:44 <LukeH> ahh no, i was thinking of something else
14:10:57 <LukeH> I am sure I fixed this, I will look into it for you, post meeting
14:11:40 <Sona> ok, maybe I am not using the latest
14:11:47 <Sona> I will check this
14:12:02 <LukeH> if you need to, you can do a git pull
14:12:10 <Sona> ok
14:12:28 <LukeH> in fact git review may ask you to do this anyway, as you will be behind / in front of the master repo
14:12:49 <LukeH> but thats good, getting close now
14:12:59 <LukeH> some info from me.
14:12:59 <Sona> Mazdak, do you have any question?
14:13:07 <LukeH> i fixed the PDF creation
14:13:11 <LukeH> #link http://artifacts.opnfv.org/review/7825/opnfvsecguide/opnfvsecguide.pdf
14:13:19 <LukeH> so now it auto builds PDF's
14:13:28 <Sona> ok, good.
14:13:33 <LukeH> duh, wrong link!
14:13:35 <LukeH> one second
14:13:46 <LukeH> #undo
14:13:46 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x1b71290>
14:13:51 <LukeH> #link http://artifacts.opnfv.org/review/7825/opnfvsecguide/opnfvsecguide.pdf
14:14:41 <mazdak> I have a question about how to sync our efforts?
14:15:07 <mazdak> I have started working on neutron and sdn security
14:15:18 <LukeH> perfect ^
14:15:31 <mazdak> but is there any way to check if someone else is doing the same thing or so
14:15:31 <mazdak> ?
14:15:35 <LukeH> thats it essentially, pick an area of interst
14:16:00 <LukeH> at the moment mazdak, no, as there is only a few of us working on it.
14:16:12 <LukeH> but going forward I will set something up
14:16:18 <mazdak> ok, got it
14:16:32 <LukeH> #action Luke to set up tracking of chapters / sections to authors
14:16:35 <mazdak> then I'll continue and try to add material
14:16:42 <LukeH> that would be great
14:16:56 <Sona> me too,
14:17:05 <LukeH> and for the material that I put up, anyone is free to suggest changes, fixes, or additions
14:17:27 <LukeH> its an open source document, so all you need to do is send a git review request.
14:17:29 <Sona> I can review them
14:18:09 <LukeH> myself and the moment, I am just filling out the structure and getting it into build shape
14:18:26 <LukeH> I still have ari's section to make on audit
14:19:03 <LukeH> but I think as it takes share, it will be exciting to work on, and we can all shape it as it gets more body
14:19:16 <LukeH> /s/share/shape
14:19:18 <Sona> yes
14:19:52 <LukeH> mazdek / sona, you both work together?
14:20:03 <Sona> yes
14:20:13 <Sona> we can sync
14:20:18 <LukeH> great, so Sona can share her experience getting set up
14:20:20 <mazdak> yes
14:20:31 <Sona> sure
14:20:58 <LukeH> great!
14:21:22 <LukeH> so I figure that's it for now, unless anything else?
14:21:33 <LukeH> we have time if anyone has further questions / points?
14:21:39 <Sona> no I don't have more to add
14:21:45 <LukeH> mazdak?
14:21:49 <mazdak> not from my side
14:21:55 <LukeH> ok, good!
14:22:21 <Sona> bye guys
14:22:22 <LukeH> #action Luke to email Aric over repo permissions for Sona and Mazdak
14:22:55 <mazdak> bye guys
14:22:58 <LukeH> Just thinking, Mazdak, once your set up, let me know and I can email aric (linux foundation admin) at the same time for both of you
14:23:30 <LukeH> so you need your linux foundations account, and ssh key added to gerriy
14:23:34 <mazdak> ok, sure. I'll do it by tomorrow
14:23:36 <LukeH> * gerrit
14:23:42 <LukeH> good stuff
14:23:47 <LukeH> #endmeeting