14:01:43 <ebrjohn> #startmeeting weekly opnfv sfc meeting, August 5, 2015
14:01:43 <collabot> Meeting started Wed Aug  5 14:01:43 2015 UTC.  The chair is ebrjohn. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:43 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:43 <collabot> The meeting name has been set to 'weekly_opnfv_sfc_meeting__august_5__2015'
14:01:55 <ebrjohn> #info ebrjohn Brady Johnson
14:02:35 <ebrjohn> Everybody connected to the meeting, please info in
14:03:20 <bryan_att> #info Bryan Sullivan
14:03:55 <trozet> #info Tim Rozet
14:03:57 <fbl> #info Flavio Leitner
14:05:24 <paulq> #info Paul Quinn
14:05:36 <paulq> for the record: Thomas did all the work!
14:05:39 <alagalah> #info Keith Burns (alagalah)
14:06:33 <alagalah> ebrjohn: As an outcome of that discussion I have a state machine for SFC orchestration I'd like to propose to the ODL SFC community
14:07:30 <ebrjohn> #link https://wiki.opnfv.org/policytest/policytest_project_proposal new GBP in OPNFV testing project
14:07:50 <ebrjohn> #chair bryan_att
14:07:50 <collabot> Current chairs: bryan_att ebrjohn
14:09:47 <bryan_att> #info alagalah: discussing PolicyTests proposal using GBP, SFC, and other OPNFV project focuses
14:11:24 <bryan_att> #info ...work in ODL on tests for various frameworks will be integrated for use in OPNFV
14:12:19 <bryan_att> #info ... will be discussed tomorrow on the tech call
14:14:12 <bryan_att> #info bryan_att: suggests that we start looking at the tools referenced in the interim while the project is bring considered
14:14:45 <alagalah> ebrjohn: Did you stop sharing ?
14:14:46 <bryan_att> #info alagalah: will update the proposal with links to the existing content
14:15:07 <bryan_att> #topic ODL Summit takeaways
14:15:57 <alagalah> #info ebrjohn I have some feedback based on the conversations on Fri at the OPNFV Hackfest
14:16:18 <bryan_att> #info ebrjohn: lots of interest in SFC at the summit; I've been invited to speak at OpenStack Tokyo on this
14:17:09 <bryan_att> #info ... for the Nov OPNFV Summit also planning sessions and encourage all to be there
14:17:39 <paulq> http://events.linuxfoundation.org/events/opnfv-summit
14:18:16 <bryan_att> #topic VNF Manager
14:21:36 <bryan_att> #info bryan_att: looked into tacker and other projects, we definitely need to look there and at other projects to assess where OPNFV puts its cards
14:22:19 <bryan_att> #info trozet: looked at tacker code and is currently modifying it to call out the SFC APIs, overall looks pretty good
14:22:30 <alagalah> ebrjohn: I added slide 11 with a proposal I would like to make the ODL SFC community tomorrow around a state diagram / sequence diagram for SFC orchestration
14:22:57 <bryan_att> #info ebrjohn: agrees that we need to look to reuse existing code as our base; how extensible is it?
14:23:41 <bryan_att> #info trozet: you can write an extension to avoid touching the core code; that's what I'm doing now
14:24:11 <bryan_att> #info ebrjohn: when can we have a POC on tacker?
14:25:51 <bryan_att> #info drozet: may not be ready by next meeting
14:26:22 <ebrjohn> #action trozet to head up an initial PoC using tacker as a VNF mgr
14:26:32 <bryan_att> #info bryan_att: we may also need murano based upon the evolving function split between these projects, per the tacker IRC logs
14:27:34 <bryan_att> #info alagalah: been working on a state machine in slide 11 of the arch draft; knowing when a NF is active is a key concern
14:29:37 <bryan_att> #info ... also how/when the classifier gets assigned to the chain is addressed
14:30:38 <bryan_att> #info bryan_att: we will look at the other VNFM options and offer a comparison; could be there is some more developed functionality that we could shift between VNFM projects to better flesh out the projects in one place or another
14:30:59 <bryan_att> #info ebrjohn: what drives tacker, e.g. conf file or REST etc?
14:31:44 <bryan_att> #info trozet: it's REST based; working on adding an ODL driver to complete the chain via SFC
14:32:03 <bryan_att> #info ebrjohn: the model should be extensible for our own calls?
14:32:25 <bryan_att> #info trozet: yes, currently adding a REST call for SFC functions
14:33:26 <bryan_att> #info ... documentation is not so great; currently hacking in prep for a demo; tacker service can be conf'd to turn on additional plugins
14:33:49 <bryan_att> #info ... will add links so the rest can come up to speed on hacking tacker
14:34:19 <bryan_att> #topic State-Machine for SFC Orchestration
14:35:21 <bryan_att> #info alagalah: (looking at slide 11 in the OPNFV_SFC_InitialSetup file)
14:35:30 <trozet> #link https://github.com/trozet/tacker-horizon/tree/SFC
14:35:37 <trozet> #link https://github.com/trozet/python-tackerclient/tree/SFC
14:35:53 <trozet> #link https://github.com/trozet/tacker/tree/SFC
14:36:13 <bryan_att> #info ... this is showing the ins/outs of the ODL SFC implementation, with the addition of "state" which isn't currently there
14:36:13 <trozet> #info I have only pushed my changes to tacker-horizon, will push the client and service changes when I get it working
14:36:56 <bryan_att> #info bryan_att: is this the first time that SFC has a notion of state, thus needs clustering to ensure that state knowledge isn't lost?
14:38:54 <bryan_att> #info alagalah: conf and operational data stores provide the HA; my team is working on clustering as part of CI testing (CSIT)
14:39:31 <bryan_att> #info ... state is managed in the ODL datastore holistically; work in tacker would feed into this to indicate when the SF is really ready
14:39:36 <ebrjohn> trozet: remember that we also have a git repo available for OPNFV SFC
14:39:58 <ebrjohn> #info git clone ssh://<username>@gerrit.opnfv.org:29418/sfc
14:40:22 <trozet> ebrjohn: you want me to move it all into the SFC repo?
14:40:37 <ebrjohn> however you see fit, but that would make sense at some point
14:40:42 <bryan_att> #info ... classifier requests an RSP, has a key role in the flow
14:41:18 <trozet> ebrjohn: github is faster if its just me working on it.  If others want to work on it too then we can move it
14:42:12 <bryan_att> #info ... the SFP requests the type of instances needed; if the resources already exist it can down further; otherwise spin up the SFs and go into a pending state until the SFs are ready, and all the SFFs for the SFs are ready
14:43:35 <bryan_att> #info ... parallel actions can take place until the SF and SFF are ready, then transition to active; folllowed by the formation of the RSP which is handed back to the classifier and eventualy back to the orchestrator
14:44:48 <bryan_att> #info ... introducing dynamics into the mapping is important for reliability, e.g. as SFs go up/down and get added/replaced in the chain
14:46:10 <bryan_att> #info ebrjohn: if time, can bring this up in the ODL SFC session tomorrow; some housekeeping to do on ODL project planning but maybe in the last half hour
14:46:38 <bryan_att> #info alagalah: have added this to the release plan proposal, along with other things for the release
14:47:19 <bryan_att> #info Prakash_: are each of the state diagram actors described somewhere?
14:48:40 <bryan_att> #info alagalah: these are existing actors defined in the draft standards, trying to stay true to the concepts in the drafts
14:49:19 <bryan_att> #link https://datatracker.ietf.org/wg/sfc/documents/
14:49:54 <bryan_att> #info paulq: involved in the ietf work on this, don't see any conflict
14:50:37 <bryan_att> #topic Testing
14:50:49 <bryan_att> #info trozet: will help
14:52:04 <bryan_att> #info bryan_att: will also be supporting this, through the new proposed project and the functest project
14:52:17 <bryan_att> #topic AOB
14:52:28 <bryan_att> #info (none)
14:52:46 <bryan_att> #endmeeting