14:02:55 <ebrjohn> #startmeeting OPNFV SFC weekly meeting: August 2, 2015
14:02:55 <collabot> Meeting started Wed Sep  2 14:02:55 2015 UTC.  The chair is ebrjohn. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:02:55 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:02:55 <collabot> The meeting name has been set to 'opnfv_sfc_weekly_meeting__august_2__2015'
14:03:26 <ChrisPriceAB> #info Chris (on IRC only)
14:04:27 <ebrjohn> #info ebrjohn Brady Johnson
14:04:44 <bryan_att> #info Bryan Sullivan
14:04:45 <trozet> #info Tim Rozet
14:04:48 <SergeM> #info Serge Manning
14:04:49 <sridhar_ram> #info sridhar_ram Sridhar Ramaswamy
14:04:59 <afredette> #info Andre Fredette
14:05:00 <bouthors> #info Nicolas Bouthors
14:05:04 <ethfci> wellcome Guys
14:05:05 <radez> #info Dan Radez
14:05:39 <bryan_att> #topic Action Item Review
14:05:47 <alagalah> ebrjohn, Do only committers #info ?
14:05:59 <bryan_att> #info Brady will update the wiki for the AIs - 3 ongoing
14:06:30 <bryan_att> #info Provide input to scripts is ongoing
14:07:24 <bryan_att> #info 2nd is NSH-aware service functions (Paul); products are in development, looking for an image the project can use if possible
14:08:19 <bryan_att> #info 3rd (Uri) to investigate VNFM test driver (no update right now)
14:08:55 <bryan_att> #topic Tacker Attendance
14:09:13 <bryan_att> #info Sridhar from the Tacker project is here
14:09:37 <bryan_att> #info Interested in bringing Tacker to this project, and moving up to NVFO
14:10:50 <bryan_att> #info looking at bringing Tim's github work into the Tacker repo, to instantiate VNFs and use the API to chain them; in future all VNFs will be written in TOSCA
14:11:06 <ChrisPriceAB> Not sure we can deliver Tacker as a component in Brahmaputra.  But the project can of course leverage any tools to develop and test use cases.
14:11:18 <bryan_att> #info current approach is fine given that the TOSCA forwarding graph work is not completed
14:11:40 <ChrisPriceAB> I will discuss the MANO topic with the board in the next board meeting.
14:11:50 <bryan_att> #info ebrjohn: what about the dependencies between projects
14:13:19 <bryan_att> #info sridhar_ram: (describes the stack) there is a general top API with ODL as one mechanism; a clear path down currently
14:13:40 <bryan_att> #info ebrjohn: concerned about any cyclic dependencies
14:14:05 <bryan_att> #info sridhar_ram: will bring a diagram to discuss
14:15:24 <ebrjohn> alagalah: for now, everyone should #info in
14:15:39 <bryan_att> #info trozet: can we have more than one option to spec the chain
14:16:18 <trozet> #link https://github.com/openstack/networking-sfc/blob/master/doc/source/api.rst
14:16:26 <trozet> #info neutron SFC spec
14:16:59 <bryan_att> #info rprakash: we should focus this on the neutron APIs with passing parameters as needed; any MANO component could drive this not just Tacker; a more appropriate way but left to the team
14:17:54 <bryan_att> #topic Too Many Meetings
14:18:18 <ethfci> weekly is okay i feel
14:18:22 <bryan_att> #info ebrjohn: should we move to bi-weekly meetings
14:18:49 <bryan_att> #info rprakash: weekly is needed until the C milestone
14:18:57 <bryan_att> #info bryan_att: agree
14:19:40 <bryan_att> #topic Need for VXLAN Port
14:20:10 <bryan_att> #info ebrjohn: can create openstack vxlan ports first
14:21:17 <bryan_att> #info (colleague explains the issue)
14:21:33 * bryan_att asks for anyone to put in IRC the issue
14:21:35 <ChrisPriceAB> does anyone have sequence diagrams for how the interface described in the above link would be used by an NBI on openstack?
14:22:07 * bryan_att is not understanding the description
14:22:47 * ebrjohn ya, the phone connection isnt the best...
14:23:14 <ebrjohn> #action ferenc will send a document explaining the results
14:24:09 <bryan_att> #info trozet: you can't add a vxlan port in neutron - it requires code changes
14:24:25 <bryan_att> #info iben: does this need a new feature?
14:24:58 <bryan_att> #info ebrjohn: ferenc is working on that in the lab; issue may be using vxlan ports for another purpose than tenant separation
14:25:35 <ethfci> te problem is: neutron uses vxlan for its own purposes
14:25:47 <bryan_att> #info edwarnicke: the problem is how ODL using forwarding tags; we are looking for hackarounds; but could someone address the root cause?
14:26:06 <bryan_att> #info ebrjohn: we are looing at patches to OVS to fix the root cause
14:26:10 <alagalah> bryan_att, OVS
14:26:27 <bryan_att> #info edwarnicke: we need avoid a pile of hackarounds
14:26:41 <ethfci> neutron programs ovvs for its own purpuses by means of openflow nbi
14:28:11 <iben> would sr-iov be a potential solution here?
14:28:17 <bryan_att> #info edwarnicke: we need a push/pop of vxlan headers via openflow; it's a pure OVS issue
14:28:54 <rprakash> #info ovs with NSH header is what we referring to if so Pritesh from Cisco was to planning to get in touch with VMware PTL of OVS when we met at ODL summit'
14:29:08 <bryan_att> #info ebrjohn: add to slides that Sam has started
14:29:54 <bryan_att> #info edwarnicke: the slides sent to the listr describe the need for a push/pop in openflow for vxlan
14:30:10 <bryan_att> #info ebrjohn: we have an arch doc; we should add this to it
14:30:42 <bryan_att> #info ebrjohn: we have this in a google doc now
14:31:06 <bryan_att> #info bryan_att: I can help put this in git as soon as its ready so we can use the OPNFV toolchain (which we should be using)
14:31:31 <ebrjohn> #link https://docs.google.com/document/d/1aoKYiExPtzyt3whETszeGh9neSKk2FpqxhgbGa0dkG0/edit OPNFV SFC Arch doc
14:31:36 <bryan_att> #info iben: we are looking to pass the virtual NIC into the VM, bypassing OVS; would that be a workaround?
14:31:56 <bryan_att> #info (calls for more description of the idea)
14:32:01 <ebrjohn> #action edwarnicke will add the actual path a packet will take from SFF to SF
14:32:33 <bryan_att> #info iben: SR-IOV as an example passes traffic straight to the VMs; OVS would be in the VM rather than the hypervisor
14:32:56 <bryan_att> #info edwarnicke: various questions come to mind but not looking at that as an option
14:33:15 <iben> #link sriov for openstack kilo https://wiki.openstack.org/wiki/SR-IOV-Passthrough-For-Networking
14:33:16 <bryan_att> #info rprakash: that prevents control/data plane separation
14:33:36 <bryan_att> #info trozet: can we get someone to work on the rool cause (push/pop) in OVS?
14:34:14 <bryan_att> #info ebrjohn: that would be great; but need to coordinate with NSH patch upstreaming
14:34:28 <bryan_att> #info paulq: existing patches are ready to go any day; they are done
14:34:59 <bryan_att> #info ebrjohn: OVS is picky; can just make it easier by coordinating?
14:35:18 <bryan_att> #info alagalah: that's not so easy
14:36:22 <bryan_att> #info rprakash: (describes an issue with OVS and SFC)
14:37:43 * bryan_att would appreciate any help noting rprakash comments
14:39:30 <fbl> I didn't understand the issue with OVS reading the IRC minutes, sorry can't dial today, my phone is borked
14:39:44 <bryan_att> #info (comments about IETF drafts and implementations)
14:40:19 <bryan_att> #info bryan_att: re drafts, we have one about MPLS based SFC; we need to ensure a common model and support in OpenStack for the various SFC methods OPNFV will support
14:40:34 <bryan_att> #topic Work in Tacker
14:40:44 <fbl> I might be able to help with OVS, but I need more info to understand the issues
14:41:00 <bryan_att> #info ebrjohn: need volunteers to help trozet in his implementation in Tacker
14:41:28 <bryan_att> #info ebrjohn: need more members helping out
14:41:56 <bryan_att> #info rprakash: will help
14:42:22 <bryan_att> #info bryan_att: is the work on github?
14:42:37 <bryan_att> #info trozet: need to define a spec first for input to OpenStack
14:43:29 <ebrjohn> rprakash: could you send me an email to brady.allen.johnson@ericsson.com, or just to the opnfv sfc list and I'll put you in touch with Tim
14:43:36 <bryan_att> #info trozet: looking for help with code and spec; code is currently in github but will move to OpenStack as soon as the spec is accepted
14:43:44 <trozet> #link https://github.com/trozet/tacker/tree/SFC
14:43:59 <trozet> #link https://github.com/trozet/python-tackerclient/tree/SFC
14:44:02 <bryan_att> #info bryan_att: we will also help to the extent we can
14:44:14 <trozet> #link https://github.com/trozet/tacker-horizon/tree/SFC
14:44:28 <trozet> #link https://github.com/trozet/sfc-random/blob/master/tacker_sfc_walkthrough.txt
14:44:29 <bryan_att> #Topic How to setup OPNFV SFC
14:44:50 <bryan_att> #info ebrjohn: haven't looked deeply into the installer discussion
14:45:48 * ChrisPriceAB is slinking away from lurking on IRC. Later folks.
14:46:16 <bryan_att> #info bryan_att: we have to ensure the max support for SFC by not focusing all effort on a single installer
14:46:59 <bryan_att> #info trozet: engage with genesis project and put requirement on the installers
14:48:19 <bryan_att> #info bryan_att: that process is new to me but sounds OK - we need to ensure that it's shared with all projects
14:48:50 <bryan_att> #info iben: concerned about the impact to installers having to support all projects
14:49:17 <bryan_att> #info trozet: if an installer is part of B release then it needs to support all requirements agreed in genesis
14:50:11 <bryan_att> #info iben: how do we address project-specific needs; likely need to work in parallel in some cases
14:50:40 <bryan_att> #info ebrjohn: we need a special version of OVS with NSH patches; will that cause a problem with genesis?
14:51:11 <bryan_att> #info trozet: there are other examples of similar requjirements; it needs to be sent to genesis
14:52:02 <ethfci> byan what about building a debian package with NSH enabled ovs wht will be deployed?
14:52:29 <iben> Does OVS support IPv6 underlays yet?
14:53:05 <bryan_att> #info trozet: there is a generic guideline for now; send an email to the genesis alias and a requirement in Jira; genesis will then vote on it as a requirement
14:53:08 <ethfci> sorry bryan_att for the typo.
14:53:22 <ebrjohn> #action trozet to send out genesis wiki guidelines
14:53:39 <ethfci> 2 weeks for NSH enabled OVS in fenesys iso?
14:54:01 <bryan_att> #info bryan_att: we need to know how this requirement relates to the C milestone
14:54:34 <bryan_att> #info ebrjohn: how do we choose an installer if generis can't support our requirements for B
14:54:55 <bryan_att> #info iben: you can use your own scripts for now
14:54:57 <ethfci> technically you fetch ovs sources apply the pach an db_build your ovs
14:55:28 <bryan_att> #info iben: need to show a working setup in a lab; that will lead to a gap assessment in genesis
14:57:19 <bryan_att> #info ebrjohn: installation of SFC in the E/// lab will be brought to the meeting next week as an example
14:57:37 <bryan_att> #info trozet: devstack just needs the right features and tacker to openstack
14:58:02 <fbl> iben: ovs does support ipv6 underlays
14:58:06 <bryan_att> #topic AOB
14:58:22 <bryan_att> #info ebrjohn: will get action points and wiki updated
14:58:25 <iben> thanks fbl
14:58:41 <bryan_att> shall I end the meeting?
14:58:43 <fbl> iben: and Red Hat is working to get ipv6 VTEP (user and kernel DP)
14:58:47 <bryan_att> #endmeeting
14:58:54 <ethfci> :)
14:59:14 <bryan_att> (it seems I am not a chair... someone else will have to end the meeting)
14:59:28 <bryan_att> (or the bot is not working)
14:59:33 <bryan_att> #Endmeeting
14:59:51 <bryan_att> ebrjohn: can you issue the #endmeeting command?
15:00:12 <ethfci> #endmeeting
15:00:24 <ethfci> #Endmeeting
15:00:29 <ethfci> no use
15:02:07 <iben> does this channel have a bot?  We may need to cut and paste into another channel
15:04:42 <fbl> collabot: alive?
15:04:42 <collabot> fbl: Error: "alive?" is not a valid command.
15:04:50 <fbl> seems alive :)
15:40:07 <iben> weird
15:48:51 <ebrjohn> #endmeeting