14:58:40 <ebrjohn> #startmeeting Weekly OPNFV SFC meeting
14:58:40 <collabot`> Meeting started Wed Mar  8 14:58:40 2017 UTC.  The chair is ebrjohn. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:58:40 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:58:40 <collabot`> The meeting name has been set to 'weekly_opnfv_sfc_meeting'
14:59:01 <ebrjohn> #info Brady Johnson
14:59:04 <jvidal> #info Juan Vidal
14:59:11 <ebrjohn> #chair jvidal
14:59:11 <collabot`> Current chairs: ebrjohn jvidal
14:59:29 <mbuil> #info Manuel Buil
15:00:11 <priya> #info priya
15:02:26 <ebrjohn> #chair mbuil priya
15:02:26 <collabot`> Current chairs: ebrjohn jvidal mbuil priya
15:02:40 <ebrjohn> #agenda https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-March/015448.html
15:03:00 <geopar> #info George Paraskevopoulos
15:03:00 <trozet> #info Tim Rozet
15:04:38 <ebrjohn> #topic Previous action items
15:04:57 <ebrjohn> #info ebrjohn Talk to Tim Rozet about implementing a symmetric classifier fix in Master and see how complicated it would be to merge to our version
15:06:33 <ebrjohn> #info it should be implemented separately in each branch, since upstream tacker is quite different
15:06:45 <ebrjohn> #info AP done
15:07:26 <ebrjohn> #info jvidal to open a JIRA and put a comment in the code for symmetric test test case
15:07:45 <jvidal> #link https://jira.opnfv.org/browse/SFC-86
15:07:58 <ebrjohn> #info AP done
15:08:05 <jvidal> #link https://gerrit.opnfv.org/gerrit/#/c/29633/
15:08:28 <ebrjohn> #info mbuil to look into marking the symmetric test case as possibly not working for the release
15:08:51 <ebrjohn> #info AP ongoing
15:09:21 <ebrjohn> #info ebrjohn to reach out to F5 to see if they will be at the PlugFest and try to schedule an integration with their VNF
15:09:50 <ebrjohn> #info AP done
15:10:11 <ebrjohn> #topic Solutions found for CI issues
15:11:00 <ebrjohn> #info mbuil the solution came from an email from trozet
15:11:25 <ebrjohn> #info there is a healthcheck when VMs come up, checking they have an IP, etc. This was not working
15:11:39 <ebrjohn> #info OVS was connecting to ODL before ODL was ready
15:14:56 <ebrjohn> #info the solution: there's a puppet script that connects OVS to ODL, so add a dependency to the puppet script, so it doesnt execute until after ODL is ready
15:15:52 <ebrjohn> #info the solution is in the Fuel ODL plugin
15:16:36 <ebrjohn> #info the patch has been merged in Fuel now
15:16:48 <ebrjohn> #topic Tacker authorization issue solved
15:17:18 <ebrjohn> #info the problem authorization was not compatable with V2 keystone
15:17:40 <ebrjohn> #info when tacker was changed to use V3 keystone, it wasnt correct
15:17:56 <ebrjohn> #info a patch has been submit for this
15:20:44 <ebrjohn> #info geopar to check to which Tacker branch to submit the fix
15:21:08 <ebrjohn> #info we should be using the Tacker Colorado branch, not the Tacker refactor branch
15:22:24 <geopar> http://pastebin.com/MmxmZPca
15:22:41 <geopar> #link http://pastebin.com/MmxmZPca
15:22:42 <priya> I am not audible i think, geopar I was testing the patch and I am getting internal server error while creating vnf
15:25:34 <johscheuer> I had the issue posted by geopar after applying his patch for tacker
15:25:56 <geopar> priya: when creating a vnf or an sfc?
15:25:58 <johscheuer> I could create a VNFD, VNF but I wasn't able to create a SFC
15:26:09 <johscheuer> creating the sfc
15:26:14 <ebrjohn> johscheuer: which Tacker branch are you using??
15:26:44 <priya> sure
15:26:45 <ebrjohn> priya: can you take that problem offline with geopar please?
15:26:58 <ebrjohn> #topic Status of the test cases being developed - need to be completed and working by this Friday
15:28:36 <ebrjohn> #info geopar is finished with multiple topos test, and the case is working
15:29:39 <ebrjohn> #info mbuil is finished with the test case... he wants to first verify the tacker issue
15:30:14 <ebrjohn> #info jvidal is finished with the test case - but its only working because everything is on the same compute
15:30:44 <ebrjohn> #info a jira has been created for the tacker bug
15:31:32 <ebrjohn> #link https://jira.opnfv.org/browse/SFC-86 reports problem with the test
15:32:31 <ebrjohn> #info in general we are in good shape with the test cases
15:33:37 <ebrjohn> #topic Preparations for MS7 this Friday (March 10)
15:33:51 <ebrjohn> #info https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description Danube Milestone Descriptions
15:33:53 <ebrjohn> #info https://wiki.opnfv.org/download/attachments/6827418/OPNFV%20Release%20%2522Danube%2522%20r4.pdf?version=1&modificationDate=1484147599000&api=v2 OPNFV Danube schedule (PDF)
15:33:54 <ebrjohn> #info OPNFV Danube MS 7 description: Projects are branched from main
15:33:56 <ebrjohn> #info OPNFV Danube MS 7 description: Commits are limited to critical issues documented in JIRA
15:33:57 <ebrjohn> #info OPNFV Danube MS 7 description: Commits must be cherry-picked to branch from master
15:34:19 <ebrjohn> #link https://wiki.opnfv.org/display/SWREL/Release+Milestone+Description Danube Milestone Descriptions
15:34:21 <ebrjohn> #link https://wiki.opnfv.org/download/attachments/6827418/OPNFV%20Release%20%2522Danube%2522%20r4.pdf?version=1&modificationDate=1484147599000&api=v2 OPNFV Danube schedule (PDF)
15:37:43 <ebrjohn> #agreed There is no rush to create the OPNFV SFC stable Danube branch, so we'll create it on Friday
15:38:23 <ebrjohn> #action mbuil to tell ebrjohn when he will be ready for the branch to be created, on Friday sometime
15:38:44 <ebrjohn> #action ebrjohn to create the stable branch on Friday
15:38:46 <jvidal> #info The stable branch window for Danube opened on February 17 (MS6).  The window will close one week from Friday, on March 10 at 12 p.m. (PST).   Please plan to branch your project by that date.
15:38:53 <jvidal> that was from David McBride's email
15:39:32 <ebrjohn> #info the window for creating the branch is 21:00 GMT+1
15:40:08 <jvidal> The 24 hour/day cycle starts at 12 midnight (often indicated as 12 a.m.), runs through 12 noon (often indicated as 12 p.m.),
15:40:13 <ebrjohn> #info I will most likely create the branch by around lunch time on Friday
15:40:14 <jvidal> according to Wikipedia ;)
15:40:49 <ebrjohn> #topic AOB
15:41:02 <ebrjohn> #info We should be able to start working on the New Netvirt SFC classifier soon.
15:41:04 <ebrjohn> #info We'll continue discussing it in today's ODL SFC meeting
15:48:51 <ebrjohn> #topic problem reported by johscheuer
15:50:07 <ebrjohn> #info johscheuer is having problems with tacker keystone authentication
15:50:22 <ebrjohn> #info johscheuer cant create a service function chain
15:51:03 <ebrjohn> #info there is an error message that it cant find the neutron port
15:52:04 <ebrjohn> opnfv-tech-discuss@lists.opnfv.org
15:52:18 <ebrjohn> Then put this in your subject "[SFC] "
15:54:03 <geopar> johscheuer: Can you try the following:
15:54:17 <geopar> johscheuer: go into /etc/heat/heat.conf
15:54:47 <ebrjohn> #endmeeting