14:01:01 <mbuil> #startmeeting SFC-week-37
14:01:01 <collabot> Meeting started Wed Sep 13 14:01:01 2017 UTC.  The chair is mbuil. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:01:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:01:01 <collabot> The meeting name has been set to 'sfc_week_37'
14:01:28 <bjohnson> #info Brady Johnson
14:01:37 <mbuil> #info Manuel Buil
14:01:38 <bcafarel> #info Bernard Cafarelli
14:02:11 <mbuil> #chair bjohnson
14:02:11 <collabot> Current chairs: bjohnson mbuil
14:02:12 <Vijayendra> mbuil, Is this the right goto meeting? https://app.gotomeeting.com/?meetingId=611478989
14:02:24 <yifei> what is the meeting id?
14:02:25 <mbuil> Vijayendra: https://app.gotomeeting.com/?meetingId=819733085
14:02:31 <mbuil> #link https://global.gotomeeting.com/join/819733085
14:02:31 <bjohnson> #link https://global.gotomeeting.com/join/819733085 meeting link
14:02:43 <Vijayendra> ok Thanks
14:02:52 <yifei> thx
14:03:00 <yifei> #info Yifei Xue
14:03:12 <Vijayendra> #info Vijayendra Radhakrishna
14:03:35 <mbuil> #topic Euphrates MS7
14:03:48 <mbuil> #info This Friday is the MS7. The requirements to comply with it are: 1 - Projects are branched from main; 2 - Commits are limited to critical issues documented in JIRA; 3- Commits must be cherry-picked to branch from master
14:04:08 <bjohnson> #info Euphrates MS7 Friday, September 15, 2017
14:04:55 <mbuil> #info We need to contact Aric to create a the stable branch in the next days
14:05:19 <bjohnson> #info Aric Gardner the Linux Foundation OPNFV Sys Admin will create the Project branches
14:06:20 <bjohnson> #info Euphrates MS8 is October 3, 2017
14:07:45 <bjohnson> #info effectively, MS7 is code freeze, so only bug fix changes can go in once we hit MS7
14:08:02 <mbuil> #topic e2e integration issues
14:08:35 <mbuil> #info Several bugs in ODL were fixed during last week
14:08:36 <mbuil> #link https://git.opendaylight.org/gerrit/#/c/62550/
14:08:36 <mbuil> #link https://git.opendaylight.org/gerrit/#/c/62561/
14:08:36 <mbuil> #link https://git.opendaylight.org/gerrit/#/c/62552/
14:09:58 <bjohnson> #info one of these fixes is in sfc, and 2 are in netvirt
14:10:09 <mbuil> #info warning! Those patches are not yet included in RC3. We need to wait for the official release
14:13:31 <mbuil> #info We have so far 6 issues
14:14:47 <mbuil> #info issue #1 tacker cannot create chains and classifiers separately. That's why we must modify the second test
14:15:12 <mbuil> #info the workaround is to create two chains and two classifiers adding a second client and a second server
14:15:27 <mbuil> #info there is a current problem in networking-sfc when creating two classifiers because there is a conflict even if they use different neutron ports
14:16:36 <bjohnson> #info According to the IETF SFC spec, the classifier should not be tightly coupled with the Service Chains, but it seems like the new Tacker has made them tightly coupled.
14:17:05 <bjohnson> #info According to the IETF SFC spec, it should be possible to change the classification on-the-fly
14:19:53 <mbuil> #info to fix the networking-sfc ==> https://review.openstack.org/#/c/419525/ but it was abandoned :(
14:20:02 <bjohnson> mbuil: have you created a bug report for the Networking SFC classifier problem?
14:20:39 <mbuil> bjohnson: not yet. good point!
14:27:25 <mbuil> #info: This is the related bug ==> https://bugs.launchpad.net/networking-sfc/+bug/1655618
14:27:36 <bjohnson> #link https://docs.google.com/presentation/d/1RfoUwL8wzYBRBh1UWR4iZbN_iXaPeD6YwvGoNFH-uLA/edit#slide=id.p13 OPNFV SFC Target Test Case, slide 10
14:29:59 <bcafarel> mbuil: https://bugs.launchpad.net/networking-sfc/+bug/1638421 has more info on the fc conflicts (and reasons on current checks)
14:31:48 <bjohnson> #info We should be able to have several pre-configured chains, and change the classification on-the-fly
14:36:07 <mbuil> #action bcafarel will test if the classification can be updated on the fly in networking-sfc
14:38:23 <bjohnson> #info Proposed way forward 1) bcafarel to test dynamic classifier changes. If it doesnt work, create a bug on networking SFC in OpenStack
14:39:04 <bjohnson> #info if it does work, then we need to focus on getting Tacker fixed. If this takes too long, then we should consider using the VnfMgrSim python tool in the OPNFV SFC repo
14:39:15 <bjohnson> #undo
14:39:15 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x315cd50>
14:39:26 <bjohnson> #info if it does work, 2) then we need to focus on getting Tacker fixed. If this takes too long, then we should consider using the VnfMgrSim python tool in the OPNFV SFC repo
14:39:38 <bjohnson> #undo
14:39:38 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x315cd50>
14:39:46 <bjohnson> #info if it does work, 2) then we need to focus on getting Tacker fixed. If this takes too long, 3) then we should consider using the VnfMgrSim python tool in the OPNFV SFC repo
14:42:33 <mbuil> #endmeeting