12:52:14 <trevor_intel> #startmeeting OPNFV Functest
12:52:14 <collabot> Meeting started Tue Apr  7 12:52:14 2015 UTC.  The chair is trevor_intel. Information about MeetBot at http://wiki.debian.org/MeetBot.
12:52:14 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
12:52:14 <collabot> The meeting name has been set to 'opnfv_functest'
12:53:05 <trevor_intel> #info Trevor Cooper (Intel)
12:53:50 <iben> Hello everyone@
12:54:24 <iben> I see you have documentation already on the agenda
12:55:39 <morgan_orange> #info morgan
12:55:45 <iben> as part of that can we get Victor Laza (Vic) to be added as a contributor?
12:55:52 <iben> #info Iben
12:56:11 <Malla> It is possible from any partner can create an audio bridge?
12:56:19 <iben> for the record - this is an IRC only meeting??? no g2m?
12:56:19 <vlaza> or just vlaza , so we don't overcomplicate
12:56:47 <iben> #info vlaza Victor Laza - from Cloudbase Solutions - will be helping with documentation
12:57:15 <fuqiao> Yes, from the invitation I think this is an irc only meeting
13:00:33 <bryan_att> hi
13:00:33 <morgan_orange> hi vlaza
13:00:34 <trevor_intel> We cant use the GTM because there is the weekly Doctor meeting now
13:00:39 <vlaza> hello
13:00:44 <bryan_att> I can provide a dial-in audio bridge if that will help
13:00:45 <ulik> hi
13:00:45 <trevor_intel> Should I send out an Intel bridge?
13:00:53 <trevor_intel> Ok Bryan thanks
13:00:56 <bryan_att> In the US, either: +1-888-388-6645x2125903# or +1-212-372-3682x2125903#
13:01:13 <pbandzi> #info Peter Bandzi
13:01:14 <bryan_att> A number in your country or in a country close to you (may be toll free): https://www.teleconference.att.com/servlet/glbAccess?process=1&accessNumber=8883886645&accessCode=2125903
13:02:33 <bryan_att> #info Bryan Sullivan
13:04:13 <trevor_intel> #chair bryan_att
13:04:13 <collabot> Current chairs: bryan_att trevor_intel
13:04:48 <collabot> bryan_att: Error: Can't start another meeting, one is in progress.  Use #endmeeting first.
13:05:02 <bryan_att> #topic Agenda runthru
13:05:06 <morgan_orange> bryan_att: trevor_intel already initiated the conf
13:06:22 <bryan_att> #info Trevor: at the RC meeting there wasn't functest representation. An action was given to provide the R1 functest state. Emails showed unclarity on who to contact etc for the project. This call is to help coordinate.
13:06:48 <bryan_att> #topic 1.	Functest leader
13:07:26 <bryan_att> #topic Agenda runthru
13:07:39 <bryan_att> (sorry - got ahead of myself)
13:08:21 <iben> can we limit the time for each topic?
13:08:27 <iben> documentation is pretty important.
13:08:41 <bryan_att> #info Trevor runs thru the rest of the agenda sent via email to the list
13:08:43 <bryan_att> #topic 1.	Functest leader
13:09:21 <bryan_att> #info Uli: about the committers - we would like to add a committer from Huawei
13:10:06 <iben> new commiters should have a role
13:10:10 <iben> what will they do?
13:10:20 <bryan_att> #info morgan: anyone should be able to nominate - its just a standard vote process
13:10:21 <fuqiao> # info Fuqiao
13:10:26 <iben> we had requests for some simple background for each new committer?
13:10:51 <iben> what will they be working on?  area of expertise?
13:11:19 <bryan_att> #info Trevor: just submit and we will vote
13:11:54 <vlaza> iben: good point, would be nice to know details like this; also related to the part of the project an individual contributes
13:11:56 <Malla> +1 Morgan
13:11:57 <bryan_att> #info ... Morgan was nominated by me; does he accept? any other nominations?
13:11:58 <iben> +1 for Morgan - but does he want it?
13:12:11 <bryan_att> #info Morgan: accepts
13:12:15 <iben> no
13:12:47 <pbandzi> +1 Morgan
13:12:49 <boss_mc> +1 Morgan
13:12:58 <vlaza> +1 Morgan
13:13:05 <bryan_att> #info Trevor: any other nominations? (no answer). Majority committer vote is required, offline since we don't have majority here
13:13:07 <iben> is morgan_orange already a committer?
13:13:15 <iben> we want to promote him to PTL
13:13:15 <morgan_orange> iyes
13:13:48 <iben> existing commiters are in the info file - right?
13:13:49 <Chitti> +1 Morgan
13:14:08 <trevor_intel> +1 Morgan
13:14:25 <bryan_att> #info Trevor: if no other nominations for leader, there is no competition and no need for a vote? (presumed)
13:14:32 <fuqiao> +1 Morgan
13:14:58 <iben> thsi the list of committers get pruned?  That might make this process easier too
13:14:59 <Malla> Congratulation Morange
13:15:04 <morgan_orange> :)
13:15:04 <iben> did
13:15:11 <bryan_att> #info ... We will asseume Morgan is the leader for now (we will verify the election process as needed)
13:15:21 <bryan_att> #topic 2.	RC1
13:16:16 <bryan_att> #info Morgan: we will have 5 test cases per the wiki, automated within the CI
13:16:34 <bryan_att> (we need a link to the wiki page, someone)
13:17:08 <vlaza> https://wiki.opnfv.org/opnfv_functional_testing   ?
13:17:08 <bryan_att> #info ... for R1 this is all that is achievable. Progress is bring made on the 5 test cases
13:17:43 <trevor_intel> #link https://wiki.opnfv.org/opnfv_functional_testing
13:17:52 <morgan_orange> #link https://wiki.opnfv.org/pharos_testing
13:18:08 <iben> this is a new page
13:18:37 <iben> #info this wiki page was made to replace the original page so now there are 2 - they need to be merged
13:18:53 <iben> #action morgan_orange to merge these pages
13:18:59 <bryan_att> #info ... will reformat the tests on the Pharos page onto the Functest wiki
13:19:07 <iben> will there still be a pharos project?
13:19:17 <bryan_att> #info ... the Functest page will be the single ref for Functest
13:19:57 <bryan_att> #info ... re Pharos, it will continue to define the testbed hardware, but not the actual testing
13:20:23 <iben> #info trevor_intel is in charge of the pharos project
13:20:51 <bryan_att> #info ... need to create a RST file for the repository since that's the R1 product
13:21:11 <iben> bryan_att: that’s what vlaza will be helping with
13:21:16 <icbts> Does the opnfv jira require a login just to view Jiras?
13:21:20 <iben> or can help with if needed
13:21:41 <bryan_att> #info ... the testing info will include the hardware (Pharos), stacks, additional functions being tested (IPv6), etc
13:21:42 <iben> but we need vlaza added as a commiter
13:22:21 <vlaza> if I can commit, I can write or rewrite whatever documentation in reST markup
13:22:41 <bryan_att> #info ... committed the RST file for Functest
13:23:01 <bryan_att> (someone please #link the gerrit review page for the RST file)\
13:23:36 <morgan_orange> #link https://gerrit.opnfv.org/gerrit/#/c/257/
13:23:41 <bryan_att> #info Trevor: what review needs to be done before commit is done?
13:24:46 <bryan_att> #info Morgan: already have support from various people; still working on Intel lab connection; need Jenkins support
13:24:58 <bryan_att> #info ... (support from Intel)
13:25:39 <bryan_att> #info ... will redo on a local testbed; who can help?
13:26:21 <bryan_att> #info Trevor: list who needs to be on a live debug session and will set it up
13:28:11 <bryan_att> #info Iben: a number of Jenkins server setups are underway - get together onto #opnfv; Victor is helping the setup process
13:28:43 <fdegir> what is meant with Jenkins servers?
13:28:47 <bryan_att> #info ... i.e. a number of debug sessions are needed
13:28:57 <fdegir> can someone clarify please?
13:29:06 <bryan_att> Jenkins is the client that pulls the repository info to the lab machines
13:29:19 <fdegir> we have one Jenkins for OPNFV
13:29:28 <fdegir> does "Jenkins servers" mean slaves?
13:29:33 <morgan_orange> yes
13:29:36 <fdegir> ok
13:29:37 <fdegir> thanks
13:29:39 <bryan_att> #link https://build.opnfv.org/ci/
13:29:40 <vlaza> clear now
13:30:44 <morgan_orange> need someone from Intel (FW) on #opnfv
13:31:36 <bryan_att> #info Trevor: still need to know who to setup the debug session with
13:31:44 <iben> i’m dropping to IRC only
13:32:05 <bryan_att> #info Morgan: ask the Intel person to join the IRC channel
13:32:17 <iben> aricg from lf can join a bridge if you need him to
13:32:22 <bryan_att> #info Trevor: will try but not sure that will help
13:32:27 <iben> just coordinate with him on irc
13:32:53 <bryan_att> #info ... I will be the point of contact for now
13:34:29 <bryan_att> suggest we move onto other agenda topics...
13:34:57 <bryan_att> #topic 3.	Communication
13:35:40 <bryan_att> #info Morgan: IRC channel #testperf, Etherpad (link?), document in the repo
13:36:01 <trevor_intel> #link     https://etherpad.opnfv.org/p/functiontestrelease1activities
13:36:11 <bryan_att> #info ... we should have enough channels to communicate
13:36:52 <bryan_att> #info ... will setup a weekly meeting for Functest, IRC only if possible; can report during Thurs meeting
13:37:16 <bryan_att> #info Trevor: suggest to use the weekly (Thurs) meeting for Functest update also until release
13:38:51 <bryan_att> #info Morgan: it's not clear the diff between the #opnfv channel and the #opnfv-ci channel
13:39:11 <iben> I can also provide a webex for jenkins server troubleshooting sessions if needed.
13:39:20 <bryan_att> #info ... the #opnfv-octopus channel
13:39:30 <bryan_att> #topic 4.	Documentation
13:40:13 <bryan_att> #info Morgan: for R1, the RST is the most important; ask for contributors to complete their part; test case descriptions, automation in CI, ...
13:40:27 <bryan_att> #info ... we can work on the wiki in the meantime
13:40:36 <fdegir> I think we should use IRC
13:40:43 <bryan_att> #info ... sent a proposal for the repo tree for the scripts
13:41:00 <fdegir> jenkins related stuff has been discussed in #opnfv-octopus channel mainly
13:41:17 <vlaza> so the plan will be to convert to reST the documentation that will be present on wiki?
13:41:23 <bryan_att> #info ... don't need more documents; assume we are using a lot of info from other projects
13:42:14 <bryan_att> (note) I suggest that the points you want to make are picked up by the chair and voiced on the call if you're not on, otherwise speak up for the floor
13:42:31 <bryan_att> #info Trevor: is it clear who owns the sections?
13:42:58 <bryan_att> #info bryan: it should be in the doc as a placeholder
13:43:24 <bryan_att> #action Morgan to put contributor info into the RST
13:43:34 <bryan_att> #topic 5.	CI integration
13:43:56 <bryan_att> #info Morgan: Intel and Spirent are already connected
13:44:01 <morgan_orange> #link https://etherpad.opnfv.org/p/octopus
13:44:05 <bryan_att> #info ... the procedure looks pretty clear
13:44:54 <bryan_att> #info ... still need the scripts to run tests; but first need to get connectivity
13:45:42 <bryan_att> #info ... anyone from CI on the bridge/IRC?
13:45:53 <bryan_att> #info ... any testing already integrated into CI?
13:46:10 <fdegir> #info We haven't integrated any testing in CI
13:46:16 <bryan_att> #info Uli: no auto integration yet
13:47:32 <bryan_att> #info bryan: is the install a blocking issue for getting the scripts updated?
13:47:35 <ulik> sorry lost my audio ......
13:49:38 <bryan_att> #info Morgan: we can write scripts to run the tests; we don't have to wait
13:50:08 <bryan_att> #topic 6.	Testing
13:50:25 <bryan_att> #info Morgan: new test case is vPing
13:51:10 <bryan_att> #info malla: connected two machines in the POD for the ping test
13:51:31 <bryan_att> #info ... just doing local testing for now
13:51:46 <bryan_att> #info Trevor: any issues still creating VMs?
13:51:56 <bryan_att> #info malla: still an issue, working on it
13:52:06 <bryan_att> #info Trevor: need help or Intel POD support?
13:52:18 <bryan_att> #info malla: yes; will contact Morgan
13:53:33 <bryan_att> #info Morgan: the installation is not complete, the config of OpenStack is likely blocking VM creation; need to discuss with BGS people
13:54:01 <bryan_att> #info ... had to load a CentOS image (the ones there were private) etc
13:54:32 <bryan_att> #info ... the lab is pre-release based upon the Foreman installer
13:54:58 <bryan_att> #info ... still some config work to do; to be sure we are not trying to test with blocking issues
13:57:21 <bryan_att> #info bryan: who knows how to verify that the config is right; we need to document those steps
13:57:52 <bryan_att> #info ... then firgure out a way to automate it
13:58:29 <bryan_att> #info Trevor: for work on R1, POD2 assumes manual steps relative to Foreman; is Functest only supporting Foreman?
13:58:45 <bryan_att> #info Morgan: should support any installer
13:59:05 <bryan_att> #info Trevor: but with 2 weeks left; is anyone doing that for Fuel, now?
13:59:27 <bryan_att> #info Morgan: don't think so, all focus is on one installer; difficult to do this in parallel
13:59:55 <bryan_att> #info ... goal is to test using Fuel on the Ericsson POD; the challenge is to get it working in one case first
14:00:25 <bryan_att> #info ... in Fuel, Tempest and Rally are integrated; we need to pull that out of the installer
14:00:49 <bryan_att> #info ... vIMS, ODL, vPING should be testable using Fuel
14:01:01 <bryan_att> #topic 7.	vIMS test suite progress
14:01:21 <bryan_att> #info Martin: blocked by inability to bring up VMs on the POD2 platform
14:01:48 <bryan_att> #info ... working to debug the OpenStack installation left by the Foreman installer; appears incomplete/misonfigured
14:02:05 <bryan_att> #info ... need to feed that back to BGS
14:03:04 <bryan_att> #info Morgan: if we are blocked, should we pause on the Ericsson POD?
14:04:32 <bryan_att> #info (corrected) should work on the Ericsson / Fuel POD in the meantime since we have a block on the Intel POD
14:04:58 <bryan_att> #info Trevor: need to coordinate with who is using the Ericsson POD
14:05:49 <fdegir> bryan_att: me (Fatih Degirmenci) and Jonas Bjurel can be contacted regarding Ericsson POD
14:06:20 <bryan_att> #info Morgan: will reach out to (Fatih Degirmenci) and Jonas Bjurel can be contacted regarding Ericsson POD
14:08:48 <trevor_intel> #info Need to get back to BGS (Foreman) for starting point to beable to spin up VMs
14:09:25 <trevor_intel> #info continue on Thursday test and performacne meeting
14:09:37 <trevor_intel> #endmeeting