13:00:03 <morgan_orange> #startmeeting functest weekly meeting 1/09
13:00:03 <collabot> Meeting started Tue Sep  1 13:00:03 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:03 <collabot> The meeting name has been set to 'functest_weekly_meeting_1_09'
13:00:09 <morgan_orange> #info Morgan Richomme
13:00:22 <jose_lausuch> #info Jose Lausuch
13:02:04 <morgan_orange> and welcome back, I can feel the Spanish sun on the functest repo (and feel better)
13:02:39 <jose_lausuch> :p
13:02:40 <jose_lausuch> thanks
13:02:59 <jose_lausuch> but I missed rain a bit
13:03:16 <morgan_orange> You have to visit our OPNFV lab in Brittany...
13:03:31 <morgan_orange> so let's start, hope other people will join...
13:03:45 <morgan_orange> #topic actions follow-up
13:04:00 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2015/opnfv-testperf.2015-08-25-16.01.html
13:04:07 <morgan_orange> meimei1: are you around?
13:04:34 <morgan_orange> peter not connected
13:04:40 <morgan_orange> guy_rodrigue: are you there?
13:04:47 <jose_lausuch> well, at least I get an overview of whats happening
13:05:05 <guy_rodrigue> #info Guy Rodrigue Koffi
13:05:12 <morgan_orange> ahhhh
13:05:17 <guy_rodrigue> yes morgan_orange
13:05:27 <morgan_orange> in action points we had "plan a demo for week 26"
13:05:30 <jose_lausuch> Hi Guy :)
13:05:32 <morgan_orange> I think it is a bit early
13:05:34 <guy_rodrigue> welcome back jose_lausuch !
13:05:40 <jose_lausuch> thanks!
13:05:50 <morgan_orange> but do you think we could propose a demo for thursday the 10th
13:06:09 <guy_rodrigue> yes
13:06:16 <jose_lausuch> next week
13:06:21 <morgan_orange> OK I take the point to propose this demo to teh agenda
13:06:32 <jose_lausuch> demo about_
13:06:33 <jose_lausuch> ?
13:06:33 <morgan_orange> we will detail the status later
13:06:51 <jose_lausuch> ah ok, API demo
13:06:53 <jose_lausuch> I see
13:07:15 <morgan_orange> yep
13:07:18 <jose_lausuch> week 36, not 26
13:07:32 <morgan_orange> #action morgan_orange plan demo API September the 10th
13:07:42 <morgan_orange> that is all for the action points
13:07:55 <morgan_orange> #topic SR1
13:08:36 <morgan_orange> #info SR1 planned for end of September
13:08:38 <jose_lausuch> when is it, morgan_orange?
13:08:42 <jose_lausuch> ok
13:08:58 <morgan_orange> #info Functest must be OK (like for Arno stable)
13:09:10 <morgan_orange> #info wiki page created to follow SR1 status
13:09:46 <jose_lausuch> can you link it and info it?
13:09:46 <morgan_orange> #info LF POD have been reconfigured
13:09:59 <morgan_orange> foreman and fuel are installed alternatively on POD2
13:10:15 <jose_lausuch> ok
13:10:17 <morgan_orange> #link https://wiki.opnfv.org/functest_release_1
13:10:25 <jose_lausuch> I saw some emails about the credentials script
13:10:47 <morgan_orange> at the moment there is an open bug on the creds retrieval. It is OK on fuel but not OK with foreman
13:11:01 <jose_lausuch> ok
13:11:09 <jose_lausuch> I expected something like that
13:11:22 <morgan_orange> #info wait for tim green light (committing a patch for foreman)
13:11:23 <jose_lausuch> that script is not super robust
13:11:33 <jose_lausuch> I'll try to have a look
13:11:49 <morgan_orange> there was a path issue I corrected (we were not sourcing the file we built)
13:11:51 <morgan_orange> it is now OK
13:12:01 <morgan_orange> but there is an issue on the value we retrieve from foreman
13:12:06 <jose_lausuch> ok
13:12:13 <morgan_orange> #info bugs declared on foreman creds retrieval
13:12:28 <morgan_orange> #info there is also an issue with ODL suite, JIRA created
13:12:40 <morgan_orange> #info var issue (a priori not too complex)
13:12:57 <morgan_orange> #info vPing was (hopefully) still working with both installer
13:13:06 <morgan_orange> #info Rally issues
13:13:19 <morgan_orange> #info Tempest still OK but Rally bench scenraio cannot be started
13:13:28 <jose_lausuch> mmm
13:13:32 <morgan_orange> #info I opened a bug on Rally
13:13:33 <jose_lausuch> do you know why?
13:13:43 <jose_lausuch> its a rally problem or ours scripts?
13:13:56 <morgan_orange> it is a rally issue or a misconfiguration of rally from our script
13:14:08 <morgan_orange> I saw on the web someone who had the same issue
13:14:15 <jose_lausuch> ok
13:14:26 <jose_lausuch> I'll check that out
13:14:29 <morgan_orange> the workaround was not working on the fuel based solution (add an endpoint in config)
13:15:11 <morgan_orange> #link https://bugs.launchpad.net/rally/+bug/1489746/
13:15:27 <morgan_orange> I planned to re-test the workaround on the foreman based installer...
13:15:41 <morgan_orange> so some work ahead for SR1
13:15:56 <morgan_orange> correction of fetch os + fix errors in ODL and Rally
13:16:19 <morgan_orange> any question for SR1?
13:16:43 <jose_lausuch> nop
13:16:52 <morgan_orange> ok so let's move to R2 topic...
13:16:59 <morgan_orange> #topic R2 dashboard
13:17:17 <morgan_orange> #info first meeting organized with LF, Ana on the test dashboard
13:17:41 <morgan_orange> #info guy_rodrigue and myself  proposed a scenario
13:18:18 <jose_lausuch> are there minutes from that meeting?
13:18:19 <morgan_orange> #link https://wiki.opnfv.org/opnfv_test_dashboard
13:18:29 <morgan_orange> it was a gotomeeting
13:18:38 <jose_lausuch> ok
13:18:48 <morgan_orange> #info during this meeting they suggested other possible scenario plugin Jenkins
13:18:56 <morgan_orange> #info apparently could lead to perfo issues
13:19:13 <morgan_orange> #info so we continue with guy_rodrigue and shall be able to make a first demo next week
13:19:27 <jose_lausuch> what about bitergia?
13:19:29 <morgan_orange> #info basicaly we store results then generate json taht could be used by a portal and a js lib
13:19:39 <jose_lausuch> any news about that option?
13:20:02 <morgan_orange> #info bitergia was an option but LF would like to use thei own resource so more portal/drupal + js lib
13:20:17 <jose_lausuch> ahmm
13:20:19 <jose_lausuch> ok
13:20:19 <morgan_orange> #info a meeting is planned this week on thursday
13:20:28 <jose_lausuch> to discuss that
13:20:30 <jose_lausuch> fair enough
13:20:51 <morgan_orange> Andrew (who is leading that for LF) and Aric will eb there
13:21:06 <morgan_orange> I will send a mail on our scenario as we have almost a fully fonctional demo
13:21:48 <morgan_orange> it looks relatively light, no constraint on CI, almost no constraint on dashboardin - each test projects generate the graph they want to show
13:22:08 <jose_lausuch> well, that removes dependencies of graphs/results
13:22:22 <morgan_orange> #action morgan_orange mail to the community to be more precise that the wiki page (but basically it is just an real implementation of the scenario described in the page)
13:22:24 <jose_lausuch> among projects
13:22:59 <morgan_orange> ok for the dashboard?
13:23:18 <morgan_orange> #topic test profile
13:23:32 <jose_lausuch> yep
13:23:41 <morgan_orange> #info bryan initiated a doc on functest gerrit and a wiki page
13:24:08 <morgan_orange> #info the idea is to define reference traffic model for the different test projects in order, if possible to compare apples with apples
13:24:37 <morgan_orange> #link https://git.opnfv.org/cgit/functest/tree/commons
13:24:51 <morgan_orange> #info he accepted to lead this task
13:25:05 <morgan_orange> #info topic API test collection
13:25:27 <morgan_orange> #info LF DB setup and reachable from anywhere
13:25:51 <morgan_orange> #info for our demo we used our own DB because we must install a DB and the python framework to manage the API
13:25:56 <morgan_orange> guy_rodrigue: you can complete
13:26:08 <jose_lausuch> morgan_orange: what is that link?
13:26:10 <jose_lausuch> ims, mobile?
13:26:41 <morgan_orange> oups that is the place where the traffic profile will be stored
13:27:00 <morgan_orange> as well as the doc to list/explain them
13:27:02 <guy_rodrigue> yes we use motor and tornado as framework
13:27:13 <morgan_orange> #info use of motor + tornado for API
13:27:32 <morgan_orange> #info you can test it if you want...
13:28:09 <morgan_orange> #link curl -X GET -H "Content-Type: application/json" http://213.77.62.197:80/results
13:28:28 <morgan_orange> I will give details in the mail and during the demo
13:28:34 <jose_lausuch> ok
13:28:45 <jose_lausuch> looking forward :)
13:29:00 <morgan_orange> I think it was OK for this week for the topics
13:29:09 <morgan_orange> I initially planned some troubleshooting
13:29:16 <morgan_orange> but SR1 is the priority...
13:29:24 <morgan_orange> so we will troubleshoot once SR1 will be fine :)
13:29:41 <jose_lausuch> sounds good
13:29:50 <morgan_orange> #topic AoB
13:29:55 <jose_lausuch> hopefully not too much work
13:30:13 <morgan_orange> question, Debra planned the release weekly meeting every tuesday
13:30:23 <morgan_orange> at 6 PM CEST
13:30:36 <morgan_orange> it was one of the 2 time slot on which we were used to alternate...
13:30:56 <morgan_orange> shall we keep it (assuming that only 1 person is needed for Debra's meeting
13:31:39 <morgan_orange> if we keep onlt the 3PM we will not have lots of californian contributors...but we do not have a lot anyway...
13:31:53 <anac1> i have one question regarding setup tools
13:32:15 <morgan_orange> I think it is important to keep a dedicated synchro meeting
13:32:27 <jose_lausuch> shall we prioritize Debras?
13:32:34 <jose_lausuch> is it only for SR1 or for R2 also?
13:32:40 <morgan_orange> I think we must attend Debra's meeting
13:32:49 <morgan_orange> at least one of us
13:32:58 <morgan_orange> it is mainly for R2
13:33:13 <morgan_orange> the first meeting is today...so we will see exactly the content...
13:33:39 <morgan_orange> For the moment we can keep as we are and see if we can IRC in // of debra's meeting
13:33:52 <morgan_orange> and if it is too complex we will change our time slot
13:34:09 <morgan_orange> other information
13:34:22 <jose_lausuch> ok
13:34:31 <jose_lausuch> anac1: shoot :)
13:34:41 <morgan_orange> #info R2 page completed and lots of Jira created (not as many as yardstick...) but reasonable number
13:35:14 <anac1> do you have any dependencies to setup tools?
13:35:32 <anac1> yardstick need 17.1 or later, any objections?
13:35:57 <morgan_orange> no, for R2, one of the task is to put functest into a container to avoir dependencies
13:36:07 <jose_lausuch> yes
13:36:14 <jose_lausuch> I take that AP
13:36:15 <morgan_orange> we used to have to dependency issues and the different testbeds we deployed functest
13:36:25 <anac1> ok, good. just checking so we don't break anything for you...
13:36:27 <morgan_orange> jose_lausuch: good it is already assigned to you :)
13:37:11 <morgan_orange> but I think most of the project should probably adopt such container view other wise it will be probably lead to some issues
13:37:27 <anac1> agree
13:37:38 <morgan_orange> at least use virtual env
13:38:24 <morgan_orange> ok any question for this week?
13:39:03 <morgan_orange> I have also to see with the contributors - I know that Uli in Octopus will start a cleaning operation...
13:39:11 <morgan_orange> I imagine I could also do that
13:39:24 <morgan_orange> We will see next week if we are more.. :)
13:39:29 <jose_lausuch> no questions
13:39:43 <jose_lausuch> I might have some when I really start working :D
13:40:01 <morgan_orange> yep
13:40:05 <morgan_orange> #endmeeting