13:00:01 <morgan_orange> #startmeeting weekly functest meeting 15 Sept
13:00:01 <collabot> Meeting started Tue Sep 15 13:00:01 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:00:01 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:00:01 <collabot> The meeting name has been set to 'weekly_functest_meeting_15_sept'
13:00:06 <morgan_orange> #chair jose_lausuch
13:00:06 <collabot> Current chairs: jose_lausuch morgan_orange
13:00:19 <morgan_orange> #info Morgan richomme
13:01:06 <May-meimei1> #info meimei
13:01:17 <morgan_orange> Hi meimei
13:01:24 <May-meimei1> hi morgan
13:01:37 <jose_lausuch> #info Jose Lausuch
13:01:45 <jose_lausuch> or chair :)
13:02:05 <morgan_orange> #info agenda https://wiki.opnfv.org/functest_meeting
13:02:17 <morgan_orange> #topic follow up of action points
13:02:36 <morgan_orange> #info there were 2 open points
13:03:09 <morgan_orange> #info contact Andrew for dashboard done, I shall re contact him to precise the sprint for the portal Proof of concept
13:03:26 <morgan_orange> #info description of orange lab still open (but more linked to pharos), Jira have been created
13:03:33 <morgan_orange> #topic SR1
13:04:04 <morgan_orange> #info functest not tested as main work consists in fixing foreman/fuel deployments
13:04:08 <jose_lausuch> functest just failed on foreman
13:04:15 <jose_lausuch> with a different error
13:04:19 <morgan_orange> ah bad luck...
13:04:28 <jose_lausuch> cp: cannot stat ‘/home/jenkins-ci/workspace/functest-foreman-master/testcases/Controllers/ODL/CI/logs’: No such file or directory
13:04:31 <jose_lausuch> anyway
13:04:36 <jose_lausuch> lets continue :)
13:04:59 <morgan_orange> #info synch IRC meeting MON/Wed/Fri 15h00 CEST
13:05:57 <morgan_orange> #link https://wiki.opnfv.org/releases/arno/stablerelease_1
13:06:07 <morgan_orange> we will have a look after the sync
13:06:14 <jose_lausuch> yes
13:06:26 <morgan_orange> #info risk for the date 'end of September)...need a stable ref env on POD2
13:06:50 <morgan_orange> #topic JIRA review
13:07:12 <morgan_orange> #info JIRA created (in time for R2)
13:07:14 <morgan_orange> #link https://jira.opnfv.org/browse/FUNCTEST
13:07:24 <morgan_orange> #info most of them allocated
13:07:40 <morgan_orange> May-meimei you want to info ONOS status?
13:07:57 <May-meimei1> just ongoing!
13:08:08 <May-meimei1> sorry, I am busy in COMPASS
13:08:29 <morgan_orange> ah the installers....:)
13:08:38 <morgan_orange> José is also working on fuel & foreman...
13:08:39 <May-meimei1> my co-workers is working on ONOS
13:08:47 <morgan_orange> ok
13:09:08 <May-meimei1> I will told them comment this jira directly
13:09:31 <morgan_orange> do you see any missing Jira regarding what we announced we will provide for R2?
13:09:40 <morgan_orange> #link https://wiki.opnfv.org/functextnexttaks
13:09:50 <jose_lausuch> mmmm
13:10:01 <jose_lausuch> me? or memei?
13:10:29 <morgan_orange> #info main tasks identified: api+DB / vIMS testcase, ODL testcase, Dashbaord, Docker, SFC, Policy + docs, automation,...
13:10:33 <morgan_orange> both
13:10:41 <jose_lausuch> not really
13:10:46 <jose_lausuch> i think its covered
13:10:50 <jose_lausuch> in jira everything
13:11:02 <morgan_orange> for SFV, BGPVPN, we declared story, it is still not clear how we will be involved
13:11:10 <jose_lausuch> SFV or SFC?
13:11:16 <morgan_orange> there is a meeting this thursday with ODL teams
13:11:19 <morgan_orange> SFC
13:11:27 <jose_lausuch> we need discussions with Brady (SFC) and anac1
13:11:44 <morgan_orange> #Brady will be surely there on thursday
13:11:48 <morgan_orange> #undo
13:11:48 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x2e94410>
13:12:21 <morgan_orange> with the other test teams we said that we must know the projects that will request test activitieis before the 25th of September
13:12:36 <morgan_orange> then 1st od December is the deadline for test specifications
13:12:42 <morgan_orange> an etherpad has been open
13:12:58 <morgan_orange> typically May-meimei you are the connection between ONOS and functest
13:13:22 <iben> We are gathering the ipv6 testing needs. But does any lab have ipv6 addresses available?
13:13:37 <May-meimei1> so the deadline is 1st od December?
13:14:10 <morgan_orange> good question for Pharos...the labs are probably not IPv6 ready
13:14:21 <morgan_orange> deadline for declaration is 25th of September
13:14:34 <morgan_orange> 1st is the deadline for the test spec (knwo precisely what will be tested)
13:14:34 <iben> But where does function run today?
13:15:04 <iben> I'd like to expand that to other labs. Is that easily done?
13:15:08 <morgan_orange> and it is really a dealine, if some dev is expected on a tool (e.g. yardstick), it may be not possible to include it
13:15:11 <morgan_orange> so the sooner the better
13:15:18 <morgan_orange> but the 25th of Septemebr was a bit early
13:15:36 <morgan_orange> iben: no idea
13:16:11 <iben> Sorry. Not function. Meant functest. Darn autocorrect
13:16:32 <iben> Where is functest running today?
13:16:39 <jose_lausuch> on pod2
13:16:49 <jose_lausuch> foreman/fuel
13:17:11 <morgan_orange> they have been also successfully run in E///, Dell and Orange labs but it is not integrated in CI yet (manual tests)
13:17:24 <morgan_orange> #link https://etherpad.opnfv.org/p/testing_requests_for_b_release
13:17:25 <iben> There are many pod 2. Is that intel? Ericsson? LF?
13:17:34 <morgan_orange> for the moment only IPv6 mentioned
13:17:35 <jose_lausuch> LF sorry
13:18:00 <jose_lausuch> from CI
13:18:08 <jose_lausuch> and then what morgan said, manually on many others
13:18:29 <morgan_orange> iben: https://build.opnfv.org/ci/computer/opnfv-jump-2/
13:18:30 <iben> Gotcha. Thanks. Is there JIRA story to extend that to other labs?
13:18:57 <jose_lausuch> it should be on releng
13:19:00 <jose_lausuch> not only functest
13:19:04 <jose_lausuch> deployment as well
13:19:09 <jose_lausuch> complete ci chain
13:19:13 <jose_lausuch> build+deploy+functest
13:19:13 <iben> I'd like to help with this.
13:19:20 <jose_lausuch> there must be something, but im not sure
13:19:21 <May-meimei1> yes
13:19:36 <May-meimei1> agree for that complete ci chain
13:19:54 <morgan_orange> all the labs will not provide build/deployement capabilities, but it shall be possible to automatically run all the test projects
13:20:26 <May-meimei1> do we need a smoke test?
13:20:32 <iben> Wait, does functest only work on Arno?  It should work on any openstack that meets opnfv specs regardless of how it was built.
13:20:37 <May-meimei1> I saw that before
13:20:46 <morgan_orange> functest work on OPNFV
13:20:52 <morgan_orange> it will work on all the versions
13:21:01 <morgan_orange> for the SR1, it must work on the stable and master version
13:21:08 <morgan_orange> It will work on the B release
13:21:38 <morgan_orange> functest is a collection of test suites that can be automatically run on any OPNFV solution
13:21:57 <morgan_orange> it can of course be run manually (most of the cases on Arno so far)
13:22:08 <morgan_orange> in Arno it includes only 4 testcases
13:22:19 <morgan_orange> in brahmaputra we have additional testcases
13:22:28 <morgan_orange> as described in https://wiki.opnfv.org/functextnexttaks
13:22:48 <jose_lausuch> you could run functest on an plain openstack installation
13:23:04 <jose_lausuch> but odl tetst wont work if you dont have the odl sdn controller
13:23:28 <morgan_orange> #topic AoB
13:23:30 <jose_lausuch> but the smoke tests, the rally bench and vPing should work
13:23:55 <May-meimei1> sorry, how to specific the sdn controller?
13:24:09 <morgan_orange> that is a good point
13:24:09 <jose_lausuch> didnt get the question
13:24:18 <morgan_orange> theoretically OPNFV is a black box for functest
13:24:18 <jose_lausuch> its odl by default now
13:24:28 <jose_lausuch> as soon as we get another one we will have to do some adaptations
13:24:46 <jose_lausuch> but we should run the tests regardless of the sdn controller we ge
13:24:48 <jose_lausuch> get
13:25:24 <May-meimei1> ok! got it
13:25:35 * fdegir sr1 sync meetings are on mon/wed/fri 15:00 UTC, not CEST
13:25:47 <morgan_orange> we may imagine to have a SDN controler suite as Peter had imagined
13:25:56 <morgan_orange> fdegir: thanks
13:26:07 <morgan_orange> #info correction sync meetings are on mon/wed/fri 15:00 UTC, not CEST
13:26:20 <jose_lausuch> better to talk UTC timezone
13:26:24 <jose_lausuch> because we will be CET soon
13:26:28 <morgan_orange> in the suite on Arno there were basic tests (creation of networks, ports, ...) with Neutron and with ODL
13:26:28 <jose_lausuch> winter is comming...
13:27:07 <morgan_orange> for me it is not clear yet how the controller config will be managed
13:27:27 <May-meimei1> I think there is a action on me
13:27:32 <morgan_orange> for the moment in CI we have genesis-<installer>-<version>
13:27:46 <May-meimei1> contact  genesis to ask for help
13:27:54 <morgan_orange> in the future I imagine we will have genesis-<installer>-<version>-<SDN> ?
13:28:20 <morgan_orange> then we will run our tests accordingly
13:28:45 <fdegir> morgan_orange: or we can divide functest and create separate jobs for sfn testing
13:28:47 <jose_lausuch> something like that
13:28:52 <jose_lausuch> so many combinations...
13:29:05 <jose_lausuch> sfn?
13:29:14 <fdegir> sdn
13:29:32 <fdegir> like fuel-master-odl
13:29:40 <fdegir> fuel-master tempest
13:30:00 <morgan_orange> but it will be linked to the POD config, we will not have several SDN controller for 1 given POD
13:30:03 <jose_lausuch> will the tests differ depending on the sdn you choose?
13:30:11 <morgan_orange> so fuel-master-whatever => you can run tempest
13:30:32 <morgan_orange> but onos it will be only possible on fuel-master-onos
13:30:52 <fdegir> if the testing is not different for different sdn controllers
13:31:01 <fdegir> than it might not be needed
13:31:02 <morgan_orange> we may start a mail thread on this to share with BGS and releng
13:31:10 <fdegir> or
13:31:24 <morgan_orange> yes when the testing is not specific...but it will not be always teh case
13:31:25 <iben> Onos can run from maas and other installers, no?
13:31:29 <morgan_orange> SFC is linked to ODL for instance
13:31:36 <May-meimei1> yes , can we use robot test onos?
13:31:41 <fdegir> we can come up with suggestions and share with the rest for feedback
13:31:42 <morgan_orange> yes
13:31:57 <morgan_orange> you can use rally, robotframework yardstick, qtip
13:32:04 <morgan_orange> there are already several tools available
13:32:09 <morgan_orange> that is why the PAD has been created
13:32:22 <morgan_orange> to avoid the (re) creation of a testing framework
13:32:34 <morgan_orange> and capitalize and already available framework
13:33:11 <morgan_orange> in functest we devploy rally and robotframework for the jumphost
13:33:16 <morgan_orange> it can be used by any project
13:33:28 <jose_lausuch> yes
13:33:36 <jose_lausuch> the robot now is adapted to test odl
13:33:46 <morgan_orange> #info discussions on the R2 testing with focus on teh dependencies with SDN controller
13:33:48 <jose_lausuch> but it can be adapted (I would say) for others
13:34:08 <morgan_orange> #info functest shall remain as agnostic as possible (even if we know it will not be always possible)
13:34:11 <May-meimei1> hope so
13:34:26 <morgan_orange> #action morgan_orange start mail to discuss how we will test multi SDN config
13:34:51 <morgan_orange> #info reminder that test frameworks are already integrated and can be reused (to avoir the redevelopment of new test frameworks)
13:35:38 <morgan_orange> #info available framework: rally, robotframework, yardstick, qtip(details on components in the dedicated pages)
13:35:55 <morgan_orange> #link https://wiki.opnfv.org/testing
13:36:10 <morgan_orange> iben: https://www.youtube.com/watch?v=7IO6t3C_OFA
13:36:30 <morgan_orange> iben: if you want we can help you to integrate it on the Spirent Lab and in the CI
13:37:11 <morgan_orange> #action jose_lausuch morgan_orange we have to prepare also the pres for the Summit (after the SR1...)
13:37:24 <morgan_orange> any other element you would like to share?
13:37:39 <iben> Link to opnfv functest demo video. Cool. It's one hour long so I can watch it later.
13:37:45 <jose_lausuch> #info discussions to extend the time for our presentations are ongoing
13:38:05 <morgan_orange> so to summarize..
13:38:07 <jose_lausuch> iben sorry for my bad english in the video xD
13:38:08 <morgan_orange> focus on SR1
13:38:25 <morgan_orange> and work on the JIRa according to the roadmap
13:38:45 <morgan_orange> jose_lausuch: you will be present on thursday? you can check with Brady if he will be around?
13:39:15 <jose_lausuch> me? presenting ?
13:39:15 <iben> No hay problemla.
13:39:22 <jose_lausuch> haha
13:39:47 <jose_lausuch> morgan_orange: am I presenting on thursday?
13:39:55 <morgan_orange> #action May-meimei check if robotframework could be used to test ONOS
13:40:02 <May-meimei1> ok
13:40:08 <jose_lausuch> sorry
13:40:11 <jose_lausuch> I get it now
13:40:17 <jose_lausuch> yes, I'll be present on thursday
13:40:22 <jose_lausuch> sorry, parallell meetings :)
13:40:27 <morgan_orange> np
13:40:27 <jose_lausuch> I'll talk to brady
13:40:48 <jose_lausuch> so that he joins
13:40:49 <morgan_orange> we probably will have to explain what Peter has done (but he is out of office until thursday)
13:40:55 <morgan_orange> no more questions?
13:40:59 <jose_lausuch> you mean the robot stuff?
13:41:07 <morgan_orange> the ODL suite
13:41:29 <morgan_orange> just to share with ODL people
13:41:54 <jose_lausuch> yep
13:42:02 <morgan_orange> #endmeeting