13:02:03 <anac1> #startmeeting Test&Performance Ops Meeting
13:02:03 <collabot> Meeting started Fri Oct  2 13:02:03 2015 UTC.  The chair is anac1. Information about MeetBot at http://wiki.debian.org/MeetBot.
13:02:03 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
13:02:03 <collabot> The meeting name has been set to 'test_performance_ops_meeting'
13:02:15 <anac1> #chair morgan_orange
13:02:15 <collabot> Current chairs: anac1 morgan_orange
13:02:33 <morgan_orange> #info Morgan Richomme
13:02:41 <anac1> #info Ana Cunha
13:02:59 <morgan_orange> shall we review the pad
13:03:04 <morgan_orange> the new demands
13:03:14 <anac1> #topic test requests
13:03:45 <morgan_orange> #info last time we initiated an answer for IPv6 and ArmBand
13:03:54 <morgan_orange> #info and Promise
13:03:54 <anac1> #link https://etherpad.opnfv.org/p/testing_requests_for_b_release
13:04:03 <morgan_orange> #info pending Copper and Doctor
13:04:16 <morgan_orange> #info for Doctor I exchanged via the backlog of Jira
13:04:21 <jose_lausuch> is this only for PTLs ? :)
13:04:35 <morgan_orange> no
13:04:50 <morgan_orange> #info they developped Rally Script
13:04:51 <anac1> will add functest to doctor's request?
13:04:59 <morgan_orange> #info so easiest way is to integate these scripts in Functest
13:05:10 <morgan_orange> #info only dependencies is the need for ceilometer
13:05:29 <anac1> #agreed doctor - functest support
13:05:37 <anac1> what about copper?
13:06:45 <morgan_orange> bryan is not on the IRC but it looks a little bit similar, except that they also need Congress
13:06:49 <anac1> functest, i think, or?
13:07:15 <morgan_orange> the same than for Doctor, they have to see with genesis if the additional OpenStack module will be integrated
13:07:26 <morgan_orange> if so, Ok to put the test in functest
13:07:39 <anac1> #agreed copper - functest support
13:08:10 <morgan_orange> jose_lausuch: do you confirm than ceilometer was not available in SR1?
13:08:32 <morgan_orange> #info OK I will update the Matrix and put a link between Copper/Promise and Functest
13:08:41 <jose_lausuch> morgan_orange: yes, I confirm
13:09:28 <morgan_orange> Ok so there is a dependency towards the installers, the feature tests will need the modules
13:09:41 <anac1> #info requests processed, all handled, so far
13:09:53 <morgan_orange> #action morgan_orange update wiki page
13:10:06 <morgan_orange> #link https://wiki.opnfv.org/feature_test_project_matrix
13:10:30 <morgan_orange> BTW anac1 I will probably copy your wiki project page, I found it very clear :
13:10:55 <anac1> thanks for feedack
13:11:01 <anac1> feedback
13:11:40 <anac1> #topic pods for testing
13:11:49 <morgan_orange> oh yes...
13:11:52 <morgan_orange> good one
13:12:16 <anac1> will not be possible to verify everything in LF POD2
13:12:18 <jose_lausuch> will be the intel one available soon?
13:12:38 <morgan_orange> we discussed on the chan this morning
13:12:46 <jose_lausuch> yep
13:13:06 <morgan_orange> I took the point to send a mail to pharos cc tech opnfv to discuss the availability of PODS for testing after SR1
13:13:11 <morgan_orange> LF POD2 is not enough for us
13:13:24 <jose_lausuch> ok
13:13:30 <morgan_orange> so we need to have at least 2 or 3 PODS for our tests / integration in CI / ..
13:13:50 <anac1> can we propose something like: feature x to be tested in pod y
13:14:09 <anac1> a list with the requests we have and the pods?
13:14:16 <jose_lausuch> anac1: +1 if we have enough pods
13:14:24 <jose_lausuch> but in the end we should test everything in all the pods
13:14:31 <morgan_orange> it shoudl be managed in Pharos JIRA I think
13:14:43 <morgan_orange> and we should have a clear view of the available PODs + available tooling
13:15:00 <morgan_orange> we should have PODs to CI and automatic testing
13:15:02 <anac1> not clear to me, though
13:15:08 <morgan_orange> and some to prepare/tune the test suites
13:15:33 <morgan_orange> we should automate as much as possible...but everything could not be automated
13:15:53 <morgan_orange> if you see VSPerf they are using IXia loader, it not present in all the PODs
13:16:26 <anac1> how's the best way to organize a list? testing wiki?
13:16:50 <morgan_orange> in a first step wiki could be OK but we need a portal at the end
13:17:19 <morgan_orange> portal will show the testbed, the OPNFV solutions installed on it, the availability for test campaigns, the list of automated tests, the requests pending...
13:17:34 <morgan_orange> I think someone from LF suggests the idea of a portal..
13:17:53 <anac1> long term sounds good, we need to get started
13:17:58 <morgan_orange> but in short term a wiki and at least 2 or 3 POD to work on the tests + N PODs for automated testing
13:18:06 <anac1> agree
13:18:36 <morgan_orange> #info POD test groups need to reference request/test/PoD in the wiki in short term
13:18:48 <anac1> do we need approval for this way of working?
13:18:49 <morgan_orange> #info need at least 2 or 3 POD to work on the tests + N PODs for automated testing
13:18:59 <morgan_orange> I think we can prepare a mail
13:19:06 <morgan_orange> exchange with the testing community and Pharos
13:19:15 <morgan_orange> and vote during the next thursday meeting
13:19:25 <anac1> ok
13:19:44 <morgan_orange> #info long term we need a Pharos portal providing all the informations (version, availability, tooling, test history,...)
13:20:00 <jose_lausuch> morgan_orange: arent they working on that already?
13:20:18 <morgan_orange> #info suggestion 1) mail to exchange with community 2) discussion and vote next thursday during weekly test meeting
13:20:36 <morgan_orange> jose_lausuch: for the moment I think they try to get resources
13:20:43 <anac1> morgan_orange: will you start 1)?
13:20:57 <morgan_orange> #action morgan_orange prepare mail
13:21:06 <jose_lausuch> ok
13:21:20 <anac1> shall we add a page in testing wiki?
13:21:25 <morgan_orange> the expectations towards Pharos are very high and they are lacking resources
13:21:42 <morgan_orange> I am even not sure that there iis 1 representative per declared paltform today
13:21:54 <morgan_orange> anac1: yes can I action this to you?
13:21:57 <anac1> yes
13:22:21 <morgan_orange> #action anac1 create wiki page to give the overview of tesbeds versus test project requests
13:23:02 <morgan_orange> shall we speak about the pres for the Summit
13:23:15 <morgan_orange> I did not start looking at that
13:23:34 <anac1> ok, we need to get a presentation ready be oct 30
13:23:38 <morgan_orange> i hope the Sprint #3 of LF will share a nice dashboard
13:23:43 <jose_lausuch> that give us 1 month
13:23:54 <jose_lausuch> you have a presentation together, right?
13:23:59 <jose_lausuch> morgan, we have another one we 2
13:24:23 <morgan_orange> yes ...I will be in vacations on week 43
13:24:39 <morgan_orange> jose_lausuch: yes
13:24:46 <jose_lausuch> and I will be in the summit week 42
13:24:56 <jose_lausuch> sdn openflow congress
13:24:58 <morgan_orange> jose_lausuch:  the one we have is about test collection and dashboard
13:25:06 <jose_lausuch> yes
13:25:12 <morgan_orange> relatively easy
13:25:18 <morgan_orange> I already made some slides and a wiki page
13:25:21 <jose_lausuch> well, its 20 min
13:25:22 <morgan_orange> just need to refator
13:25:24 <jose_lausuch> so 5-6 slides max
13:25:26 <morgan_orange> with last status
13:25:37 <anac1> morgan_orange: i will book a meeting in week 42, you, trevor and i for discussing the presentation, ok?
13:25:42 <jose_lausuch> what format should we use for the slides, anac1?
13:25:43 <morgan_orange> ok
13:25:52 <morgan_orange> jose_lausuch: anac1 sent us the template
13:26:05 <jose_lausuch> powerpoint
13:26:17 <anac1> jose_lausuch: yes, i sent the template, upload in pdf
13:26:52 <morgan_orange> jose_lausuch: we will work on it on week 44
13:27:09 <jose_lausuch> because power point is fine , but not for everyone who has a linux machine
13:27:12 <anac1> the person who sent the presentation proposal has to upload the final presentation in pdf format
13:27:25 <morgan_orange> usually I can open powerpoint with impress
13:27:29 <morgan_orange> and at the end pdf
13:27:37 <jose_lausuch> there are other ways
13:27:37 <jose_lausuch> http://slides.com/jose_lausuch/functest-in-depth#/4
13:27:43 <jose_lausuch> I started some days ago a template
13:27:45 <morgan_orange> or a js  framework
13:28:03 <morgan_orange> reveal...
13:28:07 <anac1> guys, i have to go, can we end the meeting?
13:28:15 <morgan_orange> yes
13:28:19 <anac1> #endmeeting