#opnfv-testperf: Functest weekly 6th october

Meeting started by morgan_orange at 16:00:22 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 16:00:30)
    2. Jose Lausuch (jose_lausuch, 16:00:35)

  1. R2 (morgan_orange, 16:02:18)
    1. agile board status: https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (morgan_orange, 16:02:47)
    2. SLA on Rally implemented => save more than 30 minutes (morgan_orange, 16:03:12)
    3. we can see that Nova and Neutron are failed (what we already know) (morgan_orange, 16:03:29)
    4. access to LF POD granted to juha for troubleshooting (morgan_orange, 16:03:41)
    5. run-tempest to be pushed tomorrow (morgan_orange, 16:03:53)
    6. push rally results => issue on the API (500 on Tornado) => Rodrigue is investigating (morgan_orange, 16:04:21)
    7. vIMS Valentin_Orange committed the scripts, integration in progress, maybe an issue of connectivity from the LF Jumphost to the VM created in IMS tenant (morgan_orange, 16:04:53)
    8. sprint ends 16th of October (morgan_orange, 16:05:23)
    9. we need the info of the SDN controller to perform the accurate test (Functest-49) (morgan_orange, 16:10:08)
    10. testbed running non ODL alpha Brahmaputra needed (morgan_orange, 16:10:26)
    11. ACTION: Quiglong find a compatible lab for ONOS (morgan_orange, 16:10:46)
    12. remote access to non Huawei folks possible? (jose_lausuch, 16:11:04)
    13. functest-49 could be delayed until we find a non ODL lab... (morgan_orange, 16:12:01)
    14. ACTION: morgan_orange initiate wiki page for functest-54 (morgan_orange, 16:13:40)

  2. docker (morgan_orange, 16:14:57)
    1. jose_lausuch made very good progress able to run functest from docker on LF POD2 (morgan_orange, 16:15:13)
    2. commit here : https://gerrit.opnfv.org/gerrit/#/c/2143/16 (jose_lausuch, 16:15:27)
    3. adaptations required but this item of Sprint 3 is not far... (morgan_orange, 16:15:31)
    4. 95% ready to merge (jose_lausuch, 16:15:39)
    5. there was a question from valentin about 1 docker versus N dockers (morgan_orange, 16:15:57)
    6. from my perspective one docker is fine => replace current functest running diurectly on the jumphost (morgan_orange, 16:16:15)
    7. Valentin concern was about the abaility to run a functional test independently from the others (morgan_orange, 16:16:51)
    8. 1 docker with all the possibl e scenario does not mean we will run them all (morgan_orange, 16:17:09)
    9. frommy perspective, 1 docker is fine. We can have different scripts to test the big uses cases, thats fine. But similar dockers with slightly different contents doesn't make much sense for me (jose_lausuch, 16:17:24)
    10. nothing prevent from creating a dedicated docker for a testcase that will be complex (morgan_orange, 16:17:41)
    11. if we see a real need we can always create a new one if we need a real isolated system (jose_lausuch, 16:18:05)

  3. integration of new testcases "on the fly" (morgan_orange, 16:18:26)
    1. question today on the way to submit test cases to functional testing (morgan_orange, 16:19:08)
    2. we will have a script for running tempest, the way we run tempest now might change a bit (jose_lausuch, 16:20:09)
    3. possibility to add new python-coded test cases? (jose_lausuch, 16:20:23)
    4. proposed tempest tests : failure testing, what if a VNF crashes, will traffic be impacted in a scenario with diff VNFs (jose_lausuch, 16:22:15)
    5. https://wiki.opnfv.org/candidates_for_test_cases (morgan_orange, 16:25:24)
    6. ACTION: amaged__ contact yardstick (Ana) to see if your proposals are already covered by yardstick framework (jose_lausuch, 16:25:32)
    7. new testcase => discover through IRC or mailing list (morgan_orange, 16:28:18)
    8. landing page for tests: https://wiki.opnfv.org/testing (morgan_orange, 16:28:47)
    9. process proposal in https://wiki.opnfv.org/_media/devtest_journey.pdf (morgan_orange, 16:29:01)

  4. AoB (morgan_orange, 16:30:06)
    1. trial to move Asian meeting time earlier (morgan_orange, 16:33:10)
    2. ACTION: morgan_orange propose new time (morgan_orange, 16:33:17)
    3. ACTION: morgan_orange apply contributor protocol removal for ghost contributors (morgan_orange, 16:34:16)
    4. functest repo to be restructured a bit (as suggested by fdegir ) (jose_lausuch, 16:34:29)
    5. wiki page refactored (based on yardstick) https://wiki.opnfv.org/opnfv_functional_testing (morgan_orange, 16:34:47)


Meeting ended at 16:36:39 UTC (full logs).

Action items

  1. Quiglong find a compatible lab for ONOS
  2. morgan_orange initiate wiki page for functest-54
  3. amaged__ contact yardstick (Ana) to see if your proposals are already covered by yardstick framework
  4. morgan_orange propose new time
  5. morgan_orange apply contributor protocol removal for ghost contributors


Action items, by person

  1. amaged__
    1. amaged__ contact yardstick (Ana) to see if your proposals are already covered by yardstick framework
  2. morgan_orange
    1. morgan_orange initiate wiki page for functest-54
    2. morgan_orange propose new time
    3. morgan_orange apply contributor protocol removal for ghost contributors


People present (lines said)

  1. morgan_orange (114)
  2. jose_lausuch (95)
  3. amaged__ (5)
  4. collabot (4)


Generated by MeetBot 0.1.4.