#opnfv-testperf: functest weekly oct 27th

Meeting started by morgan_orange at 10:01:21 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 10:01:28)
    2. Juha Kosonen (juhak, 10:01:34)
    3. Jose Lausuch (jose_lausuch, 10:01:40)
    4. Valentin Boucher (Valentin_Orange, 10:01:49)
    5. agenda: https://wiki.opnfv.org/functest_meeting (morgan_orange, 10:02:45)

  1. agenda bashing and action points (morgan_orange, 10:02:57)
    1. action point still to be completed (presentation for the summit) (morgan_orange, 10:03:43)
    2. pres started, i will send an updtae today or tomorrow (deadline 30th) (morgan_orange, 10:04:00)
    3. Viktor Tikkanen (viktor_nokia, 10:05:34)

  2. Sprint2 (morgan_orange, 10:08:18)
    1. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&useStoredSettings=true (morgan_orange, 10:08:38)
    2. 9 days remaining (basically the end of this sprint will take place during the design summit (morgan_orange, 10:08:58)
    3. https://jira.opnfv.org/browse/FUNCTEST-80 (jose_lausuch, 10:09:23)
    4. ACTION: morgan_orange rename epics to be more explicit (morgan_orange, 10:13:52)
    5. Jose added new tasks (dockerization + running functest offline) (morgan_orange, 10:14:22)
    6. docker wiki updated https://wiki.opnfv.org/functest_docker (jose_lausuch, 10:16:02)
    7. possible now to run only a set of tests [vping,odl,tempest,rally] instead of all of them (jose_lausuch, 10:16:26)
    8. on vIMS soon (working with Valentin_Orange today), we were able to deploy cloudify and met a timeout issue (morgan_orange, 10:16:57)
    9. test collection API has been updated (morgan_orange, 10:18:17)
    10. a new method called dashboard has been added (morgan_orange, 10:18:51)
    11. this method retrieved "dashboard ready" data and will be used by LF web team in charge of the test dashboard (morgan_orange, 10:19:18)
    12. for the moment we defined 2 testcases "dashboard ready" (morgan_orange, 10:20:00)
    13. http://213.77.62.197/dashboard?project=functest&case=Tempest (morgan_orange, 10:20:01)
    14. http://213.77.62.197/dashboard?project=functest&case=vPing (morgan_orange, 10:20:07)
    15. for each testcase you can use filter (installer, version, pod, time ) (morgan_orange, 10:20:33)
    16. http://213.77.62.197/dashboard?project=functest&case=vPing&installer=fuel&version=master&pod=opnfv-jump-2 (morgan_orange, 10:20:59)
    17. we store the results only once (the raw results of the tests) (morgan_orange, 10:21:25)
    18. then in releng through a method called functest2Dashboard.py we post processed the raw results to provide dashboard ready graphs (morgan_orange, 10:21:53)
    19. https://wiki.opnfv.org/collection_of_test_results (morgan_orange, 10:22:12)
    20. Guy Rodrigue worked on an automatic doc (swagger like) (morgan_orange, 10:23:39)
    21. we planned to work with Valentin_Orange to provide suwh results for vIMS testcase (morgan_orange, 10:24:04)
    22. LF foundation announced a version of the dashboard on the 9th of November (morgan_orange, 10:24:39)
    23. presentation planned during the summit (morgan_orange, 10:25:11)
    24. yardstick contributor shall also work on its yardstick2Dashboard.py file (morgan_orange, 10:25:37)
    25. ACTION: jose_lausuch add a flag to tell the script to report the results to the DB and tell other test projects (info to share during the summit) (morgan_orange, 10:29:15)

  3. Running Functest in CI in new platforms (morgan_orange, 10:29:33)
    1. https://build.opnfv.org/ci/view/functest/job/functest-fuel-master/ (morgan_orange, 10:31:00)
    2. ACTION: morgan_orange jose_lausuch look why CI is now failing on LF POD 2 (manual run of the container is OK) (morgan_orange, 10:31:20)
    3. ACTION: morgan_orange ask Quinglong to deploy full functest on huawei lab trhough jenkins (morgan_orange, 10:34:46)
    4. ACTION: morgan_orange ask trevor for Resources on intel for apex (morgan_orange, 10:35:38)
    5. ACTION: jose_lausuch ask for resources (run functest one one of the E/// pod) (morgan_orange, 10:36:42)

  4. Design Summit and OPNFV Summit (morgan_orange, 10:39:27)
    1. functest will be active. 1h tutorial from josé, presentation of the test collection API, and several presentations during the Summit (morgan_orange, 10:40:13)
    2. according to the dependencies, I think we need to meet at least 5 other projects (morgan_orange, 10:40:41)
    3. https://wiki.opnfv.org/feature_test_project_matrix (morgan_orange, 10:40:50)
    4. some high level Jira have been created, but they will surely not cover the needs (morgan_orange, 10:41:10)
    5. ACTION: morgan_orange prepare the Summit, contact PTL to discuss functest implication in Doctor, Copper, ONOS, OVNO, Policytest and promise (morgan_orange, 10:44:11)
    6. Tomi Juvonen (Doctor) will attend the summit (morgan_orange, 10:45:24)
    7. functest not dealing with orchestrator, just using some to ease the launch of tests (morgan_orange, 10:48:31)
    8. ok for an exploring discussion during the Summit, see if for > C release, functest could propose one (still to ease the functional testing not as part as OPNFV) (morgan_orange, 10:49:34)
    9. Summit, jam session organization in progress...feel free to join :) (morgan_orange, 10:51:52)

  5. Possible expectations for Nokia open lab (morgan_orange, 10:52:21)
    1. Nokia is seriously considering establishment of an open lab (viktor_nokia, 10:52:50)
    2. for Functest (and possibly some other OPNFV projects) testing purposes (viktor_nokia, 10:52:58)
    3. If you have any expectations regarding HW, network topology, access methods etc. please contact e.g. me or Juha (viktor_nokia, 10:53:10)
    4. ACTION: morgan_orange send procedure for CI connectivy to juhak (morgan_orange, 10:57:49)

  6. AoB (morgan_orange, 10:59:38)
    1. https://etherpad.opnfv.org/p/jam_session_summit (jose_lausuch, 11:00:01)
    2. ACTION: morgan_orange checks why LF access still not possibfor juhak (N weeks..) (morgan_orange, 11:01:55)


Meeting ended at 11:02:52 UTC (full logs).

Action items

  1. morgan_orange rename epics to be more explicit
  2. jose_lausuch add a flag to tell the script to report the results to the DB and tell other test projects (info to share during the summit)
  3. morgan_orange jose_lausuch look why CI is now failing on LF POD 2 (manual run of the container is OK)
  4. morgan_orange ask Quinglong to deploy full functest on huawei lab trhough jenkins
  5. morgan_orange ask trevor for Resources on intel for apex
  6. jose_lausuch ask for resources (run functest one one of the E/// pod)
  7. morgan_orange prepare the Summit, contact PTL to discuss functest implication in Doctor, Copper, ONOS, OVNO, Policytest and promise
  8. morgan_orange send procedure for CI connectivy to juhak
  9. morgan_orange checks why LF access still not possibfor juhak (N weeks..)


Action items, by person

  1. jose_lausuch
    1. jose_lausuch add a flag to tell the script to report the results to the DB and tell other test projects (info to share during the summit)
    2. morgan_orange jose_lausuch look why CI is now failing on LF POD 2 (manual run of the container is OK)
    3. jose_lausuch ask for resources (run functest one one of the E/// pod)
  2. juhak
    1. morgan_orange send procedure for CI connectivy to juhak
    2. morgan_orange checks why LF access still not possibfor juhak (N weeks..)
  3. morgan_orange
    1. morgan_orange rename epics to be more explicit
    2. morgan_orange jose_lausuch look why CI is now failing on LF POD 2 (manual run of the container is OK)
    3. morgan_orange ask Quinglong to deploy full functest on huawei lab trhough jenkins
    4. morgan_orange ask trevor for Resources on intel for apex
    5. morgan_orange prepare the Summit, contact PTL to discuss functest implication in Doctor, Copper, ONOS, OVNO, Policytest and promise
    6. morgan_orange send procedure for CI connectivy to juhak
    7. morgan_orange checks why LF access still not possibfor juhak (N weeks..)


People present (lines said)

  1. morgan_orange (139)
  2. jose_lausuch (101)
  3. viktor_nokia (19)
  4. juhak (10)
  5. pbandzi_ (6)
  6. collabot (3)
  7. Valentin_Orange (1)


Generated by MeetBot 0.1.4.