10:02:36 <morgan_orange> #startmeeting Functest weekly meeting November 17th
10:02:36 <collabot`> Meeting started Tue Nov 17 10:02:36 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
10:02:36 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
10:02:36 <collabot`> The meeting name has been set to 'functest_weekly_meeting_november_17th'
10:02:41 <morgan_orange> #info Morgan Richomme
10:08:22 <morgan_orange> quiete place...
10:08:46 <morgan_orange> let's keep track of the activity quickly then
10:08:59 <morgan_orange> #topic OPNFV Summit report
10:09:09 <morgan_orange> #info several presentations performed during the Summit
10:09:40 <morgan_orange> #info good exchanges with other test projects, synchro on the test strategy for Brahmaputra
10:09:53 <morgan_orange> #link https://wiki.opnfv.org/brahmaputra_testing_page
10:10:45 <morgan_orange> #info For B-Release Functest shall be run on 4 labs corresponding to the 4 installers (labs identified), including several possible configurations (controllers)
10:11:11 <morgan_orange> #action morgan_orange upadte functest B-Release page to precise dependencies towards feature projects
10:11:36 <morgan_orange> #info Copper => possible new Rally and test (for congress)
10:12:05 <fdegir> morgan_orange: can you type in those identified labs vs installers so they're captured in the minutes?
10:12:07 <morgan_orange> #info Doctor wait for Doctor suite - Doctor does everything, Functest could just help to generalize the tests on the different labs
10:12:18 * fdegir is having trouble remembering
10:12:37 <morgan_orange> ok I finish with my feature tests then I write that down
10:12:50 <fdegir> ok
10:13:01 <morgan_orange> #info ONOS suite to be provided by Qinglong
10:13:15 <morgan_orange> #info OVNO wait for suite from Stuart
10:13:41 <morgan_orange> #info PolicyTest => meeting with Keith on friday to integrate these tests (ODL suites) + extend ODL test suites
10:14:23 <morgan_orange> #info Promise => to be clarified with Peter (action atken in Promise)
10:15:07 <morgan_orange> #info the identified lab for B-release as mentioned in the wiki page: Fuel/LF POD 2, Joid/Intel POD 5, Apex/Intel POD2, Compass/Huawei
10:15:34 <morgan_orange> Huawei lab to be precised
10:15:42 <morgan_orange> Qinglong: are you here?
10:16:29 <morgan_orange> #topic Preparation Friday Meeting on ODL test case extension
10:16:50 <morgan_orange> #info goal see how to import new upstream test suites from ODL (integration + Policy Test)
10:17:10 <morgan_orange> #action pbandzi update the dedicated wiki page https://wiki.opnfv.org/odl_new_test_suites
10:17:29 <morgan_orange> #action pbandzi need to update current suite to be able to integrate the new tests
10:17:40 <morgan_orange> #topic ONOS status
10:17:50 <morgan_orange> any one from ONOS testing on the chan...?
10:18:42 <morgan_orange> #action Qinglong provide update to the project (lots of pending Jira of Sprint #2)
10:18:55 <morgan_orange> #topic tempest smoke suite: target 0 error?
10:18:56 <boris-42> morgan_orange: ?
10:19:01 <morgan_orange> hi boris-42
10:19:07 <boris-42> morgan_orange: hi there=)
10:19:12 <juhak> #info Juha Kosonen
10:19:19 <boris-42> morgan_orange: what is Cooper?)
10:20:20 <morgan_orange> Cooper is an OPNFV feature project. Mainly the use of Congress
10:21:16 <morgan_orange> link https://wiki.opnfv.org/copper
10:21:26 <morgan_orange> managed by Brian (AT&T)
10:21:49 <morgan_orange> juhak: viktor_nokia last run showed 9 errors in Tempest
10:22:01 <morgan_orange> Any view on the remaining errors?
10:22:27 <viktor_nokia> Hmmm... Need to check.
10:22:45 <viktor_nokia> and still waiting for access rights...
10:24:13 <morgan_orange> regarding the last aspect, I think it will be difficult. LF wants to restrict the access to LF PODs
10:24:28 <morgan_orange> it shall be possible to do it from a dev lab
10:24:45 <morgan_orange> I will try to setup it on Orange community labs, I will be able to grant you an access
10:24:57 <viktor_nokia> OK
10:25:02 <morgan_orange> LF POD2 is now tagged as a production LAB, dedicated to CI with restricted access
10:25:20 <morgan_orange> on the Nokia POD , how many errors do you get when running Functest?
10:26:01 <viktor_nokia> in our lab I get  ~40 errors mainly because of ODL
10:26:36 <viktor_nokia> from smoke set
10:26:44 <morgan_orange> 40 looks big, at the moment on LF POD2 we got only 9 errors https://build.opnfv.org/ci/view/functest/job/functest-fuel-master/87/consoleText
10:26:57 <morgan_orange> you are testing on a Arno SR0?
10:27:02 <viktor_nokia> SR1
10:27:14 <morgan_orange> strange
10:28:10 <viktor_nokia> I hope I can continue testing this week (was out of office last week)
10:28:58 <morgan_orange> ok
10:29:06 <morgan_orange> As far as I can read on the last run
10:29:29 <morgan_orange> we still have 2 or 3 errors linked to quotas and some network erros (floatting,..)
10:29:41 <morgan_orange> so let's see if I can setup the tests on Orange POD and grant you access
10:30:01 <morgan_orange> let's keep LF pOD2 as a refe and see if we can reproduce and have consistent results towards the different labs
10:30:15 <morgan_orange> #info 9 errors on the last tempest Run on LF POD2
10:30:28 <viktor_nokia> OK, it is very helpful when one can check configuration etc. :)
10:30:29 <morgan_orange> #info more errors on Nokia internal POD (40 errors on smoke tests)
10:30:39 <viktor_nokia> The main problem in our setup is that after some point no more networks can be created anymore and so almost all the remaining test cases fail
10:30:43 <morgan_orange> #action morgan_orange setup Functest on Orange Pod
10:31:09 <morgan_orange> #action morgan_orange grant access to Orange Pod to viktor_nokia and juhak
10:31:46 <morgan_orange> #action viktor_nokia check LF POD2 tempest error to discuss next week
10:32:07 <morgan_orange> #topic B-Release Sprint #2 status / start of Sprint #3
10:32:22 <morgan_orange> #info Jira Sprint #2 finished last week
10:32:32 <morgan_orange> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&selectedIssue=FUNCTEST-74
10:32:37 <morgan_orange> #undo
10:32:37 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Link object at 0x30aa2d0>
10:33:21 <morgan_orange> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59
10:34:28 <morgan_orange> #info proposition to ruin Sprint #3, old Jiras moved from Sprint #2 to Sprint #3 + new ones linked to feature tests
10:35:01 <morgan_orange> are you ok? shall we reduce the scope for Sprint #3 and postpone work on feature test on Sprint #4
10:35:26 <morgan_orange> we now have a better view but not sure anything will be available before freeze (1st of december)
10:36:07 <morgan_orange> I would be in favor of moving all feature projects related task to Sprint #4 and keep work on internal use case (rally, tempest, ODL, Onos, vIMS) + dashboard and API for Sprint 3
10:36:11 <morgan_orange> what do you think?
10:36:39 <viktor_nokia> sounds ok...
10:37:17 <morgan_orange> #info refactoring of Sprint, Sprint 3 = jira remaining sprint 2, all tasks related to feature tests postponed to Sprint 4
10:37:21 <morgan_orange> #action morgan_orange update Jira
10:37:35 <morgan_orange> #topic AoB
10:37:44 <morgan_orange> any question, stuff to share
10:38:39 <morgan_orange> #info slides used during the Summit
10:38:41 <morgan_orange> #link http://events.linuxfoundation.org/sites/events/files/slides/Functest%20in%20Depth_0.pdf
10:38:58 <morgan_orange> good effort to explain what we are trying to do... :)
10:39:08 <morgan_orange> another link on the test dashboard
10:39:19 <morgan_orange> #link http://events.linuxfoundation.org/sites/events/files/slides/Dashboard%20Summit.pdf
10:39:22 <morgan_orange> other slides
10:39:28 <morgan_orange> #link http://events.linuxfoundation.org/events/opnfv-summit/program/slides
10:40:00 <morgan_orange> #info people from cloudify met during the summit (as cloudify is used for vIMS test case)
10:40:10 <morgan_orange> #info testcase is now properly running
10:40:17 <viktor_nokia> Nokia lab is proceeding...
10:40:18 <morgan_orange> #link http://213.77.62.197/results?case=vIMS
10:40:29 <morgan_orange> #info Nokia lab is proceeding
10:40:37 <morgan_orange> i discussed with the Nokia board member
10:41:08 <morgan_orange> any question? additional info?
10:41:33 <morgan_orange> maybe one think to share but as the quorum is ligth this morning, i could send a mail
10:42:05 <morgan_orange> for the testing dashboard (landing page) we need to provide a synthetic view on our tests
10:42:15 <morgan_orange> I imagined just providingt the following information
10:42:22 <morgan_orange> nb of test cases
10:42:44 <morgan_orange> Openstack Test
10:42:48 <morgan_orange> Controller tests
10:43:17 <morgan_orange> with a gauge based on a savant calculation of the results we got from tempest and Rally for Openstack and the results of the different controller suites
10:43:42 <morgan_orange> the idea is to have a full automated chained jenkins => deploy => test => push results => build dahboard
10:44:08 <morgan_orange> before B release we will not have to upgrade a wiki page explaining the status, it will be self explicit
10:44:35 <morgan_orange> any idea welcome...
10:45:08 <morgan_orange> #info discussion on how we could represent Functest result in a synthetic way for the landing page of the testing dashboard
10:45:52 <morgan_orange> #action everybody prepare discussions next week on this topic
10:46:27 <morgan_orange> ok for today?
10:46:33 <viktor_nokia> ok
10:47:03 <morgan_orange> ok thanks to Nokia to attend :), jose is in the middle of the Atlantic at the moment...
10:47:16 <morgan_orange> #endmeeting