16:00:11 <morgan_orange> #startmeeting Functes/ODL test scope extension November 20th
16:00:11 <collabot`> Meeting started Fri Nov 20 16:00:11 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:00:11 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:00:11 <collabot`> The meeting name has been set to 'functes_odl_test_scope_extension_november_20th'
16:00:12 <jose_lausuch> https://jira.opnfv.org/browse/ONOSFW-141
16:00:18 <morgan_orange> #info Morgan Richomme
16:00:34 <jose_lausuch> it has to be Qinglong to remove it from that functest srpint
16:00:40 <jose_lausuch> #info Jose Lausuch
16:00:57 <morgan_orange> jose_lausuch:  I told him on the chan but did not get answers
16:01:27 <jose_lausuch> yes
16:01:30 <jose_lausuch> I will send email
16:01:46 <jose_lausuch> is that mei mei?
16:01:56 <morgan_orange> no Qinglong
16:01:58 <jose_lausuch> Qinglong
16:01:59 <jose_lausuch> yes
16:02:00 <jose_lausuch> ok
16:02:49 <mbeierl> You can also comment right on the issue itself and request them to remove it.  You can see that the Sprint field is filled in with Functest Sprint 3.  But an email is probably faster
16:03:27 <morgan_orange> jose_lausuch: if we are only 2, the meeting will be short.. :)
16:03:39 <jose_lausuch> yes, email sent :)
16:03:43 <jose_lausuch> thanks mbeierl
16:04:32 <mbeierl> jose_lausuch: anytime :)  Just happened to be lurking in the channel and noticed the convo ...
16:04:48 <jose_lausuch> well, maybe it's because we didnt send invitation and people forgot :)
16:05:00 <morgan_orange> yes
16:05:38 <morgan_orange> i copied Peter's mail in the etherpad
16:05:43 <morgan_orange> https://etherpad.opnfv.org/p/functiontest
16:06:01 <morgan_orange> #info the goal is to discuss on the extensions of ODL test scope in Functest
16:06:05 <jose_lausuch> Mark is our JIRA expert from now on
16:06:21 <jose_lausuch> ok
16:06:23 <morgan_orange> #info for the moment we have basic tests (create/update/delete port/network/subnet)
16:06:38 <morgan_orange> #info ODL team has created lots of integration tests
16:06:52 <morgan_orange> #info the idea is to include the most significant one into Functest
16:07:06 <morgan_orange> #link https://wiki.opnfv.org/odl_new_test_suites
16:07:21 <morgan_orange> #info pbandzi started looking at the topic
16:07:22 <jose_lausuch> ah, you created a new wiki :)
16:07:35 <morgan_orange> #link https://etherpad.opnfv.org/p/functiontest
16:07:44 <morgan_orange> euh no, I just copied Ana's page some weeks ago
16:07:55 <morgan_orange> let's review Peter's mail
16:08:16 <jose_lausuch> ok
16:08:25 <amaged__> morgan_orange: sorry if this sounds obvious, is there a criteria on what should be included in functest vs upstream, when it comes to odl tests ?
16:08:45 <morgan_orange> not really, we did not discuss it
16:09:01 <morgan_orange> my view is that we should focus on tets that make sense from an E2E point of view
16:09:12 <morgan_orange> our goal is not to tests all the internal compoent s of ODL
16:09:22 <morgan_orange> but ODL as part of the whole solution
16:09:28 <jose_lausuch> thats right
16:09:44 <amaged__> morgan_orange: that the core of my challenge, as u know, so thanks
16:09:47 <jose_lausuch> but if we got any contributor from ODL in functest, they could even try whatever they want
16:09:51 <morgan_orange> #info amaged__
16:10:15 <morgan_orange> #info no real criteria (so far) to move a test from ODL to Functest in OPNFV
16:10:15 <jose_lausuch> so that they also take advantage of testing their stuff in an opnfv-openstack deployment
16:10:41 <morgan_orange> #info but no need to import internal tests, we shall considered ODL as part of the wholution and priviledge End to End tests
16:11:11 <morgan_orange> we may need anyway to prepare an env including mininet
16:11:15 <morgan_orange> robot is already there
16:11:28 <morgan_orange> #info mininet may be required (not installed currently when running ODL tests)
16:11:37 <morgan_orange> #info Robot already used to run the basic tests
16:12:01 <jose_lausuch> ok
16:12:16 <morgan_orange> how do you understand his sentence
16:12:20 <jose_lausuch> question was also: on jumphost or on computes ?
16:12:26 <morgan_orange> In OPNFV it is task of deployer to install and configure ODL, together with Openstack. And we already have docker container configured for runnning robot-tests. So that means we cannot just take jjb from opendaylight and use them in OPNFV.
16:12:58 <jose_lausuch> the last sentence is obvious to me
16:13:11 <jose_lausuch> I understand we have have to automate ourselves the relevant test for us
16:13:27 <jose_lausuch> automate=integrate
16:13:30 <amaged__> Since we can do a lot with ODL, do we want to put priority to a group of functions ? or just leave it open to the submitters to add what they want
16:13:30 <morgan_orange> ok
16:14:48 <morgan_orange> good question, i amagined that regarding the timing, it will be more our decision...but you are right it would be interesting to let it open, with a mechanism for submitters who would like to integrate their results into OPNFV
16:14:55 <morgan_orange> for B release i think it is too late
16:15:10 <morgan_orange> I see more a selection of additional testcases made by us (peter, you,..)
16:15:36 <morgan_orange> but for the future it could be interesting to find a way to simplify the import
16:15:51 <jose_lausuch> yes, I agree
16:15:58 <morgan_orange> #info question amaged__:  do we want to put priority to a group of functions ? or just leave it open to the submitters to add what they want
16:15:59 <jose_lausuch> its getting late to do a lot of things now
16:16:38 <morgan_orange> #info too short to define procedure to easily import tests from ODL in an open way, but we should keep it mind for next steps
16:17:14 <morgan_orange> jose_lausuch: you question jumphost versus compute was related to mininet, right?
16:17:22 <jose_lausuch> yes morgan_orange
16:17:30 <amaged__> one more question, i hope its not disturbing the conversation, now that we covered tests related to upstream, Do we want to avoid tests that could be relevant to other projects (inside OPNFV) or they are welcomed too, for example : service function chaining project (SFC) tests would be welcomed or left to SFC project ?
16:17:37 <jose_lausuch> but I wouldnt involve jumphost at all
16:17:51 <jose_lausuch> everything we need either in docker file or computes
16:17:58 <jose_lausuch> I dont know what makes more sense
16:18:12 <jose_lausuch> but not in the jumphost
16:18:16 <jose_lausuch> to avoid again dependencies
16:18:33 <morgan_orange> #info question mininet on jumphost or compute
16:18:44 <jose_lausuch> amaged__: SFC is already covered by Yardstick and SFC team
16:18:48 <morgan_orange> #info everything we need either in docker file or compute
16:18:54 <morgan_orange> #info not in jumphost
16:18:58 <morgan_orange> agree
16:19:13 <morgan_orange> #info let's vote next tuesday :)
16:19:15 <jose_lausuch> but other test could be welcomed
16:19:28 <morgan_orange> #question test coverage Do we want to avoid tests that could be relevant to other projects (inside OPNFV) or they are welcomed too, for example : service function chaining project (SFC) tests would be welcomed or left to SFC project ?
16:19:48 <morgan_orange> #info we created companion project
16:19:52 <morgan_orange> #info SFC / yardstick
16:20:00 <morgan_orange> #info GBP / Functest
16:20:22 <morgan_orange> #info it is true that we should develop something to track it otherwise risk to be lost or to overlap
16:20:41 <morgan_orange> for the moment the test "companion" projects are limited (Functest or yardstick
16:20:59 <morgan_orange> not always easy to get rationale why it is in functest why in yardstick
16:21:09 <morgan_orange> as we have a synchro meeting we do not have overlap
16:21:15 <morgan_orange> but to caricature
16:21:24 <morgan_orange> if you perform a ping and check it works +> functest
16:21:31 <jose_lausuch> agree
16:21:38 <jose_lausuch> its not well defined, but thats another topic
16:21:40 <morgan_orange> if you perform a ping, measure time, generate traffic, ..=> you are in yardstick
16:21:58 <morgan_orange> we could probably find a better way to formalize in C release
16:22:06 <morgan_orange> for the moment we will not cover everything anyway
16:22:06 <jose_lausuch> yep
16:22:45 <morgan_orange> so for B release we planned to integrate GBP if possible + additional functional tests to be filtered from https://jenkins.opendaylight.org/releng/view/CSIT-Jobs/
16:23:02 <morgan_orange> amaged__: could you help us to define a list of relevant testcase
16:23:32 <morgan_orange> regarding the risk of overlap it is limited, yardstick is dealing with SFC and BGP VPN
16:23:53 <morgan_orange> not sure there other ODL related tests
16:24:05 <amaged__> morgan_orange: yes, i would like to do that
16:24:17 <morgan_orange> we could also onboard some BGP VPN tests in functest if necessary but we could discuss with Ana
16:24:33 <jose_lausuch> ok
16:24:36 <jose_lausuch> thanks
16:24:39 <jose_lausuch> guys, I need to leave
16:24:42 <morgan_orange> #action amaged__ help peter to find significant test cases for B release to be added into Functest
16:24:50 <morgan_orange> ok jose_lausuch have a good week end
16:24:57 <jose_lausuch> have a nice weekend too
16:25:01 <jose_lausuch> :)
16:25:02 <jose_lausuch> bye
16:25:14 <amaged__> bye
16:25:26 <mbeierl> ciao!
16:25:30 <morgan_orange> so amaged__ mean work will consists in studying how to integrate mininet in our test env (could be also useful for yardstick..)
16:25:38 <morgan_orange> and select testcases
16:25:46 <amaged__> morgan_orange: I will, any where in specific to track/add these relevant test cases ?
16:25:56 <morgan_orange> that are the question 2 , 3 and 4 of Peter
16:26:24 <morgan_orange> #info https://wiki.opnfv.org/odl_new_test_suites wiki page used to track /add testcases
16:26:29 <morgan_orange> #info or directly in Jira backlog
16:26:59 <amaged__> ok, got it, thx
16:27:10 <morgan_orange> #we do not have constraints regarding APi freeze, mainly integration work. However some dev may be neede to setup the env properly (introduction on mininet)
16:27:35 <morgan_orange> you have to synchonize with Peter...but you know him well :)
16:28:09 <amaged__> i'll do that and let you know of the outcome of our discussion
16:28:12 <morgan_orange> we discussed a little bit question 3, we will vote on Tuesday - where we should put mininet
16:28:39 <morgan_orange> as he mentioned on 4, some refactoring will be needed on his existing script
16:28:47 <morgan_orange> OK so if it is clear
16:28:56 <morgan_orange> je pense qu'on peut passer en français
16:28:57 <morgan_orange> et conclure
16:29:34 <amaged__> n'est pas a problem
16:29:46 <morgan_orange> j'ai bien compris
16:29:58 <morgan_orange> du coup réunion de sycnrho mardi prochain 8h UTC
16:30:26 <morgan_orange> #info next meeting Functest weekly, we will keep some time for ODL discussions
16:30:29 <morgan_orange> #endmeeting