16:46:56 <morgan_orange> #startmeeting synchro Functest/OVNO November 24th
16:46:56 <collabot> Meeting started Tue Nov 24 16:46:56 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
16:46:56 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
16:46:56 <collabot> The meeting name has been set to 'synchro_functest_ovno_november_24th'
16:47:02 <morgan_orange> #Morgan Richomme
16:47:12 <jose_lausuch> can you give an overview of how you run tests in open contrail project?
16:47:15 <jose_lausuch> what tools you use and so on
16:47:19 <jose_lausuch> #info Jose Lausuch
16:47:32 <morgan_orange> I created an adh hoc meeting for to get some minutes
16:47:39 <jose_lausuch> yes, thanks morgan
16:47:53 <morgan_orange> status Fuel integrated OpenContrail as far as I know
16:48:00 <morgan_orange> Juju was alreday supporting it
16:48:13 <morgan_orange> I can imagine Apex is also working on it
16:48:15 <jose_lausuch> yes, however it needs more work for Fuel
16:48:23 <jose_lausuch> it is non HA deployment I think
16:48:25 <morgan_orange> so we will have lab running OpenContrail
16:48:30 <morgan_orange> which is a good news
16:48:33 <jose_lausuch> but just for simplifying things
16:49:00 <morgan_orange> May Functest help OVNO to run the tescases after the fresh install
16:49:21 <StuartMackie> I was thinking that you would be looking for a set of scripts similar to what is used for ODL
16:49:27 <morgan_orange> StuartMackie: can you give us a status on your side (your labs and the test suites)
16:49:50 <StuartMackie> Create network, create policy, apply policy, create VMs, test connectivity
16:49:50 <jose_lausuch> StuartMackie: right
16:49:56 <morgan_orange> yes we would like at least the minimum list done for ODL on Arno (create/delete/update port/network/subnet)
16:49:58 <jose_lausuch> something like that
16:50:16 <morgan_orange> that is the baseline (we do not perform performance tests)
16:50:20 <StuartMackie> Then in addition, we will do some stuff like apply floating IP, create service chains
16:50:33 <morgan_orange> for brahmaputra, we are working on exrtending the scope based on upstream tests from ODL
16:50:49 <jose_lausuch> if we could manage together to have even something extended it would be nice
16:50:56 <jose_lausuch> but focusing on having 100% working the basic ones
16:51:08 <morgan_orange> #info OpenContrail shall be available in most of the installers , if not all
16:51:14 <jose_lausuch> I guess you have also many features to test
16:51:17 <morgan_orange> #info Functest focusing on basic tests (like ODL for Arno)
16:51:30 <morgan_orange> #info create/delete/update port/network/subnet
16:51:34 <jose_lausuch> what tools do you use StuartMackie?
16:51:50 <morgan_orange> #info additional tests may be added (SFC, floating,..)
16:53:03 <StuartMackie> There are python commands for all OpenContrail features, and some helper tools that take care of Keystone transparently
16:53:42 <StuartMackie> My thinking is to bundle some of these into scripts/tests with the same names as the ODL ones where possible
16:54:01 <jose_lausuch> my idea is:
16:54:07 <StuartMackie> What artifacts do you need me to deliver
16:54:24 <jose_lausuch> have 1 script (bash) for automation calling all the underlying python scripts you have for testing
16:54:29 <jose_lausuch> that script would be called from CI
16:54:37 <jose_lausuch> those python scripts I would say
16:54:44 <jose_lausuch> #info There are python commands for all OpenContrail features, and some helper tools that take care of Keystone transparently
16:55:07 <jose_lausuch> are they in a repository somewhere?
16:55:10 <jose_lausuch> so that we can have a look?
16:56:01 <StuartMackie> hang on - searching...
16:57:00 <StuartMackie> Take a look at https://github.com/tonyliu0592/orch/blob/master/doc/configuration.md
16:57:35 <StuartMackie> Not all Contrail features are included, but almost everything that we will need for OPNFV is there
16:58:25 <morgan_orange> #link https://github.com/tonyliu0592/orch/blob/master/doc/configuration.md
16:58:33 <jose_lausuch> I Was about to info it :)
16:58:34 <jose_lausuch> ok
16:58:41 <jose_lausuch> so the idea would be to clone that repository
16:58:44 <jose_lausuch> and use those scripts
16:58:48 <jose_lausuch> similar as we do for ODL
16:59:07 <StuartMackie> yes
16:59:10 <morgan_orange> yes
16:59:29 <morgan_orange> so what we need to start testing is a beta OPNFV including OpenContrail...
16:59:44 <morgan_orange> as far as I know there are no lab ready yet
16:59:49 <jose_lausuch> I see  things like delete-network and others which is what we wanted :)
16:59:56 <jose_lausuch> not yet
16:59:58 <jose_lausuch> I hope soon
17:00:02 <jose_lausuch> but we can start scripting
17:00:07 <morgan_orange> yes
17:00:30 <StuartMackie> There is a new lab being set up in Juniper office in NJ that should come online in next couple of weeks
17:00:31 <morgan_orange> StuartMackie: do you know if there is any dev lab using Opencontrail at the moment?
17:00:40 <morgan_orange> ok that is good
17:00:48 <jose_lausuch> I have a lab from Jonas
17:00:49 <jose_lausuch> a dev lab
17:00:53 <jose_lausuch> but not connected to CI
17:00:59 <StuartMackie> We were supposed to be in one of the Intel pods, but I don't know if that happened
17:01:01 <jose_lausuch> but good to start running some test
17:01:04 <morgan_orange> dev lab is enough to start testing script manually
17:01:07 <jose_lausuch> yes
17:01:46 <jose_lausuch> StuartMackie: its just running those scripts?
17:01:48 <jose_lausuch> nothing else?
17:01:54 <jose_lausuch> like creating an environment or something?
17:02:06 <jose_lausuch> or is there any requirement about where to run the scripts?
17:02:21 <jose_lausuch> we intend to do it from a docker container on a jumphost
17:02:38 <StuartMackie> There's another layer on top of the scripts that needs to know the IP address of OpenStack for instance, and set up OpenStack users and projects
17:03:13 <jose_lausuch> we source the credentials in the docker
17:03:33 <jose_lausuch> how many projects/users does it need?
17:03:53 <StuartMackie> Also, I need to work out how to test inter-VM communications from a jump server, since the Contrail virtual networks need a gateway to connect outside
17:04:15 <jose_lausuch> we have a similar ping
17:04:18 <jose_lausuch> sorry
17:04:20 <jose_lausuch> a similar test case
17:04:21 <jose_lausuch> vPing
17:04:29 <jose_lausuch> where we check the communication between 2 VMs
17:04:38 <jose_lausuch> but we do it in a different way
17:04:56 <StuartMackie> Actually, you can do everything as admin, but perhaps its cleaner to create a test user
17:04:57 <jose_lausuch> just grabbing the console log and see the output of a VM pinging the other
17:05:08 <jose_lausuch> we run some things as admin
17:05:10 <jose_lausuch> :)
17:05:25 <StuartMackie> If you already know  how to scrape the console, then we can do that
17:05:42 <jose_lausuch> how do you check the connectivity between 2 vms?
17:07:03 <StuartMackie> Also using ping, but was thinking of a more programmatic approach initiated by the test system. How does vPing know which IP address to ping?
17:07:17 <jose_lausuch> we create 2 ports with specific ips
17:08:44 <StuartMackie> We could take same approach
17:08:53 <jose_lausuch> ok
17:09:03 <jose_lausuch> would that mean that you have to modify that repository?
17:09:15 <StuartMackie> which repository?
17:09:18 <jose_lausuch> yours
17:09:38 <StuartMackie> This would be in the test script?
17:09:42 <jose_lausuch> I mean, the scripts doing all the things
17:09:46 <jose_lausuch> creating VMs and so on
17:09:50 <jose_lausuch> (just wondering)
17:09:50 <StuartMackie> Sure
17:10:31 <jose_lausuch> ok
17:11:04 <jose_lausuch> default_client_args = [    ('--username', 'admin'),    ('--password', 'contrail123'),    ('--region', 'RegionOne'),    ('--tenant', 'admin'),    ('--api-server', '127.0.0.1')]
17:11:15 <jose_lausuch> api server is the open contrail controller ip?
17:12:04 <StuartMackie> that's right - these defaults are for running on same server as OpenContrail
17:12:10 <jose_lausuch> ok
17:12:49 <jose_lausuch> #info Open Contrail conding automation to be started asap using existing repository with test cases
17:12:57 <jose_lausuch> I think its a good startpoint
17:13:03 <jose_lausuch> don't you think morgan_orange?
17:13:08 <jose_lausuch> we just need a lab soon :)
17:13:14 <morgan_orange> yes
17:13:29 <morgan_orange> good to see that approache is no 180 degrees
17:13:33 <StuartMackie> I'll let you know when the NJ lab is up
17:13:34 <morgan_orange> hope it will be the same for Onos
17:13:43 <jose_lausuch> yes
17:13:50 <jose_lausuch> good
17:13:58 <jose_lausuch> we need to be in touch
17:14:04 <jose_lausuch> what is your timezone StuartMackie?
17:14:17 <morgan_orange> and the test script will be available on OVNO repo or on the github used for the command tool
17:14:45 <StuartMackie> Am in EST. Test scripts will go in OVNO repo
17:14:53 <morgan_orange> ok clear
17:15:20 <morgan_orange> so we come to you as soon as we have a lab ready but this task seems realistic :)
17:15:33 <morgan_orange> I will create a Jira on my side to describe this integration task
17:15:48 <morgan_orange> I may assign to you to keep the information and follow up in the backlog
17:16:05 <morgan_orange> but we will perform the integration
17:16:06 <StuartMackie> Ok
17:16:09 <StuartMackie> We can do a web session to go through how OpenContrail works if you like, so you can get used to it.
17:16:14 <morgan_orange> #info tests will be in OVNO repo
17:16:31 <morgan_orange> #info work to be started when lab with OPNFV/contrail ready
17:16:34 <jose_lausuch> ok
17:16:38 <morgan_orange> would be great
17:16:52 <jose_lausuch> but automation scripts will be in functest repo
17:16:58 <StuartMackie> Let's do a session next week - what timezones are you
17:16:59 <jose_lausuch> I mean, the script calling your scripts :)
17:17:01 <morgan_orange> my colleagues are familiar with Contrail, I will be less ridiculous when discussing with them
17:17:09 <morgan_orange> we are both CET
17:17:53 <morgan_orange> we may open the session to the community as I am pretty sure other people will be interested
17:18:27 <jose_lausuch> so its 6 hours differene
17:18:30 <jose_lausuch> difference
17:19:05 <morgan_orange> 9 or 10 New York time is fine for us
17:19:26 <jose_lausuch> yes
17:19:38 <jose_lausuch> I will need to catch up with contrail since then
17:19:42 <jose_lausuch> I have no clue! :)
17:20:59 <morgan_orange> ok so let's propose a slot OpenContrail for the dummies, we will be there :)
17:21:18 <morgan_orange> maybe we can end the meeting
17:21:43 <StuartMackie> Looking for a slot - so many OPNFV meetings
17:21:48 <morgan_orange> and keep in touch as soon as we can start scripting (we will put you in review of our script (that will run your script))
17:22:28 <StuartMackie> Ok - cheers
17:22:58 <morgan_orange> #action StuartMackie propose a slot to dive into the beauty of OpenContrail
17:23:02 <morgan_orange> #endmeeting