08:00:19 <morgan_orange> #startmeeting Functest weekly meeting December 1st
08:00:19 <collabot> Meeting started Tue Dec  1 08:00:19 2015 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
08:00:19 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
08:00:19 <collabot> The meeting name has been set to 'functest_weekly_meeting_december_1st'
08:00:25 <juhak> #info Juha Kosonen
08:00:26 <morgan_orange> #info Morgan Richomme
08:00:48 <ArturoM> #info Arturo Martin
08:01:56 <morgan_orange> #info agenda: https://wiki.opnfv.org/functest_meeting
08:02:14 <morgan_orange> #topic follow up of action points
08:02:21 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2015/opnfv-testperf.2015-11-24-08.00.html
08:03:16 <morgan_orange> #info morgan_orange: declaration of Onos not done yet, wonder if I shall create a dedicated project or just a case onos within functest
08:03:33 <morgan_orange> Qinglong: what would you prefer?
08:03:46 <morgan_orange> for the moment for example ODL is 1 test case within functest
08:04:06 <morgan_orange> but OVNO (Opencontrail) will be a separate project with more than 10 testcases
08:04:25 <pbandzi> #info Peter Bandzi
08:04:38 <morgan_orange> the deadline for testcase declaration is ... today (will come back on this in next topic)
08:04:42 <amaged__> #info Ahmed Maged
08:05:20 <morgan_orange> #info next AP: viktor on Tempest => update done
08:05:40 <morgan_orange> #info next AP: juhak also done => we will have a dedicated topic
08:05:58 <morgan_orange> #info next AP: morgan_orange implement status for dashboard not done...hopefully this week
08:06:26 <morgan_orange> #topic B Release Functest status
08:06:34 <morgan_orange> #link https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59&view=detail&selectedIssue=FUNCTEST-63
08:06:46 <jose_lausuch> hi, sorry the late (windows takes ages to boot) :)
08:06:51 <jose_lausuch> #info Jose Lausuch
08:07:01 <viktor_nokia> #info Viktor Tikkanen
08:07:01 <morgan_orange> #info status provided to Debra
08:07:11 <David_Orange> #info David Blaisonneau
08:07:18 <morgan_orange> #info I would say we are on track...or almost
08:07:49 <morgan_orange> #info almost all testcases of companion projects declared (OVNO, SDNVPN, Promise)
08:07:51 <jose_lausuch> yes
08:07:56 <morgan_orange> #info OVNo (Open Contrail)
08:08:18 <morgan_orange> #info last project we need to get info: Doctor and Copper
08:08:29 <jose_lausuch> do we know anything about them?
08:08:32 <jose_lausuch> deadline is today
08:09:04 <morgan_orange> during the Summit, there was really open questions regarding Copper, for Doctor they have probably everything already, need to formalize
08:09:16 <morgan_orange> #action morgan_orange contact Bryan (Copper) and Ryota (Doctor)
08:09:22 <morgan_orange> #undi
08:09:24 <jose_lausuch> but we need to declare them in the db:)
08:09:25 <morgan_orange> #undo
08:09:25 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x313c250>
08:09:40 <morgan_orange> #action morgan_orange contact Bryan (Copper) and Ryota (Doctor) for status testcases
08:10:05 <morgan_orange> #info pbandzi like for ONOS, do we stay on 1 global controller testcase for ODL?
08:10:34 <morgan_orange> do we iuntegrate upstream ODl test on GBP in the testcases, or would it make sense to declare more testcases
08:10:46 <morgan_orange> for Opencontrail we will have a dedicated project + N testcases
08:10:56 <morgan_orange> for the moment all the ODL stuff is under 1 testcase in Functest
08:11:03 <jose_lausuch> thats a good point
08:11:04 <morgan_orange> not the same level of granularity...
08:11:16 <pbandzi> morgan_orange: sory I had some troubles with my computer (did not work for week) so I missed some meetings mainly the one about ODL test cases :)
08:11:16 <jose_lausuch> well, f bgp vpn there will be additional scenarios run by robot
08:12:14 <morgan_orange> a compromise could be to declare in functest odl-network, odl-gbp, odl-x if we want more details without declaring a dedicted odl project
08:12:45 <jose_lausuch> thats the point, there is no odl project as such, like OVNO or ONOS
08:12:57 <morgan_orange> yep
08:12:58 <jose_lausuch> there are small components touching different aspects of ODL
08:13:11 <jose_lausuch> but +1 to have odl-gbp, odl-network, odl-x
08:13:32 <jose_lausuch> odl-vpn is already covered by the project sdnvpn
08:13:39 <morgan_orange> any objection to the odl-X within functest to declare odl test extension
08:14:10 <morgan_orange> ok let's info that
08:14:14 <jose_lausuch> ok
08:14:24 <jose_lausuch> but the thing is we dont know yet what odl-x means :D
08:14:42 <morgan_orange> #info no specific odl project, so odl testcases are declared in functest
08:15:11 <morgan_orange> #info for the moment odl testcase declared, we may add some testcases e.g. odl-gbp if we need more details
08:15:40 <morgan_orange> #info back to JIRA and open tasks, there lots of // work
08:16:06 <morgan_orange> #info 1) deploy functest on the target lab (see mail from Fatih https://wiki.opnfv.org/octopus/brahmaputra_ci_process)
08:16:23 <morgan_orange> #info 2)extend ODL (we will come back to this point)
08:16:35 <morgan_orange> #info 3) integrate feature projects
08:16:45 <morgan_orange> #info 4) tune existing internal testcases
08:17:05 <jose_lausuch> morgan_orange: is that the order of priority?
08:17:08 <jose_lausuch> that numbering?
08:17:11 <morgan_orange> no
08:17:30 <morgan_orange> #info numbering is not the order of priority...
08:17:52 <morgan_orange> #info concerning 1, for the moment we have 1 target Lab (Fuel on LF POD2)
08:18:06 <morgan_orange> #link https://build.opnfv.org/ci/view/functest/job/functest-fuel-master/
08:18:17 <morgan_orange> #info Fuel but without ODL or any controller (pure Neutron)
08:18:33 <morgan_orange> #info restricted access (as any CI production lab)
08:18:42 <morgan_orange> #info other labs mentioned but not available yet
08:18:48 <morgan_orange> jose_lausuch: any news for Apex?
08:19:00 <jose_lausuch> regarding functest no
08:19:09 <jose_lausuch> their deployment is failing already since a couple of days
08:19:13 <jose_lausuch> so no chance to try functest
08:19:18 <jose_lausuch> and its virtual as well
08:19:22 <jose_lausuch> the jjob is created though
08:19:58 <morgan_orange> #info Apex not available for Functest yet (deployement failling for couple of days)
08:20:11 <morgan_orange> anyone from Huawei around?
08:20:17 <morgan_orange> for compas target platform?
08:20:41 <jose_lausuch> #link https://build.opnfv.org/ci/view/apex/job/apex-daily-master/63/ (latest deploy today)
08:21:09 <jose_lausuch> #info previous one failed, so no chance for functest to be triggered, but the jjob is created to run after deployment
08:21:17 <jose_lausuch> #undo
08:21:21 <jose_lausuch> undo
08:21:26 <jose_lausuch> how do you undo?
08:21:39 <morgan_orange> #chair jose_lausuch
08:21:39 <collabot> Current chairs: jose_lausuch morgan_orange
08:21:43 <jose_lausuch> #undo
08:21:43 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x313c550>
08:21:50 <morgan_orange> #action morgan_orange contact Meimei and Huawei contributors to get info on Compass target solution
08:21:57 <jose_lausuch> #info previous ones failed, so no chance for functest to be triggered, but the jjob is created to run after deployment
08:22:03 <jose_lausuch> Im messing up :D
08:22:19 <morgan_orange> it would be great to have a clear view of the target lab asap (I suggested the D milestone...but it would not be possible)
08:22:45 <morgan_orange> #info for joid, we have to discuss with joid team, but we should have a dev lab ready (with a beta version)
08:23:09 <morgan_orange> #info opnfv-fr-orange-pod2 is available for first tests
08:23:26 <morgan_orange> #info I was able to run vPing, ODL (partially), tempest and Rally
08:23:41 <morgan_orange> #action morgan_orange create jenkins job
08:24:02 <morgan_orange> #info juhak and viktor_nokia We reveived your key and shall be able to grant access to the lab
08:24:12 <viktor_nokia> great
08:24:14 <morgan_orange> #info the contact for joid lab access is David
08:24:20 <juhak> thanks
08:24:20 <morgan_orange> #unfo
08:24:22 <jose_lausuch> morgan_orange: I would like to update fetch_os_creds to support joid :)
08:24:25 <fdegir> morgan_orange: we will get our 5 minutes of fame during TSC
08:24:33 <morgan_orange> #info the contact for joid access is David_Orange
08:24:55 <fdegir> and will hopefully get the agreement regarding use of community labs
08:24:55 <David_Orange> feel free to chat me on IRC #opnfv-orange
08:24:57 <morgan_orange> fdegir: I will not be able to attend today.. :)
08:25:01 <fdegir> :(
08:25:25 <morgan_orange> BTW jose_lausuch could you attend Debra's meeting for the release for functest?
08:25:44 <jose_lausuch> yes
08:25:51 <jose_lausuch> morgan_orange: I'll take it
08:26:32 <morgan_orange> ok thanks
08:26:54 <jose_lausuch> np
08:27:10 <morgan_orange> #info target for next week: 2 installers covered from Jenkins (Fuel/joid) + info on the last 2 ones
08:27:49 <jose_lausuch> joid on organge lab?
08:27:49 <morgan_orange> jose_lausuch: any update on the armband lab? any new from ANEA colleague?
08:28:01 <jose_lausuch> nothing morgan_orange...
08:28:39 <morgan_orange> for joid, Orange in not the target, we have to discuss with Narinder (joid) to see if we can use Intel POD5 or Intel pod 6
08:29:08 <morgan_orange> #info joid: David_Orange assigned to created joid deployment jenkins script (based on what we experienced on Orange pod)
08:29:20 <jose_lausuch> ok
08:29:30 <morgan_orange> #info goal is to apply this script towards Intel POD 5 or 6 (need joid feedback)
08:29:45 <morgan_orange> so ok for the POD, let's jump into ODL extension
08:30:02 <morgan_orange> #info ODL test extension: Peter sent a mail explaining the the approach
08:30:30 <jose_lausuch> David_Orange can take fuel or apex as a baseline for the joid jjob
08:30:31 <morgan_orange> pbandzi: maybe summarize for the team
08:30:55 <David_Orange> jose_lausuch: that is my plan for this morning
08:31:41 <pbandzi> morgane_orange : So far i don't have access to my mail yet :) so far what I see as most relevant option is to continue the way we started to use bash script for ODL tests.
08:31:56 <pbandzi> #info I see as most relevant option is to continue the way we started to use bash script for ODL tests.
08:32:17 <jose_lausuch> pbandzi: your bash script is gonna be used by others
08:32:19 <morgan_orange> Hi Malla_ and raghavendrachari welcome
08:32:26 <jose_lausuch> the list of test file will be expanded with bigger list
08:32:27 <raghavendrachari> Hi all
08:32:35 <Malla_> hi all
08:32:35 <jose_lausuch> at lesat 1 line for odl vpn tests
08:32:50 <pbandzi> #info unfortunately we canot jjb scripts directly from odl as they are mostly used for confuguration of ODL which we do differentlt
08:33:08 <morgan_orange> #info pbandzi's script for ODL (used to import ODL upstream robot tests) will be used by external projects (dealing with ODL and wanting to import their specific testcases in OPNFV)
08:33:44 <morgan_orange> I think for B-Release we have to be progamatic, cherry pick what is needed, for C release we may imagine something more integrated
08:34:20 <morgan_orange> so pbandzi if you need help to refactor the script, I think you can have support from amaged__ and raghavendrachari
08:34:30 <pbandzi> yes sure
08:34:38 <raghavendrachari> ok sure
08:35:09 <morgan_orange> maybe raghavendrachari, as new contributor, you can introduce yourself to the team
08:35:41 <morgan_orange> #info refactoring of ODL scripts coordinated by pbandzi with support of amaged__ and raghavendrachari
08:36:11 <raghavendrachari> Hi all , am raghavendrachari from Hewlett Packerd Enterprises, India ,
08:36:57 <raghavendrachari> am having experience on openstack,sdn controller(opendaylight, openflow..) , nfv poc deployment
08:36:58 <jose_lausuch> nice to meet you raghavendrachari :)
08:37:11 <amaged__> Pleasure raghavendrachari
08:37:22 <raghavendrachari> Nice meeting you all
08:37:35 <morgan_orange> so just to summarize ODL topic, pbandzi did eveything on functest since the beginning of the project :)
08:37:40 <morgan_orange> on ODL
08:38:06 <morgan_orange> there are lots of robot scenario, some are not useful for OPNFV (internal testing
08:38:26 <morgan_orange> but some are very useful (integration, ODL since as an element in an E2E perspective)
08:38:47 <morgan_orange> some OPNFV feature projects are based on ODL and wants to import associated testcases
08:38:59 <morgan_orange> the first suite imported about 15 testcases
08:39:11 <morgan_orange> for brahmaputra (Release 2) we need to import more
08:39:43 <morgan_orange> for information opencontrail declared more than 20 testcases
08:40:13 <amaged__> Peter and I are supposed to define a list of relevant testcases, that means, when does it make sense to use functest, yardstick, qtip, upstream or other opnfv projects (SFC for example), just reminding ourselves
08:40:14 <morgan_orange> pbandzi do you roadmap issue regarding this refactoring?
08:40:42 <pbandzi> morgan_orange: i will send mail
08:40:53 <pbandzi> and create jira
08:41:02 <morgan_orange> perfect
08:41:35 <morgan_orange> amaged__:  there is also an OPNFV project on controller performance managed by D.Farrel himself
08:42:08 <amaged__> morgan_orange: more projects to investigate then :) thx
08:42:53 <morgan_orange> yep but at the end all the ODL testcases done with Robot in ODL will be imported in Functest as Peter already setup the env to run such tests
08:43:15 <jose_lausuch> I hope we manage integrating more odl tests, the code freeze is in January... lot of things to do in all areas :)
08:43:20 <morgan_orange> so I am pretty sure yardstick, qtip will not be involved for the Robot testcases
08:43:52 <morgan_orange> yardstick may be used to create complex scenario creation of BGP VPN between 2 compute nodes
08:44:00 <morgan_orange> but robot related tests will be in Functest
08:44:05 <jose_lausuch> yes
08:44:26 <jose_lausuch> for more info about vpn https://wiki.opnfv.org/sdnvpn/main
08:44:38 <morgan_orange> to simplify: if ODL test based on Robot then Functest else see which project is the best...
08:44:53 <morgan_orange> ok we are already late, let's keep some minutes for the other topics
08:45:01 <morgan_orange> #topic Rally evolution
08:45:26 <morgan_orange> juhak: it is up to you (share your mail with team)
08:45:38 <juhak> ok
08:45:50 <juhak> at the moment things like image name, flavor or amount of
08:46:00 <juhak> users/tenants are harcoded to scenarios itself
08:46:14 <juhak> in Rally certification schema these can be defined in a separate file common to
08:46:25 <juhak> all and delivered to scenarios as arguments
08:46:38 <juhak> also the number of iteration and concurrency can be scaled proportionally
08:46:47 <juhak> to number of controllers
08:47:05 <juhak> this could be one possible approach to apply in functest
08:47:26 <morgan_orange> #info for the moment we hardcode lots of things in Rally, new certiffication feature allows some scaling to get a qualification of OpenStack through Rally
08:47:30 <jose_lausuch> ja, we were not caring much about scaling, we should have different numbers according the the number of nodes and amount of compute powert
08:48:18 <morgan_orange> yep, but I think it is better than the hardcode approach we have. Assuming that Pharos labs shall be almost similar, we may have a Rally profile for OPNFV
08:48:46 <morgan_orange> the dynamic capability could provide useful info, that could be used once we will get Pharos lab info (> B release)
08:49:03 <morgan_orange> but I would suggest to put this mechanism in place and create an alternative run-rally2.py to do that
08:49:41 <Qinglong> #info Qinglong Lan
08:49:51 <Qinglong> Sorry for another meeting
08:50:03 <morgan_orange> np we will come back to ONOS just after that :)
08:50:12 <juhak> how about selection of what scenarios to test?
08:50:25 <jose_lausuch> what is your suggestion juhak?
08:50:51 <jose_lausuch> we can have another config file with parameters, that the user can change
08:50:59 <jose_lausuch> and used by rally scenarios
08:51:20 <juhak> is there a any requirements available?
08:51:28 <jose_lausuch> hw you mean?
08:51:44 <morgan_orange> for the moment we select all the scenarios we were able to run (service available) and merged them in one single module file (nova, authenticate, ..)
08:52:17 <morgan_orange> for me the requirements will be based on the existing service delivered by the installer, we got the list at the end of the Rally installation
08:52:18 <juhak> what are the areas (nova, neutron, cinder, heat...) to cover?
08:52:57 <jose_lausuch> authenticate Test OK glance Test OK cinder Test OK keystone Test OK neutron Test OK nova Test OK quotas Test OK requests Test OK
08:52:58 <morgan_orange> I have to check, for Arno, the installers explicitely provided this list (and excluded ceilometer for Arno for instance)
08:53:10 <jose_lausuch> no heat
08:53:16 <morgan_orange> not for Arno
08:53:23 <jose_lausuch> in brahma?
08:53:45 <morgan_orange> but we should have such list for brahma, I think heat will be added (needed by several projects)
08:53:55 <jose_lausuch> ok
08:54:04 <morgan_orange> #action morgan_orange check list of supported OpenStack services in Brahmaputra
08:54:07 <jose_lausuch> then, the same +heat
08:54:16 <morgan_orange> + ceilometer probably
08:54:49 <morgan_orange> based on this list we could build our config (+ number of compute/control nodes,..)
08:55:02 <morgan_orange> and create our OPNFV Rally profile
08:55:09 <morgan_orange> ok with that juhak?
08:55:27 <juhak> sounds good
08:55:31 <morgan_orange> ok
08:55:36 <morgan_orange> back to ONOS then
08:55:38 <morgan_orange> #topic ONOS
08:55:46 <lixiaoguang> ok
08:56:04 <morgan_orange> any update on the tests and the target lab to test it :)
08:56:22 <Qinglong> #info Lab is still under debug
08:56:37 <Qinglong> # ML3 cases already finished
08:56:45 <morgan_orange> so the Compass/onos solution is not ready for testing, right?
08:56:53 <lixiaoguang> the jira have been submmited
08:56:54 <Qinglong> yes
08:56:57 <morgan_orange> You know which Huawei lab it is, and who is the contact?
08:58:19 <lixiaoguang> yes I known
08:58:35 <morgan_orange> can you #info it?
08:58:59 <lixiaoguang> #info The Lab is in shanghai
08:59:35 <morgan_orange> ok so you can be our contact :)
08:59:51 <lixiaoguang> #info and I know who is contact
08:59:52 <morgan_orange> we would like to run the other cases as soon as possible..
09:00:06 <morgan_orange> regarding ONOS
09:00:15 <morgan_orange> and the declaratio of the test cases in the DB
09:00:17 <lixiaoguang> OK
09:00:26 <morgan_orange> do you plan to have 1 testcase onos (as we have for ODL)
09:00:27 <Qinglong> You mean run other cases in huawei POD ?
09:00:58 <morgan_orange> yes functest cases not related to the controllers but used to check the global integration
09:01:50 <morgan_orange> on this lab (Compass target production lab) we shall run Functest with Onos suite for the controller, but it includes the Tempest/Rally/vPing/vIMS...
09:01:50 <lixiaoguang> Of course we can
09:01:57 <morgan_orange> we shall do it from jenkins
09:02:20 <morgan_orange> and get only blue balls in Jenkins for all the installers....
09:02:53 <jose_lausuch> thats crucial
09:02:55 <morgan_orange> lixiaoguang: OK so if you need help to run the docker file/ create the jenkins jobs,.... do not hesitate to ask
09:03:02 <jose_lausuch> we should have a result report for all intallers
09:03:10 <jose_lausuch> mei mei started a jenkins job about that
09:03:14 <morgan_orange> ok
09:03:27 <morgan_orange> we are already 3 minutes late
09:03:31 <jose_lausuch> #link https://gerrit.opnfv.org/gerrit/#/c/3453/
09:03:35 <lixiaoguang> morgan_orange: OK
09:03:35 <jose_lausuch> but I have some concerns
09:03:36 <jose_lausuch> ok
09:04:09 <jose_lausuch> we are late
09:04:11 <morgan_orange> so just for the testcase declaration, what do you prefer: 1 ONOS global testcase? or N testcases onos-ml3, onos-...
09:04:52 <morgan_orange> the testcases must be declared today, we can help, it is up to you for the declaration, if we detail we need a link to a wiki or a document (we have already some info through the jira)
09:05:03 <morgan_orange> so just tell us what is your preference
09:05:30 <morgan_orange> http://213.77.62.197/test_projects
09:05:40 <morgan_orange> onos would be a priori cases in functest
09:05:52 <morgan_orange> http://213.77.62.197/test_projects/functest/cases
09:06:28 <jose_lausuch> onos is not yet declared :|
09:06:54 <morgan_orange> not yet, we can do it, but I need the info 1 case or N cases and if N cases need the link to the description
09:07:11 <jose_lausuch> Qinglong: can you write a brief wiki?
09:07:14 <jose_lausuch> with the onos test cases
09:07:15 <jose_lausuch> we need:
09:07:21 <Qinglong> We have
09:07:25 <Qinglong> alreay have
09:07:32 <jose_lausuch> name or slogan
09:07:32 <jose_lausuch> brief description
09:07:32 <jose_lausuch> url to the extended description
09:07:35 <jose_lausuch> where is it
09:08:00 <morgan_orange> #info Onos test suite already declared
09:08:04 <morgan_orange> #link https://wiki.opnfv.org/onos_test_suite
09:08:19 <Qinglong> https://wiki.opnfv.org/functest_onos
09:08:19 <jose_lausuch> ok
09:08:21 <morgan_orange> with this list I suggest creating only 1 testcase
09:08:33 <Qinglong> here's a link
09:08:35 <jose_lausuch> ah right
09:08:37 <jose_lausuch> I remember now
09:08:38 <jose_lausuch> this
09:08:38 <jose_lausuch> https://wiki.onosproject.org/plugins/viewsource/viewpagesrc.action?pageId=4163875
09:08:40 <Qinglong> to the testcases
09:08:45 <jose_lausuch> thats more than enough for us then :)
09:08:49 <jose_lausuch> but the question from Morgan was
09:08:53 <jose_lausuch> do you want separate test cases?
09:09:14 <jose_lausuch> I think for this case https://wiki.onosproject.org/plugins/viewsource/viewpagesrc.action?pageId=4163875
09:09:18 <jose_lausuch> we should have 1 test case declared
09:09:24 <jose_lausuch> because it is the same principle as ODL test
09:09:26 <jose_lausuch> create port, subnet, etc
09:09:38 <morgan_orange> OK Qinglong lixiaoguang Ok to declare onos suite like odl suite?
09:09:46 <morgan_orange> only 1 case for all the basic tests
09:09:50 <jose_lausuch> and for these : https://wiki.onosproject.org/plugins/viewsource/viewpagesrc.action?pageId=4163953
09:09:56 <jose_lausuch> maybe separate tests cases
09:10:16 <Qinglong> ok, we will read odl suite
09:10:33 <morgan_orange> #action morgan_orange create onos testcase
09:10:38 <jose_lausuch> basically, odl suite now does: create nets, subnets,ports, and delete them
09:10:41 <jose_lausuch> similar
09:10:47 <jose_lausuch> and we declare it as 1 test case(1 graph)
09:10:51 <Qinglong> jose_lausuch: similar
09:10:55 <morgan_orange> #info this suite cover the basics (like odl) create nets, subnets,ports, and delete them
09:10:56 <morgan_orange> Ok
09:10:59 <morgan_orange> so sorry to be late
09:10:59 <Qinglong> use one case to do this ?
09:11:32 <jose_lausuch> the report to the database will be number of test run/number of test failed (hopefully 0)
09:11:56 <morgan_orange> just for the declaration in the DB, we declare 1 test suite (including several testcases)
09:12:20 <Qinglong> ok, maybe we need morgan's help
09:12:35 <morgan_orange> Qinglong: I will do it for you (2 minutes)
09:12:37 <morgan_orange> thank you for joining, enjoy Sprint 3 and see you next week, same place, same time
09:12:41 <morgan_orange> #endmeeting