#opnfv-testperf: functest weekly meeting December 15th

Meeting started by morgan at 08:04:34 UTC (full logs).

Meeting summary

    1. Juha Kosonen (juhak, 08:04:51)
    2. Viktor Tikkanen (viktor_nokia, 08:04:57)
    3. Jose Lausuch (jose_lausuch, 08:05:02)
    4. morgan (Guest21419, 08:05:15)
    5. previous minutes: http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2015/opnfv-testperf.2015-12-08-08.00.html (jose_lausuch, 08:07:33)
    6. Peter Bandzi (pbandzi, 08:09:07)
    7. rally / dashboard task postponed as we may use now the results from the rally/certification feature (Guest21419, 08:12:37)
    8. ACTION: morgan start Sprint #4 (Guest21419, 08:12:48)
    9. try to run the given list of tempest test cases and test it during following days (jose_lausuch, 08:13:20)
    10. tempest customization from smoke to opnfv suite to be tested and integrated (Guest21419, 08:13:20)
    11. ACTION: jose: change the call to rally verify in run_tempest.py (jose_lausuch, 08:13:35)
    12. we, together with BGPVPN, started to write some code about their tempest test cases which will be included in Functest as well (jose_lausuch, 08:14:44)
    13. but not in run_tempest.py (jose_lausuch, 08:14:52)
    14. Compass: CI is working and tests are triggered (jose_lausuch, 08:17:32)
    15. Compass: vPing spawns the 2 VMs, but the ping doesn't work.. to be troubleshooted (help needed) (jose_lausuch, 08:17:53)
    16. Compass: Tempest 106 tests and 51 failed.. probably due to the same issue (jose_lausuch, 08:18:14)
    17. Compass: vIMS and Rally => same issue seemed to be linked to some issue to connect admin network (need to have a deeper look) (jose_lausuch, 08:18:35)
    18. Fuel we have full CI and running tests, https://build.opnfv.org/ci/view/fuel/job/fuel-daily-master/ (jose_lausuch, 08:19:45)
    19. ODL plugin to be activated in Mirantis Fuel 7.0 this week (jose_lausuch, 08:20:05)
    20. Apex: first try to run the jjob, but functest detected failures creating routeres in OpenStack. Apex team troubleshooting and providing a fix (jose_lausuch, 08:21:21)
    21. joid tests runnable on Intel POD 5 (Guest21419, 08:22:05)
    22. Joid: Functest jjob ran on that installer and it worked, but there has been some changes in our jjob and we need to do some adaptations to make it work again. (jose_lausuch, 08:22:08)
    23. Last week I was able to start Functest from jenkins. vPing, Tempest and Rallye were runnable. Odl and vIMS not probably due to misconfiguration (jose_lausuch, 08:22:40)
    24. Tempest: only 6 errors with Fuel (but pure OpenStack) lots of errors seen with joid and compass (Guest21419, 08:23:18)
    25. all the jenkins jobs have been refactored, clear Functest page now... (Guest21419, 08:24:12)
    26. Openstack cleanup script created to be run after the tests that leave leftovers (Tempest, vIMS, ...) https://gerrit.opnfv.org/gerrit/#/c/2345/ (jose_lausuch, 08:24:39)
    27. goal if the 4 installers could launch Functest before xmas break, i will be great (Guest21419, 08:24:41)
    28. January will be dedicated to intagration of feature tests (already started with sdnvpn), troubleshooting, and documentation (Guest21419, 08:25:39)
    29. in progress still. not yet more updates :) (pbandzi, 08:28:19)
    30. https://jira.opnfv.org/browse/FUNCTEST-54? (jose_lausuch, 08:30:34)
    31. https://github.com/opendaylight/releng-builder/blob/defb069fcee740e3cc0792ae175c551f26146715/vagrant/basic-mininet-fedora-node/bootstrap.sh (jose_lausuch, 08:34:42)
    32. Orange dev pod should be back in town today for testing (Guest21419, 08:49:27)
    33. could be reused by viktor_nokia juhak and raghavendrachari for Functest tests (Guest21419, 08:49:58)
    34. ACTION: David_Orange confirm when platform is ready (Guest21419, 08:50:15)
    35. new Orange pod shall be available in January (Guest21419, 08:50:25)
    36. ACTION: raghavendrachari assign tasks on mininet installation in Functest (Guest21419, 08:51:08)
    37. ACTION: morgan create the Jira (Guest21419, 08:51:16)
    38. ACTION: raghavendrachari send public SSH key to David_Orange for access (Guest21419, 08:51:31)
    39. meeting next week but no meeting on the 29th (Guest21419, 09:06:14)


Meeting ended at 09:07:57 UTC (full logs).

Action items

  1. morgan start Sprint #4
  2. jose: change the call to rally verify in run_tempest.py
  3. David_Orange confirm when platform is ready
  4. raghavendrachari assign tasks on mininet installation in Functest
  5. morgan create the Jira
  6. raghavendrachari send public SSH key to David_Orange for access


Action items, by person

  1. David_Orange
    1. David_Orange confirm when platform is ready
    2. raghavendrachari send public SSH key to David_Orange for access
  2. morgan
    1. morgan start Sprint #4
    2. morgan create the Jira
  3. raghavendrachari
    1. raghavendrachari assign tasks on mininet installation in Functest
    2. raghavendrachari send public SSH key to David_Orange for access


People present (lines said)

  1. jose_lausuch (111)
  2. Guest21419 (72)
  3. pbandzi (18)
  4. David_Orange (15)
  5. raghavendrachari (8)
  6. juhak (3)
  7. amaged__ (3)
  8. collabot` (3)
  9. morgan (2)
  10. viktor_nokia (1)


Generated by MeetBot 0.1.4.