#opnfv-testperf: Functest weekly meeting January 5th

Meeting started by morgan_orange at 08:00:20 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 08:00:34)
    2. Viktor Tikkanen (viktor_nokia, 08:00:38)
    3. Juha Kosonen (juhak, 08:00:40)
    4. Ahmed Maged (amaged__, 08:01:03)
    5. agenda for today https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:02:21)
    6. Orange POD status to be confirmed this week, ssh creds pushed to jumphost (morgan_orange, 08:04:09)
    7. Sprint 4 created, and additional Jira created (morgan_orange, 08:04:25)

  1. B-Release (morgan_orange, 08:04:50)
    1. https://jira.opnfv.org/secure/RapidBoard.jspa?rapidView=59 (morgan_orange, 08:05:18)
    2. good progress on tempest => we now use our custom suite https://build.opnfv.org/ci/view/functest/job/functest-fuel-opnfv-jump-2-daily-master/lastSuccessfulBuild/consoleText (morgan_orange, 08:07:43)
    3. progress in Rally with rally_cert scenario (morgan_orange, 08:08:02)
    4. vIMS updated => last run on Fuel/NoSDN OK https://build.opnfv.org/ci/view/functest/job/functest-fuel-opnfv-jump-2-daily-master/lastSuccessfulBuild/consoleText (morgan_orange, 08:09:29)
    5. Jose also upgraded the system to clean the system after functest (morgan_orange, 08:10:59)
    6. regarding Functest versus Installer in Jenkins, the Status is today: (morgan_orange, 08:11:18)
    7. fuel/no SDN OK, compass partly OK (e.g. vIMS successfully tested manually but not through enkins, May-meimei listed prerequisites for Functests - access to admin network from Jumphost, ext network, ..), Apex?, Joid no progress - able to run partially on Orange POD but not yet on target lab (Intel Pod 5 due to creds retrieval issue) (morgan_orange, 08:12:51)
    8. ACTION: morgan_orange fix joid creds issues asap (morgan_orange, 08:13:01)
    9. odl tests successfully run manually on compass (morgan_orange, 08:14:09)
    10. lixiaoguang (lixiaoguang, 08:15:13)
    11. ACTION: May-meimei run tempest (recent version based on last rally version and custom config file) and troubleshoot with viktor_nokia (morgan_orange, 08:16:48)
    12. http://213.77.62.197/results?case=vIMS&installer=compass (morgan_orange, 08:19:38)
    13. http://213.77.62.197/results?case=vPing&installer=compass (morgan_orange, 08:19:49)
    14. https://jira.opnfv.org/secure/RapidBoard.jspa (morgan_orange, 08:26:41)

  2. Functest E milestone (morgan_orange, 08:28:05)
    1. I started to complete the form for E milestone (morgan_orange, 08:28:19)
    2. https://wiki.opnfv.org/releases/brahmaputra/release_plan/functest_milestone_e_report (morgan_orange, 08:28:27)
    3. ACTION: all review the wiki page on the E milestone (morgan_orange, 08:29:04)
    4. as mentioned in the page I have several concerns: not sure we can really extend internal ODL test suite as we imagined (we will discuss it in next topic on controller), not sure SUT will be ready in time to allow a real troubleshooting campaign to ensure a minimum set of test consistency towards all the installers, and difficult to have a good view on the integration of our companion feature projects (as (morgan_orange, 08:30:44)
    5. https://jira.opnfv.org/browse/GENESIS-78 (chenshuai, 08:34:21)
    6. ACTION: morgan_orange task priorization for E release (but wait for meeting today) (morgan_orange, 08:38:46)
    7. https://gerrit.opnfv.org/gerrit/#/c/5439/ (r-mibu, 08:39:40)

  3. controller (morgan_orange, 08:44:39)
    1. i am trying to make odl test work also with mininet now. and in the future we can thonk how to get rod of moninet (pbandzi, 08:45:53)
    2. The ONOSFW L3 test scripts and CI are almost finished (lixiaoguang, 08:47:08)
    3. https://build.opnfv.org/ci/view/compass4nfv/ (May-meimei, 08:52:43)
    4. ACTION: lixiaoguang May-meimei morgan_orange setup onos test from functest suite on compass virtual env (morgan_orange, 08:52:54)
    5. ACTION: pbandzi raghavendrachari amaged__ synchro on work on ODL - target first refactoring before ennd of the week (morgan_orange, 08:54:21)

  4. AoB (morgan_orange, 08:56:12)


Meeting ended at 08:59:44 UTC (full logs).

Action items

  1. morgan_orange fix joid creds issues asap
  2. May-meimei run tempest (recent version based on last rally version and custom config file) and troubleshoot with viktor_nokia
  3. all review the wiki page on the E milestone
  4. morgan_orange task priorization for E release (but wait for meeting today)
  5. lixiaoguang May-meimei morgan_orange setup onos test from functest suite on compass virtual env
  6. pbandzi raghavendrachari amaged__ synchro on work on ODL - target first refactoring before ennd of the week


Action items, by person

  1. amaged__
    1. pbandzi raghavendrachari amaged__ synchro on work on ODL - target first refactoring before ennd of the week
  2. lixiaoguang
    1. lixiaoguang May-meimei morgan_orange setup onos test from functest suite on compass virtual env
  3. May-meimei
    1. May-meimei run tempest (recent version based on last rally version and custom config file) and troubleshoot with viktor_nokia
    2. lixiaoguang May-meimei morgan_orange setup onos test from functest suite on compass virtual env
  4. morgan_orange
    1. morgan_orange fix joid creds issues asap
    2. morgan_orange task priorization for E release (but wait for meeting today)
    3. lixiaoguang May-meimei morgan_orange setup onos test from functest suite on compass virtual env
  5. pbandzi
    1. pbandzi raghavendrachari amaged__ synchro on work on ODL - target first refactoring before ennd of the week
  6. raghavendrachari
    1. pbandzi raghavendrachari amaged__ synchro on work on ODL - target first refactoring before ennd of the week
  7. viktor_nokia
    1. May-meimei run tempest (recent version based on last rally version and custom config file) and troubleshoot with viktor_nokia


People present (lines said)

  1. morgan_orange (109)
  2. chenshuai (11)
  3. lixiaoguang (7)
  4. May-meimei (6)
  5. raghavendrachari (5)
  6. leo_wang (5)
  7. pbandzi (4)
  8. viktor_nokia (4)
  9. juhak (3)
  10. r-mibu (3)
  11. collabot` (3)
  12. amaged__ (1)
  13. Valentin_Orange (1)


Generated by MeetBot 0.1.4.