#opnfv-testperf: Functest weekly meeting January 26th

Meeting started by morgan_orange at 08:00:07 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 08:00:17)
    2. Juha Kosonen (juhak, 08:00:29)
    3. Viktor Tikkanen (viktor_nokia, 08:00:37)
    4. https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:01:27)

  1. review of action points (morgan_orange, 08:02:07)
    1. AP1: creation of odl page => done by me (morgan_orange, 08:02:41)
    2. https://wiki.opnfv.org/odl_brahmaputra_page (morgan_orange, 08:02:43)
    3. AP2 meimei1 add pexpect lib => done (morgan_orange, 08:03:03)
    4. AP3 run rally-cert on the target labs => done on fuel and apex (morgan_orange, 08:03:36)
    5. we will discuss that on topic rally (morgan_orange, 08:03:46)
    6. AP4 lixiaoguang update onos section in doc done (morgan_orange, 08:04:03)
    7. AP5 investigation on userdata => creation of 2 vPing scenario but still some issues on some scenario (morgan_orange, 08:04:35)

  2. B-Release folow up (morgan_orange, 08:05:01)
  3. vPings (morgan_orange, 08:05:19)
    1. https://wiki.opnfv.org/vping_brahmaputra_page (morgan_orange, 08:05:40)
    2. creation of a seconf vPing scenario (connection to the Vm to perform the ping instead of using userdata/cloudinit mechanism) (morgan_orange, 08:06:22)
    3. troubleshooting in progress (morgan_orange, 08:06:35)
    4. if vPings fail => vIMS will fail (morgan_orange, 08:07:46)

  4. onos (morgan_orange, 08:07:53)
    1. 11/11 on all the labs (to be check if test run on joid to update the table) (morgan_orange, 08:08:11)
    2. https://wiki.opnfv.org/onos_brahmaputra_page (morgan_orange, 08:08:24)
    3. Jose Lausuch (jose_lausuch, 08:08:27)
    4. doc updated (morgan_orange, 08:08:30)
    5. http://testresults.opnfv.org/testapi/results?case=vPing&installer=apex (morgan_orange, 08:11:26)

  5. tempest (morgan_orange, 08:13:05)
    1. https://wiki.opnfv.org/tempest_brahmaputra_page (morgan_orange, 08:13:20)
    2. 2 major issues with tempest cases (morgan_orange, 08:18:29)
    3. 1. ODL instability. As long as network creation will not succeed reliably, many test cases will fail because network creation is part of their test setup. (morgan_orange, 08:18:35)
    4. 2. Suspected problem with worker threads. It is under investigation. (morgan_orange, 08:18:43)
    5. ACTION: jose_lausuch morgan_orange May-meimei check Jumphost HW conf (see influence on Rally workersà (morgan_orange, 08:22:01)

  6. rally (morgan_orange, 08:23:09)
    1. ACTION: juhak short refactoring to manage voume for rally-cert only (morgan_orange, 08:29:53)
    2. move to rally-cert scenario in CI (morgan_orange, 08:30:03)

  7. ONOS (morgan_orange, 08:36:27)
    1. tests are running fine, doc updated... (morgan_orange, 08:36:42)

  8. ODL (morgan_orange, 08:37:05)
    1. tests run on apex/compass/fuel (morgan_orange, 08:37:21)
    2. probelm on joid, probably due to the fact that ODL test scenario use the same IP for Neutron and keystone API, which is not the case on joid (morgan_orange, 08:37:47)
    3. case to be updated to take this specificity into account (morgan_orange, 08:37:59)
    4. feedback from redhat on the fact that the tests may be deprecated (morgan_orange, 08:38:19)
    5. discussions in progress with ODL community (morgan_orange, 08:38:31)
    6. ACTION: morgan_orange adapt ODL suite to joid (morgan_orange, 08:38:58)
    7. ACTION: jose_lausuch check if tests are deprecated and if we should point to new ODL Robot scenario (morgan_orange, 08:39:30)

  9. vIMS (morgan_orange, 08:39:51)
    1. scenario used to work with nosdn but no scenario up&running with a controller scenario (morgan_orange, 08:40:44)
    2. troubleshooting in progress, currently no odl or onos scenario are OK and we may have some restrictions (morgan_orange, 08:42:43)
    3. prerequisites for vIMS = vPing... (morgan_orange, 08:42:51)

  10. Ovno (morgan_orange, 08:43:16)
    1. no OCl lab ready to test and wait for patch correction on ovno side (morgan_orange, 08:45:36)

  11. promise (morgan_orange, 08:45:40)
    1. integration tests started (morgan_orange, 08:45:47)
    2. promise in the CI loop (morgan_orange, 08:45:59)
    3. so far issue due to dependencies, node version seems to be old on Ubuntu 14.04.... (morgan_orange, 08:46:24)
    4. investigation on promise side (morgan_orange, 08:46:30)

  12. SDNVPN (morgan_orange, 08:46:46)
    1. patch submitted yesterday to integrate tests on CI (morgan_orange, 08:47:05)
    2. patch patched by May-meimei an else was missing in the if condition of run_test.sh (morgan_orange, 08:47:24)
    3. scenario available in CI fule/bgpvpn ...wait and see...and debug (morgan_orange, 08:47:44)

  13. doc (morgan_orange, 08:49:16)
    1. update in progress but my wish to pleade doc8 lead to regression (thanks viktor_nokia for reporting) (morgan_orange, 08:50:11)
    2. request to new contributors to review the current draft doc (morgan_orange, 08:50:55)

  14. release date (morgan_orange, 08:53:35)


Meeting ended at 09:02:48 UTC (full logs).

Action items

  1. jose_lausuch morgan_orange May-meimei check Jumphost HW conf (see influence on Rally workersà
  2. juhak short refactoring to manage voume for rally-cert only
  3. morgan_orange adapt ODL suite to joid
  4. jose_lausuch check if tests are deprecated and if we should point to new ODL Robot scenario


Action items, by person

  1. jose_lausuch
    1. jose_lausuch morgan_orange May-meimei check Jumphost HW conf (see influence on Rally workersà
    2. jose_lausuch check if tests are deprecated and if we should point to new ODL Robot scenario
  2. juhak
    1. juhak short refactoring to manage voume for rally-cert only
  3. May-meimei
    1. jose_lausuch morgan_orange May-meimei check Jumphost HW conf (see influence on Rally workersà
  4. morgan_orange
    1. jose_lausuch morgan_orange May-meimei check Jumphost HW conf (see influence on Rally workersà
    2. morgan_orange adapt ODL suite to joid


People present (lines said)

  1. morgan_orange (149)
  2. jose_lausuch (68)
  3. viktor_nokia (10)
  4. juhak (5)
  5. collabot (4)
  6. May-meimei (3)
  7. RAGHAVENDRACHARI (1)


Generated by MeetBot 0.1.4.