#opnfv-testperf: Functest weekly meeting February 2nd

Meeting started by morgan_orange at 08:00:08 UTC (full logs).

Meeting summary

    1. Morgan Richomme (morgan_orange, 08:00:14)
    2. Viktor Tikkanen (viktor_nokia, 08:00:18)
    3. Juha Kosonen (juhak, 08:00:19)
    4. agenda https://wiki.opnfv.org/functest_meeting (morgan_orange, 08:00:54)
    5. topic Action point follow up (morgan_orange, 08:01:12)
    6. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-01-26-08.00.html (morgan_orange, 08:01:21)
    7. hardware configuration check done on Huawei, Orange POD2 and LF POD2 (morgan_orange, 08:01:50)
    8. Jose Lausuch (jose_lausuch, 08:01:55)
    9. juhak refactoring of volume management on rally-cert done (morgan_orange, 08:05:55)
    10. morgan_orange adaptation of oDL suite for JOID done (morgan_orange, 08:06:08)
    11. robot scenario path changed in ODL repo, but scenario did not change (morgan_orange, 08:06:45)

  1. Release B (morgan_orange, 08:06:57)
    1. refactoring of traces of Tempest and Rally in Jenkins done => nice results (morgan_orange, 08:07:28)
    2. question on rally issue on live migration => shall these scenario be excluded? (morgan_orange, 08:07:49)
    3. possible now to have a synthetic view of the different results (morgan_orange, 08:09:49)
    4. http://testresults.opnfv.org/proto/index-pod.html (morgan_orange, 08:09:57)
    5. http://testresults.opnfv.org/proto/index-scenario.html (morgan_orange, 08:10:07)
    6. http://testresults.opnfv.org/proto/index2.html (morgan_orange, 08:10:18)
    7. regarding B release, still investigations mainly on vPing, vIMS (morgan_orange, 08:14:43)
    8. ACTION: juhak perform cinder test on Orange pod2 (morgan_orange, 08:15:52)
    9. ODL suite on joid now looks like in apex (15OK /3 KO) I think that it is due to an update of the code, the tests did not follow => so I can change the test or just document it (morgan_orange, 08:16:03)
    10. ONOS tests OK (morgan_orange, 08:16:09)
    11. promise tests run (morgan_orange, 08:16:22)
    12. Tempest was relatively stable alert on regression on Orange POD2 (last 2 run => impossible to find the config) => I will have a look at it (morgan_orange, 08:16:52)
    13. ACTION: morgan_orange Tempest on Orange POD2 where is the tempest.conf... (morgan_orange, 08:17:05)
    14. ACTION: morgan_orange ODL check the delete scenario from upstream repo (instead of tests in OPNFV repo) (morgan_orange, 08:18:01)
    15. Rally suite seems Ok for the release (morgan_orange, 08:19:02)
    16. ACTION: juhak checkheat cases on Orange POD2 (morgan_orange, 08:21:21)
    17. vPing some scenario now working apex/odl_l2, compass/onos, joid/odl_l2.... (morgan_orange, 08:24:37)
    18. ACTION: jose_lausuch push to DB if vPing test timeout (jose_lausuch, 08:24:40)
    19. more run needed to update and confirm the status (morgan_orange, 08:24:52)
    20. as you know theoretically we have slot for troubleshooting (morgan_orange, 08:26:10)
    21. https://wiki.opnfv.org/vims_brahmaputra_page (morgan_orange, 08:28:17)
    22. progress on vIMS test case (morgan_orange, 08:28:29)
    23. vIMS OK on fuel and apex odl_l2, investigation in progress on joid and compass (morgan_orange, 08:28:49)
    24. reminder troubleshooting slots for Functest : LF POD1 (Apex) 18-20 UTC / LF POD2 (Fuel) 5-16 UTC, POD5 (Joid) 19-18 UTC, POD8 (Compass??) 13-15UTC, POD6 (joid), 19-20 UTC... (morgan_orange, 08:29:08)
    25. so to summarize on Functest for B release (morgan_orange, 08:31:26)
    26. vPing => need more scenario to check, recent progress in apex/odl_l2 and compass/onos but all combinations still not there (morgan_orange, 08:32:10)
    27. vPing_userdata need more scenario to confirm existing results (all old_l2 scenario OK) (morgan_orange, 08:32:53)
    28. ODL => check the 3 custom tests but OK on the different labs (just a test to check norhbound API of the Controller at the end) (morgan_orange, 08:33:32)
    29. ONOS => ok on all installers (need more run to confirm stability) (morgan_orange, 08:33:50)
    30. vIMS OK on apex/fuel still issues with compass/joid, complex test cases (more close to realistic needs of Telco) (morgan_orange, 08:34:45)
    31. promise OK (morgan_orange, 08:38:01)
    32. ovno a bit late but theoretically it is ready from a Functest/CI perspective (morgan_orange, 08:38:22)
    33. sdnvpn idem ovno wait for a run of the scenario to see if the tests are properly triggered (morgan_orange, 08:38:44)
    34. ACTION: morgan_orange propose scenario strategy for CI to get more deployment and then more tests (morgan_orange, 08:40:26)
    35. labs still not really ready for troubleshooting (no CI labs available yesterady) (morgan_orange, 08:40:54)
    36. doc has been updated, ChrisPriceAB split it to provide a global doc, everbody can still review it and patch it especially for the troubleshooting section (morgan_orange, 08:41:37)
    37. ACTION: leo_wang provide access to Compass labs to Valentin_Orange for vIMS troubleshooting on compass (morgan_orange, 08:42:30)

  2. plugfest (morgan_orange, 08:46:45)
    1. as you know a plug fest is on track. it will be organized in Colorado in May (Cable Labs) (morgan_orange, 08:47:03)
    2. Nokia and Orange will probably participate (need confirmation, people not designated at the moment) (morgan_orange, 08:50:22)
    3. question what can we bring as input for such event (morgan_orange, 08:50:47)

  3. Release C (morgan_orange, 08:52:19)
    1. https://etherpad.opnfv.org/p/functest_release_C (morgan_orange, 08:52:59)
    2. for the moment it is a white page, I see already some possible actions/improvements and I have questions (morgan_orange, 08:53:37)
    3. etherpad open for Functest Release C (morgan_orange, 08:58:09)
    4. we should consider: (morgan_orange, 08:58:18)
    5. - existing testcases (evolution, in&out) (morgan_orange, 08:58:36)
    6. next test cases (sync with Intel and new VNF) (morgan_orange, 08:58:45)
    7. role of orchestrator for testing (morgan_orange, 08:58:54)
    8. -upstream contribution( E.g. Rally) (morgan_orange, 08:59:08)
    9. - analytics? (morgan_orange, 08:59:17)
    10. moving from home made API + Mongo to ELK? (morgan_orange, 08:59:35)
    11. ACTION: evrybody complete this etherpad (morgan_orange, 08:59:52)
    12. https://etherpad.opnfv.org/p/functest_release_C (morgan_orange, 09:00:02)
    13. https://wiki.opnfv.org/functextnexttaks (morgan_orange, 09:01:15)

  4. AoB (morgan_orange, 09:01:53)


Meeting ended at 09:04:27 UTC (full logs).

Action items

  1. juhak perform cinder test on Orange pod2
  2. morgan_orange Tempest on Orange POD2 where is the tempest.conf...
  3. morgan_orange ODL check the delete scenario from upstream repo (instead of tests in OPNFV repo)
  4. juhak checkheat cases on Orange POD2
  5. jose_lausuch push to DB if vPing test timeout
  6. morgan_orange propose scenario strategy for CI to get more deployment and then more tests
  7. leo_wang provide access to Compass labs to Valentin_Orange for vIMS troubleshooting on compass
  8. evrybody complete this etherpad


Action items, by person

  1. jose_lausuch
    1. jose_lausuch push to DB if vPing test timeout
  2. juhak
    1. juhak perform cinder test on Orange pod2
    2. juhak checkheat cases on Orange POD2
  3. leo_wang
    1. leo_wang provide access to Compass labs to Valentin_Orange for vIMS troubleshooting on compass
  4. morgan_orange
    1. morgan_orange Tempest on Orange POD2 where is the tempest.conf...
    2. morgan_orange ODL check the delete scenario from upstream repo (instead of tests in OPNFV repo)
    3. morgan_orange propose scenario strategy for CI to get more deployment and then more tests
  5. Valentin_Orange
    1. leo_wang provide access to Compass labs to Valentin_Orange for vIMS troubleshooting on compass


People present (lines said)

  1. morgan_orange (151)
  2. jose_lausuch (86)
  3. juhak (8)
  4. leo_wang (7)
  5. ChrisPriceAB (5)
  6. collabot (4)
  7. raghavendrachari (3)
  8. Valentin_Orange (3)
  9. GeraldK_ (2)
  10. viktor_nokia (2)


Generated by MeetBot 0.1.4.