14:00:06 <morgan_orange> #startmeeting OPNFV Testing working group weekly meeting September, 29th
14:00:06 <collabot> Meeting started Thu Sep 29 14:00:06 2016 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
14:00:06 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
14:00:06 <collabot> The meeting name has been set to 'opnfv_testing_working_group_weekly_meeting_september__29th'
14:00:16 <morgan_orange> #topic call role
14:00:26 <jose_lausuch> #info Jose Lausuch
14:00:28 <morgan_orange> "info Morgan Richomme
14:00:34 <morgan_orange> #info Morgan Richomme
14:00:34 <mbeierl> #info Mark Beierl
14:00:40 <morgan_orange> #chair mbeierl
14:00:40 <collabot> Current chairs: mbeierl morgan_orange
14:00:59 <kubi001> #info kub
14:00:59 <JingLu> #info Jing
14:01:03 <kubi001> #info kubi
14:01:46 <morgan_orange> #info agenda for today https://wiki.opnfv.org/display/meetings/TestPerf
14:02:49 <morgan_orange> #topic Action point follow-up
14:02:59 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2016/opnfv-testperf.2016-09-22-14.00.html
14:03:11 <morgan_orange> #info AP1: kubi plan soemthing on grafana
14:03:13 <morgan_orange> #info done
14:03:30 <morgan_orange> #info AP2: yujunz-zte send mail invitation for next APAC slots
14:03:35 <morgan_orange> #info done calendar created
14:03:43 <morgan_orange> #info AP3 morgan_orange initiate etherpad Colorado post-mortem for Test working group
14:03:55 <morgan_orange> #info done https://etherpad.opnfv.org/p/Colorado-Testing-postmortem
14:04:06 <morgan_orange> #info all brainstorm on relationships between projects to avoid overlaping
14:04:09 <morgan_orange> #info we will see
14:04:22 <morgan_orange> #info AP5 morgan_orange send mail on community to associate other working groups
14:04:24 <morgan_orange> #info done
14:04:42 <morgan_orange> #topic Presentation IEEE SDN initiative to collect Open Source toolkits dealing with SDN/NFV (C. Rothenberg, G.Carella)
14:05:02 <yujunz> #info Yujun Zhang / IRC only
14:06:27 <morgan_orange> #info presentation initiative, first presentation done during OPNFV Summit
14:06:46 <morgan_orange> #info initiative academic driven
14:07:47 <morgan_orange> #info currently using docuwiki, migration to confluence planned
14:08:03 <morgan_orange> #info idea of a catalog
14:13:48 <mtahhan> morgan_orange: should we not be collating a list of all the toolkits we are using across the test projects and doing a quality check on the testing tools we are using
14:14:19 <mtahhan> I think the catalog you mention is for tools that are out there in the wild atm
14:14:35 <mtahhan> but perhaps we also need to catalog the tools we are using
14:15:00 <mtahhan> as well as the specs and tests implemented across the testing projects
14:15:15 <mtahhan> forgot to mention I'm only available on IRC
14:15:17 <mtahhan> today
14:17:26 <morgan_orange> #info target for IEEE web site beginning of Novemebr
14:17:26 <mbeierl> #info live version is planned for the beginning of November
14:17:37 <morgan_orange> #info meanwhile google doc used to reference the documents
14:17:40 <mbeierl> morgan_orange: you type quickly :)
14:19:07 <ljlamers__> #info Larry Lamers
14:19:36 <mbeierl> #topic Docker proposal for CI
14:21:05 <mbeierl> #info jose_lausuch is presenting overview of https://hub.docker.com/r/opnfv/ and the Jenkins jobs that push to it
14:21:43 <mbeierl> #link https://wiki.opnfv.org/display/INF/Docker+handling+in+CI
14:22:09 <morgan_orange> #info google doc for previosu topic: https://docs.google.com/spreadsheets/d/1NHI4MZZWVDpxF_Rs7OOSTUa_aHL2ACUVA_Ov-YQs1DA/edit#gid=0
14:23:07 <morgan_orange> #info previous topic proto site http://www.sdn-os-toolkits.org/ (until official IEEE web site planned beginning of November)
14:23:46 <mbeierl> #info explanation of numbering scheme: first push on a new branch creates a 0.0, next one 0.1, etc
14:24:37 <morgan_orange> #info manual cleaning needed
14:27:25 <mbeierl> #info an example is shown in the Yardstick docker repo, where there are 74 Brahmaputra versions
14:27:52 <mbeierl> #info release of Colorado 1.0 (or other official releases) must be done manually.  Contact jose_lausuch for help doing that for now
14:29:06 <mbeierl> #info at this time, logic is needed to determine where the dockerfile is located
14:29:38 <mbeierl> #info proposal to standardize this for all projects so that dockerfile is always found at $WORKSPACE/docker/dockerfile
14:29:58 <mbeierl> #info currently this only affects bottlenecks and yardstick
14:29:59 <morgan_orange> #info refactoring affects only bottleneck + yardstick
14:30:02 <morgan_orange> #undo
14:30:02 <collabot> Removing item from minutes: <MeetBot.ircmeeting.items.Info object at 0x3063490>
14:30:46 <morgan_orange> #action MatthewLi kubi1refactor docker dir so all the projects using docker will have the same docker path
14:31:29 <mbeierl> #info changes required: bottlenecks/ci/docker -> bottlenecks/docker and for yardstick: yardstick/tests/ci/docker/yardstick-ci to yardstick/docker
14:31:31 <morgan_orange> #agreed docker path refactoring
14:31:53 <morgan_orange> #info harmonization on the docker jenkins job
14:33:03 <morgan_orange> #action kubi001 review yardstick / docker job and align jobs with other test projects
14:33:16 <mbeierl> #info jose_lausuch will propose a patch to harmonize the opnfv-docker.yaml for review
14:33:40 <jose_lausuch> #link https://wiki.opnfv.org/display/INF/Docker+handling+in+CI
14:34:46 <kubi001> I'm a bit surprise that yardstick is so different with other projects with docker handing in CI.
14:34:57 <kubi001> we will try to align with others projects
14:35:11 <mbeierl> kubi001: yardstick was a pioneer in this area :)
14:35:29 <morgan_orange> #startvote Do you approve Docker refactoring presented by jose_lausuch? Yes, No
14:35:29 <collabot> Begin voting on: Do you approve Docker refactoring presented by jose_lausuch? Valid vote options are Yes, No.
14:35:29 <collabot> Vote using '#vote OPTION'. Only your last vote counts.
14:35:36 <kubi001> mbeierl: wa, I see
14:35:36 <morgan_orange> #vote yes
14:35:43 <mbeierl> #vote yes
14:35:44 <kubi001> #vote yes
14:36:03 <jose_lausuch> #vote yes
14:36:27 <morgan_orange> yujunz:  mtahhan ?
14:36:40 <yujunz> kubi001 #vote yes
14:36:51 <kubi001> yuyang: ping
14:37:01 <morgan_orange> #stopvote
14:37:05 <morgan_orange> #endvote
14:37:05 <collabot> Voted on "Do you approve Docker refactoring presented by jose_lausuch?" Results are
14:37:05 <collabot> Yes (4): jose_lausuch, morgan_orange, mbeierl, kubi001
14:37:23 <morgan_orange> #agreed docker refactoring, jose_lausuch will create a patch and put people in review
14:37:40 <yujunz> Sorry I have something else in hand
14:37:44 <yujunz> ping me if required
14:37:48 <morgan_orange> #topic Update on Grafana
14:40:24 <jose_lausuch> #link http://testresults.opnfv.org/grafana/
14:40:47 <kubi001> user/pwd:opnfv/opnfv
14:41:13 <jose_lausuch> #info Grafana Dashboard access: opnfv/opnfv
14:49:44 <mbeierl> #info only registered administrator accounts can modify dashboards
14:53:58 <yuyang> bad connections for my part, sorry for any late response
14:55:26 <morgan_orange> #topic Colorado post-mortem: https://etherpad.opnfv.org/p/Colorado-Testing-postmortem
14:56:29 <morgan_orange> #action kubi001 MatthewLi  mtahhan mbeierl jose_lausuch dfarrell07 review post mortem for a discussion next week
14:56:42 <morgan_orange> #topic AoB
14:57:12 <jose_lausuch> congrats everyone for Colorado testing! :)
14:57:24 * mbeierl pats everyone on the back :)
14:57:28 <kubi001> :)
14:58:14 <kubi001> I have to ask a leave for next meeting, we will be in the National Day vacation
14:59:05 <jose_lausuch> kubi001: sure, enjoy !
14:59:44 <mbeierl> I really like the new calendar in the wiki - should we remove the table format now?
15:00:02 <kubi001> jose_lausuch: :)
15:02:34 <morgan_orange> #end meeting
15:02:41 <mbeierl> #endmeeting