#opnfv-testperf: Weekly Testing working group meeting November 3rd

Meeting started by morgan_orange at 14:10:03 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 14:10:32)
    1. Morgan Richomme (morgan_orange, 14:10:56)
    2. kubi (kubi001, 14:10:58)
    3. Mingjiang (Rex) (Mingjiang5, 14:11:14)
    4. yujunz (yujunz, 14:11:16)
    5. Bryan Sullivan (bryan_att, 14:11:24)

  2. action point follow up (morgan_orange, 14:14:38)
    1. old points, skipped for this meeting (morgan_orange, 14:14:47)

  3. Feedback from OpenStack Barcelona (morgan_orange, 14:14:59)
    1. Functest meetup organized during the event: roadmap, topic, resources allocation (morgan_orange, 14:15:19)
    2. meeting with bitergia during OpenStack, minutes available (morgan_orange, 14:26:57)
    3. We need to start applying some new/stronger criteria on scenario creation, and eliminate scenarios that don't need to be distinct, understand the reasons why some are distinct and work to address those reasons so we can eliminate the distinction, etc (bryan_att, 14:28:09)
    4. link on Functest meetup to be provided (morgan_orange, 14:28:27)
    5. ACTION: trevor_intel initiate a etherpad to collect Testing working group top priority for Danube (morgan_orange, 14:28:27)
    6. give 2 weeks for all contributor to work on the etherpad and organize a vote in 2 weeks (morgan_orange, 14:28:55)
    7. We also need to strongly promote convergence between Dovetail and Functest re the test framework/design (if not already converged, I am not sure) as that impacts the developers of tests (bryan_att, 14:29:07)
    8. i.e. we cannot afford the "luxury" (?) of developing tests twice (bryan_att, 14:29:53)
    9. ACTION: everybody complete etherpad (morgan_orange, 14:33:54)
    10. ACTION: trevor_intel allocate slots for discussions in the next 2 weekly meeting (morgan_orange, 14:34:15)
    11. the goal is to work on the "glue" between the different test projects and give a more consistent view (morgan_orange, 14:34:39)
    12. question from Chris on guideline on which project for my tests? (morgan_orange, 14:35:00)
    13. presenation done in Berlin to try to formalize that (morgan_orange, 14:35:17)
    14. https://www.youtube.com/watch?v=FWkmzypZhnY (morgan_orange, 14:36:38)
    15. https://wiki.opnfv.org/download/attachments/2926690/OPNFV_testing_group.png?version=1&modificationDate=1467636653000&api=v2 (morgan_orange, 14:36:56)
    16. Mirek Walukiewicz presentes the ISB (Industry Standard Benchmark) for NFV Overview (jose_lausuch, 14:37:33)
    17. it's an extension of Yardstick (jose_lausuch, 14:37:49)
    18. aims to deliver benchmarks, tools, test suites reference VNFs (jose_lausuch, 14:38:17)
    19. rprakash (rprakash_, 14:42:05)
    20. the intention is to integrate with Yardstick, not creating a new project (jose_lausuch, 14:42:06)
    21. VNF aproximation to Functest: is Functest the home for ISB VNFs? (jose_lausuch, 14:43:55)
    22. usage of "approximations" of VNFs, which are not meant for production (jose_lausuch, 14:45:04)
    23. plans to work with MODELS project (jose_lausuch, 14:45:35)
    24. FYI the Models project would be happy to work with any other projects or collaborators on development of the reference VNF library and developing blueprints to support deployment of those VNFs on OPNFV scenarios via the various MANO project VNFMs... this is in scope for Danube (bryan_att, 14:56:34)
    25. The "hosting place" for the library, and what purposes we put them to, is a subject we should discuss. The Models project has the goal of testing these *functionally* ala vIMS and demonstrated/validate their deployment using the various VNFM tools used in the various MANO projects. This is specifically focused on the role/scope of Functest and (bryan_att, 14:59:21)
    26. In the meantime I am hosting the build/test scripts int he Models project. (bryan_att, 14:59:55)
    27. e.g. I just uploaded the 3Node Hello World script/test to the repo. (bryan_att, 15:02:02)


Meeting ended at 15:02:24 UTC (full logs).

Action items

  1. trevor_intel initiate a etherpad to collect Testing working group top priority for Danube
  2. everybody complete etherpad
  3. trevor_intel allocate slots for discussions in the next 2 weekly meeting


Action items, by person

  1. trevor_intel
    1. trevor_intel initiate a etherpad to collect Testing working group top priority for Danube
    2. trevor_intel allocate slots for discussions in the next 2 weekly meeting


People present (lines said)

  1. morgan_orange (21)
  2. bryan_att (9)
  3. jose_lausuch (8)
  4. collabot` (4)
  5. yujunz (4)
  6. rprakash_ (2)
  7. kubi001 (2)
  8. Mingjiang5 (1)
  9. trevor_intel (0)


Generated by MeetBot 0.1.4.