15:01:23 <morgan_orange> #startmeeting testing working group weekly meeting January 19th
15:01:23 <collabot> Meeting started Thu Jan 19 15:01:23 2017 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:01:23 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:01:23 <collabot> The meeting name has been set to 'testing_working_group_weekly_meeting_january_19th'
15:01:27 <morgan_orange> #topic call role
15:01:36 <mbeierl> #info Mark Beierl
15:01:41 <morgan_orange> #info Morgan Richomme
15:01:43 <kubi001> #info kubi
15:02:00 <trevor_intel> #info Trevor Cooper
15:02:04 <yujunz> #info Yujun Zhang
15:02:06 <yujunz> IRC only
15:02:10 <jose_lausuch> #info Jose Lausuch
15:02:24 <morgan_orange> #agenda for today https://wiki.opnfv.org/display/meetings/TestPerf
15:03:28 <morgan_orange> #topic action point follow up
15:03:31 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-01-11-08.07.html
15:05:18 <morgan_orange> #info APi kubi001 make synthesis of the proposal for week 4
15:05:37 <morgan_orange> #action point  APi kubi001 make synthesis of the proposal  moved to week 6
15:06:59 <trevor_intel> #topic
15:07:08 <hongbo55> #info hongbo
15:07:12 <trevor_intel> #undo
15:07:15 <morgan_orange> #inof mbeierl summary on discussion on unit tests (best practices, recommendations,..) + presentation on week 3
15:07:17 <morgan_orange> #info done
15:07:20 <mbeierl> #link https://wiki.opnfv.org/display/meetings/TestPerf
15:07:21 <trevor_intel> #topic Unit test best practices/recommendations fort Test projects (Mark)
15:07:24 <morgan_orange> #info morgan_orange sync with infra group to see if it is possible
15:07:28 <morgan_orange> #info not done yet
15:07:38 <morgan_orange> #action morgan_orange sync with infra group to see if it is possible (nned lab for long duration tests)
15:07:46 <morgan_orange> #info morgan_orange organize meeting on Alassane work (either on week 3 or 6)
15:07:47 <morgan_orange> #info done
15:08:02 <morgan_orange> #info ad-hoc meeting organized this week
15:08:09 <morgan_orange> #info Alassane created a wiki page
15:08:17 <morgan_orange> #link https://wiki.opnfv.org/display/testing/R+post-processing+of+the+Yardstick+results
15:08:27 <morgan_orange> #info presentation could be re do for US if needed
15:08:40 <morgan_orange> #info open quesiton on the project where we could include this post processing module
15:08:45 <morgan_orange> #topic unit tests
15:10:07 <morgan_orange> #info mbeierl sharing presentation on unit tests (video of Berlin summit available on youtube)
15:10:32 <morgan_orange> #chair trevor_intel
15:10:32 <collabot> Current chairs: morgan_orange trevor_intel
15:11:48 * ChrisPriceAB was looking for morgan_orange earlier about the docs patch. merged now so no stress. :)
15:14:52 <trevor_intel> morgan_orange: Jill is on and should be next (Communication action on OPNFV testing)
15:15:48 <mbeierl> #info slide 9 - tests as documentation
15:16:06 <morgan_orange> trevor_intel: yes
15:16:33 <yujunz-zte> I can see and hear, just too quite to talk in bedroom mbeierl
15:17:34 <morgan_orange> #info test as documentation => show how to use an API
15:17:53 <morgan_orange> #info no need to unit test too simple things (getter/setter)
15:18:34 <trevor_intel> #info Tests shall not launch a missile
15:19:51 <morgan_orange> #info unit test you can mock your mock and you will get mock results!
15:20:26 <trevor_intel> Is fake class the same as fake news?
15:24:06 <mbeierl> #link https://build.opnfv.org/ci/view/storperf
15:24:19 <jose_lausuch> graph for Functest: https://build.opnfv.org/ci/view/functest/job/functest-verify-master/2934/cobertura/
15:24:39 <jose_lausuch> #link https://build.opnfv.org/ci/view/storperf/job/storperf-verify-master/123/cobertura/
15:26:09 <morgan_orange> with cobertura, we can see if the code is tested or not: yes we can
15:27:34 <trevor_intel> morgan_orange: ha ha
15:29:15 <trevor_intel> #topic Communication action on OPNFV testing (Jill Lovato)
15:29:41 <mbeierl> #info code coverage reports on the % of code from inside the git repo for the project
15:30:25 <bryan_att> what was the announcement of a new testing initiative last year?
15:31:09 <trevor_intel> https://newsroom.cisco.com/press-release-content?articleId=1812628
15:31:45 <pjlynch> NFV-ITI?
15:31:48 <morgan_orange> just before Xmas
15:32:07 <morgan_orange> pjlynch: yes
15:32:45 <morgan_orange> #info OPNFV would like to communicate on testing activities
15:32:49 <morgan_orange> #info document in progress
15:33:09 <ChrisPriceAB> can we get the link on IRC and in the minutes as well?
15:34:26 <morgan_orange> #link https://docs.google.com/document/d/1O1BKT7OVXwA8YlIXPcad9_Gk0--0-h-9Zvpio-0H8Ok/edit?usp=sharing
15:34:41 <ChrisPriceAB> thanks morgan_orange
15:35:37 <morgan_orange> #info target end of month
15:36:20 <morgan_orange> #action testing community invited to review the documentation
15:37:57 <morgan_orange> #action morgan_orange set slot during next weekly meeting to sync testing group view
15:38:27 <morgan_orange> #topic New diagram proposal
15:38:44 <morgan_orange> #link https://wiki.opnfv.org/display/testing/TestPerf?preview=/8688867/8688868/EcoSystem%20Copy.png
15:43:47 <yujunz-zte> Looks good, just one comment on QTIP.
15:43:57 <yujunz-zte> I would like to replace QPI with benchmarking
15:44:12 <yujunz-zte> QPI is something hard to understand for outsider
15:45:48 <morgan_orange> #action trevor_intel send a mail to the community to share the figure for review
15:45:57 <morgan_orange> #info feature tests not reflected here
15:46:10 <morgan_orange> #info use benchmarking instead QPI
15:49:11 <morgan_orange> #info functest and yardstick can be used to help feature project to run their own tests
15:49:16 <morgan_orange> #topic dovetail update
15:51:02 <trevor_intel> yujunz-zte: Other projects do benchmarking e.g. VSPERF ... I think we should discuss what it means
15:51:18 <kubi001> agree with trevor_intel
15:51:25 <yujunz-zte> OK, we can discuss in mailing list
15:52:35 <kubi001> all the performance testing project are involved with Benchmark. It seems that Storpef also named with benchmark
15:54:26 <gabriel_yuyang> Some benchmarking work also involved in Bottlenecks.
15:56:07 <yujunz-zte> It's fine. One goal of QTIP is providing benchmark service to other projects. We would avoid function overlap and focus more on benchmark service itself
15:57:28 <yujunz-zte> If you check the qtip vision, you would find compute, network and storage are actually under the category "sample"
15:57:34 <yujunz-zte> #link https://wiki.opnfv.org/display/qtip/Vision
15:59:52 <mbeierl> #link https://ask.opnfv.org/question/1273/swagger-access/ <- people are asking for testresults db username and password.  Is this publicly available or no?
16:00:36 <ChrisPriceAB> why do we have a password on it at all?
16:00:42 <ChrisPriceAB> For read access?
16:01:08 <mbeierl> ChrisPriceAB: I don't think anyone has invested the work to create a read-only view yet
16:01:09 <morgan_orange> because swagger give you access to the GET and POST and PUT
16:01:24 <morgan_orange> if you want a read only you can directly call the API
16:01:28 <morgan_orange> no need to use swagger
16:01:44 <mbeierl> morgan_orange: however, it is not as easy to browse :(
16:02:03 <morgan_orange> with a json plugins it is fine...
16:02:14 <ChrisPriceAB> morgan_orange: reading it is not the purpose of using swagger. But if we are using swagger reading it is a use that we should accomodate
16:02:45 <morgan_orange> http://testresults.opnfv.org/test/api/v1/projects/dovetail/cases
16:02:58 <morgan_orange> http://testresults.opnfv.org/test/api/v1/projects/functest/cases
16:03:18 <morgan_orange> mbeierl: creds are in the documentation
16:04:46 <mbeierl> morgan_orange: but is that something that should be put into the ask.com answer?
16:05:03 <mbeierl> or... ask.opnfv.org, I mean
16:05:06 <morgan_orange> mbeierl: hmm not sure
16:05:28 <morgan_orange> I will answer to this thread
16:05:36 <mbeierl> morgan_orange: ok, thanks!
16:05:52 <morgan_orange> #endmeeting