#opnfv-testperf: Test community weekly meeting March 16th

Meeting started by morgan_orange at 14:59:59 UTC (full logs).

Meeting summary

  1. call role (morgan_orange, 15:00:06)
    1. Morgan Richomme (morgan_orange, 15:00:09)
    2. agenda https://wiki.opnfv.org/display/meetings/TestPerf (morgan_orange, 15:01:33)
    3. gabriel_yuyang (gabriel_yuyang, 15:02:00)
    4. Chris Price (ChrisPriceAB, 15:02:30)
    5. kubi (kubi001, 15:03:57)

  2. Action point follow-up (morgan_orange, 15:04:02)
    1. http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-03-08-08.00.html (morgan_orange, 15:04:10)
    2. AP1 David will get back to Test Group with a proposal for test project milestones (morgan_orange, 15:04:21)
    3. see next topic (morgan_orange, 15:04:25)
    4. morgan_orange ask jmorgan1 if it could be a E feature (API providing SUT information) (morgan_orange, 15:04:34)
    5. Al Morton (acm, 15:04:40)
    6. see mail from Uli from the infra group (morgan_orange, 15:04:48)
    7. ACTION: morgan_orange ask jmorgan1 on an api to get infra resources (morgan_orange, 15:05:09)
    8. AP3 kubi001 gabriel rex check who could do the stress demo (morgan_orange, 15:05:22)
    9. remote demo to be planned, no people attending the plugfest (morgan_orange, 15:06:23)

  3. Euphrates milestone (morgan_orange, 15:06:35)
  4. Refstack (morgan_orange, 15:07:08)
    1. Refstack_defcore is a reference test suite developped by Refstack project (OpenStack) (morgan_orange, 15:15:48)

  5. refstack and dovetail reporting database (ChrisPriceAB, 15:28:28)
    1. morgan_orange outlines the current state of the test reporting database (ChrisPriceAB, 15:28:48)
    2. although not used today it does support reporting from the refstack and the use of tokens for test result reporting security (ChrisPriceAB, 15:29:28)
    3. morgan outlines that the test DB coule be replicated for DoveTail and that the exact same reporting could be used (ChrisPriceAB, 15:29:52)
    4. it should also be possible to extend with additional test result information (ChrisPriceAB, 15:30:20)
    5. the Database front end could support users and reporting per test run, the front end is quite flexible (ChrisPriceAB, 15:30:56)
    6. http://artifacts.opnfv.org/releng/docs/testapi.html (morgan_orange, 15:32:50)
    7. doc in progress to set test api/ Db in local env (request from this morning) (morgan_orange, 15:33:11)

  6. plugfest (morgan_orange, 15:33:17)
    1. discussions on traffic generators needed (4 or 5 used in vsperf) (morgan_orange, 15:33:51)
    2. ACTION: trevor plan a slot during the hackfest to discuss this topic (morgan_orange, 15:34:20)
    3. acm and trevor will attend the plugfest => good place to discuss/organize tutorial on traffic generation (morgan_orange, 15:36:17)
    4. other key topic performance testing seen from end user perspective (not developer perspective) (morgan_orange, 15:36:46)
    5. traffic generator aaS within OPNFV to be considered for Euphrates (morgan_orange, 15:37:00)
    6. today, end user journey for performance testing is difficult => need self containted way to perform such testing (morgan_orange, 15:37:38)
    7. to be connected to CVP (morgan_orange, 15:37:49)
    8. discussion on stress test strategy for Euphrates to be organized (morgan_orange, 15:41:05)
    9. I think we should also make sure the many different test generator suppliers/developers know they would be welcome. (acm, 15:41:18)
    10. ACTION: trevor : plan sessions on stress test strategy during the plugfest (morgan_orange, 15:41:41)
    11. especially the OS and SW-based generators, like MoonGen and Xena (acm, 15:42:34)

  7. MANO testing (morgan_orange, 15:43:47)
    1. ACTION: MANO Testing (Prakash & Bryan) (morgan_orange, 15:44:37)

  8. Danube last miles (morgan_orange, 15:44:44)
    1. currently very few system availabel to perform tests (morgan_orange, 15:45:48)
    2. it looks like we did not reached MS3.. (morgan_orange, 15:46:27)

  9. Test WG feedback on VINA, Bamboo (morgan_orange, 15:49:59)
    1. https://wiki.opnfv.org/display/bamboo/Bamboo+Project+Proposal (morgan_orange, 15:51:00)
    2. https://wiki.opnfv.org/display/vina/VINA+Project+Proposal (morgan_orange, 15:51:12)

  10. CFP Beijing (morgan_orange, 15:52:37)
    1. deadline 27th of March (morgan_orange, 15:52:43)
    2. https://etherpad.opnfv.org/p/TestCommunitySummit (morgan_orange, 15:53:03)
    3. ACTION: trevor_intel acm kubi001 gabriel_yuyang mbeier review etherpad proposal and suggest a top 3 (morgan_orange, 15:57:30)
    4. ACTION: morgan_orange slot next week to select the top 3 (morgan_orange, 15:59:47)

  11. AoB (morgan_orange, 16:00:12)


Meeting ended at 16:00:42 UTC (full logs).

Action items

  1. morgan_orange ask jmorgan1 on an api to get infra resources
  2. trevor plan a slot during the hackfest to discuss this topic
  3. trevor : plan sessions on stress test strategy during the plugfest
  4. MANO Testing (Prakash & Bryan)
  5. trevor_intel acm kubi001 gabriel_yuyang mbeier review etherpad proposal and suggest a top 3
  6. morgan_orange slot next week to select the top 3


Action items, by person

  1. acm
    1. trevor_intel acm kubi001 gabriel_yuyang mbeier review etherpad proposal and suggest a top 3
  2. gabriel_yuyang
    1. trevor_intel acm kubi001 gabriel_yuyang mbeier review etherpad proposal and suggest a top 3
  3. jmorgan1
    1. morgan_orange ask jmorgan1 on an api to get infra resources
  4. kubi001
    1. trevor_intel acm kubi001 gabriel_yuyang mbeier review etherpad proposal and suggest a top 3
  5. morgan_orange
    1. morgan_orange ask jmorgan1 on an api to get infra resources
    2. morgan_orange slot next week to select the top 3
  6. UNASSIGNED
    1. trevor plan a slot during the hackfest to discuss this topic
    2. trevor : plan sessions on stress test strategy during the plugfest
    3. MANO Testing (Prakash & Bryan)


People present (lines said)

  1. morgan_orange (49)
  2. ChrisPriceAB (10)
  3. collabot` (6)
  4. acm (3)
  5. gabriel_yuyang (1)
  6. kubi001 (1)
  7. jmorgan1 (1)


Generated by MeetBot 0.1.4.