15:05:05 <mbeierl> #startmeeting TestPerf Weekly Meeting
15:05:05 <collabot`> Meeting started Thu May 25 15:05:05 2017 UTC.  The chair is mbeierl. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:05:05 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:05:05 <collabot`> The meeting name has been set to 'testperf_weekly_meeting'
15:05:36 <mbeierl> #info Discussion on Big Data for Testing
15:05:39 <acm_> #info Al Morton
15:05:52 <mbeierl> #topic Roll Call
15:05:57 <mbeierl> #info Mark Beierl
15:06:06 <yujunz> #info Yujun Zhang
15:06:11 <Ace> #info Ace Lee
15:06:15 <mbeierl> #topic Discussion on Big Data for Testing
15:06:19 <JackChan> #info Jack
15:06:23 <mbeierl> #chair yujunz
15:06:23 <collabot`> Current chairs: mbeierl yujunz
15:06:28 <yujunz> #link https://docs.google.com/presentation/d/1GISQICDX3s9Od7eDGO-N9X-czMCcCrL3gxygr3hTePg/edit?usp=sharing
15:08:21 <yujunz> #info many people are on holiday, so we shall discuss just about storperf test data
15:08:47 <dfarrell07> I guess no one else is seeing "Unable to Process Your Request" errors? https://global.gotomeeting.com/join/305553637
15:09:05 <mbeierl> dfarrell07: hang on - the id is different I think
15:09:18 <mbeierl> https://global.gotomeeting.com/join/819733085
15:09:21 <mbeierl> dfarrell07: $
15:12:03 <dfarrell07> mbeierl: cool, that worked, thanks :)
15:24:11 <acm_> #info mbeierl described the multidimentional storperf raw data and summaries
15:24:24 <mbeierl> #chair acm_
15:24:24 <collabot`> Current chairs: acm_ mbeierl yujunz
15:24:52 <mbeierl> #link http://testresults.opnfv.org/test/api/v1/results/590b2ea581fe76000ab366a2
15:24:59 <acm_> #info bw is in bytes per second
15:25:13 <mbeierl> #info an example of all the summary data that is stored in the OPNFV testresults DB from StorPerf
15:25:39 <trevor_intel__> #info Trevor Cooper
15:25:50 <mbeierl> #info the "metrics" JSON element is a summary of all the values
15:26:15 <mbeierl> #info the "report_data" is the raw numbers used to calculate the "metrics" summary
15:26:36 <yujunz> #info raw data of storperf current kept in storperf container and discarded with daily job
15:27:24 <yujunz> raw data is saved in carbon and visualized in graphite ?
15:27:37 <acm_> #info bw typically delcines with time as the test runs, the convention is that declining values must reach a certain tolerance before the test is terminated and stable values are declared as achieved
15:28:58 <acm_> #info there seems to be quite a bit of variation in results reporting for each test project.
15:31:13 <acm_> #info Mark has to go, thanks!
15:31:43 <acm_> #topic Big Data
15:32:39 <yujunz> #info Trevor talks about how data processing in vsperf
15:42:39 <yujunz> #info trevor expect a dynamic way of creating comparison calculation and play with the data
15:46:22 <acm_> #info Bryan described a stress testing tool that will be OS at some point, as an example of mass data collection in a data lake...
15:50:27 <acm_> #info there is a realtionship to chaos monkey / failure injection testing, examine failure scenarios of interest.
15:50:45 <acm_> #info data lake becomes an ocean...
15:54:08 <yujunz> #topic AoB
15:54:27 <yujunz> open discussion
15:56:33 <yujunz> #action yujunz provide a travel guide from airport to hotel in Chinese for the taxi driver
15:57:21 <yujunz> #endmeeting