15:00:43 <morgan_orange> #startmeeting Testing working group weekly meeting 6th of July
15:00:43 <collabot`> Meeting started Thu Jul  6 15:00:43 2017 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:43 <collabot`> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:43 <collabot`> The meeting name has been set to 'testing_working_group_weekly_meeting_6th_of_july'
15:00:54 <morgan_orange> #topic call roll
15:01:01 <morgan_orange> #info Morgan richomme
15:01:13 <mbeierl> #link https://global.gotomeeting.com/join/819733085
15:01:22 <mbeierl> #info Mark Beierl
15:01:26 <yujunz-zte> #info Yujun Zhang
15:01:45 <JackChan> #info Jack
15:03:23 <morgan_orange> #topic action point follow up
15:03:29 <morgan_orange> #chait jose_lausuch mbeierl
15:03:42 <mbeierl> morgan_orange: chair was a typo
15:03:43 <morgan_orange> #link http://ircbot.wl.linuxfoundation.org/meetings/opnfv-testperf/2017/opnfv-testperf.2017-06-29-15.00.html
15:03:55 <morgan_orange> #chair jose_lausuch mbeierl
15:03:55 <collabot`> Current chairs: jose_lausuch mbeierl morgan_orange
15:04:10 <morgan_orange> #info AP1: organ_orange change swagger login/password (publically available in the book...)
15:05:48 <morgan_orange> #action update status to amar
15:05:52 <morgan_orange> #undo
15:05:52 <collabot`> Removing item from minutes: <MeetBot.ircmeeting.items.Action object at 0x26ddb10>
15:06:26 <morgan_orange> #action morgan_orange update status to amar
15:06:51 <morgan_orange> #info AP2 add better mechanism to track access to the API
15:07:01 <morgan_orange> #info work in progress through web protal /API
15:07:09 <morgan_orange> #info morgan_orange send a mail for a status
15:07:24 <morgan_orange> #action morgan_orange send a mail for a status on landing page
15:07:37 <morgan_orange> #info AP4 morgan_orange initiate a wiki page on tooling
15:07:42 <morgan_orange> #info started see next slot
15:07:53 <morgan_orange> #info AP5 jose_lausuch start a email thread to see if we should reset the black list for each new versions / up to scenario owners / exceptios shall be validated by TSC?
15:08:46 <morgan_orange> #info discussions related to Danube 3.0 - main concern is on the failed temepst cases
15:09:07 <morgan_orange> #info a reste for Euphrates has been done to clean the black list (all installers/all scenarios)
15:10:17 <morgan_orange> #topic Short status On EnergyAaS activity
15:11:34 <morgan_orange> #info presentation of the work done by Benoit around Energy consumption
15:12:29 <morgan_orange> #info google knows which application is consuming too much power on smartphone, the idea was to start doing something similar on NFVI (which VNF / application / ) consumes what
15:13:02 <morgan_orange> #info possible to leverage OPNFV Pharos federation, with deterministic runs thanks to CI pipelines
15:13:29 <morgan_orange> #link https://wiki.opnfv.org/display/testing/Power+consumption+monitoring
15:14:10 <morgan_orange> #info presentaiton during the summit on benoit's work
15:14:13 <morgan_orange> #link https://www.youtube.com/watch?v=jVc9Z5OuIYY&list=PLiM029E-zvrtlTmH0h0mHt_-g8B-6609P&t=16s&index=25
15:15:47 <morgan_orange> #chair gabriel_yuyang kubi001 trevor_intel
15:15:47 <collabot`> Current chairs: gabriel_yuyang jose_lausuch kubi001 mbeierl morgan_orange trevor_intel
15:17:28 <morgan_orange> #info first results  (first PODs equiped)
15:17:33 <morgan_orange> #link http://opnfv.fr:3000
15:17:39 <morgan_orange> admin/admin
15:18:50 <morgan_orange> #info on E//, LF POD2 it is possible to see the whole CI cycles
15:19:26 <morgan_orange> #info on Orange-POD3 Benoit added the possibility to get more details through the SDK for specific use
15:26:57 <morgan_orange> #info question from Mark where shall we integrate it for stress tests (Bottlenecks?)
15:27:32 <morgan_orange> #info for the moment collector code is not yet in OPNFV ... need to figure out where to put it
15:32:33 <morgan_orange> #action benoit send a mail to the community to evaluate the need for such activity around Energy
15:32:38 <morgan_orange> #info New project or could it be hosted in Pharos see with jack Morgan?
15:34:39 <morgan_orange> #info trevor_intel mentioned that Energy monitoring could be interesting for security topics
15:37:17 <morgan_orange> #info discussions on collector (IPMI, Redfish, HUI scrapping)
15:39:54 <morgan_orange> #topic Bitergia sync point
15:40:12 <morgan_orange> #info synchro next week
15:41:53 <morgan_orange> #info Jesus "We have some data collected in an enriched in Kibana"
15:42:03 <morgan_orange> #link https://opnfv.biterg.io:443/goto/93ebe8aca496facba752ced47379e1b4
15:42:11 <morgan_orange> #info The index has only some data because the data retrieval from the API failed when retrieving a longer time frame. Álvaro already reported the problem.
15:42:20 <morgan_orange> #info There is a very preliminar version of a panel for visualizing the data. Even when it still needs some work, and it is showing a small dataset (because of the above problem) you can start commenting on it, if you want (at least to know if you feel we're on the right direction or not).
15:42:31 <morgan_orange> #link https://opnfv.biterg.io:443/goto/dd9aa660f1fa5d8dd63f7f455609aa80
15:43:41 <morgan_orange> #topic Tooling catalog
15:43:51 <morgan_orange> #info work initiated
15:44:06 <morgan_orange> #link https://wiki.opnfv.org/display/testing/Testing+tooling+catalog
15:44:29 <morgan_orange> #info remark from yujunz: list only the external tools or indicate python requirements?
15:44:43 <morgan_orange> #action everybody complete the table..we will discuss next week
15:44:58 <morgan_orange> #topic Dockerfile discussion
15:45:08 <morgan_orange> #info more than one dockerfile (for compose) per project, and can we use merge jobs to trigger docker push instead of timer?
15:46:53 * yujunz-zte suggests if we want to include python requirements, we can do it automatically by writing a script to pull all requirement.txt from different projects
15:47:25 <morgan_orange> #info yujunz-zte suggests if we want to include python requirements, we can do it automatically by writing a script to pull all requirement.txt from different projects
15:48:42 <yujunz-zte> For multiple Dockerfile in one repo, does anybody try the service on docker hub?
15:48:49 <yujunz-zte> #link https://docs.docker.com/docker-hub/builds/
15:49:44 <yujunz-zte> It should be easy to integrate with the Github mirror of OPNFV projects. I'm not sure if there is any limitation on build frequency.
15:50:47 <morgan_orange> #info for the moment the logic to build docker file is in releng, docker file is in the project repos
15:52:01 <rbbratta> yujunz-zte: you can trigger dockerhub builds by URL, but by default you don't get parallel builds, and it takes ~5-10 min to queue a build
15:52:42 <rbbratta> yujunz-zte: we have used dockerhub to build >100 kolla containers
15:52:46 <jose_lausuch> https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker-arm.yml   https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker.yml
15:54:27 <rbbratta> we would have to specify dockerfile ordering for dependencies
15:54:48 <yujunz-zte> Thanks, rbbratta , from the introduction, it seems automated build when integrated with Github. Did I understand anything wrong?
15:55:20 <rbbratta> yujunz-zte: it is supposed to trigger to github events, but I didn't get that to work, and kolla has complicated dependency ordering, so we used manual triggers
15:55:26 <jose_lausuch> https://git.opnfv.org/releng/tree/jjb/releng/opnfv-docker.yml#n130
15:56:15 <yujunz-zte> I see. If there is a dependency ordering, it could be difficult.
15:56:46 <yujunz-zte> I'll give the auto trigger a try tomorrow
15:57:04 <yujunz-zte> Currently we publish qtip pip package automatically from Github
15:57:56 <morgan_orange> #action jose_lausuch mbeierl review changes needed to support multiple docker in releng
15:58:13 <morgan_orange> #action mbeierl jose_lausuch evaluate moving from cron to post merge mechanism for docker production
15:58:24 <morgan_orange> #topic AoB
15:58:49 <mbeierl> #info Can anyone think of a good way to deliver docker-compose.yaml files to end users?
15:58:57 <morgan_orange> #info next meeting APAC slot 12th of July
16:00:16 <yujunz-zte> mbeierl you may consider provide oneline script like the installer quickstart
16:00:36 <yujunz-zte> There was a discussion recently in mailing list
16:01:41 <yujunz-zte> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-June/016857.html
16:01:59 <morgan_orange> #endmeeting