15:00:55 <morgan_orange> #startmeeting Testing working group weekly meeting 7/9
15:00:55 <collabot> Meeting started Thu Sep  7 15:00:55 2017 UTC.  The chair is morgan_orange. Information about MeetBot at http://wiki.debian.org/MeetBot.
15:00:55 <collabot> Useful Commands: #action #agreed #help #info #idea #link #topic.
15:00:55 <collabot> The meeting name has been set to 'testing_working_group_weekly_meeting_7_9'
15:01:12 <morgan_orange> #topic call role
15:01:15 <mtahhan> has the bridge opened?
15:01:25 <mtahhan> #info Maryam Tahhan
15:01:43 <morgan_orange> gabriel_yuyang: can you open it, still some right issue
15:01:49 <morgan_orange> #info Morgan Richomme
15:01:55 <alec-cisco> #info Alec Hothan
15:02:30 <gabriel_yuyang> morgan_orange: ok
15:02:39 <trevor_intel> #info Trevor Cooper
15:02:56 <mtahhan> I will open it... it's the same bridge as barometer
15:03:30 <morgan_orange> #topic action point follow-up
15:03:36 <morgan_orange> #info AP1: gabriel_yuyang collect names for intel18 access
15:03:42 <morgan_orange> #info done, JIRA to be created soon
15:03:49 <morgan_orange> #info AP2 mbeierl create wiki page on docker creation for arm
15:04:05 <morgan_orange> #chair trevor_intel gabriel_yuyang
15:04:05 <collabot> Current chairs: gabriel_yuyang morgan_orange trevor_intel
15:04:12 <mbeierl> #info Mark Beierl
15:04:14 <morgan_orange> #info AP3 testing PTL: provide feedback to Alec
15:04:21 <mbeierl> morgan_orange: shoot.  I need to get working on that
15:04:22 <morgan_orange> #info mail discussion initiated
15:04:32 <morgan_orange> #info AP4 review https://etherpad.openstack.org/p/etsi-nfv-openstack-gathering-denver & https://etherpad.openstack.org/p/qa-queens-ptg
15:04:36 <morgan_orange> #info AP5 morgan_orange plan a topic on Testing group contribution to PTG next week
15:04:41 <morgan_orange> #info done see next section
15:04:47 <morgan_orange> #info AP6 mbeierl share the mail new testing features for Euphrates
15:04:55 <morgan_orange> #info done
15:05:27 <trevor_intel> #topic Barometer
15:06:03 <morgan_orange> #link https://wiki.opnfv.org/display/fastpath
15:06:42 <morgan_orange> #info Barometer = OPNFV telemetry project
15:07:03 <trevor_intel> #info Maryam Tahhan presents overview of Barometer
15:07:51 <morgan_orange> #info scope NFVI + Hypervisor
15:08:30 <mbeierl> #info Email from Amar on Euphrates release
15:08:31 <mbeierl> #link https://lists.opnfv.org/pipermail/opnfv-tech-discuss/2017-August/017698.html
15:10:43 <trevor_intel> #info collectd = system stats collection daemon
15:10:55 <morgan_orange> #info barometer based on collectd (10 years, stable, widely adopted by industry, modular, ..)
15:14:10 <mtahhan> #link https://wiki.opnfv.org/display/fastpath/Collectd+Metrics+and+Events
15:19:36 <trevor_intel> #info More than 90 plugins cover many interfaces
15:26:22 <trevor_intel> #info Barometer only tested with Apex today ... due to resourcing for Euphrates
15:27:38 <trevor_intel> #info Morgan proposes to use Barometer for long duration tests
15:28:14 <mbeierl> morgan_orange: where should I put the page on multiarch docker?  Under the test working group, or ...?
15:28:39 <morgan_orange> mbeierl:  I would suggest a page under testing/Euphrates ?
15:28:49 <mbeierl> morgan_orange: ok, thanks.
15:30:36 <trevor_intel> #info Barometer dockerization is WIP (collecd daemon, Influxdb with Grafana)
15:32:27 <morgan_orange> #info question on prometheus => integration with collectd relatively easy
15:33:53 <trevor_intel> #info Prometheus uses pull model ... collectd typically uses push
15:35:31 <morgan_orange> #info no clustering support in prometheus (local stoage)
15:36:54 <mbeierl> mtahhan: I'd like to touch base later about having Barometer run and collect host metrics while StorPerf is running to show how Ceph is behaving on the host :)
15:37:20 <mbeierl> mtahhan: @mentioned you in the StorPerf F release planning page so I remember to do that :)
15:38:51 <mbeierl> bryan_att: ONAP's telemetry project is Baramoter?
15:39:04 <mtahhan> mbeierl: sure thing... no stress :D
15:41:01 <mbeierl> I need to drop now, thanks everyone!
15:44:23 <morgan_orange> #topic Euphrates Documentation
15:54:26 <trevor_intel> #topic OpenStack PTG review: OPNFV testing group proposal: https://etherpad.openstack.org/p/qa-queens-ptg  https://etherpad.openstack.org/p/etsi-nfv-openstack-gathering-denver
15:54:57 <morgan_orange> #action morgan_orange create wiki to irganize doc cross review + testing group doc
15:55:13 <trevor_intel> #info Gabriel to summarise what we are planning for long duration
15:55:37 <morgan_orange> #action alec-cisco jose sync with infra group to create the docker best practice solution in the documentation
15:55:49 <morgan_orange> #topic OpenStack PTG review
15:55:57 <morgan_orange> #link https://etherpad.openstack.org/p/qa-queens-ptg
15:56:12 <trevor_intel> #info Bryan suggests to prioritize failure modes that are known to occur
15:56:15 <morgan_orange> #agree gabriel_yuyang to summarize Testing group activity in the etherpad for the OpenStack group
15:57:56 <trevor_intel> #info Morgan suggests asking EUAG for input on failure mode priorities
15:58:03 <morgan_orange> #topic AoB
15:59:13 <mtahhan> β€œIn each cluster's (of 1,800 servers) first year, it's typical that 1,000 individual
15:59:13 <mtahhan> machine failures will occur; thousands of hard drive failures will occur; one
15:59:13 <mtahhan> power distribution unit will fail, bringing down 500 to 1,000 machines for
15:59:13 <mtahhan> about 6 hours; 20 racks will fail, each time causing 40 to 80 machines to vanish
15:59:13 <mtahhan> from the network; 5 racks will "go wonky," with half their network packets
15:59:14 <mtahhan> missing in action; and there's about a 50 percent chance that the cluster will
15:59:16 <mtahhan> overheat, taking down most of the servers in less than 5 minutes and taking 1
15:59:18 <mtahhan> to 2 days to recover. β€œ – Jeff Dean 2008
15:59:21 <mtahhan> https://www.cnet.com/news/google-spotlights-data-center-inner-workings/
15:59:28 <mtahhan> and some interesting reading here:
15:59:36 <mtahhan> https://blog.thousandeyes.com/top-internet-outages-2016/
16:00:13 <mtahhan> first qoute was from google launching a cluster
16:04:55 <morgan_orange> #info TSC election in progress: woudl be good to have a Testing group candidature
16:05:18 <morgan_orange> #info but as testing group is unformal => no nomination on behlaf, just use standard way
16:05:21 <morgan_orange> #endmeeting